[gentoo-dev] Automated Package Removal and Addition Tracker, for the week ending 2017-11-26 23:59 UTC

2017-11-26 Thread Robin H. Johnson
The attached list notes all of the packages that were added or removed
from the tree, for the week ending 2017-11-26 23:59 UTC.

Removals:
app-emulation/vmware-vix 20171125-12:35 dilfridge  f9792cc8567
dev-perl/Apache-SessionX 20171122-08:19 kentnl 2e0fa305e35
dev-perl/File-Stat-Moose 20171122-08:21 kentnl 1d66e0a381b
kde-misc/kcollectd   20171119-15:47 asturm e02b71c5a95
kde-misc/kdesudo 20171119-15:47 asturm e02b71c5a95
media-sound/kmid 20171119-15:47 asturm e02b71c5a95
media-sound/konvertible  20171119-15:47 asturm e02b71c5a95
media-sound/kstreamripper20171119-15:47 asturm e02b71c5a95
net-im/qutim 20171119-15:47 asturm e02b71c5a95
net-misc/knutclient  20171119-15:47 asturm e02b71c5a95
sci-calculators/keurocalc20171119-15:47 asturm e02b71c5a95

Additions:
app-portage/gemato   20171121-22:22 mgorny 4b3b7f011e8
dev-ada/gps  20171121-20:47 tupone 282d7dccde2
dev-ada/libadalang   20171120-20:51 tupone b3c3fb418d5
dev-lang/micropython 20171125-11:48 monsieurp  c3fe6df715e
dev-perl/Linux-PipeMagic 20171122-09:10 kentnl c5ca6eea2b6
dev-python/bz2file   20171121-21:20 mgorny 9542b6dff22
dev-python/collectd-rabbitmq 20171120-17:23 monsieurp  b1c1468619e
media-sound/pulseeffects 20171126-22:56 prometheanfire 4a1a8d9365a
media-tv/dtv-scan-tables 20171126-22:49 chewi  eb84f08c045
sys-block/sas3flash  20171120-20:55 zmedico619cee02f1a

--
Robin Hugh Johnson
Gentoo Linux Developer
E-Mail : robb...@gentoo.org
GnuPG FP   : 11AC BA4F 4778 E3F6 E4ED  F38E B27B 944E 3488 4E85
Removed Packages:
app-emulation/vmware-vix,removed,dilfridge,20171125-12:35,f9792cc8567
dev-perl/File-Stat-Moose,removed,kentnl,20171122-08:21,1d66e0a381b
dev-perl/Apache-SessionX,removed,kentnl,20171122-08:19,2e0fa305e35
kde-misc/kcollectd,removed,asturm,20171119-15:47,e02b71c5a95
kde-misc/kdesudo,removed,asturm,20171119-15:47,e02b71c5a95
media-sound/kmid,removed,asturm,20171119-15:47,e02b71c5a95
media-sound/konvertible,removed,asturm,20171119-15:47,e02b71c5a95
media-sound/kstreamripper,removed,asturm,20171119-15:47,e02b71c5a95
net-im/qutim,removed,asturm,20171119-15:47,e02b71c5a95
net-misc/knutclient,removed,asturm,20171119-15:47,e02b71c5a95
sci-calculators/keurocalc,removed,asturm,20171119-15:47,e02b71c5a95
Added Packages:
media-sound/pulseeffects,added,prometheanfire,20171126-22:56,4a1a8d9365a
media-tv/dtv-scan-tables,added,chewi,20171126-22:49,eb84f08c045
dev-lang/micropython,added,monsieurp,20171125-11:48,c3fe6df715e
dev-perl/Linux-PipeMagic,added,kentnl,20171122-09:10,c5ca6eea2b6
app-portage/gemato,added,mgorny,20171121-22:22,4b3b7f011e8
dev-python/bz2file,added,mgorny,20171121-21:20,9542b6dff22
dev-ada/gps,added,tupone,20171121-20:47,282d7dccde2
sys-block/sas3flash,added,zmedico,20171120-20:55,619cee02f1a
dev-ada/libadalang,added,tupone,20171120-20:51,b3c3fb418d5
dev-python/collectd-rabbitmq,added,monsieurp,20171120-17:23,b1c1468619e

Done.

[gentoo-dev] Last rites: dev-tex/isotope

2017-11-26 Thread Jonas Stein
# Jonas Stein  (26 Nov 2017)
# The latest version of this LaTeX package is part of
# dev-texlive/texlive-latexextra (bug #421881)
# Masked for removal on 2017-12-30
dev-tex/isotope

--
Best regards,
Jonas Stein











signature.asc
Description: OpenPGP digital signature


Re: [gentoo-dev] Patch for toolchain.eclass for uclibc-ng

2017-11-26 Thread Anthony G. Basile
On 11/26/17 10:50 AM, Andreas K. Huettel wrote:
> Am Samstag, 25. November 2017, 15:01:20 CET schrieb Anthony G. Basile:
>> Hi everyone,
>>
>> With the stabilization of gcc-6.4.0, the uclibc build broke because the
>> eclass requires UCLIBC_VER to be define on uclibc systems else it will
>> die().  Since uclibc specific patches are no longer needed in gcc-6 and
>> above, we don't want to error out in the eclass when the patchset is not
>> found.
>>
> 
> I'd guard this so it only applies to gcc-6 and later... for the simple reason 
> that 
> otherwise people will try to emerge some historical gcc versions and fail..

I don't think that's necessary because the ebuild is supposed to provide
a value of UCLIBC_VER if and only if a patchset is needed, and writing
the ebuild is up to us toolchain folks.  I can see the possibility of
upstream porting the fix to versions of gcc previous to 6 and then we'd
have to go back and hack away at the toolchain.eclass.

I'm planning to use the same logic for musl specific patches:  if
MUSL_VER is provided in the gcc ebuild, then there is a musl patchset to
be applied, otherwise there isn't.

This seems to be the cleanest approach without littering the eclass with
tc_version_is_at_least.

Comment?

> 
> Otherwise WFM
> 
> diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
> index 503f7dbe94f..58d859dfaf3 100644
> --- a/eclass/toolchain.eclass
> +++ b/eclass/toolchain.eclass
> @@ -378,9 +378,6 @@ toolchain_pkg_pretend() {
>   "in your make.conf if you want to use this 
> version."
>   fi
>  
> - [[ -z ${UCLIBC_VER} ]] && [[ ${CTARGET} == *-uclibc* ]] && \
> - die "Sorry, this version does not support uClibc"
> -
>   if ! use_if_iuse cxx ; then
>   use_if_iuse go && ewarn 'Go requires a C++ compiler, 
> disabled due to USE="-cxx"'
>   use_if_iuse objc++ && ewarn 'Obj-C++ requires a C++ 
> compiler, disabled due to USE="-cxx"'
> 


-- 
Anthony G. Basile, Ph.D.
Gentoo Linux Developer [Hardened]
E-Mail: bluen...@gentoo.org
GnuPG FP  : 1FED FAD9 D82C 52A5 3BAB  DC79 9384 FA6E F52D 4BBA
GnuPG ID  : F52D4BBA



Re: [gentoo-dev] Patch for toolchain.eclass for uclibc-ng

2017-11-26 Thread Andreas K. Huettel
Am Samstag, 25. November 2017, 15:01:20 CET schrieb Anthony G. Basile:
> Hi everyone,
> 
> With the stabilization of gcc-6.4.0, the uclibc build broke because the
> eclass requires UCLIBC_VER to be define on uclibc systems else it will
> die().  Since uclibc specific patches are no longer needed in gcc-6 and
> above, we don't want to error out in the eclass when the patchset is not
> found.
> 

I'd guard this so it only applies to gcc-6 and later... for the simple reason 
that 
otherwise people will try to emerge some historical gcc versions and fail..

Otherwise WFM

diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index 503f7dbe94f..58d859dfaf3 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -378,9 +378,6 @@ toolchain_pkg_pretend() {
"in your make.conf if you want to use this 
version."
fi
 
-   [[ -z ${UCLIBC_VER} ]] && [[ ${CTARGET} == *-uclibc* ]] && \
-   die "Sorry, this version does not support uClibc"
-
if ! use_if_iuse cxx ; then
use_if_iuse go && ewarn 'Go requires a C++ compiler, 
disabled due to USE="-cxx"'
use_if_iuse objc++ && ewarn 'Obj-C++ requires a C++ 
compiler, disabled due to USE="-cxx"'
-- 
2.13.6




> Note that there are some musl specific patches which I would like to
> migrate out of the overlay and into the tree.  In a future patch, I'd
> like to duplicate the uclibc code for musl in toolchain.eclass.
> 
> Feedback welcome.


-- 
Andreas K. Hüttel
dilfri...@gentoo.org
Gentoo Linux developer (council, perl, libreoffice)


signature.asc
Description: This is a digitally signed message part.