Re: [gentoo-dev] Should we allow "GPL, v2 or later" for ebuilds?

2020-01-27 Thread Rich Freeman
On Mon, Jan 27, 2020 at 6:41 AM Ulrich Mueller wrote: > > Historically, all ebuilds in the Gentoo repository were licensed under > GPL-2+. At a later point they were relicensed [1] to GPL-2. See [2] for > a rationale (or absence of it, YMMV). I think the historical policy made sense in its

[gentoo-dev] Last rites: dev-python/twisted-* (the rest of split packages)

2020-01-27 Thread Michał Górny
# Michał Górny (2020-01-27) # Remaining split Twisted packages. All remaining reverse dependencies # are entirely happy with merged dev-python/twisted. # Removal in 30 days. Bug #706636. dev-python/twisted-core dev-python/twisted-names dev-python/twisted-web dev-python/twisted-words -- Best

Re: [gentoo-dev] Should we allow "GPL, v2 or later" for ebuilds?

2020-01-27 Thread Jonas Stein
> Note that we could easily revert from GPL-2+ to GPL-2 if it would turn > out to be too much trouble. > > Thoughts? I would prefer a single license for all ebuilds. GPL-2+ or GPL-2 or GPL-... does not matter to me, I am willing to sign, that all my contributions may be licensed also as GPL-...

Re: [gentoo-dev] Should we allow "GPL, v2 or later" for ebuilds?

2020-01-27 Thread Michał Górny
On Mon, 2020-01-27 at 12:41 +0100, Ulrich Mueller wrote: > The following came up in #gentoo-qa yesterday, in a discussion between > mgorny, soap and myself. Hey, I was waiting for the Council agenda mail to discuss this ;-). > So, the question is, should we allow ebuilds > # Distributed under

[gentoo-dev] Should we allow "GPL, v2 or later" for ebuilds?

2020-01-27 Thread Ulrich Mueller
The following came up in #gentoo-qa yesterday, in a discussion between mgorny, soap and myself. Historically, all ebuilds in the Gentoo repository were licensed under GPL-2+. At a later point they were relicensed [1] to GPL-2. See [2] for a rationale (or absence of it, YMMV). However, in GLEP

Re: [gentoo-dev] Last rites: virtual/cargo

2020-01-27 Thread Georgy Yakovlev
On Mon, 27 Jan 2020 10:48:51 +0100 David Seifert wrote: > On Sun, 2020-01-26 at 21:53 -0500, Michael Orlitzky wrote: > > On 1/26/20 9:46 PM, Georgy Yakovlev wrote: > > > # update your rust packages running emerge with the > > > # --changed-deps option if you have problems > > > > If this advice

[gentoo-dev] Last rites: games-action/cs2d

2020-01-27 Thread Ulrich Mueller
# Ulrich Müller (2020-01-27) # Removal requested by proxied maintainer: # "Game already available in Valve Steam." # License issues, unclear if zipball is redistributable. # Masked for removal in 30 days. Bug #703496. games-action/cs2d signature.asc Description: PGP signature

[gentoo-dev] Last rites: dev-python/twisted-* split & related, no revdep packages

2020-01-27 Thread Michał Górny
# Michał Górny (2020-01-27) # Old split Twisted and related packages with no reverse dependencies # and only Python 2 support. # Removal in 30 days. Bug #706636. dev-python/axiom dev-python/epsilon dev-python/pyutil dev-python/twisted-conch dev-python/twisted-lore dev-python/twisted-mail

Re: [gentoo-dev] Last rites: virtual/cargo

2020-01-27 Thread David Seifert
On Sun, 2020-01-26 at 21:53 -0500, Michael Orlitzky wrote: > On 1/26/20 9:46 PM, Georgy Yakovlev wrote: > > # update your rust packages running emerge with the > > # --changed-deps option if you have problems > > If this advice helps, you have violated the PMS. > Agreed, if possible revbump any

[gentoo-dev] Last rites: dev-python/zsi

2020-01-27 Thread Michał Górny
# Michał Górny (2020-01-27) # Dead upstream. Last (alpha) release in 2007. Requires old version # of Twisted. Python 2-only. # Removal in 30 days. Bug #660660. dev-python/zsi -- Best regards, Michał Górny signature.asc Description: This is a digitally signed message part