Re: [gentoo-dev] Package up for grabs: x11-libs/libfm

2020-08-12 Thread Joonas Niilola

On 8/13/20 7:25 AM, Jimi Huotari wrote:
> Unless I'm being blind, the LXQt project does not need this one, making it
> 'maintainer-needed':
>
> x11-libs/libfm
>
Seems to be needed by LXDE stuff only. Regarding that, should we
last-rite remaining LXDE stuff? It's pretty clear the development has
shifted to LXQT, and LXDE seems abandoned upstream.

-- juippis




signature.asc
Description: OpenPGP digital signature


[gentoo-dev] Package up for grabs: x11-libs/libfm

2020-08-12 Thread Jimi Huotari
Unless I'm being blind, the LXQt project does not need this one, making it
'maintainer-needed':

x11-libs/libfm

See also:

- https://bugs.gentoo.org/show_bug.cgi?id=699016
- https://bugs.gentoo.org/show_bug.cgi?id=700186
- https://github.com/gentoo/gentoo/pull/17109


pgprURBlXgtec.pgp
Description: OpenPGP digital signature


[gentoo-portage-dev] [PATCH] lib/portage/xml/metadata.py: tolerate xml.parsers.expat import failures (bug 736912)

2020-08-12 Thread Zac Medico
Tolerate broken or missing xml support in python.
This reverts a behavior change from commit
935c47d972d986f1822850618442c19c97e300c3.

Fixes: 935c47d972d9 ("lib/portage/xml/metadata.py: fix ungrouped-imports 
w/refactor")
Bug: https://bugs.gentoo.org/736912
Signed-off-by: Zac Medico 
---
 lib/portage/xml/metadata.py | 5 -
 1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/lib/portage/xml/metadata.py b/lib/portage/xml/metadata.py
index 808ba2246..875cc4044 100644
--- a/lib/portage/xml/metadata.py
+++ b/lib/portage/xml/metadata.py
@@ -34,7 +34,10 @@ __all__ = ('MetaDataXML', 'parse_metadata_use')
 import re
 import xml.etree.ElementTree as etree
 
-from xml.parsers.expat import ExpatError
+try:
+   from xml.parsers.expat import ExpatError
+except Exception:
+   ExpatError = SyntaxError
 
 from portage import _encodings, _unicode_encode
 from portage.util import cmp_sort_key, unique_everseen
-- 
2.25.3




[gentoo-dev] Packages up for grabs: x11-misc/gpaste

2020-08-12 Thread Jonas Stein
Dear all

the following packages are up for grabs after retirement
of the proxied maintainer:

x11-misc/gpaste
https://packages.gentoo.org/packages/x11-misc/gpaste

-- 
Best,
Jonas



















































signature.asc
Description: OpenPGP digital signature


[gentoo-dev] Packages up for grabs: app-admin/apg

2020-08-12 Thread Jonas Stein
Dear all

the following packages are up for grabs after retirement
of the proxied maintainer:

app-admin/apg
https://packages.gentoo.org/packages/app-admin/apg

https://bugs.gentoo.org/629272
https://bugs.gentoo.org/643368

-- 
Best,
Jonas

















































signature.asc
Description: OpenPGP digital signature


Re: [gentoo-dev] rfc: switching default udev provider for new systems to udev

2020-08-12 Thread Tomas Mozes
On Sat, Aug 8, 2020 at 8:51 PM William Hubbs  wrote:

> All,
>
> I would like to propose that we switch the default udev provider on new
> systems from eudev to udev.
>
> This is not a lastrites, and it will not affect current systems since
> they have to migrate manually. Also, this change can be overridden at
> the profile level if some profile needs eudev (the last time I checked,
> this applies to non-glibc configurations).
>
> What do people think?
>
> Thanks,
>
> William
>
>
I had the opposite problem, udev failed to work with newer
udev-init-scripts so all my systems were migrated to eudev. Looking at the
bug report (https://bugs.gentoo.org/681586), some of the others had the
same experience.

It was a drop-in replacement for me, personally I don't care if I have udev
or eudev installed (if it works).

Tomas