Re: [gentoo-dev] Asking for permission to update packages from LINGUAS to L10N

2016-08-10 Thread Ben de Groot
On 11 August 2016 at 04:22, NP-Hardass wrote: > Looks to me like we can't edit that eclass in place, so if we are to > keep it, we should probably revbump it, update the -r1 to L10N, and add > a deprecation warning to the old eclass to help maintainers migrate over. > > Any

Re: [gentoo-dev] .gitignore

2015-08-14 Thread Ben de Groot
On 14 August 2015 at 14:02, Michał Górny mgo...@gentoo.org wrote: Dnia 2015-08-13, o godz. 21:17:22 Patrick McLean chutz...@gentoo.org napisał(a): We should have common editor artifacts and backup files in there, I generally use this in just about every repository I touch: *~ .*.sw[po]

Re: [gentoo-dev] Re: Referencing bug reports in git

2015-08-13 Thread Ben de Groot
I vote for a simple Bug: 333531 If it is going to be any longer than that, then you need to make sure it is part of the commit message template magic. Because I'm surely not the only one who is lazy and thus averse to typing anything longer for the most common use case: Gentoo bugs. -- Cheers,

Re: [gentoo-dev] useflag policies

2015-08-05 Thread Ben de Groot
On 4 August 2015 at 22:56, Ian Stakenvicius a...@gentoo.org wrote: Are there any cases where things actually break if a package has both flags enabled? IE, is three a package with IUSE=qt4 qt5 that when both flags are enabled would build for qt5 only, and happens to be a dependency atom of

Re: [gentoo-dev] useflag policies

2015-08-05 Thread Ben de Groot
On 5 August 2015 at 03:09, Davide Pesavento p...@gentoo.org wrote: On Mon, Aug 3, 2015 at 8:59 PM, Ben de Groot yng...@gentoo.org wrote: On 4 August 2015 at 04:20, Rich Freeman ri...@gentoo.org wrote: [...] Gentoo should be the best of both worlds. We should give users the power to tweak

Re: [gentoo-dev] useflag policies

2015-08-03 Thread Ben de Groot
On 4 August 2015 at 04:20, Rich Freeman ri...@gentoo.org wrote: [...] Gentoo should be the best of both worlds. We should give users the power to tweak things, but we shouldn't force them to play with config files all day long just to have a functional system. If users want to care we let

Re: [gentoo-dev] useflag policies

2015-08-02 Thread Ben de Groot
On 3 August 2015 at 01:33, Andrew Savchenko birc...@gentoo.org wrote: On Mon, 3 Aug 2015 00:34:51 +0800 Ben de Groot wrote: [...] This policy will allow to USE both qt versions whichever is available preferring newer one. Quite reasonable approach. Alternatives (^^() and ??()) will require

Re: [gentoo-dev] useflag policies

2015-08-02 Thread Ben de Groot
On 3 August 2015 at 09:37, Rich Freeman ri...@gentoo.org wrote: On Sun, Aug 2, 2015 at 9:03 PM, Patrick Lauer patr...@gentoo.org wrote: I find setting USE=qt4 -qt5 a lot more obvious than having USE=qt (why not USE=X ?) which then does different things based on another useflag, sometimes.

Re: [gentoo-dev] useflag policies

2015-08-02 Thread Ben de Groot
On 3 August 2015 at 11:30, Rich Freeman ri...@gentoo.org wrote: On Sun, Aug 2, 2015 at 11:24 PM, Ben de Groot yng...@gentoo.org wrote: I want to use fooplayer and bargrapher which are two qt-based applications. fooplayer only supports qt4, and bargrapher only supports qt5. What USE flags

[gentoo-dev] useflag policies

2015-08-02 Thread Ben de Groot
Recently some team members of the Qt project have adopted these ebuild policies: https://wiki.gentoo.org/wiki/Project:Qt/Policies I have an issue with the policy adopted under Requires one of two Qt versions. In my opinion, in the case where a package offers a choice between qt4 or qt5, we should

Re: [gentoo-dev] Re: Reverted python3.4 defaults

2015-07-21 Thread Ben de Groot
On 20 July 2015 at 17:27, Jason Zaman perfin...@gentoo.org wrote: On Mon, Jul 20, 2015 at 10:39:25AM +0200, Dirkjan Ochtman wrote: On Mon, Jul 20, 2015 at 6:03 AM, Ben de Groot yng...@gentoo.org wrote: I would like to hear from the other team members, yes. I have sympathy towards those who

Re: [gentoo-dev] Re: Reverted python3.4 defaults

2015-07-19 Thread Ben de Groot
On 20 July 2015 at 00:03, Mike Gilbert flop...@gentoo.org wrote: If there are no objections, I would like to enable python3.4 by default on Saturday, July 25. That means making the following change: profiles/base/make.defaults: PYTHON_TARGETS=python2_7 python3_4 I would like to note that we

Re: [gentoo-dev] Re: Reverted python3.4 defaults

2015-07-19 Thread Ben de Groot
On 20 July 2015 at 02:31, Mike Gilbert flop...@gentoo.org wrote: On Sun, Jul 19, 2015 at 12:42 PM, Ben de Groot yng...@gentoo.org wrote: On 20 July 2015 at 00:03, Mike Gilbert flop...@gentoo.org wrote: If there are no objections, I would like to enable python3.4 by default on Saturday, July 25

Re: [gentoo-dev] Re: Reverted python3.4 defaults

2015-07-19 Thread Ben de Groot
On 20 July 2015 at 01:01, Anthony G. Basile bluen...@gentoo.org wrote: On 7/19/15 12:42 PM, Ben de Groot wrote: On 20 July 2015 at 00:03, Mike Gilbert flop...@gentoo.org wrote: If there are no objections, I would like to enable python3.4 by default on Saturday, July 25. That means making

Re: [gentoo-dev] Problems updating Qt from 4.8.6 to 4.8.7

2015-07-05 Thread Ben de Groot
On 6 July 2015 at 03:25, Sebastian Pipping sp...@gentoo.org wrote: On 05.07.2015 20:44, Alexandre Rostovtsev wrote: What I usually end up doing is listing my installed dev-qt/qt* ebuilds, and updating all of them together explicitly: emerge -1 qtcore:4 qtgui:4 qtsql:4 etc. That's what I

Re: [gentoo-dev] RFC News item: FFmpeg default

2015-04-16 Thread Ben de Groot
On 11 April 2015 at 15:19, Ben de Groot yng...@gentoo.org wrote: And since this is now on the Council's agenda, we're waiting for their decision. Since the Council had no objections, this has now been committed. Thanks for all the feedback. -- Cheers, Ben | yngwin Gentoo developer

Re: [gentoo-dev] RFC News item: FFmpeg default

2015-04-11 Thread Ben de Groot
On 7 April 2015 at 15:00, Alexis Ballier aball...@gentoo.org wrote: On Tue, 7 Apr 2015 07:13:16 +0800 Ben de Groot yng...@gentoo.org wrote: Please also note that some packages support only one of the two implementations. An attempt to install one of those packages may result in blockers

Re: [gentoo-dev] libressl status

2015-04-06 Thread Ben de Groot
On 7 April 2015 at 06:07, Jason A. Donenfeld zx...@gentoo.org wrote: Solution: Packages that will compile against either one get || (openssl libressl). Packages that require a specific one will just have that one listed. Openssl will block Libressl and vice versa. This would result in a

Re: [gentoo-dev] RFC News item: FFmpeg default

2015-04-06 Thread Ben de Groot
On 6 April 2015 at 17:35, Michał Górny mgo...@gentoo.org wrote: Dnia 2015-04-06, o godz. 14:10:12 Ben de Groot yng...@gentoo.org napisał(a): On 30 March 2015 at 00:23, Michał Górny mgo...@gentoo.org wrote: Dnia 2015-03-30, o godz. 00:07:16 Include example code. Updated version

Re: [gentoo-dev] RFC News item: FFmpeg default

2015-04-06 Thread Ben de Groot
On 30 March 2015 at 00:23, Michał Górny mgo...@gentoo.org wrote: Dnia 2015-03-30, o godz. 00:07:16 Include example code. Updated version: Title: FFmpeg default Author: Ben de Groot yng...@gentoo.org Content-Type: text/plain Posted: 2015-04-07 Revision: 1 News-Item-Format: 1.0 Display

[gentoo-dev] RFC News item: FFmpeg default

2015-03-29 Thread Ben de Groot
Title: FFmpeg default Author: Ben de Groot yng...@gentoo.org Content-Type: text/plain Posted: 2015-04-01 Revision: 1 News-Item-Format: 1.0 Display-If-Installed: virtual/ffmpeg Since the choice between ffmpeg and libav has been made more explicit, there has been a lot of discussion about what

[gentoo-dev] Last-rite x11-themes/gtk-engines-qtcurve

2015-03-28 Thread Ben de Groot
# Ben de Groot yng...@gentoo.org (29 Mar 2015) # Merged with qtcurve-qt4 into x11-themes/qtcurve (with gtk useflag) # Removal in 30 days. See also bug #544406. x11-themes/gtk-engines-qtcurve -- Cheers, Ben | yngwin Gentoo developer

Re: [gentoo-dev] RFC: app-eselect category

2015-03-28 Thread Ben de Groot
On 29 March 2015 at 04:47, Ulrich Mueller u...@gentoo.org wrote: Now the number of eselect-* packages in the app-admin category has grown to 52. Should we create a new app-eselect category for them? I think this is a good idea. So +1 from me. -- Cheers, Ben | yngwin Gentoo developer

Re: [gentoo-dev] rfc: zsh completions -- optional or mandatory?

2015-03-27 Thread Ben de Groot
On 27 March 2015 at 00:51, William Hubbs willi...@gentoo.org wrote: The other method is shown by dev-vcs/hub at least, and maybe several other packages -- e.g. unconditionally installing the completions according to our small files installation practice and not reflecting the rdepend on

Re: [gentoo-dev] Re: multilib amd64 news item for review

2015-03-18 Thread Ben de Groot
On 18 March 2015 at 20:46, Duncan 1i5t5.dun...@cox.net wrote: Ben de Groot posted on Wed, 18 Mar 2015 15:40:02 +0800 as excerpted: On 17 March 2015 at 23:33, Michał Górny mgo...@gentoo.org wrote: Dnia 2015-03-15, o godz. 15:11:47 Michał Górny mgo...@gentoo.org napisał(a): Here's -r1

Re: [gentoo-dev] multilib amd64 news item for review

2015-03-18 Thread Ben de Groot
On 17 March 2015 at 23:33, Michał Górny mgo...@gentoo.org wrote: Dnia 2015-03-15, o godz. 15:11:47 Michał Górny mgo...@gentoo.org napisał(a): Here's -r1: [...] I think this is really great! Just one small nitpick: Note that after performing this step, 32-bit applications on user's system

Re: [gentoo-dev] Re: [gentoo-dev-announce] Last rites: media-video/mplayer2 media-video/smplayer2

2015-03-16 Thread Ben de Groot
On 16 March 2015 at 21:54, Юра Цимбалов yura.t...@gmail.com wrote: That would be great, but it depends on getting newer mpv stable, while (s)mplayer2 is dead and broken right now. https://bugs.gentoo.org/buglist.cgi?quicksearch=mplayer2list_id=2703540 Why it's broken? As stated in my

Re: [gentoo-dev] Re: [gentoo-dev-announce] Last rites: media-video/mplayer2 media-video/smplayer2

2015-03-16 Thread Ben de Groot
On 16 March 2015 at 19:17, Alexander Berntsen berna...@gentoo.org wrote: -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 On 16/03/15 11:09, Nikos Chantziaras wrote: On 16/03/15 11:58, Alexander Berntsen wrote: Does smplayer work with mpv? Version 14.9.0.6690 and up supports mpv. Then I

Re: [gentoo-dev] multilib amd64 news item for review

2015-03-15 Thread Ben de Groot
On 15 March 2015 at 22:43, Ulrich Mueller u...@gentoo.org wrote: On Sun, 15 Mar 2015, Michał Górny wrote: Hello, everyone. Here's the first draft of news item for gx86-multilib. I tried to cover all the important aspects. Please review and let me know what you think. Title: True multilib

[gentoo-dev] Last rites: media-video/mplayer2 media-video/smplayer2

2015-03-15 Thread Ben de Groot
# Ben de Groot yng...@gentoo.org (15 Mar 2015) # These projects have been abandoned upstream. Most mplayer2 devs have moved # on to media-video/mpv, and users are suggested to do the same. We have # media-video/baka-mplayer and media-video/smplayer available as Qt-based GUIs. # See bugs 452484

Re: [gentoo-dev] Naming of repositories: gento-x86 edition, bike shedding wanted

2015-03-14 Thread Ben de Groot
On 15 March 2015 at 06:34, Andreas K. Huettel dilfri...@gentoo.org wrote: imho, Questions: 0. What names for the tree/repository. gentoo (it's also the repo_name) Our repo is already named gentoo, so this makes the most sense. But I wouldn't mind gentoo-main either. But then we should

[gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in profiles/base: package.use.mask

2015-03-14 Thread Ben de Groot
mr_bones_15/03/09 18:15:22 Modified: package.use.mask Log: hide the qt5 stuff for yabause for now [...] +# Michael Sterrett mr_bones_@g.o (09 Mar 2015) +# Mask qt5 support until qt5 is stable so as to not +# hold up making yabause stable. +games-emulation/yabause

Re: [gentoo-dev] Re: Should there be a preference with qt4 and qt5 USE flags?

2015-03-09 Thread Ben de Groot
On 9 March 2015 at 04:17, Johannes Huber j...@gentoo.org wrote: Am Sonntag, 8. März 2015, 21:50:02 schrieb Nikos Chantziaras: On 08/03/15 21:35, Alexandre Rostovtsev wrote: On Sun, 2015-03-08 at 21:31 +0200, Nikos Chantziaras wrote: Some ebuilds in portage for Qt-based software support both

Re: [gentoo-dev] Re: Fonts project meeting and elections

2015-03-04 Thread Ben de Groot
On 1 March 2015 at 23:36, Guilherme Amadio ama...@gentoo.org wrote: On Sun, Mar 01, 2015 at 08:59:38PM +0800, Ben de Groot wrote: On 28 February 2015 at 19:52, Michael Orlitzky m...@gentoo.org wrote: On 02/28/2015 01:47 AM, Ben de Groot wrote: If we do the use expand, we should leave it up

Re: [gentoo-dev] Re: Fonts project meeting and elections

2015-03-01 Thread Ben de Groot
On 28 February 2015 at 19:52, Michael Orlitzky m...@gentoo.org wrote: On 02/28/2015 01:47 AM, Ben de Groot wrote: Since this is mostly used for web developers, I recommend to leave it off for desktop users, but possibly on for servers, for example. If we do the use expand, we should leave

Re: [gentoo-dev] [RFC] luajit global useflag

2015-03-01 Thread Ben de Groot
On 26 February 2015 at 22:44, Michał Górny mgo...@gentoo.org wrote: Ben de Groot yng...@gentoo.org napisał: % quse -D luajit local:luajit:app-editors/gvim: Use dev-lang/luajit instead of dev-lang/lua local:luajit:app-editors/vim: Use dev-lang/luajit instead of dev-lang/lua local:luajit:app

Re: [gentoo-dev] Re: Fonts project meeting and elections

2015-02-27 Thread Ben de Groot
On 28 February 2015 at 00:26, Guilherme Amadio ama...@gentoo.org wrote: On Fri, Feb 27, 2015 at 03:45:23PM +0800, Ben de Groot wrote: 1. lu_zero, matsuu, pva: do you still want to be members of the Fonts project? Then add yourselves to the new project page: https://wiki.gentoo.org/wiki

Re: [gentoo-dev] Re: Fonts project meeting and elections

2015-02-27 Thread Ben de Groot
On 27 February 2015 at 18:34, Peter Stuge pe...@stuge.se wrote: Ben de Groot wrote: I propose that we prefer installing just OpenType. But this should be user configurable, so in those cases I propose we do: IUSE=+opentype if use opentype; then FONT_SUFFIX=otf else FONT_SUFFIX=ttf

[gentoo-dev] Re: Fonts project meeting and elections

2015-02-26 Thread Ben de Groot
On 22 February 2015 at 03:43, Ben de Groot yng...@gentoo.org wrote: To anyone within Gentoo who is interested in fonts I would like to announce a meeting to be held in #gentoo-meetings on Freenode, on Friday February 27 at 06:00 UTC, unless another date and/or time will be suggested by people

Re: [gentoo-dev] [PATCH] qmake-utils.eclass: add qt{4,5}_get_bindir helper functions

2015-02-25 Thread Ben de Groot
On 20 February 2015 at 04:06, Jeroen Roovers j...@gentoo.org wrote: On Wed, 18 Feb 2015 19:58:29 +0800 Ben de Groot yng...@gentoo.org wrote: The attached patch proposes two helper functions to be added to qmake-utils.eclass. These functions echo the correct directory where qt binaries

[gentoo-dev] [RFC] luajit global useflag

2015-02-25 Thread Ben de Groot
% quse -D luajit local:luajit:app-editors/gvim: Use dev-lang/luajit instead of dev-lang/lua local:luajit:app-editors/vim: Use dev-lang/luajit instead of dev-lang/lua local:luajit:app-editors/vim-qt: Use dev-lang/luajit instead of dev-lang/lua local:luajit:games-action/minetest: Use

Re: [gentoo-dev] [RFC] please review ebuilds for neovim and deps

2015-02-23 Thread Ben de Groot
On 23 February 2015 at 14:17, Vadim A. Misbakh-Soloviov m...@mva.name wrote: I'd also say: neovim: CDEPEND=dev-lang/luajit ... dev-lua/LuaBitOp 1) I'm not sure luajit:1 fits the dep 2) LuaJIT:2 has it's own bit modules and is unneded LuaBitOp Thanks! I don't know that much about

Re: [gentoo-dev] [RFC] please review ebuilds for neovim and deps

2015-02-22 Thread Ben de Groot
On 23 February 2015 at 01:39, William Hubbs willi...@gentoo.org wrote: On Sat, Feb 21, 2015 at 09:18:08AM +0100, Michał Górny wrote: neovim: # Copyright 1999-2015 Gentoo Foundation # Distributed under the terms of the GNU General Public License v2 # $Header: $ EAPI=5 inherit

Re: [gentoo-dev] Fonts project meeting and elections

2015-02-22 Thread Ben de Groot
On 22 February 2015 at 23:27, Guilherme Amadio ama...@gentoo.org wrote: Hello, On Sun, Feb 22, 2015 at 03:43:33AM +0800, Ben de Groot wrote: To anyone within Gentoo who is interested in fonts I would like to announce a meeting to be held in #gentoo-meetings on Freenode, on Friday February

Re: [gentoo-dev] Hello Everyone

2015-02-22 Thread Ben de Groot
On 22 February 2015 at 20:05, Tushar Rajput tushra...@gmail.com wrote: I am novice programmer and wants to contribute to gentoo.Can you give me some details? Thanks We actually have a wiki page that does: https://wiki.gentoo.org/wiki/Contributing_to_Gentoo -- Cheers, Ben | yngwin Gentoo

Re: [gentoo-dev] Fonts project meeting and elections

2015-02-22 Thread Ben de Groot
On 22 February 2015 at 17:52, Alexis Ballier aball...@gentoo.org wrote: Hi Ben, On Sun, 22 Feb 2015 03:43:33 +0800 Ben de Groot yng...@gentoo.org wrote: To anyone within Gentoo who is interested in fonts I would like to announce a meeting to be held in #gentoo-meetings on Freenode

Re: [gentoo-dev] [RFC] please review ebuilds for neovim and deps

2015-02-21 Thread Ben de Groot
On 21 February 2015 at 16:18, Michał Górny mgo...@gentoo.org wrote: Hi, Don't you think it sucks to review a few ebuilds in one e-mail? :) No. :) neovim: # Copyright 1999-2015 Gentoo Foundation # Distributed under the terms of the GNU General Public License v2 # $Header: $ EAPI=5

[gentoo-dev] Fonts project meeting and elections

2015-02-21 Thread Ben de Groot
To anyone within Gentoo who is interested in fonts I would like to announce a meeting to be held in #gentoo-meetings on Freenode, on Friday February 27 at 06:00 UTC, unless another date and/or time will be suggested by people who want to attend. There hasn't been much activity in the fonts area

[gentoo-dev] Fonts project meeting and elections

2015-02-21 Thread Ben de Groot
To anyone within Gentoo who is interested in fonts I would like to announce a meeting to be held in #gentoo-meetings on Freenode, on Friday February 27 at 06:00 UTC, unless another date and/or time will be suggested by people who want to attend. There hasn't been much activity in the fonts area

[gentoo-dev] Last rites: media-fonts/culmus-ancient

2015-02-20 Thread Ben de Groot
# Ben de Groot yng...@gentoo.org (21 Feb 2015) # Duplicates media-fonts/culmus[ancient] (bug #486814). # Masked for removal in 30 days. media-fonts/culmus-ancient -- Cheers, Ben | yngwin Gentoo developer

[gentoo-dev] [RFC] please review ebuilds for neovim and deps

2015-02-20 Thread Ben de Groot
At the suggestion of radhermit, I'm putting my neovim deps ebuilds up here for review, before I commit them to the official tree. Do you see any possible improvements? Right now the neovim ebuild does not install any global default nvimrc like we do with vim. We should probably consider doing

[gentoo-dev] [PATCH] qmake-utils.eclass: add qt{4,5}_get_bindir helper functions

2015-02-18 Thread Ben de Groot
The attached patch proposes two helper functions to be added to qmake-utils.eclass. These functions echo the correct directory where qt binaries such as moc and lrelease are located. They can be used in ebuilds when such binaries need to be called directly. (Ebuilds should not rely on qtchooser

Re: [gentoo-dev] ffmpeg vs libav choice of default

2015-02-14 Thread Ben de Groot
On 4 February 2015 at 17:26, Alexis Ballier aball...@gentoo.org wrote: On Wed, 4 Feb 2015 10:12:12 +0100 Ulrich Mueller u...@gentoo.org wrote: With the recent introduction of the libav USE flag, the Gentoo default for ffmpeg vs libav is more pronounced than it was before (with libav being

Re: [gentoo-dev] Git mirror news: travis-ci running repoman, git-cvs merge revert tools

2015-02-09 Thread Ben de Groot
On 8 February 2015 at 18:38, Michał Górny mgo...@gentoo.org wrote: Hello, everyone. I would like to announce that our little rsync-git band-aid mirror [1] is doing fine and we're actively working towards improving Gentoo development experience. First of all, we have enabled tree-wide

Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in games-board/stockfish: stockfish-6.ebuild metadata.xml Manifest ChangeLog

2015-02-07 Thread Ben de Groot
On 7 February 2015 at 23:06, hasufell hasuf...@gentoo.org wrote: DEPEND= unzip is missing from DEPEND I thought portage auto-depends on this. But I can add || ( unzip zip ) to be explicit. I don't know, but it's definitely not in @system. Afair we are only allowed to omit deps from that

Re: [gentoo-dev] ffmpeg vs libav choice of default

2015-02-06 Thread Ben de Groot
On 7 February 2015 at 07:03, Jason A. Donenfeld zx...@gentoo.org wrote: Welp, the votes clearly show ffmpeg is desired by users. Can we stop this nonsense and just do that? The people have spoken. Ffmpeg shall be default. Except Gentoo is not a democracy. It is still important data to take

[gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in games-board/stockfish: stockfish-6.ebuild metadata.xml Manifest ChangeLog

2015-02-06 Thread Ben de Groot
On 7 February 2015 at 00:59, hasufell hasuf...@gentoo.org wrote: Ben de Groot (yngwin): yngwin 15/02/05 20:09:33 Added:stockfish-6.ebuild metadata.xml Manifest ChangeLog Log: Initial commit (bug #318337) First off: thank you for the review! EAPI=5 inherit

Re: [gentoo-dev] Re: ffmpeg vs libav choice of default

2015-02-06 Thread Ben de Groot
On 7 February 2015 at 10:08, Mike Auty ike...@gentoo.org wrote: [...] I was concerned that a warning which had been in place in package.mask since September was removed by a different developer than the one who put it in place, I discussed this beforehand with said developer on IRC. and

Re: [gentoo-dev] ffmpeg vs libav choice of default

2015-02-06 Thread Ben de Groot
On 6 February 2015 at 00:20, hasufell hasuf...@gentoo.org wrote: Ben de Groot: On 4 February 2015 at 21:49, Chí-Thanh Christopher Nguyễn chith...@gentoo.org wrote: Ulrich Mueller schrieb: In the replies to http://forums.gentoo.org/viewtopic.php?p=7694982 several users have expressed

Re: [gentoo-dev] ffmpeg vs libav choice of default

2015-02-06 Thread Ben de Groot
On 4 February 2015 at 20:43, Mike Auty ike...@gentoo.org wrote: Whilst the default *is* still in place (and particularly after the recent news article detailing that users should be using libav), could we please keep commits like the following until *after* we've made an agreed upon decision

Re: [gentoo-dev] ffmpeg vs libav choice of default

2015-02-05 Thread Ben de Groot
On 4 February 2015 at 21:49, Chí-Thanh Christopher Nguyễn chith...@gentoo.org wrote: Ulrich Mueller schrieb: In the replies to http://forums.gentoo.org/viewtopic.php?p=7694982 several users have expressed their preference for ffmpeg. To help finding out what users actually think, I added a

Re: [gentoo-dev] ffmpeg vs libav choice of default

2015-02-04 Thread Ben de Groot
On 4 February 2015 at 17:21, Michał Górny mgo...@gentoo.org wrote: Dnia 2015-02-04, o godz. 10:12:12 Ulrich Mueller u...@gentoo.org napisał(a): With the recent introduction of the libav USE flag, the Gentoo default for ffmpeg vs libav is more pronounced than it was before (with libav being

Re: [gentoo-dev] ffmpeg vs libav choice of default

2015-02-04 Thread Ben de Groot
On 4 February 2015 at 17:55, Michał Górny mgo...@gentoo.org wrote: Dnia 2015-02-04, o godz. 17:24:03 Ben de Groot yng...@gentoo.org napisał(a): From an upstream that I care about: https://github.com/mpv-player/mpv/wiki/FFmpeg-versus-Libav Based on that I would say we should switch back

Re: [gentoo-dev] Quick RFC: USE=libav vs FFMPEG_IMPL=libav|ffmpeg

2015-02-02 Thread Ben de Groot
On 3 February 2015 at 00:00, Michael Orlitzky m...@gentoo.org wrote: On 02/02/2015 10:50 AM, Michał Górny wrote: Maybe. Though it still will keep the confusion of !libav meaning ffmpeg. We could remove USE=libav from the tree, leaving only USE=ffmpeg. Then ffmpeg_impl_libav would switch the

Re: [gentoo-dev] git.gentoo.org/git.overlays.gentoo.org upgrades, 2014/12/24 2014/12/26: gitolite upgrade done

2014-12-28 Thread Ben de Groot
On 28 December 2014 at 11:36, Robin H. Johnson robb...@gentoo.org wrote: We are now running gitolite-gentoo-3.6.2.1, a huge jump from our prior 2.3.3. File a bug if you see anything weird, and ping me in IRC (#gentoo-dev) if you think it's urgent. There still is no web interface for browsing

Re: [gentoo-dev] rfc: glibc versions prior to 2.19-r1

2014-12-24 Thread Ben de Groot
On 23 December 2014 at 00:11, Andreas K. Huettel dilfri...@gentoo.org wrote: +1 for an archive overlay I set up the graveyard overlay for such purposes, a couple of years ago. But it hasn't taken off: https://github.com/gentoo/graveyard Feel free to resurrect it. (pun intended) -- Cheers,

Re: [gentoo-dev] Make 'vaapi' USE flag global

2014-11-30 Thread Ben de Groot
On 28 November 2014 at 20:20, Sergey Popov pinkb...@gentoo.org wrote: Packages that uses 'vaapi' local USE-flag: media-libs/avidemux-core media-libs/xine-lib media-tv/mythtv media-tv/xbmc media-video/avidemux media-video/ffmpeg media-video/hwdecode-demos media-video/libav.

Re: [gentoo-dev] Last rites: razorqt-base/*

2014-11-08 Thread Ben de Groot
On 8 November 2014 19:15, Jauhien Piatlicki jauh...@gentoo.org wrote: Hi Ben, Have you read comments on Qt overlay commit? Have you check reverse dependencies of packages you are masking? razorqt-base/libqtxdg is used by LXQt. So, please, unmask it. I will move it into lxqt-base category.

[gentoo-dev] Last rites: razorqt-base/*

2014-11-07 Thread Ben de Groot
# Ben de Groot yng...@gentoo.org (7 Nov 2014) # Unmaintained, no longer supported, and starting to throw compilation # errors (bug #513906, bug #528372). Masked for removal in 30 days. # Update to lxqt-base/* packages. razorqt-base/libqtxdg razorqt-base/razorqt-appswitcher razorqt-base/razorqt

Re: [gentoo-dev] Add bc back to the stage3

2014-09-27 Thread Ben de Groot
On 27 September 2014 20:40, Ciaran McCreesh ciaran.mccre...@googlemail.com wrote: On Sat, 27 Sep 2014 18:31:03 +0600 Vladimir Romanov bluebo...@gmail.com wrote: Em. I don't agree. I prefer Emacs and don't like Vim. But if i must choose between Vim and Nano, i prefer Nano But vi is POSIX. vi

Re: [gentoo-dev] gentoo-x86 tree cleanup for 'DESCRIPTION ends with a '.' character' warnings

2014-08-18 Thread Ben de Groot
On 13 August 2014 02:46, Michał Górny mgo...@gentoo.org wrote: Dnia 2014-08-11, o godz. 20:48:20 William Hubbs willi...@gentoo.org napisał(a): got a minor (but chatty) QA warning: DESCRIPTION ends with a '.' character Why is this a QA warning in the first place? Because it is a

Re: [gentoo-dev] Supporting both Qt4 and Qt5 builds

2014-08-11 Thread Ben de Groot
On 10 August 2014 18:51, Georg Rudoy 0xd34df...@gmail.com wrote: Hi, I'm thinking of converting a few ebuilds (x11-libs/qwt, dev-libs/kqoauth, net-libs/qxmpp among them) to support building with both Qt4 and Qt5. Should this better be done by adding the corresponding useflags (qt4 and qt5

Re: [gentoo-dev] New category lxqt-base

2014-05-12 Thread Ben de Groot
On 12 May 2014 03:28, Jauhien Piatlicki jauh...@gentoo.org wrote: Hi all, LXQt 0.7.0 has been released [1]. As it is project different from LXDE That is debatable. LXQt is released by the merged LXDE and Razor-Qt upstreams. One could say there are simply two expressions of LXDE now: one in

Re: [gentoo-dev] Re: Banning modification of pkg-config files

2014-05-09 Thread Ben de Groot
On 10 May 2014 04:34, Markos Chandras hwoar...@gentoo.org wrote: On 05/09/2014 09:32 PM, Tom Wijsman wrote: On Fri, 9 May 2014 16:15:58 -0400 Rich Freeman ri...@gentoo.org wrote: I think fixing upstream is a no-brainer. It indeed is, this is the goal; you can force them in multiple ways,

[gentoo-dev] Packages up for grabs / looking for new primary maintainers

2014-04-20 Thread Ben de Groot
As my time is limited, and certain issues also drain my motivation, I am stepping down as primary maintainer for the following packages. They are also assigned to a herd, but since these are relatively high maintenance they need a dedicated maintainer. (And fonts herd has been basically inactive

Re: [gentoo-dev] Stable masks on multilib packages

2014-04-02 Thread Ben de Groot
On 1 April 2014 21:58, Alexandre Rostovtsev tetrom...@gentoo.org wrote: On Tue, 2014-04-01 at 13:13 +0800, Ben de Groot wrote: On 1 April 2014 06:16, Michał Górny mgo...@gentoo.org wrote: Hello, all. The late multilib ppc issues made me re-check our stable masks on abi_x86_* flags

Re: [gentoo-dev] Stable masks on multilib packages

2014-04-02 Thread Ben de Groot
On 2 April 2014 07:38, Patrick Lauer patr...@gentoo.org wrote: On 04/01/2014 01:13 PM, Ben de Groot wrote: On 1 April 2014 06:16, Michał Górny mgo...@gentoo.org wrote: Hello, all. The late multilib ppc issues made me re-check our stable masks on abi_x86_* flags and, honestly, I'm not sure

Re: [gentoo-dev] Stable masks on multilib packages

2014-03-31 Thread Ben de Groot
On 1 April 2014 06:16, Michał Górny mgo...@gentoo.org wrote: Hello, all. The late multilib ppc issues made me re-check our stable masks on abi_x86_* flags and, honestly, I'm not sure if we're doing things the right way. That said, I have an alternate idea inspired by the ppc breakage.

Re: [gentoo-dev] RFC: GTK USE flag situation (gtk, gtk2, gtk3; relevant to bug #420493)

2014-02-18 Thread Ben de Groot
On 12 February 2014 07:04, Samuli Suominen ssuomi...@gentoo.org wrote: [...] It's sad that people don't follow common sense (which happens to be the GNOME highlights) and that everything must be turned into a policy of somesort so people get it. [...] Just make the gnome gtk3 policy the

Re: [gentoo-dev] Please consider removing use.stable.mask and package.use.stable.mask

2013-11-14 Thread Ben de Groot
On 14 November 2013 13:13, Michał Górny mgo...@gentoo.org wrote: Dnia 2013-11-14, o godz. 07:49:55 Patrick Lauer patr...@gentoo.org napisał(a): On 11/13/2013 11:02 PM, Ian Stakenvicius wrote: It's also worth pointing out that the whole reason why abi_x86_32 is {package.,}use.stable.masked

Re: [gentoo-dev] Please consider removing use.stable.mask and package.use.stable.mask

2013-11-14 Thread Ben de Groot
On 14 November 2013 20:32, Rich Freeman ri...@gentoo.org wrote: On Thu, Nov 14, 2013 at 7:21 AM, Ben de Groot yng...@gentoo.org wrote: On 14 November 2013 13:13, Michał Górny mgo...@gentoo.org wrote: And how is it possible to discuss anything properly in Gentoo? That's because we have

Re: [gentoo-dev] Please consider removing use.stable.mask and package.use.stable.mask

2013-11-14 Thread Ben de Groot
On 14 November 2013 23:12, Rich Freeman ri...@gentoo.org wrote: On Thu, Nov 14, 2013 at 7:57 AM, Ben de Groot yng...@gentoo.org wrote: I said As it is always happy to point out, Council doesn't see itself as leadership, just as a supreme court of appeal, when everything else seems to have

Re: [gentoo-dev] Please consider removing use.stable.mask and package.use.stable.mask

2013-11-14 Thread Ben de Groot
On 15 November 2013 01:32, Rich Freeman ri...@gentoo.org wrote: On Thu, Nov 14, 2013 at 11:38 AM, Ben de Groot yng...@gentoo.org wrote: I was particularly hit by this as maintainer of freetype, see bugs 455070 and 459352 for some of the mess that could have been avoided. Looks like 455070

Re: [gentoo-dev] Policy-level discussion for minimum versions on dependencies

2013-11-08 Thread Ben de Groot
On 8 November 2013 08:55, Rémi Cardona r...@gentoo.org wrote: Le jeudi 07 novembre 2013 à 10:44 +0100, Alexis Ballier a écrit : in short: if a package requires version X then the ebuild should require version X; it can be forgotten but it's a bug. That _is_ our policy. Since this thread was

Re: [gentoo-dev] Releng breakage with respect to move from dev-python/python-exec to dev-lang/python-exec

2013-11-03 Thread Ben de Groot
On 3 November 2013 17:02, Alan McKinnon alan.mckin...@gmail.com wrote: On 03/11/2013 01:45, yac wrote: Afaik there is no official way to update gentoo, is there? It's always been emerge -avuND world I personally got used to -uaNDv and I don't even know what exactly is the difference and

Re: [gentoo-dev] rfc: converting /etc/mtab to a symlink

2013-10-14 Thread Ben de Groot
On 14 October 2013 03:32, William Hubbs willi...@gentoo.org wrote: All, from what I'm seeing, we should look into converting /etc/mtab to a symlink to /proc/self/mounts [1]. Are there any remaining concerns about doing this? If not, it seems like it would be pretty easy to make baselayout

Re: [gentoo-dev] Re: sys-kernel/tuxonice-sources up for grabs

2013-09-22 Thread Ben de Groot
On 23 September 2013 08:14, Ian Stakenvicius a...@gentoo.org wrote: -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 On 21/09/13 08:21 PM, Rick Zero_Chaos Farina wrote: On 09/21/2013 08:44 AM, Pacho Ramos wrote: El sáb, 21-09-2013 a las 14:42 +0200, Pacho Ramos escribió: I don't have time

Re: [gentoo-dev] [RFC] git.eclass, git-2.eclass... git-r1.eclass?

2013-08-28 Thread Ben de Groot
On 28 August 2013 16:00, Michał Górny mgo...@gentoo.org wrote: Hello, all. I think I'm finally ready to put all the breaking awesomeness that was waiting for the git eclasses. However, I'm wondering what's the best way of proceeding with it. We've just lately finished the git-git-2 eclass

Re: [gentoo-dev] Moving more arches to dev profiles

2013-08-22 Thread Ben de Groot
On 22 August 2013 18:01, Rich Freeman ri...@gentoo.org wrote: On Thu, Aug 22, 2013 at 1:39 AM, Ben de Groot yng...@gentoo.org wrote: On 22 August 2013 01:19, Matt Turner matts...@gentoo.org wrote: On Wed, Aug 21, 2013 at 8:50 AM, Markos Chandras hwoar...@gentoo.org wrote

Re: [gentoo-dev] Moving more arches to dev profiles

2013-08-21 Thread Ben de Groot
On 21 August 2013 19:04, Markos Chandras hwoar...@gentoo.org wrote: Hi, It's time of year again to consider moving a few arches to dev-only status. I propose the following arches to lose their stable keywords - s390 - sh - ia64 - alpha - m68k - sparc ++ And consider adding ppc and

Re: [gentoo-dev] Sets in the tree

2013-08-21 Thread Ben de Groot
On 21 August 2013 23:03, Sergey Popov pinkb...@gentoo.org wrote: 15.08.2013 12:12, Pacho Ramos пишет: El mié, 14-08-2013 a las 15:17 +0100, Ciaran McCreesh escribió: Ah, looks like I was too optimistic and we are (again) with the usual blocking (and blocker) issues -_- (PMS refusing to

Re: [gentoo-dev] Moving more arches to dev profiles

2013-08-21 Thread Ben de Groot
On 22 August 2013 01:19, Matt Turner matts...@gentoo.org wrote: On Wed, Aug 21, 2013 at 8:50 AM, Markos Chandras hwoar...@gentoo.org wrote: Is there an alternative? afaik a profile can be either stable,dev or exp. I can't see how we can implement something between stable and dev. And what

Re: [gentoo-dev] gtk2/gtk3 use flags

2013-08-20 Thread Ben de Groot
On 21 August 2013 07:36, Gilles Dartiguelongue e...@gentoo.org wrote: Le mardi 20 août 2013 à 17:31 +0400, Sergey Popov a écrit : 16.08.2013 21:15, hasufell пишет: https://bugs.gentoo.org/show_bug.cgi?id=420493 gtk2 and gtk3 useflags are discouraged and should only be used in special

Re: [gentoo-dev] rfc: stabilization policies

2013-08-20 Thread Ben de Groot
On 21 August 2013 04:12, Michael Orlitzky mich...@orlitzky.com wrote: [snip] Ok, this one is ridiculous. The stable version of Rails is 2.3.18, and 3.0 was released almost exactly three years ago. Every time rails-3.x gets bumped, I have to manually update the entire list above. I need to do

Re: [gentoo-dev] gtk2/gtk3 use flags

2013-08-16 Thread Ben de Groot
On 17 August 2013 01:12, Michael Weber x...@gentoo.org wrote: Hello, gtk is a global use flag [1], gtk2 and gtk3 are used in metadata.xml [2]. Is there a consensus how to use these flags if an app provides gtk2 and gtk3 gui in parallel or exclusive? Michael [1]

Re: [gentoo-dev] desktop experience on smartphone: thoughts and plans against Ubuntu edge

2013-08-13 Thread Ben de Groot
On 13 August 2013 13:21, heroxbd hero...@gentoo.org wrote: Dear Fellows, I would like to kick out a sub-project of Gentoo targeting smartphone and tablets. It would be nice to find out a solution based on Gentoo for desktop/smartphone hybrid *before* Canonical's release. I would be

Re: [gentoo-dev] Gnome Stabilization 3.6 or 3.8

2013-08-09 Thread Ben de Groot
On 9 August 2013 21:57, Michał Górny mgo...@gentoo.org wrote: Dnia 2013-08-09, o godz. 13:45:25 Tom Wijsman tom...@gentoo.org napisał(a): On Fri, 09 Aug 2013 19:39:08 +0800 Patrick Lauer patr...@gentoo.org wrote: On 08/09/2013 07:26 PM, Tom Wijsman wrote: On Fri, 09 Aug 2013 19:31:22

Re: [gentoo-dev] Gnome Stabilization 3.6 or 3.8

2013-08-08 Thread Ben de Groot
On 7 August 2013 20:45, Michael Weber x...@gentoo.org wrote: Greetings, Gnome Herd decided to target stablilization of 3.8 [1] which requires systemd. What are the reasons to stable 3.8 and not 3.6, a version w/o this restriction, enabling all non systemd users to profit from this

Re: [gentoo-dev] renaming gentoo-oldnet

2013-08-04 Thread Ben de Groot
On 4 August 2013 10:38, Brian Dolbec dol...@gentoo.org wrote: On Sat, 2013-08-03 at 21:03 -0500, Doug Goldstein wrote: On Sat, Aug 3, 2013 at 7:30 PM, William Hubbs willi...@gentoo.org wrote: On Sun, Aug 04, 2013 at 01:49:46AM +0300, Alon Bar-Lev wrote: On Sun, Aug 4, 2013 at 1:38 AM,

Re: [gentoo-dev] newsitem: Kernel Team vanilla-sources policy

2013-08-04 Thread Ben de Groot
On 4 August 2013 09:56, Alex Xu alex_y...@yahoo.ca wrote: Minor grammar/typographical errata: On 04/08/13 12:53 AM, Mike Pagano wrote: The Gentoo Kernel Team will no longer be providing stable vanilla-sources kernels. All currently stabilized vanilla-sources versions will be dropped to

  1   2   3   4   5   >