Re: [gentoo-dev] [RFC] Anti-spam for goose

2020-05-22 Thread waebbl
Am Fr., 22. Mai 2020 um 15:40 Uhr schrieb Gordon Pettey <
petteyg...@gmail.com>:

> On Fri, May 22, 2020 at 1:18 AM waebbl  wrote:
>
>> Am Do., 21. Mai 2020 um 22:14 Uhr schrieb Viktar Patotski <
>> xp.vit@gmail.com>:
>>
>>> I believe that we are all have forgotten about Donald Knuth: Premature
>>> optimisation is the root of all evill.
>>>
>> I won't consider spam protection to be a optimisation. Instead, the
>> occurence of spam is IMO a proper use-case from a developers PoV. Therefore
>> thinking about how to handle it, is a necessary task.
>>
> Abusing Knuth's words as an excuse to avoid any and all good practice is
> the root of all evil.
>

Would you consider not even thinking about it a good practice?


Re: [gentoo-dev] [RFC] Anti-spam for goose

2020-05-22 Thread waebbl
Am Do., 21. Mai 2020 um 22:14 Uhr schrieb Viktar Patotski <
xp.vit@gmail.com>:

I believe that we are all have forgotten about Donald Knuth: Premature
> optimisation is the root of all evill.
>

I won't consider spam protection to be a optimisation. Instead, the
occurence of spam is IMO a proper use-case from a developers PoV. Therefore
thinking about how to handle it, is a necessary task.

--
With Regards
Bernd 


Re: [gentoo-dev] Last rites: media-gfx/aoi, media-gfx/exiftags, media-gfx/jpeg2ps

2019-11-06 Thread waebbl
The media-gfx/aoi package looks like it might be worth preserving. I'm
currently low on ressources, but I'm going to copy the package over to my
overlay, and when I get some time, will bump the package and probably ask
for re-adding it.

Regards,
Bernd


Am Mi., 6. Nov. 2019 um 19:53 Uhr schrieb Michał Górny :

> # Michał Górny  (2019-11-06)
> # Old EAPI 0 graphics-related packages.
> #
> # media-gfx/aoi was last bumped in Nov 2009.  It is still actively
> # developed upstream, and it's waiting for a bump since Dec 2009.
> # It suffers from bundled dependencies (#177026).
> #
> # media-gfx/exiftags was last bumped in 2007.  It did not have any new
> # releases since, and does not seem to have any unique features.
> # media-gfx/exiv2 seems to be a more commonly installed replacement.
> #
> # media-gfx/jpeg2ps was last bumped in 2004.  The upstream homepage
> # is gone.  The package is non-free.
> #
> # Removal in 30 days.  Bug #697288.
> media-gfx/aoi
> media-gfx/exiftags
> media-gfx/jpeg2ps
>
> --
> Best regards,
> Michał Górny
>
>
-BEGIN PGP SIGNATURE-

iQIzBAEBCAAdFiEEKbqdX3+q71mbfP1xLiRqTnFapoMFAlu7OCEACgkQLiRqTnFa
poNFsw//biiEGzWLCUZLsdk1hm2zWrvPlCH877La1bLV/xuqFGs/y4X3Nv4CLX4g
5NWzgWdC1cLDD9hRbY+MM5U1GQjDX1E4rC5c12sA23n4cn0STM97LL4ofYZasBGV
2vIAhkJe+KwFuGhpprjGBqZAbizB2q5ymfNfNUycJxcyadt2Uq52iEheOBNpAIXB
apout3xQlZG+7QRsiqbpOY+UoTPPZJPUNs24YCbBXHUg+8qNnNhvjrleFleWOtOl
U814TOZQSebgUt6IOdVZm3M1tjZSVIgSHvGsWf70zDqLHQW6h5rgp3C6Ie59J9L8
5hPptR01Fu3SiYOQSW1gj1NRZkFZljjWLMGdI21ZA8cQbyqKKo51YLnPETevV17r
OzAE03na0wMxUdXyZMbh5ZykyH9HaSBKSG4Cpbx1ukq2421w8DHgbuW0yN7xyRDY
3KGtBhYPF3P78vhOQONVsCLGq3JWNIHoDWJYaZ9h2Cj1i5RZBN3VoDmMwZq5omdL
Dpbe7y2L2kZRI3qKeg9jQggyjtokyt/usNTAICLDRqWd+Zrqj9HHcgGvKJumGj9m
5JIJeKGl0JwrtvpUHPBh/W27Aium60NylXKxL0biWLHkOLEXVklxEYsdE5s7IZgy
E6ZHEpA55qC64JLkRWh3P+jN4qaLED+QUF856L3+wmhNePMrmSo=
=+sCv
-END PGP SIGNATURE-


Re: [gentoo-dev] Last rites: multiple unfetchable packages (games-*, net-print/adobeps, sci-chem/xdsstat-bin, sci-libs/{openfoam,parmgridgen})

2019-09-28 Thread waebbl
Version 7 doesn't require parmgridgen. I has dependencies on scoth,
paraview and cgal, all of which are available in the tree.


Am Sa., 28. Sept. 2019 um 21:50 Uhr schrieb Michał Górny :

> On Sat, 2019-09-28 at 20:57 +0200, waebbl wrote:
> > > sci-libs/openfoam
> >
> > sci-libs/openfoam is available at https://github.com/OpenFOAM, including
> > old versions for slots 2.{2,3,4}, each in it's own repository. I haven't
> > checked whether those ancient version still compile, with the sources
> from
> > github, but I've started working on a bump to current version 7, some
> time
> > ago, after I noticed that parmgridgen isn't building and I didn't find
> any
> > updates for it.
> > I would consider taking responsibility of the package for the new
> versions,
> > once my ebuild is ready and get's accepted into the tree, as it's a
> package
> > which can be supported by freecad, on which I'm actively working for
> almost
> > a year now.
> >
>
> OpenFOAM is not the problem -- parmgridgen is.  OpenFOAM apparently
> requires it unconditionally.
>
> --
> Best regards,
> Michał Górny
>
>
-BEGIN PGP SIGNATURE-

iQIzBAEBCAAdFiEEKbqdX3+q71mbfP1xLiRqTnFapoMFAlu7OCEACgkQLiRqTnFa
poNFsw//biiEGzWLCUZLsdk1hm2zWrvPlCH877La1bLV/xuqFGs/y4X3Nv4CLX4g
5NWzgWdC1cLDD9hRbY+MM5U1GQjDX1E4rC5c12sA23n4cn0STM97LL4ofYZasBGV
2vIAhkJe+KwFuGhpprjGBqZAbizB2q5ymfNfNUycJxcyadt2Uq52iEheOBNpAIXB
apout3xQlZG+7QRsiqbpOY+UoTPPZJPUNs24YCbBXHUg+8qNnNhvjrleFleWOtOl
U814TOZQSebgUt6IOdVZm3M1tjZSVIgSHvGsWf70zDqLHQW6h5rgp3C6Ie59J9L8
5hPptR01Fu3SiYOQSW1gj1NRZkFZljjWLMGdI21ZA8cQbyqKKo51YLnPETevV17r
OzAE03na0wMxUdXyZMbh5ZykyH9HaSBKSG4Cpbx1ukq2421w8DHgbuW0yN7xyRDY
3KGtBhYPF3P78vhOQONVsCLGq3JWNIHoDWJYaZ9h2Cj1i5RZBN3VoDmMwZq5omdL
Dpbe7y2L2kZRI3qKeg9jQggyjtokyt/usNTAICLDRqWd+Zrqj9HHcgGvKJumGj9m
5JIJeKGl0JwrtvpUHPBh/W27Aium60NylXKxL0biWLHkOLEXVklxEYsdE5s7IZgy
E6ZHEpA55qC64JLkRWh3P+jN4qaLED+QUF856L3+wmhNePMrmSo=
=+sCv
-END PGP SIGNATURE-


Re: [gentoo-dev] Last rites: multiple unfetchable packages (games-*, net-print/adobeps, sci-chem/xdsstat-bin, sci-libs/{openfoam,parmgridgen})

2019-09-28 Thread waebbl
> sci-libs/openfoam

sci-libs/openfoam is available at https://github.com/OpenFOAM, including
old versions for slots 2.{2,3,4}, each in it's own repository. I haven't
checked whether those ancient version still compile, with the sources from
github, but I've started working on a bump to current version 7, some time
ago, after I noticed that parmgridgen isn't building and I didn't find any
updates for it.
I would consider taking responsibility of the package for the new versions,
once my ebuild is ready and get's accepted into the tree, as it's a package
which can be supported by freecad, on which I'm actively working for almost
a year now.
Thanks all!

Am Sa., 28. Sept. 2019 um 14:35 Uhr schrieb Michał Górny :

> # Michał Górny  (2019-09-28)
> # All of the following packages are unfetchable and mirror-restricted.
> #
> # games-fps/enemy-territory-etpro: #638092
> # games-fps/ut2003-bonuspack-cm: #640552
> # games-rpg/runescape-launcher: #625884
> # games-server/bf1942-lnxded: #640576
> # games-server/nwn-ded: #640578
> # games-strategy/mindrover-demo: #640586
> # media-fonts/hkscs-ming: #640590
> # net-print/adobeps: #687000
> # sci-chemistry/xdsstat-bin: #673962
> # sci-libs/parmgridgen (+ revdep sci-libs/openfoam): #633888
> #
> # Removal in 30 days.
> games-fps/enemy-territory-etpro
> games-fps/ut2003-bonuspack-cm
> games-rpg/runescape-launcher
> games-server/bf1942-lnxded
> games-server/nwn-ded
> games-strategy/mindrover-demo
> media-fonts/hkscs-ming
> net-print/adobeps
> sci-chemistry/xdsstat-bin
> sci-libs/openfoam
> sci-libs/parmgridgen
>
> --
> Best regards,
> Michał Górny
>
>
-BEGIN PGP SIGNATURE-

iQIzBAEBCAAdFiEEKbqdX3+q71mbfP1xLiRqTnFapoMFAlu7OCEACgkQLiRqTnFa
poNFsw//biiEGzWLCUZLsdk1hm2zWrvPlCH877La1bLV/xuqFGs/y4X3Nv4CLX4g
5NWzgWdC1cLDD9hRbY+MM5U1GQjDX1E4rC5c12sA23n4cn0STM97LL4ofYZasBGV
2vIAhkJe+KwFuGhpprjGBqZAbizB2q5ymfNfNUycJxcyadt2Uq52iEheOBNpAIXB
apout3xQlZG+7QRsiqbpOY+UoTPPZJPUNs24YCbBXHUg+8qNnNhvjrleFleWOtOl
U814TOZQSebgUt6IOdVZm3M1tjZSVIgSHvGsWf70zDqLHQW6h5rgp3C6Ie59J9L8
5hPptR01Fu3SiYOQSW1gj1NRZkFZljjWLMGdI21ZA8cQbyqKKo51YLnPETevV17r
OzAE03na0wMxUdXyZMbh5ZykyH9HaSBKSG4Cpbx1ukq2421w8DHgbuW0yN7xyRDY
3KGtBhYPF3P78vhOQONVsCLGq3JWNIHoDWJYaZ9h2Cj1i5RZBN3VoDmMwZq5omdL
Dpbe7y2L2kZRI3qKeg9jQggyjtokyt/usNTAICLDRqWd+Zrqj9HHcgGvKJumGj9m
5JIJeKGl0JwrtvpUHPBh/W27Aium60NylXKxL0biWLHkOLEXVklxEYsdE5s7IZgy
E6ZHEpA55qC64JLkRWh3P+jN4qaLED+QUF856L3+wmhNePMrmSo=
=+sCv
-END PGP SIGNATURE-