[gentoo-dev] Re: please stop using foo-${PV}-bar.patch in other ebuild versions than ${PV}

2009-03-24 Thread Duncan
Marijn Schouten (hkBst) hk...@gentoo.org posted 49c8d6ee.3070...@gentoo.org, excerpted below, on Tue, 24 Mar 2009 13:49:50 +0100: Lastly I prefer to have the source changes right there in the ebuild when they are not too elaborate and patches don't allow that. The preference makes sense, but

Re: [gentoo-dev] Re: please stop using foo-${PV}-bar.patch in other ebuild versions than ${PV}

2009-03-23 Thread Alin Năstac
On 3/23/09 1:42 AM, Ryan Hill wrote: On Mon, 23 Mar 2009 01:19:26 +0100 Alin Năstac mrn...@gentoo.org wrote: Fine, then remove $PV from patch name and use it in any ebuild version you want. Or just decouple the patch version from the ebuild version (foo-bar-r1.patch sounds OK to me).

Re: [gentoo-dev] Re: please stop using foo-${PV}-bar.patch in other ebuild versions than ${PV}

2009-03-23 Thread Alin Năstac
On 3/23/09 1:44 AM, Jeremy Olexa wrote: Alin Năstac wrote: snip Fine, then remove $PV from patch name and use it in any ebuild version you want. Or just decouple the patch version from the ebuild version (foo-bar-r1.patch sounds OK to me). What exactly is your problem that you are trying

[gentoo-dev] Re: please stop using foo-${PV}-bar.patch in other ebuild versions than ${PV}

2009-03-23 Thread Ryan Hill
On Mon, 23 Mar 2009 09:04:32 +0100 Alin Năstac mrn...@gentoo.org wrote: I suppose what everyone does in their part of the tree is their business, but a small subset of packages I maintain have other maintainers as well. It is annoying to see rules you assume being respected on your ebuilds

Re: [gentoo-dev] Re: please stop using foo-${PV}-bar.patch in other ebuild versions than ${PV}

2009-03-23 Thread Sebastian Pipping
Ryan Hill wrote: Alin Năstac mrn...@gentoo.org wrote: I suppose what everyone does in their part of the tree is their business, but a small subset of packages I maintain have other maintainers as well. It is annoying to see rules you assume being respected on your ebuilds being broken at

Re: [gentoo-dev] Re: please stop using foo-${PV}-bar.patch in other ebuild versions than ${PV}

2009-03-23 Thread Fabian Groffen
On 23-03-2009 11:41:08 +0100, Sebastian Pipping wrote: People split into three groups: - Friends of ${P}-fix-issue.patch naming - Friends of ${PN}-fix-issue.patch naming - Friends of ${PN}-1.2.3-fix-issue.patch naming Qualities [snip] I think what's missing is the following

Re: [gentoo-dev] Re: please stop using foo-${PV}-bar.patch in other ebuild versions than ${PV}

2009-03-23 Thread Sebastian Pipping
Fabian Groffen wrote: I think what's missing is the following observation: ${PN}-fix-issue.patch naming is bad if you patch code that is (likely) to change in newer releases. This is almost always the case. Ultimate example, patch something in ffmpeg or mplayer, and the next snapshot will

[gentoo-dev] Re: please stop using foo-${PV}-bar.patch in other ebuild versions than ${PV}

2009-03-23 Thread Ryan Hill
On Mon, 23 Mar 2009 11:51:28 +0100 Fabian Groffen grob...@gentoo.org wrote: On 23-03-2009 11:41:08 +0100, Sebastian Pipping wrote: People split into three groups: - Friends of ${P}-fix-issue.patch naming - Friends of ${PN}-fix-issue.patch naming - Friends of

[gentoo-dev] Re: please stop using foo-${PV}-bar.patch in other ebuild versions than ${PV}

2009-03-22 Thread Ryan Hill
On Sun, 22 Mar 2009 13:24:26 -0400 Mounir Lamouri mounir.lamo...@gmail.com wrote: On Sun, Mar 22, 2009 at 1:18 PM, Ulrich Mueller u...@gentoo.org wrote: On Sun, 22 Mar 2009, mrness wrote: Please do not apply patches that have ${P} prefix in other ebuild versions than ${PV}. Is that

Re: [gentoo-dev] Re: please stop using foo-${PV}-bar.patch in other ebuild versions than ${PV}

2009-03-22 Thread Sebastian Pipping
Ryan Hill wrote: Please do not apply patches that have ${P} prefix in other ebuild versions than ${PV}. Is that hard to create a new patch with a proper name? Um, why? I'm not having six identical patches with different version numbers in FILESDIR. Good point. Sebastian

Re: [gentoo-dev] Re: please stop using foo-${PV}-bar.patch in other ebuild versions than ${PV}

2009-03-22 Thread Alin Năstac
On 3/22/09 11:47 PM, Ryan Hill wrote: On Sun, 22 Mar 2009 17:50:26 +0100 Alin Năstac mrn...@gentoo.org wrote: Please do not apply patches that have ${P} prefix in other ebuild versions than ${PV}. Is that hard to create a new patch with a proper name? Um, why? I'm not having

[gentoo-dev] Re: please stop using foo-${PV}-bar.patch in other ebuild versions than ${PV}

2009-03-22 Thread Ryan Hill
On Mon, 23 Mar 2009 01:19:26 +0100 Alin Năstac mrn...@gentoo.org wrote: Fine, then remove $PV from patch name and use it in any ebuild version you want. Or just decouple the patch version from the ebuild version (foo-bar-r1.patch sounds OK to me). No. It's done this way for a reason. --

Re: [gentoo-dev] Re: please stop using foo-${PV}-bar.patch in other ebuild versions than ${PV}

2009-03-22 Thread Jeremy Olexa
Alin Năstac wrote: snip Fine, then remove $PV from patch name and use it in any ebuild version you want. Or just decouple the patch version from the ebuild version (foo-bar-r1.patch sounds OK to me). What exactly is your problem that you are trying to solve here? Posting to the community to