[gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in dev-util/netbeans: ChangeLog netbeans-6.9-r3.ebuild

2010-07-21 Thread Miroslav Ć ulc (fordfrog)
 Dne 21.7.2010 16:35, Jeremy Olexa napsal(a):
> On Mon, 19 Jul 2010 20:24:40 + (UTC), "Miroslav Sulc (fordfrog)"
>  wrote:
>> fordfrog10/07/19 20:24:40
>>
>>   Modified: ChangeLog netbeans-6.9-r3.ebuild
>>   Log:
>>   netbeans-6.9-r3: added support for including custom patches when
>> building netbeans
>> +# Support for custom patches
>> +if [ -n "{NETBEANS_PATCHES_DIR}" -a -d "${NETBEANS_PATCHES_DIR}" ] ; 
>> then
>> +local files=`find "${NETBEANS_PATCHES_DIR}" -type f`
>> +
>> +if [ -n "${files}" ] ; then
>> +einfo "Applying custom patches:"
>> +
>> +for file in ${files} ; do
>> +epatch "${file}"
>> +done
>> +fi
>> +fi
>> +
> Miroslav, You just reinvented the wheel :) Any reason why epatch_user()
> from euitls.eclass doesn't work here?
> -Jeremy
y, i did not expect this function to exist, i only recall that i saw
some custom code for applying patches in some other ebuild few years
back when i needed to tweak some package, so did it the same way.

so this is called automatically for
/etc/portage/patches//(PF|P|PN) if i read the code right? i
also tried to search man pages for portage and emerge but there is
nothing about it (or i am blind) ... so this is undocumented feature? i
did not know about this cool feature till now.

m.



[gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in dev-util/netbeans: ChangeLog netbeans-6.9-r3.ebuild

2010-07-21 Thread Jeremy Olexa
On Mon, 19 Jul 2010 20:24:40 + (UTC), "Miroslav Sulc (fordfrog)"
 wrote:
> fordfrog10/07/19 20:24:40
> 
>   Modified: ChangeLog netbeans-6.9-r3.ebuild
>   Log:
>   netbeans-6.9-r3: added support for including custom patches when
> building netbeans

> + # Support for custom patches
> + if [ -n "{NETBEANS_PATCHES_DIR}" -a -d "${NETBEANS_PATCHES_DIR}" ] ; 
> then
> + local files=`find "${NETBEANS_PATCHES_DIR}" -type f`
> +
> + if [ -n "${files}" ] ; then
> + einfo "Applying custom patches:"
> +
> + for file in ${files} ; do
> + epatch "${file}"
> + done
> + fi
> + fi
> +

Miroslav, You just reinvented the wheel :) Any reason why epatch_user()
from euitls.eclass doesn't work here?
-Jeremy