[gentoo-dev] Last rites: ruby24-only packages

2020-04-13 Thread Hans de Graaff
# Hans de Graaff  (2020-04-13)
# ruby24-only packages. Ruby 2.4 is EOL and will be masked for removal
# shortly. These packages either have newer ruby25 slots available, or
# are no longer maintained and have no reverse dependencies. Masked
# for removal in 30 days.
dev-ruby/activeldap:4
dev-ruby/bones
dev-ruby/github_api
dev-ruby/http:0.8
dev-ruby/http-form_data:0.8
dev-ruby/rack-test:0.6
dev-ruby/rails-deprecated_sanitizer
dev-ruby/riel
dev-ruby/shoulda-matchers:0
dev-ruby/vcr:1
dev-ruby/webmock:2


signature.asc
Description: This is a digitally signed message part


Re: [gentoo-dev] Last rites: ruby24-only packages

2019-10-21 Thread Alec Warner
On Sun, Oct 20, 2019 at 10:31 PM Hans de Graaff  wrote:

> On Sun, 2019-10-20 at 12:15 -0700, Alec Warner wrote:
>
> Infra uses thin a lot, is there a replacement?
>
>
> www-servers/puma would be a good replacement.
>
> Feel free to unmask it for now if that helps infra to transition. Upstream
> EOL for ruby 2.4 is March 2020, so we could wait until then if needed.
>

Nope, keep it masked in ::gentoo please.


>
> Hans
>
>


Re: [gentoo-dev] Last rites: ruby24-only packages

2019-10-20 Thread Hans de Graaff
On Sun, 2019-10-20 at 16:52 -0400, Michael Orlitzky wrote:
> > dev-ruby/vcard
> 
> And this one's used by a popular Redmine plugin. I'll have to do
> something to keep it working. Redmine is still making releases (as of
> yesterday) that support only ruby24, so I don't expect the plugin
> developers to treat this very urgently.
> 
> I filed an issue at least...
> 
>   https://github.com/qoobaa/vcard/issues/30
> 

Thanks. I've removed the mask for now.

Hans


signature.asc
Description: This is a digitally signed message part


Re: [gentoo-dev] Last rites: ruby24-only packages

2019-10-20 Thread Hans de Graaff
On Sun, 2019-10-20 at 12:15 -0700, Alec Warner wrote:
> Infra uses thin a lot, is there a replacement?

www-servers/puma would be a good replacement.
Feel free to unmask it for now if that helps infra to transition.
Upstream EOL for ruby 2.4 is March 2020, so we could wait until then if
needed.
Hans


signature.asc
Description: This is a digitally signed message part


Re: [gentoo-dev] Last rites: ruby24-only packages

2019-10-20 Thread Michael Orlitzky
> dev-ruby/vcard

And this one's used by a popular Redmine plugin. I'll have to do
something to keep it working. Redmine is still making releases (as of
yesterday) that support only ruby24, so I don't expect the plugin
developers to treat this very urgently.

I filed an issue at least...

  https://github.com/qoobaa/vcard/issues/30



Re: [gentoo-dev] Last rites: ruby24-only packages

2019-10-20 Thread Alec Warner
Infra uses thin a lot, is there a replacement?

On Sun, Oct 20, 2019, 05:41 Hans de Graaff  wrote:

> # Hans de Graaff  (2019-10-19)
> # ruby24-only packages with no reverse dependencies and no recent
> # releases.
> dev-ruby/cocaine
> dev-ruby/debugger-linecache
> dev-ruby/escape_utils
> dev-ruby/http-form_data:1.0
> dev-ruby/ruby-beautify
> dev-ruby/termcolor
> dev-ruby/terrapin
> dev-ruby/vcard
> www-servers/thin
>


[gentoo-dev] Last rites: ruby24-only packages

2019-10-20 Thread Hans de Graaff
# Hans de Graaff  (2019-10-19)
# ruby24-only packages with no reverse dependencies and no recent
# releases.
dev-ruby/cocaine
dev-ruby/debugger-linecache
dev-ruby/escape_utils
dev-ruby/http-form_data:1.0
dev-ruby/ruby-beautify
dev-ruby/termcolor
dev-ruby/terrapin
dev-ruby/vcard
www-servers/thin


signature.asc
Description: This is a digitally signed message part