Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-cdr/cdrdao: ChangeLog cdrdao-1.2.2-r3.ebuild

2009-06-02 Thread Samuli Suominen
David Leverton wrote:
> On Sunday 10 May 2009 09:58:22 Ryan Hill wrote:
>> On Sun, 10 May 2009 02:00:17 -0600
>>
>> Ryan Hill  wrote:
>>> You can't test FEATURES in an ebuild.  It's portage-specific.
>> Actually, am I right?
> 
> Yes.  (http://bugs.gentoo.org/show_bug.cgi?id=239671#c10 gives a better 
> approach for this particular problem.)

It's been fixed in latest cdrdao ebuild, thanks loki_val, so there is
absolutely no point in continuing this discussion about cdrdao.

The version without the check is going stable in some weeks.

> 
>> There's a crapload of stuff in the tree doing 
>> things like this and worse with FEATURES.
> 
> Welcome to Gentoo.
> 

Go away if you have nothing productive to contribute.



[gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-cdr/cdrdao: ChangeLog cdrdao-1.2.2-r3.ebuild

2009-05-11 Thread Ryan Hill
On Mon, 11 May 2009 23:29:10 +1200
Alistair Bush  wrote:

> I would assume it would be better to directly test whether the user is
> root, than test that userpriv is set?

AFAIK:

if [[ ${EUID} -eq 0 ]]; then
  rootstuff
else
  nonrootstuff
fi

But for tests that fail with userpriv just because they don't have the proper
permissions you can usually just use a -r or -w test.
( eg. [[ -w ${S}/testdir/runtestsdir ]] || skiptest )

Bonus points for patching this into the test itself and getting it upstream.


-- 
gcc-porting,  by design, by neglect
treecleaner,  for a fact or just for effect
wxwidgets @ gentoo EFFD 380E 047A 4B51 D2BD C64F 8AA8 8346 F9A4 0662


signature.asc
Description: PGP signature


Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-cdr/cdrdao: ChangeLog cdrdao-1.2.2-r3.ebuild

2009-05-11 Thread Alistair Bush

> 
> You can't test FEATURES in an ebuild.  It's portage-specific.
> 

To 1) try and turn this thread into something a little more constructive
and a little less childish; and 2) help improve the tree.  I present one
of the offending ebuilds  dev-java/commons-io

Without posting the whole file here it is

src_test() {
if has userpriv ${FEATURES}; then
ANT_OPTS="-Djava.io.tmpdir=${T} -Duser.home=${T}" \
ANT_TASKS="ant-junit" \
eant test \
-Dgentoo.classpath="$(java-pkg_getjars junit)" \
-Dlibdir="libdir" \
-Djava.io.tmpdir="${T}"
else
elog "Tests fail unless userpriv is enabled because they
test for"
elog "file permissions which doesn't work when run as root."
fi
}

I would assume it would be better to directly test whether the user is
root, than test that userpriv is set?

Alistair



Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-cdr/cdrdao: ChangeLog cdrdao-1.2.2-r3.ebuild

2009-05-11 Thread Thilo Bangert
Fabian Groffen  said:
> On 11-05-2009 11:26:46 +0200, Thilo Bangert wrote:
> > FEATURE-misuse.txt was generated by
> > $ find -name '*.ebuild' | xargs grep -nH FEATURES >
> > FEATURES-misuse.txt and sifting through the false positives.
>
> Have you checked if eclasses use it as well?

nope - thanks for the pointer ;-)

bang...@marsupilami ~/gentoo/portage/eclass $ grep FEATURES *
db.eclass:  if has test $FEATURES; then
eutils.eclass:  has preserve-libs ${FEATURES} && return 0
eutils.eclass:  has preserve-libs ${FEATURES} && return 0
gnatbuild.eclass:   has noinfo ${FEATURES} \
gnatbuild.eclass:   has noman  ${FEATURES} \
java-utils-2.eclass:if hasq test ${FEATURES} && ! hasq -test 
${FEATURES} \
java-utils-2.eclass:eerror "You specified FEATURES=test, but 
USE=test is needed"
kmod.eclass:if [ "${FEATURES/sandbox/}" != "${FEATURES}" ]
mysql.eclass:   if hasq test ${FEATURES} ; then
mysql.eclass:   eerror "Testing with FEATURES=-
userpriv is no longer supported by upstream. Tests MUST be run as non-
root."
mysql.eclass:   # Check FEATURES="collision-protect" before removing this
myth.eclass:FEATURES="${FEATURES} nostrip"
selinux-policy-2.eclass:if has "loadpolicy" $FEATURES ; then
selinux-policy-2.eclass:einfo "\"loadpolicy\" to the 
FEATURES in make.conf."
selinux-policy.eclass:  if has "loadpolicy" $FEATURES ; then
selinux-policy.eclass:  einfo "\"loadpolicy\" to the FEATURES in 
make.conf."
toolchain-binutils.eclass:  if ! has noinfo ${FEATURES} ; then
toolchain-binutils.eclass:  has noinfo ${FEATURES} && rm -r 
"${D}"/${DATAPATH}/info
toolchain-binutils.eclass:  has noman ${FEATURES} && rm -r 
"${D}"/${DATAPATH}/man
toolchain.eclass:FEATURES=${FEATURES/multilib-strict/}
toolchain.eclass:   eerror "of a multilib gcc.  Please set 
FEATURES=-sandbox and try again."
toolchain.eclass:   die "No 32bit sandbox.  Retry with 
FEATURES=-sandbox."
toolchain.eclass:   has noinfo ${FEATURES} \
toolchain.eclass:   has noman ${FEATURES} \

(the above has been filtered for obvious false positives)


signature.asc
Description: This is a digitally signed message part.


Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-cdr/cdrdao: ChangeLog cdrdao-1.2.2-r3.ebuild

2009-05-11 Thread Fabian Groffen
On 11-05-2009 11:26:46 +0200, Thilo Bangert wrote:
> FEATURE-misuse.txt was generated by
> $ find -name '*.ebuild' | xargs grep -nH FEATURES > FEATURES-misuse.txt
> and sifting through the false positives.

Have you checked if eclasses use it as well?


-- 
Fabian Groffen
Gentoo on a different level



Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-cdr/cdrdao: ChangeLog cdrdao-1.2.2-r3.ebuild

2009-05-11 Thread Thilo Bangert
a list cleaned for obvious false positives leaves the following 44 affected 
packages.
i have treated ebuilds which mention FEATURES in an ewarn or einfo as 
false positives although they probably should be fixed as well.

most of these have do one of the following (or a variant thereof)

hasq test $FEATURES
hasq distcc ${FEATURES}
hasq userpriv "${FEATURES}"
has nodoc ${FEATURES}
has noinfo ${FEATURES}
has noman ${FEATURES}
has collision-protect ${FEATURES}
hasq sandbox ${FEATURES}
has usersandbox ${FEATURES}
has "loadpolicy" $FEATURES  (selinux-base-policy)
has livecvsportage ${FEATURES}  (portage)

i'll start opening bugs for these:

bang...@marsupilami ~/gentoo $ cat FEATURES-misuse.txt | awk -F"/" '{print 
$2"/"$3}' | sort | uniq 
app-cdr/cdrdao  
   
app-forensics/memdump   
   
app-forensics/zzuf  
   
app-text/dictd  
   
dev-db/libodbc++
   
dev-db/mysql
   
dev-db/mysql-community  
   
dev-db/postgresql   
   
dev-db/postgresql-server
   
dev-db/sqlite   
   
dev-java/commons-io 
   
dev-java/rjava  
   
dev-lang/fpc
   
dev-lang/mono   
   
dev-libs/boost  
   
dev-libs/klibc  
   
dev-libs/openssl
   
dev-libs/poco   
   
dev-python/logilab-common   
   
dev-python/pyqwt
   
dev-scheme/bigloo   
   
dev-util/cvs
   
dev-util/git
   
dev-util/mercurial  
   
dev-util/monotone
gnome-base/eel
mail-mta/courier
media-sound/line6usb
media-tv/mythtv
media-video/avidemux
net-analyzer/tcpreplay
net-misc/l7-filter
sci-libs/hdf5
sec-policy/selinux-base-policy
sys-apps/dbus
sys-apps/mlocate
sys-apps/portage
sys-cluster/mpich2
sys-devel/gcc
sys-fs/evms
sys-libs/cracklib
sys-libs/db
sys-libs/glibc
sys-power/iasl

FEATURE-misuse.txt was generated by
$ find -name '*.ebuild' | xargs grep -nH FEATURES > FEATURES-misuse.txt
and sifting through the false positives.

see it here http://dev.gentoo.org/~bangert/FEATURES-misuse.txt
kind regards
Thilo


signature.asc
Description: This is a digitally signed message part.


[gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-cdr/cdrdao: ChangeLog cdrdao-1.2.2-r3.ebuild

2009-05-10 Thread Ryan Hill
On Sun, 10 May 2009 10:41:03 +0100
David Leverton  wrote:

> On Sunday 10 May 2009 09:58:22 Ryan Hill wrote:
> > On Sun, 10 May 2009 02:00:17 -0600
> >
> > Ryan Hill  wrote:
> > > You can't test FEATURES in an ebuild.  It's portage-specific.
> >
> > Actually, am I right?
> 
> Yes.  (http://bugs.gentoo.org/show_bug.cgi?id=239671#c10 gives a better 
> approach for this particular problem.)

Thanks.  It's still kind of icky but better than nothing.

> > There's a crapload of stuff in the tree doing 
> > things like this and worse with FEATURES.
> 
> Welcome to Gentoo.

Yes, business as usual.  People, if you need to know if "test" is in
FEATURES, there's a reason it automatically and unconditionally sets USE=test.


-- 
gcc-porting,  by design, by neglect
treecleaner,  for a fact or just for effect
wxwidgets @ gentoo EFFD 380E 047A 4B51 D2BD C64F 8AA8 8346 F9A4 0662


signature.asc
Description: PGP signature


Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-cdr/cdrdao: ChangeLog cdrdao-1.2.2-r3.ebuild

2009-05-10 Thread Dawid Węgliński
On Sunday 10 of May 2009 14:47:45 Ben de Groot wrote:
> Thilo Bangert wrote:
> >> Welcome to Gentoo.
> >
> > nice attitude...
> > i am sure that'll make the problem go away :-(
>
> What do you expect? He's an exherbo dev, only here to criticize Gentoo
> and gloat over its perceived failings.

Shut your pretty mouth up.



Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-cdr/cdrdao: ChangeLog cdrdao-1.2.2-r3.ebuild

2009-05-10 Thread Ben de Groot
Thilo Bangert wrote:
> Ben de Groot  said:
> and what exactly are _you_ contributing?
> i was trying to point out, that somebody was rather unhelpful, and all you 
> can come up with is being unhelpful? we can do better than that!

I thought I was helpful in pointing out that certain people cannot be
expected to be helpful.

> ..now back to the topic!

Yeah, I'll shut up now. Let's get back to work.

Cheers,
-- 
Ben de Groot
Gentoo Linux developer (qt, media, lxde, desktop-misc)
Gentoo Linux Release Engineering PR liaison
__



[gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-cdr/cdrdao: ChangeLog cdrdao-1.2.2-r3.ebuild

2009-05-10 Thread Duncan
Ben de Groot  posted 4a06ccf1.7040...@gentoo.org,
excerpted below, on  Sun, 10 May 2009 14:47:45 +0200:

> Thilo Bangert wrote:
> 
>>> Welcome to Gentoo.
>> 
>> nice attitude...
>> i am sure that'll make the problem go away :-(
>> 
> What do you expect? He's an exherbo dev, only here to criticize Gentoo
> and gloat over its perceived failings.

Guys, this isn't going anywhere useful.  Please just stop it... or take 
it offlist if you must continue.

-- 
Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman




Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-cdr/cdrdao: ChangeLog cdrdao-1.2.2-r3.ebuild

2009-05-10 Thread Thilo Bangert
Ben de Groot  said:
> Thilo Bangert wrote:
> >> Welcome to Gentoo.
> >
> > nice attitude...
> > i am sure that'll make the problem go away :-(
>
> What do you expect? He's an exherbo dev, only here to criticize Gentoo
> and gloat over its perceived failings.

and what exactly are _you_ contributing?
i was trying to point out, that somebody was rather unhelpful, and all you 
can come up with is being unhelpful? we can do better than that!

same goes to some other people in this thread...

..now back to the topic!

Thanks
Thilo




signature.asc
Description: This is a digitally signed message part.


Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-cdr/cdrdao: ChangeLog cdrdao-1.2.2-r3.ebuild

2009-05-10 Thread Ben de Groot
David Leverton wrote:
> On Sunday 10 May 2009 14:02:57 Ben de Groot wrote:
>> Just your activity on Gentoo channels (IRC, ML, etc), which is what my
>> assessment is based on.
> 
> Nothing I've ever done anywhere, in Gentoo channels or elsewhere, in any way 
> implies that I'm "only here to criticize Gentoo and gloat over its perceived 
> failings."
> 
Then maybe you should reflect on your behavior, as you certainly come
across that way.

Cheers,
-- 
Ben de Groot
Gentoo Linux developer (qt, media, lxde, desktop-misc)
Gentoo Linux Release Engineering PR liaison
__



Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-cdr/cdrdao: ChangeLog cdrdao-1.2.2-r3.ebuild

2009-05-10 Thread David Leverton
On Sunday 10 May 2009 14:02:57 Ben de Groot wrote:
> Just your activity on Gentoo channels (IRC, ML, etc), which is what my
> assessment is based on.

Nothing I've ever done anywhere, in Gentoo channels or elsewhere, in any way 
implies that I'm "only here to criticize Gentoo and gloat over its perceived 
failings."



Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-cdr/cdrdao: ChangeLog cdrdao-1.2.2-r3.ebuild

2009-05-10 Thread David Leverton
On Sunday 10 May 2009 14:02:48 Nirbheek Chauhan wrote:
> It's even more hilarious that you expect to "fix" Gentoo's problems by
> bitching about them.

Same to you as I said to yngwin.



Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-cdr/cdrdao: ChangeLog cdrdao-1.2.2-r3.ebuild

2009-05-10 Thread Nirbheek Chauhan
On Sun, May 10, 2009 at 6:22 PM, David Leverton
 wrote:
> On Sunday 10 May 2009 13:47:45 Ben de Groot wrote:
>> What do you expect? He's an exherbo dev, only here to criticize Gentoo
>> and gloat over its perceived failings.
>
> It's pretty hilarious that you think you know anything about me.
>

It's even more hilarious that you expect to "fix" Gentoo's problems by
bitching about them. And at the same time you put yourself in a
situation where people would expect you to gloat and smirk rather than
help.

In short, you were practically asking for it.


-- 
~Nirbheek Chauhan



Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-cdr/cdrdao: ChangeLog cdrdao-1.2.2-r3.ebuild

2009-05-10 Thread Ben de Groot
David Leverton wrote:
> It's pretty hilarious that you think you know anything about me.
> 

Just your activity on Gentoo channels (IRC, ML, etc), which is what my
assessment is based on.

Cheers,
-- 
Ben de Groot
Gentoo Linux developer (qt, media, lxde, desktop-misc)
Gentoo Linux Release Engineering PR liaison
__



Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-cdr/cdrdao: ChangeLog cdrdao-1.2.2-r3.ebuild

2009-05-10 Thread David Leverton
On Sunday 10 May 2009 13:47:45 Ben de Groot wrote:
> What do you expect? He's an exherbo dev, only here to criticize Gentoo
> and gloat over its perceived failings.

It's pretty hilarious that you think you know anything about me.



Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-cdr/cdrdao: ChangeLog cdrdao-1.2.2-r3.ebuild

2009-05-10 Thread Ben de Groot
Thilo Bangert wrote:

>> Welcome to Gentoo.
> 
> nice attitude... 
> i am sure that'll make the problem go away :-(
> 
What do you expect? He's an exherbo dev, only here to criticize Gentoo
and gloat over its perceived failings.

-- 
Ben de Groot
Gentoo Linux developer (qt, media, lxde, desktop-misc)
Gentoo Linux Release Engineering PR liaison
__



Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-cdr/cdrdao: ChangeLog cdrdao-1.2.2-r3.ebuild

2009-05-10 Thread Thilo Bangert
> > There's a crapload of stuff in the tree doing
> > things like this and worse with FEATURES.

there is roughly 150 packages using FEATURES (including a number of false 
positives). see the list below...

FEATURES variable is used in the tree
http://bugs.gentoo.org/show_bug.cgi?id=174335

>
> Welcome to Gentoo.

nice attitude... 
i am sure that'll make the problem go away :-(


bang...@marsupilami ~/gentoo/portage $ find -name '*.ebuild' | xargs grep -
nH FEATURES | awk -F"/" '{print $2"/"$3}' | sort | uniq
app-editors/emacs   
  
app-editors/emacs-cvs   
  
app-editors/le  
  
app-forensics/memdump   
  
app-forensics/zzuf  
  
app-shells/bash 
  
app-text/dictd  
  
dev-ada/polyorb 
  
dev-db/libodbc++
  
dev-db/mysql
  
dev-db/mysql-community  
  
dev-db/postgresql   
  
dev-db/postgresql-server
  
dev-db/sqlite   
  
dev-dotnet/smartirc4net 
  
dev-haskell/alex
  
dev-haskell/alut
  
dev-haskell/arrows  
  
dev-haskell/binary  
  
dev-haskell/bzlib   
  
dev-haskell/c2hs
  
dev-haskell/cabal   
  
dev-haskell/cabal-install   
  
dev-haskell/cgi 
  
dev-haskell/cpphs   
  
dev-haskell/editline
  
dev-haskell/fgl 
  
dev-haskell/filepath
  
dev-haskell/frown   
  
dev-haskell/ghc-paths   
  
dev-haskell/glut
  
dev-haskell/haddock 
  
dev-haskell/happy   
  
dev-haskell/harp
   

Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-cdr/cdrdao: ChangeLog cdrdao-1.2.2-r3.ebuild

2009-05-10 Thread David Leverton
On Sunday 10 May 2009 09:58:22 Ryan Hill wrote:
> On Sun, 10 May 2009 02:00:17 -0600
>
> Ryan Hill  wrote:
> > You can't test FEATURES in an ebuild.  It's portage-specific.
>
> Actually, am I right?

Yes.  (http://bugs.gentoo.org/show_bug.cgi?id=239671#c10 gives a better 
approach for this particular problem.)

> There's a crapload of stuff in the tree doing 
> things like this and worse with FEATURES.

Welcome to Gentoo.



[gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-cdr/cdrdao: ChangeLog cdrdao-1.2.2-r3.ebuild

2009-05-10 Thread Ryan Hill
On Sun, 10 May 2009 02:00:17 -0600
Ryan Hill  wrote:

> On Sun, 10 May 2009 07:38:43 +
> "Samuli Suominen (ssuominen)"  wrote:
> 
> > ssuominen09/05/10 07:38:43
> > 
> >   Modified: ChangeLog cdrdao-1.2.2-r3.ebuild
> >   Log:
> >   Doesn't compile with distcc wrt #264170.
> >   (Portage version: 2.1.6.13/cvs/Linux x86_64)
> 
> > +pkg_setup() {
> > +   if hasq distcc ${FEATURES}; then
> > +   die "Please emerge without distcc in FEATURES, see bug #264170."
> > +   fi
> > +}
> > +
> 
> You can't test FEATURES in an ebuild.  It's portage-specific.
> 

Actually, am I right?  There's a crapload of stuff in the tree doing
things like this and worse with FEATURES.


-- 
gcc-porting,  by design, by neglect
treecleaner,  for a fact or just for effect
wxwidgets @ gentoo EFFD 380E 047A 4B51 D2BD C64F 8AA8 8346 F9A4 0662


signature.asc
Description: PGP signature


[gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-cdr/cdrdao: ChangeLog cdrdao-1.2.2-r3.ebuild

2009-05-10 Thread Ryan Hill
On Sun, 10 May 2009 07:38:43 +
"Samuli Suominen (ssuominen)"  wrote:

> ssuominen09/05/10 07:38:43
> 
>   Modified: ChangeLog cdrdao-1.2.2-r3.ebuild
>   Log:
>   Doesn't compile with distcc wrt #264170.
>   (Portage version: 2.1.6.13/cvs/Linux x86_64)

> +pkg_setup() {
> + if hasq distcc ${FEATURES}; then
> + die "Please emerge without distcc in FEATURES, see bug #264170."
> + fi
> +}
> +

You can't test FEATURES in an ebuild.  It's portage-specific.

-- 
gcc-porting,  by design, by neglect
treecleaner,  for a fact or just for effect
wxwidgets @ gentoo EFFD 380E 047A 4B51 D2BD C64F 8AA8 8346 F9A4 0662


signature.asc
Description: PGP signature