On 20:14 Sun 13 Jan     , Martin Jackson (mjolnir) wrote:
> 1.1                  dev-db/postgresql/postgresql-7.4.19.ebuild
> 
> file : 
> http://sources.gentoo.org/viewcvs.py/gentoo-x86/dev-db/postgresql/postgresql-7.4.19.ebuild?rev=1.1&view=markup
> plain: 
> http://sources.gentoo.org/viewcvs.py/gentoo-x86/dev-db/postgresql/postgresql-7.4.19.ebuild?rev=1.1&content-type=text/plain

> src_compile() {
>       filter-flags -ffast-math -feliminate-dwarf2-dups
> 
>       # Correctly support the XML stuff
>       if use xml ; then
>               CFLAGS="${CFLAGS} $(pkg-config --cflags libxml-2.0)"
>               LIBS="${LIBS} $(pkg-config --libs libxml-2.0)"
>       fi
> 
>       # Detect mips systems properly
>       gnuconfig_update
> 
>       cd "${S}"
> 
>       ./configure --prefix=/usr \
>               --includedir=/usr/include/postgresql/pgsql \
>               --sysconfdir=/etc/postgresql \
>               --mandir=/usr/share/man \
>               --host=${CHOST} \
>               --docdir=/usr/share/doc/${PF} \
>               --libdir=/usr/$(get_libdir) \

Could you add a comment if econf doesn't work here, and all the other 
PG-related ebuilds you committed recently? It looks like these options 
pretty much mirror what econf does.

>       emake -j1 LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die "main emake failed"

Is upstream aware that its parallel build is broken? It might be nice to 
add a link to the upstream bug, if one exists.

Thanks,
Donnie
-- 
gentoo-dev@lists.gentoo.org mailing list

Reply via email to