Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in dev-util/netbeans: ChangeLog netbeans-6.5-r1.ebuild netbeans-6.5.ebuild

2008-11-23 Thread Miroslav Šulc (fordfrog)
Thank you both for the suggestions, I fixed these issues in updated 
netbeans-6.5-r1.


Miroslav Šulc (fordfrog)
Gentoo Java Team

Jeremy Olexa napsal(a):

Peter Volkov wrote:

В Сбт, 22/11/2008 в 18:11 +, Miroslav Sulc (fordfrog) пишет:

fordfrog08/11/22 18:11:25
  Added:netbeans-6.5-r1.ebuild
  Log: netbeans compiles fine even with JDK 1.6 so I dropped the 
restriction on JDK, also commons-fileupload linking fixed



Index: netbeans-6.5-r1.ebuild
===
pkg_setup() {
if use netbeans_modules_apisupport  ! ( use 
netbeans_modules_harness  use netbeans_modules_ide  use 
netbeans_modules_java ) ; then
eerror 'apisupport' USE flag requires 'harness', 'ide' and 
'java' USE flags


Additionally, 'apisupport', 'harness', 'ide' and 'java' are not USE 
flags. You have to set NETBEANS_MODULES, not USE. You can easily test 
this by trying NETBEANS_MODULES=apisupport USE=java emerge -pv 
netbeans and see that netbeans_modules_java does not get set.

-Jeremy


exit 1
fi


Why do you use exit 1 instead of die?


local tmpfileplatform=${T}/platform.txt
cat ${tmpfile} | grep -v libs.jna/external/jna-3.0.2.jar  
${tmpfileplatform}

mv ${tmpfileplatform} ${tmpfile}


grep can read files on it's own so no need for cat file | grep... Also 
possibly


sed -e /libs\.jna\/external\/jna-3\.0\.2\.jar/d -i ${tmpfile}

will work better here and in some other places...








[gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in dev-util/netbeans: ChangeLog netbeans-6.5-r1.ebuild netbeans-6.5.ebuild

2008-11-22 Thread Peter Volkov
В Сбт, 22/11/2008 в 18:11 +, Miroslav Sulc (fordfrog) пишет:
 fordfrog08/11/22 18:11:25
   Added:netbeans-6.5-r1.ebuild
   Log: netbeans compiles fine even with JDK 1.6 so I dropped the restriction 
 on JDK, also commons-fileupload linking fixed

 Index: netbeans-6.5-r1.ebuild
 ===
 pkg_setup() {
   if use netbeans_modules_apisupport  ! ( use netbeans_modules_harness 
  use netbeans_modules_ide  use netbeans_modules_java ) ; then
   eerror 'apisupport' USE flag requires 'harness', 'ide' and 
 'java' USE flags
   exit 1
   fi

Why do you use exit 1 instead of die?

   local tmpfileplatform=${T}/platform.txt
   cat ${tmpfile} | grep -v libs.jna/external/jna-3.0.2.jar  
 ${tmpfileplatform}
   mv ${tmpfileplatform} ${tmpfile}

grep can read files on it's own so no need for cat file | grep... Also possibly

sed -e /libs\.jna\/external\/jna-3\.0\.2\.jar/d -i ${tmpfile}

will work better here and in some other places...

-- 
Peter.




Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in dev-util/netbeans: ChangeLog netbeans-6.5-r1.ebuild netbeans-6.5.ebuild

2008-11-22 Thread Jeremy Olexa

Peter Volkov wrote:

В Сбт, 22/11/2008 в 18:11 +, Miroslav Sulc (fordfrog) пишет:

fordfrog08/11/22 18:11:25
  Added:netbeans-6.5-r1.ebuild
  Log: netbeans compiles fine even with JDK 1.6 so I dropped the restriction on 
JDK, also commons-fileupload linking fixed



Index: netbeans-6.5-r1.ebuild
===
pkg_setup() {
if use netbeans_modules_apisupport  ! ( use netbeans_modules_harness  use 
netbeans_modules_ide  use netbeans_modules_java ) ; then
eerror 'apisupport' USE flag requires 'harness', 'ide' and 'java' 
USE flags


Additionally, 'apisupport', 'harness', 'ide' and 'java' are not USE 
flags. You have to set NETBEANS_MODULES, not USE. You can easily test 
this by trying NETBEANS_MODULES=apisupport USE=java emerge -pv 
netbeans and see that netbeans_modules_java does not get set.

-Jeremy


exit 1
fi


Why do you use exit 1 instead of die?


local tmpfileplatform=${T}/platform.txt
cat ${tmpfile} | grep -v libs.jna/external/jna-3.0.2.jar  
${tmpfileplatform}
mv ${tmpfileplatform} ${tmpfile}


grep can read files on it's own so no need for cat file | grep... Also possibly

sed -e /libs\.jna\/external\/jna-3\.0\.2\.jar/d -i ${tmpfile}

will work better here and in some other places...