[gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in net-proxy/polipo: ChangeLog polipo-1.0.3.ebuild polipo-1.0.1.ebuild polipo-1.0.0.ebuild polipo-0.9.12-r1.ebuild

2007-11-03 Thread Alin Năstac
Donnie Berkholz wrote:
 On 15:38 Fri 02 Nov , Alin Nastac (mrness) wrote:
   
 1.1 net-proxy/polipo/polipo-1.0.3.ebuild

 file : 
 http://sources.gentoo.org/viewcvs.py/gentoo-x86/net-proxy/polipo/polipo-1.0.3.ebuild?rev=1.1view=markup
 plain: 
 http://sources.gentoo.org/viewcvs.py/gentoo-x86/net-proxy/polipo/polipo-1.0.3.ebuild?rev=1.1content-type=text/plain
 

   
 pkg_setup() {
  enewgroup polipo
  enewuser polipo -1 -1 /var/cache/polipo polipo
 }
 

 ...

   
 pkg_preinst() {
  pkg_setup
 }
 

 What's up with this?
   

You have to create users and groups in both pkg_ functions:
  - pkg_setup : when installation is performed the usual way, through
compilation
  - pkg_preinst: when installed from binary package (-k)




signature.asc
Description: OpenPGP digital signature


Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in net-proxy/polipo: ChangeLog polipo-1.0.3.ebuild polipo-1.0.1.ebuild polipo-1.0.0.ebuild polipo-0.9.12-r1.ebuild

2007-11-03 Thread Donnie Berkholz
On 10:37 Sat 03 Nov , Alin Năstac wrote:
 You have to create users and groups in both pkg_ functions:
   - pkg_setup : when installation is performed the usual way, through
 compilation
   - pkg_preinst: when installed from binary package (-k)

You shouldn't, all pkg_* functions should always be run regardless of 
binary or source package. File a portage bug if pkg_setup() isn't 
getting run, don't work around it.

Thanks,
Donnie
-- 
[EMAIL PROTECTED] mailing list



Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in net-proxy/polipo: ChangeLog polipo-1.0.3.ebuild polipo-1.0.1.ebuild polipo-1.0.0.ebuild polipo-0.9.12-r1.ebuild

2007-11-03 Thread Alin Năstac
Donnie Berkholz wrote:
 On 10:37 Sat 03 Nov , Alin Năstac wrote:
   
 You have to create users and groups in both pkg_ functions:
   - pkg_setup : when installation is performed the usual way, through
 compilation
   - pkg_preinst: when installed from binary package (-k)
 

 You shouldn't, all pkg_* functions should always be run regardless of 
 binary or source package. File a portage bug if pkg_setup() isn't 
 getting run, don't work around it.
   

If that is true (dunno, I didn't tested it yet) then someone should
correct http://www.gentoo.org/proj/en/devrel/handbook/handbook.xml .

Quote from the aforementioned document:

pkg_setup Use this function to perform any miscellaneous
prerequisite tasks. This might include checking for an existing
configuration file. If it is necessary to add users here, you must
also do this check in pkg_preinst() before the package gets installed.





signature.asc
Description: OpenPGP digital signature


Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in net-proxy/polipo: ChangeLog polipo-1.0.3.ebuild polipo-1.0.1.ebuild polipo-1.0.0.ebuild polipo-0.9.12-r1.ebuild

2007-11-03 Thread Mike Frysinger
On Saturday 03 November 2007, Alin Năstac wrote:
 Donnie Berkholz wrote:
  On 10:37 Sat 03 Nov , Alin Năstac wrote:
  You have to create users and groups in both pkg_ functions:
- pkg_setup : when installation is performed the usual way, through
  compilation
- pkg_preinst: when installed from binary package (-k)
 
  You shouldn't, all pkg_* functions should always be run regardless of
  binary or source package. File a portage bug if pkg_setup() isn't
  getting run, don't work around it.

 If that is true (dunno, I didn't tested it yet)

it is true, please update your package to create the users whenever it's 
appropriate, and only once.

 then someone should 
 correct http://www.gentoo.org/proj/en/devrel/handbook/handbook.xml .

 Quote from the aforementioned document:

fixed.
-mike


signature.asc
Description: This is a digitally signed message part.


[gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in net-proxy/polipo: ChangeLog polipo-1.0.3.ebuild polipo-1.0.1.ebuild polipo-1.0.0.ebuild polipo-0.9.12-r1.ebuild

2007-11-02 Thread Donnie Berkholz
On 15:38 Fri 02 Nov , Alin Nastac (mrness) wrote:
 1.1 net-proxy/polipo/polipo-1.0.3.ebuild
 
 file : 
 http://sources.gentoo.org/viewcvs.py/gentoo-x86/net-proxy/polipo/polipo-1.0.3.ebuild?rev=1.1view=markup
 plain: 
 http://sources.gentoo.org/viewcvs.py/gentoo-x86/net-proxy/polipo/polipo-1.0.3.ebuild?rev=1.1content-type=text/plain

 pkg_setup() {
   enewgroup polipo
   enewuser polipo -1 -1 /var/cache/polipo polipo
 }

...

 pkg_preinst() {
   pkg_setup
 }

What's up with this?

Thanks,
Donnie
-- 
[EMAIL PROTECTED] mailing list