>  EAPI=2
> -
>  inherit eutils
>  
>  DESCRIPTION="Mailfilter is a utility to get rid of unwanted spam mails"
> @@ -19,16 +18,16 @@
>  RDEPEND=""
>  
>  src_prepare() {
> -     epatch "${FILESDIR}"/0.8.2-gcc44.patch
> +     epatch "${FILESDIR}"/0.8.2-gcc44.patch \
> +             "${FILESDIR}"/0.8.2-openssl-1.patch
>  }
>  
>  src_compile() {
> -     # bug #281069
> -     emake -j1 || die "emake failed"
> +     emake -j1 || die #281069
>  }
>  
>  src_install() {
> -     emake DESTDIR="${D}" install || die "make install failed"
> +     emake DESTDIR="${D}" install || die
>       dodoc INSTALL doc/FAQ "${FILESDIR}"/rcfile.example{1,2} \
> -             README THANKS ChangeLog AUTHORS NEWS || die "doc failed"
> +             README THANKS ChangeLog AUTHORS NEWS || die
>  }

Etiquette policy 
<http://www.gentoo.org/proj/en/devrel/handbook/handbook.xml?part=3&chap=2>:
| Respect developers' coding preferences. Unnecessarily changing the
| syntax of an ebuild increases the load on the CVS server and can cause
| complications for others. Syntax changes should only be done if there is
| a real benefit, such as faster compilation, improved information for the
| end user, or compliance to Gentoo policies.

If you are not the maintainer, don't quote any policy compliance in
ChangeLog, I think this is a breach of the etiquette policy.

Thanks

Reply via email to