Re: [gentoo-dev] gentoo-x86 commit in sys-cluster/csync2: ChangeLog csync2-1.34.ebuild

2007-09-21 Thread Denis Dupeyron
On 9/20/07, Bo Ørsted Andresen [EMAIL PROTECTED] wrote:
 On Thursday 20 September 2007 19:54:16 Donnie Berkholz wrote:
   econf has default econf failed die message.
   The following would be sufficient:
   econf \
   --localstatedir=/var \
   --sysconfdir=/etc/csync2
 
  Is that so ... when did that appear? Does it happen for all of the
  package managers? Which functions do this? Where is it documented?

 The currect PMS draft documents it (for econf only). All three package
 managers conform to it.

As you seem to know, PMS is still a draft and as such can't be
considered a valid reference document yet. The econf function is
indeed the only one that is officially documented as aborting
automatically via die(). You can find this in our Gentoo Development
Guide available at devmanual.gentoo.org.

In any case it is considered good practice to always add '||
die(message)' after all helper functions. The reason is you can't
(or shouldn't) rely on any of them dying properly now or in the
future. Plus adding a specific message helps debugging.

And about the existence of other package managers, yes, I've heard
that rumor too. I've even heard that they may work, but I can't
confirm.

Denis.
���^����(� ��X��X�

Re: [gentoo-dev] gentoo-x86 commit in sys-cluster/csync2: ChangeLog csync2-1.34.ebuild

2007-09-20 Thread Arfrever Frehtes Taifersar Arahesis
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1

2007-09-20 19:20:41 Donnie Berkholz napisał(a):
 On 08:49 Thu 20 Sep , Christian Zoffoli (xmerlin) wrote:
  xmerlin 07/09/20 08:49:25
  
Modified: ChangeLog
Added:csync2-1.34.ebuild
Log:
Version bump.
(Portage version: 2.1.2.2)
 
  1.1  sys-cluster/csync2/csync2-1.34.ebuild
  
  file : 
  http://sources.gentoo.org/viewcvs.py/gentoo-x86/sys-cluster/csync2/csync2-1.34.ebuild?rev=1.1view=markup
  plain: 
  http://sources.gentoo.org/viewcvs.py/gentoo-x86/sys-cluster/csync2/csync2-1.34.ebuild?rev=1.1content-type=text/plain
 
  src_compile() {
  econf \
  --localstatedir=/var \
  --sysconfdir=/etc/csync2 \
  || die
  
  emake || die
 
 These could really use some die() messages, so you know which one failed.

econf has default econf failed die message.
The following would be sufficient:
econf \
--localstatedir=/var \
--sysconfdir=/etc/csync2


- -- 
Arfrever Frehtes Taifersar Arahesis
-BEGIN PGP SIGNATURE-
Version: GnuPG v2.0.7 (GNU/Linux)

iD8DBQFG8q6q/axNJ4Xo/ZERAkj4AJ9D2hO+CfjENmHB6fhTlP8afVvyaACgprji
ARAvSORW6ojPwlzE8f/2CFw=
=UfIJ
-END PGP SIGNATURE-
-- 
[EMAIL PROTECTED] mailing list



Re: [gentoo-dev] gentoo-x86 commit in sys-cluster/csync2: ChangeLog csync2-1.34.ebuild

2007-09-20 Thread Donnie Berkholz
On 19:31 Thu 20 Sep , Arfrever Frehtes Taifersar Arahesis wrote:
   src_compile() {
 econf \
 --localstatedir=/var \
 --sysconfdir=/etc/csync2 \
 || die
   
 emake || die
  
  These could really use some die() messages, so you know which one failed.
 
 econf has default econf failed die message.
 The following would be sufficient:
   econf \
   --localstatedir=/var \
   --sysconfdir=/etc/csync2

Is that so ... when did that appear? Does it happen for all of the 
package managers? Which functions do this? Where is it documented?

Thanks,
Donnie
-- 
[EMAIL PROTECTED] mailing list



Re: [gentoo-dev] gentoo-x86 commit in sys-cluster/csync2: ChangeLog csync2-1.34.ebuild

2007-09-20 Thread Arfrever Frehtes Taifersar Arahesis
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1

2007-09-20 19:53:53 Donnie Berkholz napisał(a):
 On 19:31 Thu 20 Sep , Arfrever Frehtes Taifersar Arahesis wrote:
src_compile() {
econf \
--localstatedir=/var \
--sysconfdir=/etc/csync2 \
|| die

emake || die
   
   These could really use some die() messages, so you know which one failed.
  
  econf has default econf failed die message.
  The following would be sufficient:
  econf \
  --localstatedir=/var \
  --sysconfdir=/etc/csync2
 
 Does it happen for all of the package managers?

I don't know.

 Which functions do this?

Read /usr/lib/portage/bin/ebuild.sh:econf().

 Where is it documented?

Unfortunately it's probably undocumented.

- -- 
Arfrever Frehtes Taifersar Arahesis
-BEGIN PGP SIGNATURE-
Version: GnuPG v2.0.7 (GNU/Linux)

iD8DBQFG8rXB/axNJ4Xo/ZERAqh5AJ9iwuH3EEWKXLb5P9L/TZCaM2r95ACfdWiz
Ogzh4t/qqSvvwvjwSY/Z0R4=
=19/n
-END PGP SIGNATURE-
-- 
[EMAIL PROTECTED] mailing list



Re: [gentoo-dev] gentoo-x86 commit in sys-cluster/csync2: ChangeLog csync2-1.34.ebuild

2007-09-20 Thread Bo Ørsted Andresen
On Thursday 20 September 2007 19:54:16 Donnie Berkholz wrote:
  econf has default econf failed die message.
  The following would be sufficient:
    econf \
    --localstatedir=/var \
    --sysconfdir=/etc/csync2

 Is that so ... when did that appear? Does it happen for all of the
 package managers? Which functions do this? Where is it documented?

The currect PMS draft documents it (for econf only). All three package 
managers conform to it.

-- 
Bo Andresen


signature.asc
Description: This is a digitally signed message part.


Re: [gentoo-dev] gentoo-x86 commit in sys-cluster/csync2: ChangeLog csync2-1.34.ebuild

2007-09-20 Thread Mike Frysinger
On Thursday 20 September 2007, Donnie Berkholz wrote:
 On 19:31 Thu 20 Sep , Arfrever Frehtes Taifersar Arahesis wrote:
src_compile() {
econf \
--localstatedir=/var \
--sysconfdir=/etc/csync2 \
   
|| die
   
emake || die
  
   These could really use some die() messages, so you know which one
   failed.
 
  econf has default econf failed die message.
  The following would be sufficient:
  econf \
  --localstatedir=/var \
  --sysconfdir=/etc/csync2

 Is that so ... when did that appear? Does it happen for all of the
 package managers? Which functions do this? Where is it documented?

econf has always died as far as i know ... however, we've been using econf||
die as a standard for just as long and i dont think we should change now
-mike


signature.asc
Description: This is a digitally signed message part.