Re: [gentoo-dev] lurking *.ebuild'less packages

2012-03-16 Thread Corentin Chary
On Thu, Mar 15, 2012 at 10:42 PM, Matt Turner matts...@gentoo.org wrote:
 On Thu, Mar 15, 2012 at 4:59 PM, Sergei Trofimovich sly...@gentoo.org wrote:
 slep noticed and reported an odd thing:

 $ euse -i kate
 ...
 ls: cannot access 
 /gentoo/portage/metadata/cache/kde-base/kdebindings-perl-*: No such file or 
 directory
 ls: cannot access 
 /gentoo/portage/metadata/cache/kde-base/kdebindings-ruby-*: No such file or 
 directory
 ...

 The dirs they don't contain ebuilds. Only metadata.
 KDE team is aware and fixing their orphans.

 I've decided to write a hack to find such instances in tree:

 $ ./find_empty.sh ~/portage/gentoo-x86/
 kde-base/kdeaccessibility-colorschemes
 kde-base/kdeaccessibility-iconthemes
 kde-base/kdebase-wallpapers
 kde-base/kdebindings-csharp
 kde-base/kdebindings-perl
 kde-base/kdebindings-ruby
 kde-base/kvtml-data
 kde-base/smoke
 media-plugins/mytharchive
 media-plugins/mythbrowser
 media-plugins/mythgallery
 media-plugins/mythgame
 media-plugins/mythmovies
 media-plugins/mythmusic
 media-plugins/mythnetvision
 media-plugins/mythnews
 media-plugins/mythweather
 x11-themes/mythtv-themes

 Is there any reason to leave such ebuildless directories?

 Thanks!

 --

  Sergei

 Let's get this script added to http://qa-reports.gentoo.org/


Speaking about qa-reports, do you think SRC_URI not using mirror://
when they should and metadata.xml not containing remote-id when they
should belong there ?
If yes, please take a look at:
- https://github.com/iksaif/portage-janitor
- https://bugs.gentoo.org/show_bug.cgi?id=405533
- https://bugs.gentoo.org/show_bug.cgi?id=406287

Thanks,
-- 
Corentin Chary
http://xf.iksaif.net



[gentoo-dev] lurking *.ebuild'less packages

2012-03-15 Thread Sergei Trofimovich
slep noticed and reported an odd thing:

$ euse -i kate
...
ls: cannot access /gentoo/portage/metadata/cache/kde-base/kdebindings-perl-*: 
No such file or directory
ls: cannot access /gentoo/portage/metadata/cache/kde-base/kdebindings-ruby-*: 
No such file or directory
...

The dirs they don't contain ebuilds. Only metadata.
KDE team is aware and fixing their orphans.

I've decided to write a hack to find such instances in tree:

$ ./find_empty.sh ~/portage/gentoo-x86/
kde-base/kdeaccessibility-colorschemes
kde-base/kdeaccessibility-iconthemes
kde-base/kdebase-wallpapers
kde-base/kdebindings-csharp
kde-base/kdebindings-perl
kde-base/kdebindings-ruby
kde-base/kvtml-data
kde-base/smoke
media-plugins/mytharchive
media-plugins/mythbrowser
media-plugins/mythgallery
media-plugins/mythgame
media-plugins/mythmovies
media-plugins/mythmusic
media-plugins/mythnetvision
media-plugins/mythnews
media-plugins/mythweather
x11-themes/mythtv-themes

Is there any reason to leave such ebuildless directories?

Thanks!

-- 

  Sergei


find_empty.sh
Description: application/shellscript


signature.asc
Description: PGP signature


Re: [gentoo-dev] lurking *.ebuild'less packages

2012-03-15 Thread Matt Turner
On Thu, Mar 15, 2012 at 4:59 PM, Sergei Trofimovich sly...@gentoo.org wrote:
 slep noticed and reported an odd thing:

 $ euse -i kate
 ...
 ls: cannot access /gentoo/portage/metadata/cache/kde-base/kdebindings-perl-*: 
 No such file or directory
 ls: cannot access /gentoo/portage/metadata/cache/kde-base/kdebindings-ruby-*: 
 No such file or directory
 ...

 The dirs they don't contain ebuilds. Only metadata.
 KDE team is aware and fixing their orphans.

 I've decided to write a hack to find such instances in tree:

 $ ./find_empty.sh ~/portage/gentoo-x86/
 kde-base/kdeaccessibility-colorschemes
 kde-base/kdeaccessibility-iconthemes
 kde-base/kdebase-wallpapers
 kde-base/kdebindings-csharp
 kde-base/kdebindings-perl
 kde-base/kdebindings-ruby
 kde-base/kvtml-data
 kde-base/smoke
 media-plugins/mytharchive
 media-plugins/mythbrowser
 media-plugins/mythgallery
 media-plugins/mythgame
 media-plugins/mythmovies
 media-plugins/mythmusic
 media-plugins/mythnetvision
 media-plugins/mythnews
 media-plugins/mythweather
 x11-themes/mythtv-themes

 Is there any reason to leave such ebuildless directories?

 Thanks!

 --

  Sergei

Let's get this script added to http://qa-reports.gentoo.org/



Re: [gentoo-dev] lurking *.ebuild'less packages

2012-03-15 Thread Andreas K. Huettel
Am Donnerstag, 15. März 2012, 21:59:44 schrieb Sergei Trofimovich:
 ls: cannot access
 /gentoo/portage/metadata/cache/kde-base/kdebindings-perl-*: No such file
 or directory ls: cannot access
 /gentoo/portage/metadata/cache/kde-base/kdebindings-ruby-*: No such file
 or directory ...

In the case of kde ebuilds it's a slip-up, a side effect of kde-4.6 removal... 
some code got refactored and moved to different package names. E.g. 
kdebindings-ruby is now partly in korundum and krossruby... When one of us 
then runs 
find kde-base -name *4.6.5*ebuild -exec cvs rm -f {} +
and commits, oops, suddenly we have an empty dir kdebindings-ruby... :| 
Obviously undesired but can happen, and repoman does not complain (yet).

(It makes no sense to do any last-riting here, in effect this is more like a 
package move and we try to make it as transparent to the users as possible.)

Cheers, A

-- 
Andreas K. Huettel
Gentoo Linux developer 
kde, sci, tex, arm, printing
dilfri...@gentoo.org
http://www.akhuettel.de/


signature.asc
Description: This is a digitally signed message part.