Re: [gentoo-dev] Summary of suggested new features in EAPI=4

2010-12-18 Thread Fabian Groffen
On 18-12-2010 02:45:06 +0100, Arfrever Frehtes Taifersar Arahesis wrote: Problem #1: USE flags cannot contain . characters. The following solutions have been suggested: - Add support for . characters in USE flags in EAPI=4. Like Donnie said, this feels like a purely cosmetic change. I

Re: [gentoo-dev] Summary of suggested new features in EAPI=4

2010-12-18 Thread Zac Medico
On 12/18/2010 01:57 AM, Fabian Groffen wrote: On 18-12-2010 02:45:06 +0100, Arfrever Frehtes Taifersar Arahesis wrote: Problem #1: USE flags cannot contain . characters. The following solutions have been suggested: - Add support for . characters in USE flags in EAPI=4. Like Donnie said,

Re: [gentoo-dev] What are || ( ) dependencies?

2010-12-18 Thread Ciaran McCreesh
On Fri, 17 Dec 2010 20:13:55 -0600 Donnie Berkholz dberkh...@gentoo.org wrote: What about if you decide upon a early on, and then later on something hard-depends upon b? Then you're collapsing the graph too early. =) (speaking as an utter novice) Yeah, but unfortunately, there's no way to

[gentoo-dev] Re: What are || ( ) dependencies?

2010-12-18 Thread Ryan Hill
On Fri, 17 Dec 2010 15:25:04 + Ciaran McCreesh ciaran.mccre...@googlemail.com wrote: So would anyone be especially opposed to making best leftmost an explicit requirement, enforced by repoman where possible (at least for the = / case)? I already thought that was the case, so +1 from me.

Re: [gentoo-dev] Summary of suggested new features in EAPI=4

2010-12-18 Thread Ciaran McCreesh
On Fri, 17 Dec 2010 20:48:26 -0600 Donnie Berkholz dberkh...@gentoo.org wrote: I don't know of anyone who's actually done this, but setting IUSE based on ACCEPT_KEYWORDS being ~arch should be possible. There may be better or easier solutions. Uhm... IUSE has to be metadata-invariant. --

[gentoo-dev] Lastrite: gnome-device-manager, devtray

2010-12-18 Thread Samuli Suominen
# Samuli Suominen ssuomi...@gentoo.org (19 Dec 2010) # Graphical interface for sys-apps/hal. Removal in 30 days. gnome-extra/gnome-device-manager # Samuli Suominen ssuomi...@gentoo.org (19 Dec 2010) # Replaced by rox-base/rox-media, bug 313431, Comment #2 # Still using obsolete sys-apps/hal and

Re: [gentoo-dev] Re: What are || ( ) dependencies?

2010-12-18 Thread Jorge Manuel B. S. Vicetto
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 18-12-2010 18:35, Ryan Hill wrote: On Fri, 17 Dec 2010 15:25:04 + Ciaran McCreesh ciaran.mccre...@googlemail.com wrote: So would anyone be especially opposed to making best leftmost an explicit requirement, enforced by repoman where

[gentoo-dev] Lastrite: hal-cups-utils

2010-12-18 Thread Samuli Suominen
# Samuli Suominen ssuomi...@gentoo.org (19 Dec 2010) # Orphaned package, still using deprecated HAL # Removal in 30 days, bug 344313 app-misc/hal-cups-utils

Re: [gentoo-dev] What are || ( ) dependencies?

2010-12-18 Thread Zac Medico
On 12/17/2010 06:13 PM, Donnie Berkholz wrote: On 15:25 Fri 17 Dec , Ciaran McCreesh wrote: Things get messier when you've got || ( a b-2.1 ) and b-2.0 is installed and a is not. Should b be upgraded to 2.1, or should a be selected? It depends ... see later. What about if you decide