[gentoo-dev] [PATCH] l10n.eclass: Update for unexpanded LINGUAS.

2017-12-29 Thread Ulrich Müller
--- This is meant to be merged after removal of LINGUAS from USE_EXPAND. Any packages inheriting l10n.eclass but not using any of its functions (i.e. relying only on the global scope snippet that adds linguas_* USE flags) will be updated at the same time. eclass/l10n.eclass | 40

[gentoo-dev] Dropping stable USE flags for 4.14

2017-12-29 Thread Alice Ferrazzi
Hello, We have recently started the stabilization of gentoo-sources-4.14.8. Very soon we received reports regarding broken e1000e driver [1] and moved to gentoo-sources-4.14.8-r1. Since then we keep receiving new problems related to 4.14.x kernel: - IPSec is broken [2] - Change in 4.14.9

Re: [gentoo-dev] Dropping stable USE flags for 4.14

2017-12-29 Thread Toralf Förster
On 12/29/2017 02:58 PM, Alice Ferrazzi wrote: > While not all issues are present in gentoo-sources-4.14.8-r1 we are > concerned about the current stability/quality of the 4.14.x branch in 4.14.9 prevents both my desktop and my server from being boot, hangs very early in the process before dmesg

Re: [gentoo-portage-dev] [PATCH] bin/doins.py: implement install -p option (bug 642632)

2017-12-29 Thread Mike Gilbert
On Fri, Dec 29, 2017 at 3:35 PM, Zac Medico wrote: > + if self._parsed_options.preserve_timestamps: > + if sys.version_info >= (3, 3): > + os.utime(dest, ns=(sstat.st_mtime_ns, >

Re: [gentoo-dev] Dropping stable USE flags for 4.14

2017-12-29 Thread Andreas K. Huettel
Am Freitag, 29. Dezember 2017, 15:46:03 CET schrieb Toralf Förster: > On 12/29/2017 02:58 PM, Alice Ferrazzi wrote: > > While not all issues are present in gentoo-sources-4.14.8-r1 we are > > concerned about the current stability/quality of the 4.14.x branch in > I'd suggest dropping stable for

[gentoo-portage-dev] [PATCH] bin/doins.py: implement install -p option (bug 642632)

2017-12-29 Thread Zac Medico
Bug: https://bugs.gentoo.org/642632 --- bin/doins.py| 13 ++--- pym/portage/tests/bin/test_doins.py | 4 ++-- 2 files changed, 12 insertions(+), 5 deletions(-) diff --git a/bin/doins.py b/bin/doins.py index 92e450979..dceffee83 100644 --- a/bin/doins.py +++

Re: [gentoo-dev] [PATCH 1/1] profiles: drop USE=cracklib from base/make.defaults.

2017-12-29 Thread William Hubbs
On Thu, Dec 28, 2017 at 05:42:19PM -0500, Michael Orlitzky wrote: > We now have IUSE="+cracklib" in sys-apps/shadow, sys-auth/pambase, and > sys-libs/pam (thanks robbat2). > > Does that address everyone's concerns? > > Enough so that I can revert the revert without anyone reverting the > revert

Re: [gentoo-portage-dev] [PATCH] bin/doins.py: implement install -p option (bug 642632)

2017-12-29 Thread Zac Medico
On 12/29/2017 02:13 PM, Mike Gilbert wrote: > On Fri, Dec 29, 2017 at 3:35 PM, Zac Medico wrote: >> + if self._parsed_options.preserve_timestamps: >> + if sys.version_info >= (3, 3): >> +

[gentoo-portage-dev] [PATCH v2] bin/doins.py: implement install -p option (bug 642632)

2017-12-29 Thread Zac Medico
Bug: https://bugs.gentoo.org/642632 --- [PATCH v2] fix to copy atime, and split out _set_timestamps function bin/doins.py| 28 +--- pym/portage/tests/bin/test_doins.py | 6 -- 2 files changed, 29 insertions(+), 5 deletions(-) diff --git

[gentoo-dev] Masking 4.12

2017-12-29 Thread Alice Ferrazzi
Hello, We recently dropped the stable keywords for 4.14, but 4.12 (the next stable in gentoo-sources) is no more maintained from upstream. The last update that 4.12 got from upstream was 2017-09-20, and upstream is no more backporting security fixes since then. Because of this, we will proceed