Re: [gentoo-dev] Patches to update toolchain.eclass to EAPI=5

2017-12-30 Thread Anthony G. Basile
On 12/30/17 9:13 AM, Anthony G. Basile wrote: > On 12/30/17 9:08 AM, Michael Orlitzky wrote: >> On 12/30/2017 07:22 AM, Anthony G. Basile wrote: >>> use_if_iuse !nopie && return 0 >> >> Does this work? The "use" function supports negation (undocumented, but >> it's in the PMS), but I don't think

[gentoo-dev] [PATCH] Migrate CROSSCOMPILE_OPTS=headers-only -> USE=headers-only

2017-12-30 Thread Sergei Trofimovich
) - added global 'headers-only' USE - CROSSCOMPILE_OPTS USE_EXPAND is removed 'headers-only' flag is used by crossdev to bootstrap stage1 compiler before libc is available. crossdev switched to USE=headers-only in =sys-devel/crossdev-20171230. After crossdev goes stable this change can go in. CC: toolch

Re: [gentoo-dev] Patches to update toolchain.eclass to EAPI=5

2017-12-30 Thread Andreas K. Huettel
Am Samstag, 30. Dezember 2017, 13:22:52 CET schrieb Anthony G. Basile: > Hi everyone, > > We've been stuck on EAPI=4 with toolchain.eclass for a while. This is > causing problems with subslotting libraries like mpfr, mpc, gmp and isl > that gcc depend on (see bug #642316). I went through and

Re: [gentoo-dev] Patches to update toolchain.eclass to EAPI=5

2017-12-30 Thread Anthony G. Basile
On 12/30/17 9:08 AM, Michael Orlitzky wrote: > On 12/30/2017 07:22 AM, Anthony G. Basile wrote: >> use_if_iuse !nopie && return 0 > > Does this work? The "use" function supports negation (undocumented, but > it's in the PMS), but I don't think use_if_iuse does. > Okay I'll read the code and

Re: [gentoo-dev] Masking 4.12

2017-12-30 Thread Rich Freeman
On Sat, Dec 30, 2017 at 3:49 AM, Toralf Förster wrote: > On 12/30/2017 07:52 AM, Alice Ferrazzi wrote: >> Hello, >> >> We recently dropped the stable keywords for 4.14, >> but 4.12 (the next stable in gentoo-sources) is no more >> maintained from upstream. >> >> The last update

[gentoo-dev] Patches to update toolchain.eclass to EAPI=5

2017-12-30 Thread Anthony G. Basile
Hi everyone, We've been stuck on EAPI=4 with toolchain.eclass for a while. This is causing problems with subslotting libraries like mpfr, mpc, gmp and isl that gcc depend on (see bug #642316). I went through and made the changes necessary to get the eclass up to EAPI=5 and compile tested across

Re: [gentoo-dev] Patches to update toolchain.eclass to EAPI=5

2017-12-30 Thread Michael Orlitzky
On 12/30/2017 07:22 AM, Anthony G. Basile wrote: > use_if_iuse !nopie && return 0 Does this work? The "use" function supports negation (undocumented, but it's in the PMS), but I don't think use_if_iuse does.

[gentoo-dev] Re: [gentoo-kernel] Dropping stable USE flags for 4.14

2017-12-30 Thread Greg KH
On Fri, Dec 29, 2017 at 10:58:28PM +0900, Alice Ferrazzi wrote: > Hello, > > We have recently started the stabilization of gentoo-sources-4.14.8. > > Very soon we received reports regarding broken e1000e driver [1] and moved > to gentoo-sources-4.14.8-r1. > > Since then we keep receiving new

[gentoo-dev] Re: [gentoo-kernel] Dropping stable USE flags for 4.14

2017-12-30 Thread Greg KH
On Sat, Dec 30, 2017 at 03:14:45PM +0100, Greg KH wrote: > On Fri, Dec 29, 2017 at 10:58:28PM +0900, Alice Ferrazzi wrote: > > > > - Unbootable system with CONFIG_MCORE2 [6] This turns out to be a gentoo-specific bug, not much upstream can do about a broken compiler that some profiles are using

Re: [gentoo-dev] LINGUAS to be removed from USE_EXPAND

2017-12-30 Thread grozin
On Thu, 28 Dec 2017, Ulrich Mueller wrote: Last year we had announced introduction of a new L10N variable intended to replace LINGUAS as a USE_EXPAND variable [1]. Since then, many packages have been converted to the new variable. The next step in the conversion will be removal of LINGUAS from

Re: [gentoo-portage-dev] [PATCH v2] bin/doins.py: implement install -p option (bug 642632)

2017-12-30 Thread Zac Medico
On 12/30/2017 01:45 PM, Mike Gilbert wrote: > On Fri, Dec 29, 2017 at 7:19 PM, Zac Medico wrote: >> +def _set_timestamps(source_stat, dest): >> + """Apply timestamps from source_stat to dest. >> + >> + Args: >> + source_stat: stat result for the

Re: [gentoo-dev] LINGUAS to be removed from USE_EXPAND

2017-12-30 Thread Chí-Thanh Christopher Nguyễn
gro...@gentoo.org schrieb: > The package sci-mathematics/maxima for ages uses linguas_* flags for > installing translated documentation, the possible values of * are > > de es pt pt_BR > > This usage is, I suppose, wrong. I tried simply to replace all linguas_ to > l10n_ in the ebuild, but

Re: [gentoo-portage-dev] [PATCH v2] bin/doins.py: implement install -p option (bug 642632)

2017-12-30 Thread Mike Gilbert
On Fri, Dec 29, 2017 at 7:19 PM, Zac Medico wrote: > +def _set_timestamps(source_stat, dest): > + """Apply timestamps from source_stat to dest. > + > + Args: > + source_stat: stat result for the source file. > + dest: path to the dest

[gentoo-dev] Last rites: vmware-bundle.eclass

2017-12-30 Thread Mike Gilbert
vmwware-bundle.eclass is unused since the vmware ebuilds were removed from the gentoo repository. The eclass will be removed in 30 days. A copy of the eclass has already been added to the vmware repository. https://bugs.gentoo.org/642710

Re: [gentoo-dev] Patches to update toolchain.eclass to EAPI=5

2017-12-30 Thread Anthony G. Basile
On 12/30/17 12:18 PM, Andreas K. Huettel wrote: > Am Samstag, 30. Dezember 2017, 13:22:52 CET schrieb Anthony G. Basile: >> Hi everyone, >> >> We've been stuck on EAPI=4 with toolchain.eclass for a while. This is >> causing problems with subslotting libraries like mpfr, mpc, gmp and isl >> that

[gentoo-dev] Packages up for grabs: media-sound/supercollider, media-gfx/maim, x11-misc/slop

2017-12-30 Thread Jonas Stein
Dear all, The following packages are up for grabs: media-sound/supercollider media-gfx/maim x11-misc/slop after retirement of the proxied maintainer. https://bugs.gentoo.org/615364 https://packages.gentoo.org/packages/media-sound/supercollider

Re: [gentoo-dev] Masking 4.12

2017-12-30 Thread Toralf Förster
On 12/30/2017 07:52 AM, Alice Ferrazzi wrote: > Hello, > > We recently dropped the stable keywords for 4.14, > but 4.12 (the next stable in gentoo-sources) is no more > maintained from upstream. > > The last update that 4.12 got from upstream was 2017-09-20, > and upstream is no more backporting