Re: [gentoo-dev] Deleting old news items

2018-01-05 Thread Alec Warner
On Fri, Jan 5, 2018 at 5:09 PM, Kristian Fiskerstrand wrote: > On 01/05/2018 10:28 PM, Aaron W. Swenson wrote: > > On 2018-01-05 15:16, William Hubbs wrote: > >> If we have a default expiration, it should be one year after the date > >> posted to go along with our current policy

Re: [gentoo-dev] Deleting old news items

2018-01-05 Thread Kristian Fiskerstrand
On 01/05/2018 11:40 PM, Alec Warner wrote: >> I might sound like a broken CD here, but why define the expiration as >> part of the news format instead of specifying it in the package manager >> as a user defined variable? Various use cases requires different >> treatment, so leaving it up to user

[gentoo-dev] sys-kernel/genkernel-3.5.2.5 stable testing request (bug #641774)

2018-01-05 Thread Robin H. Johnson
Hi all, I'd like to ask for more testers for sys-kernel/genkernel-3.5.2.5, so that it soon be stabilized for early CPU microcode loading with the Meltdown/Spectre vulnerabilities. I'm thinking there will probably be a 3.5.2.6 with a further fix for bug #505810, but that only affects users who

Re: [gentoo-dev] Deleting old news items

2018-01-05 Thread Kristian Fiskerstrand
On 01/05/2018 10:28 PM, Aaron W. Swenson wrote: > On 2018-01-05 15:16, William Hubbs wrote: >> If we have a default expiration, it should be one year after the date >> posted to go along with our current policy of not supporting things that >> are older than a year. >> >> William > > I thought it

[gentoo-dev] LINGUAS added to info_vars

2018-01-05 Thread Ulrich Mueller
I have added LINGUAS to profiles/info_vars, so it will show up in the output of emerge --info. Any objections? If yes, it is easy to revert. Ulrich pgpWGCcGAX5s_.pgp Description: PGP signature

Re: [gentoo-dev] Deleting old news items

2018-01-05 Thread William Hubbs
On Fri, Jan 05, 2018 at 09:01:26AM -0500, Alec Warner wrote: > On Fri, Jan 5, 2018 at 5:08 AM, Ulrich Mueller wrote: > > > +In news item format ``>2.0``, this field is mandatory. > > > > I think it should not be mandatory, for the purpose of the tools > > dealing with news

Re: [gentoo-dev] Deleting old news items

2018-01-05 Thread Kristian Fiskerstrand
On 01/05/2018 11:47 PM, Kristian Fiskerstrand wrote: > On 01/05/2018 11:40 PM, Alec Warner wrote: >>> I might sound like a broken CD here, but why define the expiration as >>> part of the news format instead of specifying it in the package manager >>> as a user defined variable? Various use cases

Re: [gentoo-dev] Deleting old news items

2018-01-05 Thread Aaron W. Swenson
On 2018-01-05 15:16, William Hubbs wrote: > If we have a default expiration, it should be one year after the date > posted to go along with our current policy of not supporting things that > are older than a year. > > William I thought it was three years. At any rate, I think a year is too

Re: [gentoo-dev] Deleting old news items

2018-01-05 Thread Alec Warner
On Fri, Jan 5, 2018 at 6:55 PM, Michał Górny wrote: > W dniu pią, 05.01.2018 o godzinie 23∶09 +0100, użytkownik Kristian > Fiskerstrand napisał: > > On 01/05/2018 10:28 PM, Aaron W. Swenson wrote: > > > On 2018-01-05 15:16, William Hubbs wrote: > > > > If we have a default

Re: [gentoo-dev] Deleting old news items

2018-01-05 Thread Michał Górny
W dniu pią, 05.01.2018 o godzinie 23∶09 +0100, użytkownik Kristian Fiskerstrand napisał: > On 01/05/2018 10:28 PM, Aaron W. Swenson wrote: > > On 2018-01-05 15:16, William Hubbs wrote: > > > If we have a default expiration, it should be one year after the date > > > posted to go along with our

[gentoo-dev] Re: LINGUAS to be removed from USE_EXPAND

2018-01-05 Thread Ulrich Mueller
> On Thu, 28 Dec 2017, Ulrich Mueller wrote: > Last year we had announced introduction of a new L10N variable > intended to replace LINGUAS as a USE_EXPAND variable [1]. Since then, > many packages have been converted to the new variable. > The next step in the conversion will be removal of

Re: [gentoo-dev] Deleting old news items

2018-01-05 Thread Michał Górny
W dniu czw, 04.01.2018 o godzinie 20∶20 -0500, użytkownik Alec Warner napisał: > The attached patch proposes a new news item format (2.1). > > In format 2.1, the Expires: header is mandatory. > > PMs can detect whether a given news item is "expired" by comparing the > current date in UTC to the

Re: [gentoo-dev] Deleting old news items

2018-01-05 Thread Ulrich Mueller
> On Thu, 4 Jan 2018, Alec Warner wrote: > Brief amendment. In the case where the PM cannot parse the expires header; it > should assume the item is not expired and display it (e.g. it should fail > open.) > Updated patch attached. > + ``Expires:`` > +Date of expiration, in

Re: [gentoo-dev] Deleting old news items

2018-01-05 Thread nado
January 5, 2018 3:58 AM, "Alec Warner" wrote: > ... snip ... > + compatability with GLEP 45 [#glep-45]_. Translations should use the date of > + the original news item. An item is expired if the current date in UTC is > + greater than the expiration date of the item. Package

[gentoo-dev] Re: [gentoo-commits] repo/gentoo:master commit in: eclass/

2018-01-05 Thread Michał Górny
W dniu pią, 05.01.2018 o godzinie 13∶13 +, użytkownik Lars Wendler napisał: > commit: 1e09cba657ccb2b8e6fbcbeb28c5c593da2127eb > Author: Gary Macindoe garymacindoe co uk> > AuthorDate: Thu Sep 28 21:32:34 2017 + > Commit: Lars Wendler gentoo org> > CommitDate: Fri Jan 5

Re: [gentoo-dev] Deleting old news items

2018-01-05 Thread Alec Warner
On Fri, Jan 5, 2018 at 5:08 AM, Ulrich Mueller wrote: > > On Thu, 4 Jan 2018, Alec Warner wrote: > > > Brief amendment. In the case where the PM cannot parse the expires > header; it > > should assume the item is not expired and display it (e.g. it should fail > > open.) > >

Re: [gentoo-dev] Deleting old news items

2018-01-05 Thread Alec Warner
On Fri, Jan 5, 2018 at 5:15 AM, wrote: > January 5, 2018 3:58 AM, "Alec Warner" wrote: > > ... snip ... > > + compatability with GLEP 45 [#glep-45]_. Translations should use the > date of > > + the original news item. An item is expired if the current

Re: [gentoo-dev] Deleting old news items

2018-01-05 Thread Alec Warner
On Fri, Jan 5, 2018 at 4:00 AM, Michał Górny wrote: > W dniu czw, 04.01.2018 o godzinie 20∶20 -0500, użytkownik Alec Warner > napisał: > > The attached patch proposes a new news item format (2.1). > > > > In format 2.1, the Expires: header is mandatory. > > > > PMs can detect

Re: [gentoo-dev] Deleting old news items

2018-01-05 Thread Alec Warner
Latest version. I still want to discuss whether Expires is Mandatory or Optional and how that actually ends up being used. -A On Fri, Jan 5, 2018 at 9:01 AM, Alec Warner wrote: > > > On Fri, Jan 5, 2018 at 5:15 AM, wrote: > >> January 5, 2018 3:58 AM,

Re: [gentoo-dev] Deleting old news items

2018-01-05 Thread Ulrich Mueller
> On Fri, 5 Jan 2018, Alec Warner wrote: > Latest version. > I still want to discuss whether Expires is Mandatory or Optional and how that > actually ends up being used. If it is going to be mandatory, then we need to allow a special value like "never" which would indicate that an item will

Re: [gentoo-dev] vanilla-sources broken

2018-01-05 Thread Alice Ferrazzi
On Fri, Jan 5, 2018 at 11:08 PM, Nicolas Bock wrote: > Hi, > > currently vanilla-sources are broken, but there is an upstream patch that > fixes it (appended at the end). I know that vanilla-sources are supposed to > be vanilla, but it would help if we added this patch

Re: [gentoo-dev] vanilla-sources broken

2018-01-05 Thread Nicolas Bock
On Fri, Jan 05, 2018 at 11:47:51PM +0900, Alice Ferrazzi wrote: On Fri, Jan 5, 2018 at 11:08 PM, Nicolas Bock wrote: Hi, currently vanilla-sources are broken, but there is an upstream patch that fixes it (appended at the end). I know that vanilla-sources are supposed