Re: [gentoo-portage-dev] [PATCH] repoman: Warn on = dependencies without * or revision

2018-03-04 Thread Michał Górny
W dniu nie, 04.03.2018 o godzinie 12∶18 +0100, użytkownik Ulrich Mueller napisał: > > > > > > On Sat, 3 Mar 2018, Michał Górny wrote: > > Warn if the '=' package dependency operator is used along with pure > > version with no revision specified. This means to catch a common mistake > > of

Re: [gentoo-portage-dev] [PATCH] repoman: Warn on = dependencies without * or revision

2018-03-04 Thread Ulrich Mueller
> On Sat, 3 Mar 2018, Michał Górny wrote: > Warn if the '=' package dependency operator is used along with pure > version with no revision specified. This means to catch a common mistake > of developers copying '=' from upstream dependency specification while > '~' operator would be more

Re: [gentoo-portage-dev] [PATCH 08/10] dolib.{a,so}: inline the logic from dolib

2018-03-04 Thread Michał Górny
W dniu pon, 26.02.2018 o godzinie 16∶59 +0100, użytkownik Michał Górny napisał: > This cleans up the kinda-ugly logic necessary to preserve dolib.a/so > while removing dolib in EAPI 7, and removes the undesirable symlink > handling in dolib.a. > --- > bin/ebuild-helpers/dolib| 2 +- >

[gentoo-dev] Last rites: sci-chemistry/PyMca

2018-03-04 Thread Andreas Sturmlechner
# Andreas Sturmlechner (04 Mar 2018) # Depends on deprecated dev-python/pyqwt, blocks Qt4 removal. # Masked for removal in 30 days unless someone bumps to 5.2.2. # Bug 645218, 649094 sci-chemistry/PyMca

[gentoo-dev] RFC: Repoman to warn about suspicious =-dependencies

2018-03-04 Thread Michał Górny
Hi, everyone. I have proposed a new check for repoman [1] (with a patch at [2]) that would warn developers about suspicious '=' deps. By suspicious, I mean dependencies '=foo-1.2.3' which are sometimes mistakenly used instead of '~foo-1.2.3', and cause some degree of mayhem when someone revbumps

[gentoo-dev] Packages up for grabs: media-libs/ffmpegsource media-video/aegisub

2018-03-04 Thread Ilya Tumaykin
The following packages are up for grabs: media-libs/ffmpegsource media-video/aegisub No open bugs, no verbumps are required. Note that aegisub upstream is semi-dead. -- Best regards. Ilya Tumaykin. signature.asc Description: This is a digitally signed message part.

[gentoo-dev] Last rites: sci-chemistry/massxpert

2018-03-04 Thread Andreas Sturmlechner
# Andreas Sturmlechner (04 Mar 2018) # Dead upstream, depends on deprecated Qt4. # Masked for removal in 30 days. Bug 645436 sci-chemistry/massxpert

[gentoo-dev] Last rites: sci-chemistry/gsim

2018-03-04 Thread Andreas Sturmlechner
# Andreas Sturmlechner (04 Mar 2018) # Dead upstream, depends on deprecated Qt4. # Masked for removal in 30 days. Bug 514438, 644522 sci-chemistry/gsim

[gentoo-portage-dev] [PATCH] gnome2-utils postinst: fix false positive for gtk-update-icon-cache (bug 649464)

2018-03-04 Thread Zac Medico
For the first install of gtk-update-icon-cache, there's no way to initialize state during preinst, so we have to ignore this package in order to avoid false positives. Bug: https://bugs.gentoo.org/649464 --- bin/postinst-qa-check.d/50gnome2-utils | 3 +++ 1 file changed, 3 insertions(+) diff

[gentoo-dev] Last rites: media-sound/qmpdclient

2018-03-04 Thread Andreas Sturmlechner
# Andreas Sturmlechner (04 Mar 2018) # Dead upstream, depends on deprecated Qt4. media-sound/cantata # is an actively developed alternative based on Qt5. # Masked for removal in 30 days. Bug 644412 media-sound/qmpdclient

Re: [gentoo-dev] glibc 2.16/19 for Gentoo Prefix on antique kernels

2018-03-04 Thread Andreas K. Huettel
Am Samstag, 3. März 2018, 15:39:50 CET schrieb Michał Górny: > > That's not a solution. That's cheap a cheap excuse that works for one > package, for today. It does not solve the generic case, it does not mean > that other members of toolchain or any other team will not end up having > to remember

Re: [gentoo-portage-dev] [PATCH 00/10] EAPI 7, part one

2018-03-04 Thread Michał Górny
W dniu sob, 03.03.2018 o godzinie 17∶58 -0800, użytkownik Zac Medico napisał: > On 02/26/2018 07:59 AM, Michał Górny wrote: > > Hi, everyone. > > > > Here's the first part of EAPI 7 support patches. All changes included > > here were tested and should not break anything. I'd like to merge them >

[gentoo-dev] Automated Package Removal and Addition Tracker, for the week ending 2018-03-04 23:59 UTC

2018-03-04 Thread Robin H. Johnson
/hupnp-ng 20180304-09:32 asturm 05a1fe8519c media-sound/qpitch20180301-11:16 asturm 346e5c6fca1 media-sound/qtagconvert 20180301-11:16 asturm 346e5c6fca1 media-video/qgifer20180227-09:24 asturm 216fd1d0c5b media-video/qx11grab