[gentoo-dev] Last-rites: x11-drivers/xf86-input-{keyboard,mouse}

2020-05-03 Thread Piotr Karbowski
# Piotr Karbowski (2020-05-03) # Obsolete input drivers, use x11-drivers/xf86-input-libinput # or x11-drivers/xf86-input-evdev instead. # Removal in 30 days. x11-drivers/xf86-input-keyboard x11-drivers/xf86-input-mouse For more information see

Re: [gentoo-dev] Cleaning up the installation handbook (Legacy boot / MBR / ...)

2020-05-03 Thread Thomas Deutschmann
On 2020-05-02 22:30, Andreas K. Hüttel wrote: > * Legacy boot and MBR will get kicked out. * > > This is your chance to protest or support. *holdingupprotestsign* Why? There are still a lot of people out there who don't have (U)EFI or don't use GPT. Please keep this information or share why

Re: [gentoo-dev] Cleaning up the installation handbook (Legacy boot / MBR / ...)

2020-05-03 Thread Joshua Kinard
On 5/2/2020 16:30, Andreas K. Hüttel wrote: > Hey all, > > our installation handbook is right now something of a mess (in particular > regarding partitioning, bootloader, gpt/uefi, ...) > > I'm hereby volunteering to clean things up. But - I'll go the brutal way: > > * Legacy boot and MBR

[gentoo-dev] Last-rites: media-plugins/gimp-lensfun

2020-05-03 Thread Andreas Sturmlechner
# Andreas Sturmlechner (2020-05-03) # Last release in 2015, not compatible with >=media-gfx/gimp-2.10.0 # Masked for removal in 30 days. media-plugins/gimp-lensfun signature.asc Description: This is a digitally signed message part.

Re: [gentoo-portage-dev] [PATCH] phase-functions.sh: do not set PKG_CONFIG_PATH

2020-05-03 Thread Zac Medico
On 5/3/20 2:31 PM, Mike Gilbert wrote: > Recent pkg-config should have the correct path built in by default. > > Bug: https://bugs.gentoo.org/720866 > Signed-off-by: Mike Gilbert > --- > bin/phase-functions.sh | 4 > 1 file changed, 4 deletions(-) > > diff --git a/bin/phase-functions.sh

[gentoo-dev] Automated Package Removal and Addition Tracker, for the week ending 2020-05-03 23:59 UTC

2020-05-03 Thread Robin H. Johnson
92a3d5612f0 dev-perl/App-FatPacker 20200503-14:12 kentnl 8241011ae89 dev-perl/Config-MVP-Slicer 20200503-12:44 kentnl 49f28dfc95b dev-perl/Dist-Milla 20200503-13:15 kentnl 5eec6ce8512 dev

[gentoo-portage-dev] [PATCH] phase-functions.sh: do not set PKG_CONFIG_PATH

2020-05-03 Thread Mike Gilbert
Recent pkg-config should have the correct path built in by default. Bug: https://bugs.gentoo.org/720866 Signed-off-by: Mike Gilbert --- bin/phase-functions.sh | 4 1 file changed, 4 deletions(-) diff --git a/bin/phase-functions.sh b/bin/phase-functions.sh index 709fd7527..90e622e75 100644

Re: [gentoo-dev] Cleaning up the installation handbook (Legacy boot / MBR / ...)

2020-05-03 Thread Jonas Stein
Hi Andreas, > * Legacy boot and MBR will get kicked out. * > This is your chance to protest or support. Please keep. I have several systems with legacy boot and know many people, who prefer/need this too. -- Best, Jonas signature.asc Description: OpenPGP digital signature

Re: [gentoo-dev] [PATCH v2 08/10] ruby-ng-gnome2.eclass: support non-build packages

2020-05-03 Thread Michał Górny
On Mon, 2020-05-04 at 11:22 +0900, Naohiro Aota wrote: > Some ruby-gnome2 ebuild does not build C bindings, so there is no need to > call each_ruby_{configure,compile} and emake install of this eclass. Check > if "extconf.rb" and "Makefile" to decide what to do. > > Signed-off-by: Naohiro Aota >

[gentoo-dev] [PATCH v2 02/10] ruby-ng-gnome2.eclass: drop support for

2020-05-03 Thread Naohiro Aota
All users of ruby-ng-gnome2 in the official tree are on EAPI=6, so we can drop old EAPI support to reduce "if" branches and make the feature updates simple. Signed-off-by: Naohiro Aota --- eclass/ruby-ng-gnome2.eclass | 15 --- 1 file changed, 4 insertions(+), 11 deletions(-) diff

[gentoo-dev] [PATCH v2 01/10] ruby-ng-gnome2.eclass: drop support for 0.19.x

2020-05-03 Thread Naohiro Aota
The official tree no longer have ruby-gnome2 packages with 0.19.x. Drop support for them. Signed-off-by: Naohiro Aota --- eclass/ruby-ng-gnome2.eclass | 14 +- 1 file changed, 5 insertions(+), 9 deletions(-) diff --git a/eclass/ruby-ng-gnome2.eclass b/eclass/ruby-ng-gnome2.eclass

[gentoo-dev] [PATCH v2 03/10] ruby-ng-gnome2.eclass: fix LICENSE

2020-05-03 Thread Naohiro Aota
All ruby-gnome2 packages in the tree is now licensed under LGPL-2.1+. Signed-off-by: Naohiro Aota --- eclass/ruby-ng-gnome2.eclass | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/eclass/ruby-ng-gnome2.eclass b/eclass/ruby-ng-gnome2.eclass index 67a5d58fba58..42325ce4f33c

[gentoo-dev] [PATCH v2 04/10] ruby-ng-gnome2.eclass: drop subbinding variable

2020-05-03 Thread Naohiro Aota
Since we can set RUBY_S only from RUBY_FAKEGEM_NAME, we no longer need $subbinding. Signed-off-by: Naohiro Aota --- eclass/ruby-ng-gnome2.eclass | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/eclass/ruby-ng-gnome2.eclass b/eclass/ruby-ng-gnome2.eclass index

[gentoo-dev] [PATCH v2 06/10] ruby-ng-gnome2.eclass: add test dependency

2020-05-03 Thread Naohiro Aota
Signed-off-by: Naohiro Aota --- eclass/ruby-ng-gnome2.eclass | 7 +-- 1 file changed, 5 insertions(+), 2 deletions(-) diff --git a/eclass/ruby-ng-gnome2.eclass b/eclass/ruby-ng-gnome2.eclass index ac112e006205..a1a84f3045ed 100644 --- a/eclass/ruby-ng-gnome2.eclass +++

[gentoo-dev] [PATCH v2 07/10] ruby-ng-gnome2.eclass: implement common test code

2020-05-03 Thread Naohiro Aota
Fold common test code from runy-gnome2 ebuild to this eclass. To support test under virtx, introduce RUBY_GNOME2_NEED_VIRTX variable. Signed-off-by: Naohiro Aota --- eclass/ruby-ng-gnome2.eclass | 23 +++ 1 file changed, 23 insertions(+) diff --git

[gentoo-dev] [PATCH v2 08/10] ruby-ng-gnome2.eclass: support non-build packages

2020-05-03 Thread Naohiro Aota
Some ruby-gnome2 ebuild does not build C bindings, so there is no need to call each_ruby_{configure,compile} and emake install of this eclass. Check if "extconf.rb" and "Makefile" to decide what to do. Signed-off-by: Naohiro Aota --- eclass/ruby-ng-gnome2.eclass | 14 ++ 1 file

[gentoo-dev] [PATCH v2 09/10] ruby-ng-gnome2.eclass: fold common all_ruby_prepare

2020-05-03 Thread Naohiro Aota
Signed-off-by: Naohiro Aota --- eclass/ruby-ng-gnome2.eclass | 22 ++ 1 file changed, 22 insertions(+) diff --git a/eclass/ruby-ng-gnome2.eclass b/eclass/ruby-ng-gnome2.eclass index 7ffe57d1a9ff..7beb03e778c8 100644 --- a/eclass/ruby-ng-gnome2.eclass +++

[gentoo-dev] [PATCH v2 10/10] ruby-ng-gnome2.eclass: add support for 3.4.x

2020-05-03 Thread Naohiro Aota
Update SRC_URI since the primary release site is moved to github. Signed-off-by: Naohiro Aota --- eclass/ruby-ng-gnome2.eclass | 12 +--- 1 file changed, 9 insertions(+), 3 deletions(-) diff --git a/eclass/ruby-ng-gnome2.eclass b/eclass/ruby-ng-gnome2.eclass index

[gentoo-dev] [PATCH v2 05/10] ruby-ng-gnome2.eclass: Use [[ instead of [

2020-05-03 Thread Naohiro Aota
Signed-off-by: Naohiro Aota --- eclass/ruby-ng-gnome2.eclass | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/eclass/ruby-ng-gnome2.eclass b/eclass/ruby-ng-gnome2.eclass index 4f3f6011501b..ac112e006205 100644 --- a/eclass/ruby-ng-gnome2.eclass +++

Re: [gentoo-dev] [PATCH v2 06/10] ruby-ng-gnome2.eclass: add test dependency

2020-05-03 Thread Michał Górny
On Mon, 2020-05-04 at 11:22 +0900, Naohiro Aota wrote: > Signed-off-by: Naohiro Aota > --- > eclass/ruby-ng-gnome2.eclass | 7 +-- > 1 file changed, 5 insertions(+), 2 deletions(-) > > diff --git a/eclass/ruby-ng-gnome2.eclass b/eclass/ruby-ng-gnome2.eclass > index

Re: [gentoo-dev] [PATCH v2 05/10] ruby-ng-gnome2.eclass: Use [[ instead of [

2020-05-03 Thread Michał Górny
On Mon, 2020-05-04 at 11:22 +0900, Naohiro Aota wrote: > Signed-off-by: Naohiro Aota > --- > eclass/ruby-ng-gnome2.eclass | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/eclass/ruby-ng-gnome2.eclass b/eclass/ruby-ng-gnome2.eclass > index 4f3f6011501b..ac112e006205

Re: [gentoo-dev] Last standing Python 2.7 dependency

2020-05-03 Thread Brian Evans
On 5/3/20 2:58 AM, Fabian Groffen wrote: > On 02-05-2020 23:24:42 -0700, Brian Dolbec wrote: >> On Sun, 3 May 2020 07:28:50 +0200 >> Viktar Patotski wrote: >> >>> Hi all, >>> >>> I'd also like to clean my system and have it Python 2.7 free. Are >>> there any guidelines to check which packages are

Re: [gentoo-dev] Last standing Python 2.7 dependency

2020-05-03 Thread Fabian Groffen
On 02-05-2020 23:24:42 -0700, Brian Dolbec wrote: > On Sun, 3 May 2020 07:28:50 +0200 > Viktar Patotski wrote: > > > Hi all, > > > > I'd also like to clean my system and have it Python 2.7 free. Are > > there any guidelines to check which packages are still using pyton2_7 > > in my system? > >

Re: [gentoo-dev] Last standing Python 2.7 dependency

2020-05-03 Thread Brian Dolbec
On Sun, 3 May 2020 07:28:50 +0200 Viktar Patotski wrote: > Hi all, > > I'd also like to clean my system and have it Python 2.7 free. Are > there any guidelines to check which packages are still using pyton2_7 > in my system? > > Thanks, > Viktar > There are both equery and enalyze commands

Re: [gentoo-dev] Last standing Python 2.7 dependency

2020-05-03 Thread Brian Dolbec
On Sun, 3 May 2020 08:37:27 -0400 Brian Evans wrote: > On 5/3/20 2:58 AM, Fabian Groffen wrote: > > On 02-05-2020 23:24:42 -0700, Brian Dolbec wrote: > >> On Sun, 3 May 2020 07:28:50 +0200 > >> Viktar Patotski wrote: > >> > >>> Hi all, > >>> > >>> I'd also like to clean my system and have