Re: [gentoo-dev] [PATCH 2/2] selinux-policy-2.eclass: drop EAPI 5

2020-11-03 Thread Ulrich Mueller
> On Tue, 03 Nov 2020, Ulrich Mueller wrote: > Presumably it would also be cleaner to test if POLICY_PATCH is an array, > and use '"${POLICY_PATCH[@]}"' if it is but '${POLICY_PATCH}' if it is > not. In fact you could use the same code as in default src_prepare:

Re: [gentoo-dev] [PATCH 2/2] selinux-policy-2.eclass: drop EAPI 5

2020-11-03 Thread Ulrich Mueller
> On Mon, 02 Nov 2020, David Michael wrote: > for POLPATCH in ${POLICY_PATCH[@]}; > do > - if [[ ${EAPI:-0} == 5 ]]; then > - epatch "${POLPATCH}" > - else > - eapply

Re: [gentoo-dev] New QA policy suggestion: Disallow "live-only" packages

2020-11-03 Thread Joonas Niilola
On 11/3/20 10:10 AM, Michał Górny wrote: I'm with you on this though I think it should be relaxed to disallow only long term presence of pure live packages. It's fine to add a live ebuild first for a month or two if you're still working on something (just like it's fine to add a masked

Re: [gentoo-dev] New QA policy suggestion: Disallow "live-only" packages

2020-11-03 Thread Tim Harder
On 2020-11-03 Tue 01:28, Joonas Niilola wrote: > Initially Arfrever suggested the same, I wasn't a fan of it because I > believe it's much simpler to make this into a pkgcheck/repoman check like > this. > > However with pkgcheck maybe a similar logic can be used as is used with >

[gentoo-dev] [PATCH 0/1] depend.apache.eclass: support EAPI-7

2020-11-03 Thread Marek Szuba
The fact this eclass does not support EAPI-7 yet blocks migration of www-apache/mod_security to Lua eclasses. Seems simple enough to address though, likely simpler than adding EAPI-6 support to lua.eclass.

[gentoo-dev] Re: Slotted Lua: let's get this done!

2020-11-03 Thread Marek Szuba
On 2020-10-14 17:29, Marek Szuba wrote: I'll likely start opening please-migrate tickets for them on Friday, i.e. once my latest proposed change set to the eclasses (which will likely be needed by e.g. x11-wm/awesome) has been merged. Sorry about the delay, ended up almost entirely offline

[gentoo-dev] [PATCH] depend.apache.eclass: support EAPI-7

2020-11-03 Thread Marek Szuba
Signed-off-by: Marek Szuba --- eclass/depend.apache.eclass | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/eclass/depend.apache.eclass b/eclass/depend.apache.eclass index 79bfdcc493f..5aa55254268 100644 --- a/eclass/depend.apache.eclass +++ b/eclass/depend.apache.eclass

Re: [gentoo-dev] [PATCH 1/2] selinux-policy-2.eclass: add EAPI 7

2020-11-03 Thread David Michael
On Tue, Nov 3, 2020 at 2:46 AM Ulrich Mueller wrote: > > On Mon, 02 Nov 2020, David Michael wrote: > > > +if [[ ${EAPI:-0} == [56] ]]; then > > Substituting 0 is not necessary here. I wrote it that way to match all other EAPI conditions in the file. I'll remove it in the second patch where

Re: [gentoo-dev] New QA policy suggestion: Disallow "live-only" packages

2020-11-03 Thread Michał Górny
On Tue, 2020-11-03 at 07:13 +0200, Joonas Niilola wrote: > I'm suggesting a new QA policy to disallow any "live-ebuild-only > packages" being hosted in ::gentoo. I'm with you on this though I think it should be relaxed to disallow only long term presence of pure live packages. It's fine to add a

[gentoo-dev] Packages up for grabs: dev-libs/intel-neo and dependencies

2020-11-03 Thread Marek Szuba
I haven't got any Intel APUs available to test this any more, and with upstream pushing towards a move to LLVM-11, being able to conduct runtime testing will likely be important. Therefore, effective immediately I no longer maintain: dev-libs/intel-neo dev-libs/level-zero

[gentoo-dev] [PATCH v2 2/2] selinux-policy-2.eclass: drop EAPI 5

2020-11-03 Thread David Michael
Signed-off-by: David Michael --- Changes since v1: - Dropped unnecessary EAPI default value - Fixed eapply array awareness eclass/selinux-policy-2.eclass | 47 +- 1 file changed, 12 insertions(+), 35 deletions(-) diff --git a/eclass/selinux-policy-2.eclass

Re: [gentoo-dev] [PATCH 0/1] depend.apache.eclass: support EAPI-7

2020-11-03 Thread Michael Orlitzky
On 11/3/20 11:25 AM, Marek Szuba wrote: The fact this eclass does not support EAPI-7 yet blocks migration of www-apache/mod_security to Lua eclasses. Seems simple enough to address though, likely simpler than adding EAPI-6 support to lua.eclass. It's likely broken in EAPI=7, because it was in

Re: [gentoo-dev] [PATCH] depend.apache.eclass: support EAPI-7

2020-11-03 Thread Pacho Ramos
El mar, 03-11-2020 a las 17:25 +0100, Marek Szuba escribió: > Signed-off-by: Marek Szuba > --- > eclass/depend.apache.eclass | 6 +++--- > 1 file changed, 3 insertions(+), 3 deletions(-) > > diff --git a/eclass/depend.apache.eclass b/eclass/depend.apache.eclass > index 79bfdcc493f..5aa55254268

[gentoo-dev] Last rites: fdo-mime.eclass

2020-11-03 Thread David Seifert
# @DEAD # No consumers left. Removal in 30 days. signature.asc Description: This is a digitally signed message part

Re: [gentoo-dev] Packages & projects up for grabs due to jer's retirement

2020-11-03 Thread James Le Cuirot
On Tue, 03 Nov 2020 22:32:11 +0100 Michał Górny wrote: > Additionally, the following packages are looking for a new maintainer: > > net-misc/chrony I may take this if no one else really wants it. I run a simple client and server setup on Gentoo at home but I have no interest in the fancy

[gentoo-dev] Packages & projects up for grabs due to jer's retirement

2020-11-03 Thread Michał Górny
Hi. The following projects have no members right now: https://wiki.gentoo.org/wiki/Project:Debian_Tools Additionally, the following packages are looking for a new maintainer: app-admin/fam app-admin/killproc app-admin/sysstat app-admin/whowatch app-arch/mt-st app-benchmarks/nbench

Re: [gentoo-dev] Re: [gentoo-dev-announce] Packages & projects up for grabs due to jer's retirement

2020-11-03 Thread David Seifert
On Tue, 2020-11-03 at 22:48 +0100, Michał Górny wrote: > On Tue, 2020-11-03 at 22:32 +0100, Michał Górny wrote: > > Hi. > > > > The following projects have no members right now: > > > > https://wiki.gentoo.org/wiki/Project:Debian_Tools > > > > Additionally, the following packages are looking

Re: [gentoo-dev] Packages & projects up for grabs due to jer's retirement

2020-11-03 Thread Lars Wendler
On Tue, 03 Nov 2020 22:32:11 +0100 Michał Górny wrote: >Hi. > >The following projects have no members right now: > >https://wiki.gentoo.org/wiki/Project:Debian_Tools > >Additionally, the following packages are looking for a new maintainer: > I'll take these: >app-admin/whowatch >net-ftp/lftp

[gentoo-dev] Re: [gentoo-dev-announce] Packages & projects up for grabs due to jer's retirement

2020-11-03 Thread Michał Górny
On Tue, 2020-11-03 at 22:32 +0100, Michał Górny wrote: > Hi. > > The following projects have no members right now: > > https://wiki.gentoo.org/wiki/Project:Debian_Tools > > Additionally, the following packages are looking for a new maintainer: > [...] Of course, missed an eclass:

Re: [gentoo-dev] Packages & projects up for grabs due to jer's retirement

2020-11-03 Thread Michał Górny
On Tue, 2020-11-03 at 22:32 +0100, Michał Górny wrote: > dev-libs/libevent I'll take this one. > net-dns/libidn > net-dns/libidn2 And these two. > net-libs/http-parser Plus this. > net-misc/youtube-dl Maybe this but co-maintainers appreciated. -- Best regards, Michał Górny

Re: [gentoo-dev] Packages & projects up for grabs due to jer's retirement

2020-11-03 Thread Conrad Kostecki
Am 03.11.2020 um 22:32 schrieb Michał Górny: app-benchmarks/nbench I will take that one. net-ftp/lftp net-misc/putty x11-terms/rxvt-unicode Anyone want's to maintain? I could imagine to help as co-maintainer. Conrad

Re: [gentoo-dev] Packages & projects up for grabs due to jer's retirement

2020-11-03 Thread Sam James
> On 3 Nov 2020, at 21:53, James Le Cuirot wrote: > > On Tue, 03 Nov 2020 22:32:11 +0100 > Michał Górny wrote: > >> Additionally, the following packages are looking for a new maintainer: >> >> net-misc/chrony > > I may take this if no one else really wants it. I run a simple client > and