Re: [gentoo-dev] Packages up for grabs

2020-04-14 Thread Sam James
Hi, > On 14 Apr 2020, at 09:36, Joonas Niilola wrote: > > net-irc/ngircd (b,v) Quite happy to take this on. I’ll do a bump with GLEP 81 in there, provided nobody else is interested in this. Sam

[gentoo-dev] Re: [gentoo-dev-announce] Last rites: net-proxy/mitmproxy

2020-04-19 Thread Sam James
I’ll try look at this. > On 19 Apr 2020, at 21:05, Michał Górny wrote: > > # Michał Górny (2020-04-19) > # Unmaintained. Stuck on Python 3.6. Needs version bump. > # Removal in 30 days. Bug #718458. > net-proxy/mitmproxy > > -- > Best regards, > Michał Górny >

Re: [gentoo-dev] Gentoo clang team

2020-05-12 Thread Sam James
> On 12 May 2020, at 14:48, Alexander Bilyak wrote: > > Hello everyone in this mailing list. > > I apologize for myself as I am not sure if it is the right place to write, > but anyway... > I am the (only) maintainer of gentoo-clang > overlay. >

Re: [gentoo-dev] Last rites: media-video/subliminal

2020-05-06 Thread Sam James
> On 2 May 2020, at 11:12, Nikos Chantziaras wrote: > > On 19/04/2020 22:47, Michał Górny wrote: >> # Michał Górny (2020-04-19) >> # Unmaintained. Stuck on Python 3.6. Last release in 2016. >> # Removal in 30 days. Bug #718410. >> media-video/subliminal > > It's an active project. Just

Re: [gentoo-dev] Cleaning up the installation handbook (Legacy boot / MBR / ...)

2020-05-06 Thread Sam James
> On 2 May 2020, at 21:30, Andreas K. Hüttel wrote: > > Hey all, > > our installation handbook is right now something of a mess (in particular > regarding partitioning, bootloader, gpt/uefi, ...) > > I'm hereby volunteering to clean things up. But - I'll go the brutal way: > > * Legacy

[gentoo-dev] Last rites: net-irc/irc-server

2020-08-29 Thread Sam James
# Sam James (2020-08-30) # Collection of quite dead net-irc/* pkgs # Please speak up if you use any of these # and a modern alternative doesn't work for you. # None of these have alive upstreams, and we're # the only distro packaging them in many cases. # Unmaintained. Removal in 30 days. # bug

[gentoo-dev] Last rites: net-irc/ptlink-ircd, net-irc/ptlink-opm

2020-08-29 Thread Sam James
# Sam James (2020-08-30) # Collection of quite dead net-irc/* pkgs # Please speak up if you use any of these # and a modern alternative doesn't work for you. # None of these have alive upstreams, and we're # the only distro packaging them in many cases. # Unmaintained. Removal in 30 days. # bug

[gentoo-dev] Last rites: net-irc/xaric

2020-08-29 Thread Sam James
# Sam James (2020-08-30) # Collection of quite dead net-irc/* pkgs # Please speak up if you use any of these # and a modern alternative doesn't work for you. # None of these have alive upstreams, and we're # the only distro packaging them in many cases. # Unmaintained. Removal in 30 days

[gentoo-dev] Last rites: net-irc/nebula

2020-08-30 Thread Sam James
This one is stuck on EAPI 4 and we’re the only ones packaging it. Dead upstream. # Sam James (2020-08-30) # Collection of quite dead net-irc/* pkgs # Please speak up if you use any of these # and a modern alternative doesn't work for you. # None of these have alive upstreams, and we're

Re: [gentoo-dev] Please port your packages to Python 3.8

2020-09-02 Thread Sam James
> On 1 Sep 2020, at 12:02, Michał Górny wrote: > > Hello, > > [snip] > Python 3.8 is planned to become the default on 2020-12-01. > Note that this means we need to keep in mind stabilisation of Python 3.8+ supporting-packages going forward. Please request stabilisation of your Python 3.8+

[gentoo-dev] Last rites: sys-fs/ufsutils

2020-09-15 Thread Sam James
# Sam James (2020-09-15) # No longer exists upstream, stuck on long-obsolete EAPI 4, # and fails to build with glibc-2.32. # Vestige of Gentoo/FreeBSD. # bug #715506, #737892, #740916, #547244. sys-fs/ufsutils signature.asc Description: Message signed with OpenPGP

[gentoo-dev] Last rites: dev-tex/biblatex-apa

2020-09-12 Thread Sam James
# Sam James (2020-09-12) # Merged into dev-texlive/texlive-bibtexextra # Removal in 30 days dev-tex/biblatex-apa signature.asc Description: Message signed with OpenPGP

[gentoo-dev] Last rites: dev-tex/chktex

2020-09-12 Thread Sam James
# Sam James (2020-09-12) # Merged into app-text/texlive-core # Removal in 30 days dev-tex/chktex signature.asc Description: Message signed with OpenPGP

[gentoo-dev] Last rites: dev-lang/cll1h

2020-09-12 Thread Sam James
# Sam James (2020-09-13) # Dead upstream, EAPI 4, no maintainer # Removal in 30 days # bug #740954 dev-lang/cll1h signature.asc Description: Message signed with OpenPGP

[gentoo-dev] Last rites: net-dialup/tkvoice

2020-09-12 Thread Sam James
# Sam James (2020-09-13) # Dead upstream, EAPI 4, no maintainer # Removal in 30 days net-dialup/tkvoice signature.asc Description: Message signed with OpenPGP

Re: [gentoo-dev] OSL 1.11.8.0 ebuild

2020-10-09 Thread Sam James
Hi, Can you submit this on Bugzilla and/or via a GitHub pullrequest? Thanks! > On 9 Oct 2020, at 19:31, Luke A. Guest wrote: > > Hi, > > I copied and updated the osl ebuild. There's a bit of a hack in there to find > the LLVM_ROOT. But it builds. > > signature.asc Description: Message

Re: [gentoo-dev] sys-apps/firejail and sys-apps-firejail lts are up for grabs

2020-10-14 Thread Sam James
> On 14 Oct 2020, at 18:40, Hank Leininger wrote: > > On 2020-10-11, Dennis Lamm wrote: >> the following packages are up for grabs: >> >> - sys-apps/firejail >> - sys-apps/firejail-lts > > I will proxy maintain both of these. Preparing a PR shortly... > I think ajak is also working on this

[gentoo-dev] Last rites: dev-db/sqliteodbc

2020-08-29 Thread Sam James
# Sam James (2020-08-30) # Serious security bug, unmaintained. # Stuck on long-obsolete EAPI 4. # Several open bugs. # bug 720732, bug 729714, bug 722644, # bug 724184. dev-db/sqliteodbc signature.asc Description: Message signed with OpenPGP

[gentoo-dev] Last rites: www-apps/ampache

2020-08-29 Thread Sam James
# Sam James (2020-08-30) # Serious security vulns, outdated. # bug 699834. Removal in 30 days. www-apps/ampache signature.asc Description: Message signed with OpenPGP

Re: [gentoo-dev] Packages up for grabs

2020-05-26 Thread Sam James
> On 26 May 2020, at 23:12, Andrey Utkin wrote: > > I have transitioned to "away" state as I have to reclaim my time for other > uses. Here I am trying to reduce the scope of my Gentoo responsibilities to > make potential return to activity less dreadful and overwhelming. Nothing wrong with

Re: [gentoo-dev] RFC: GID assignment for gamemode

2020-09-20 Thread Sam James
> On 20 Sep 2020, at 18:40, Kai Krakow wrote: > > Supersedes: > https://archives.gentoo.org/gentoo-dev/message/06a2f464c836a0f8d9dd1d48963aefb1 > > > > I would like to reserve GID 37 for games-util/gamemode. >

[gentoo-dev] Last rites: app-admin/recursos

2020-09-16 Thread Sam James
# Sam James (2020-09-16) # Stuck on EAPI 4, only source is mirror://gentoo, # unmaintained, HOMEPAGE gone. app-admin/recursos signature.asc Description: Message signed with OpenPGP

Re: [gentoo-dev] Last rites: */* More Py2 only items

2020-06-29 Thread Sam James
> On 29 Jun 2020, at 01:35, Aaron Bauman wrote: > > # Aaron Bauman (2020-06-28) > # More Py2 only stuff. Plz see -dev ML for discussions > # Remove bindings, port to Py3, etc > > net-irc/irker > Upstream seem to be about to release 2.19 which includes several patches for Python 3

Re: [gentoo-dev] glsa-check: missing CVE-2020-6509 for current stable chromium version

2020-06-23 Thread Sam James
> On 23 Jun 2020, at 21:57, Samuel Bernardo > wrote: > > Hi, > > Sorry if I miss any detail about glsa-check context, but I think that it > misses the CVE[1] id review I left in subject. > A GLSA (see https://security.gentoo.org/glsa ) has not yet been

Re: [gentoo-dev] Graphics Project disbanded [pkgs up for grabs]

2020-06-07 Thread Sam James
> On 8 Jun 2020, at 00:22, Philip Webb wrote: > > 200607 Pacho Ramos wrote: >> I think this is the list of completely unmaintained packages now, >> indeed most of them, around 100. > > -- extract from list -- > >> media-gfx/imagemagick : 200516 >> media-libs/giflib : 200312 >>

Re: [gentoo-dev] [RFC] Discontinuing LibreSSL support?

2020-12-29 Thread Sam James
> On 29 Dec 2020, at 09:13, Marcel Schilling > wrote: > > > I just want to comment that I switched to LibreSSL on several Gentoo > systems years ago and never had any major issues. > I run both desktop and server systems with LibreSSL, based on X and > Wayland. The only issues I ran into is a

Re: [gentoo-dev] [RFC] Discontinuing LibreSSL support?

2020-12-29 Thread Sam James
> On 28 Dec 2020, at 10:02, Hanno Böck wrote: > > If it has any weight: > I think I was the first person to build Gentoo with LibreSSL. I support > this. > I’m pleased to have yours and blueness’ input. Really, I think going is probably best. Just make it clear it can come back with some new

Re: [gentoo-dev] Non-maintainer commits and CI

2021-01-07 Thread Sam James
> On 7 Jan 2021, at 14:28, Agostino Sarubbo wrote: > > Hello, > > it happens frequently that CI discovers failure(s) in non-maintainer commits. > > The most striking examples are maintainer-needed, proxy-maint and general pull > request where who made the change has no visibility on the new

Re: [gentoo-dev] PSA: switching default tmpfiles virtual provider

2020-11-26 Thread Sam James
> On 26 Nov 2020, at 22:37, Peter Stuge wrote: > Michael Orlitzky wrote: >> Corollary: the tmpfiles.d specification can only be implemented (safely) >> on Linux after all. > > So should virtual/tmpfiles differentiate based on system? > It won’t be keyworded where it’s not available so Portage

Re: [gentoo-dev] Packages & projects up for grabs due to jer's retirement

2020-11-03 Thread Sam James
> On 3 Nov 2020, at 21:53, James Le Cuirot wrote: > > On Tue, 03 Nov 2020 22:32:11 +0100 > Michał Górny wrote: > >> Additionally, the following packages are looking for a new maintainer: >> >> net-misc/chrony > > I may take this if no one else really wants it. I run a simple client > and

Re: [gentoo-dev] ml project created

2021-01-13 Thread Sam James
> On 12 Jan 2021, at 19:24, Alfredo Tupone wrote: > > As I have interest on lot of ebuild on dev-ml, and most of them are not > managed by any project, I have created a project to handle them. > Thanks Alfredo, I’m in and I joined #gentoo-ml too. > I have build

Re: [gentoo-dev] Packages up for grabs

2021-01-17 Thread Sam James
> On 17 Jan 2021, at 09:26, Michał Górny wrote: > > Hello, > > The following packages are in need of a new maintainer due to their > current maintainer being MIA: > > […] > [ ] app-admin/stow Adopted the wonderful stow, but I’ll leave xstow for others. > [Bv] app-admin/xstow Thanks, Sam

[gentoo-dev] Last rites: dev-libs/ilbc-rfc3951

2021-01-04 Thread Sam James
# Jaco Kroon (2021-01-04) # media-libs/libilbc is (for every package I manage) a drop-in for # dev-libs/ilbc-rfc3951. The latter had net-misc/asterisk, # net-libs/pjproject and net-voip/yate as dependencies. # (All of which has been bumped to no longer have this dependency.) # Removal in 30 days,

[gentoo-dev] Package up for grabs: media-gfx/frogr

2021-02-01 Thread Sam James
Hello, Packages up for grabs due to the retirement of sobhan@: media-gfx/frogr It has 1 open bug and a version bump pending according to Repology. Thanks! Sam signature.asc Description: Message signed with OpenPGP

[gentoo-dev] Package up for grabs: x11-misc/i3blocks

2021-02-01 Thread Sam James
Hello, Packages up for grabs due to the retirement of mudler@: x11-misc/i3blocks No open bugs and no version bump pending. Thanks! Sam signature.asc Description: Message signed with OpenPGP

[gentoo-dev] Last rites: media-sound/sc2mpd

2021-06-14 Thread Sam James
# Sam James (2021-06-15) # Fails to build with GCC 11. Strange build system that needs more # work to function properly (and integrate better). Several open bugs. # bug #795999, bug #787902, bug #766033, bug #724674, bug #713206. # Removal on 15-07-2021. media-sound/sc2mpd signature.asc

Re: [gentoo-dev] [RFC] Should we switch IRC client defaults off Freenode?

2021-06-16 Thread Sam James
> On 16 Jun 2021, at 16:12, Sam James wrote: > > > >> On 16 Jun 2021, at 10:13, Michał Górny wrote: >> >> [snip] > > The only case not covered by your questions is where an IRC client > might autojoin #gentoo@libera (Smuxi does this with #s

Re: [gentoo-dev] [RFC] Should we switch IRC client defaults off Freenode?

2021-06-16 Thread Sam James
> On 16 Jun 2021, at 10:13, Michał Górny wrote: > > [snip] The only case not covered by your questions is where an IRC client might autojoin #gentoo@libera (Smuxi does this with #smuxi) in which case we want to update it. > 1. Should we be proactively changing the default network in IRC

[gentoo-dev] Up for grabs: various base-system@ packages

2021-06-16 Thread Sam James
Hi, base-system@ has decided to shed some packages which no longer fit within its remit: - app-editors/hexcurse - app-shells/bashdb - app-shells/rc - dev-util/autoproject - dev-util/unifdef - net-misc/netkit-rsh - sys-devel/remake - sys-fs/dmg2img Most of these packages are in a pretty good

[gentoo-dev] Last rites: mail-client/etpan-ng

2021-06-12 Thread Sam James
# Sam James (2021-06-10) # Fails to build with modern libetpan. Unmaintained. # See bug #699570, bug #448574. # Removal on 2021-07-10. mail-client/etpan-ng signature.asc Description: Message signed with OpenPGP

Re: [gentoo-dev] Packages up for grabs

2021-06-13 Thread Sam James
> On 13 Jun 2021, at 10:01, David Seifert wrote: > > The following packages have been dropped to m-n, since johu hasn't > touched them in over a year and show no signs of maintaining them: > > acct-group/quassel > acct-user/quassel [...] > net-irc/quassel > Adopted these. best, sam

Re: [gentoo-dev] Copyright lines in the profiles directory

2021-06-20 Thread Sam James
> On 21 Jun 2021, at 01:11, Joshua Kinard wrote: > > Doing some review/cleanups in the MIPS profiles and there's some degree of > variability going on with the top copyright header, mainly in the beginning > year. I'm wanting to fix all of those up, but what is the appropriate > beginning year

Re: [gentoo-dev] [PATCH 1/8] gnuconfig.eclass: Support EAPI 8

2021-06-21 Thread Sam James
> On 21 Jun 2021, at 17:49, Ulrich Müller wrote: > > Signed-off-by: Ulrich Müller > --- > eclass/gnuconfig.eclass | 9 +++-- > 1 file changed, 3 insertions(+), 6 deletions(-) I'm happy with the whole series. Thanks for working on this. sam signature.asc Description: Message signed with

Re: [gentoo-dev] EAPI 8 is here!

2021-06-16 Thread Sam James
> On 17 Jun 2021, at 03:28, Peter Stuge wrote: > > Sam James wrote: >> * Brings IDEPEND, usev enhancements, --disable-static by default, and more! > > How to undo that --disable-static ? > > I'm asking both for my own ebuilds and as a regular portage user. >

[gentoo-dev] EAPI 8 is here!

2021-06-16 Thread Sam James
Hi! EAPI 8 is here! In fact, it arrived a few days ago on Sunday: 1) Council approval of EAPI 8 on Sunday at the regular meeting 2) Swift release of Portage 3.0.20 containing EAPI 8 by Zac shortly thereafter. Summary: * mgorny's traditional summary is already out and can be found on his website

Re: [gentoo-dev] Need help with perl-cleaner (and app-admin/gentoo-perl-helpers)

2021-05-13 Thread Sam James
> On 13 May 2021, at 12:15, Andreas K. Huettel wrote: > > Am Donnerstag, 13. Mai 2021, 12:02:32 CEST schrieb Andreas K. Huettel: >> Hi all, >> >> due to having somewhat too many Gentoo projects and not enough time >> at the moment, I'd like to ask for help with perl-cleaner here. >> > >

Re: [gentoo-dev] News item: >=net-p2p/syncthing-1.17.0 incompatibility with

2021-05-14 Thread Sam James
> On 14 May 2021, at 15:31, Marek Szuba wrote: > > Nb. 1.17.0 has not come out yet but given 1.17.0-rc.3 came out 3 days ago and > Syncthing upstream normally only has 3 release candidates before an actual > release, we can expect it to come out quite soon. > > * * * > > Title:

[gentoo-dev] Package up for grabs: media-libs/libplacebo

2021-05-11 Thread Sam James
Hi, media-libs/libplacebo is now maintainer-needed after its proxy maintainer decided to retire. It has several open bugs and a version bump pending. Thanks, sam signature.asc Description: Message signed with OpenPGP

Re: [gentoo-dev] Packages up for grabs (m-n batch)

2021-07-02 Thread Sam James
> On 2 Jul 2021, at 08:41, Sergei Trofimovich wrote: > > I don't use these any more. > [snip] > # bumps weekly, relatively small wrapper around > # a ton of backend tools. Needs some test suite love. > dev-util/diffoscope Adopted, thanks! best, sam signature.asc Description: Message

[gentoo-dev] [PATCH] Add 2021-06-30-libxcrypt-migration

2021-06-27 Thread Sam James
Please note that the 2021-07-07 migration date is preliminary. Bug: https://bugs.gentoo.org/699422 Signed-off-by: Sam James --- .../2021-06-30-libxcrypt-migration.en.txt | 46 +++ 1 file changed, 46 insertions(+) create mode 100644 2021-06-30-libxcrypt-migration/2021-06-30

Re: [gentoo-dev] News item: media-sound/pulseffects "renaming"

2021-07-12 Thread Sam James
> On 13 Jul 2021, at 01:11, Sam James wrote: > > > >> On 13 Jul 2021, at 01:08, Marek Szuba wrote: >> >> On 2021-07-13 01:01, Marek Szuba wrote: >> >>> Title: PipeWire versions of PulseEffects are now media-sound/easyeffects >>> Autho

Re: [gentoo-dev] News item: media-sound/pulseffects "renaming"

2021-07-12 Thread Sam James
> On 13 Jul 2021, at 01:08, Marek Szuba wrote: > > On 2021-07-13 01:01, Marek Szuba wrote: > >> Title: PipeWire versions of PulseEffects are now media-sound/easyeffects >> Author: Marek Szuba >> Posted: 2021-07-16 >> Revision: 1 >> News-Item-Format: 2.0 >> Display-If-Installed:

Re: [gentoo-dev] [PATCH] Add 2021-06-30-libxcrypt-migration

2021-07-05 Thread Sam James
> On 1 Jul 2021, at 23:52, Alexey Sokolov wrote: > > Hi, Russian translation attached. Pushed, thank you. > <0001-Translate-libxcrypt-news-to-Russian.patch> signature.asc Description: Message signed with OpenPGP

Re: [gentoo-dev] [PATCH] lua*.eclass: standardize the guard variables

2021-07-06 Thread Sam James
> On 6 Jul 2021, at 22:59, William Hubbs wrote: > > Change the _R0 suffix on these variable names to _ECLASS. > Signed-off-by: William Hubbs Seems good, thanks William! > [snip] best, sam signature.asc Description: Message signed with OpenPGP

Re: [gentoo-dev] [PATCH news v2] Add Python 3.9 news item

2021-04-29 Thread Sam James
> On 29 Apr 2021, at 22:01, Michał Górny wrote: > > Signed-off-by: Michał Górny > --- > .../2021-04-29-python3-9.en.txt | 93 +++ > 1 file changed, 93 insertions(+) > create mode 100644 2021-04-29-python3-9/2021-04-29-python3-9.en.txt > > diff --git

Re: [gentoo-dev] python and frieds installs test code

2021-04-22 Thread Sam James
> On 22 Apr 2021, at 11:50, Joakim Tjernlund > wrote: > > I have noted that python, portage and gentoolkit appers to install many MB of > what appers > to be test code: > python: /usr/lib/python*/test, /usr/lib/python*/ctypes/test, > /usr/lib/python*/lib2to3/tests, >

Re: [gentoo-dev] Continuous integration on GURU

2021-04-22 Thread Sam James
> On 22 Apr 2021, at 13:59, Ionen Wolkens wrote: > [snip] > And, even if you don't see it like that, someday someone may want > to go on a fixing spree using those trackers (may it be for ::guru > or ::gentoo) but will keep seeing them mixed up together. Yes, this is particularly apt for me.

Re: [gentoo-dev] Continuous integration on GURU

2021-04-22 Thread Sam James
> On 22 Apr 2021, at 14:31, Agostino Sarubbo wrote: > > Thanks for all feedback. > > Please discuss all points internally (branch, email, trackers and so on) and > send me an email with all changes you would like to have. As an aside, I do appreciate the CI and it’s turned out to be pretty

Re: [gentoo-dev] gcc-11 enters ~arch tree

2021-04-27 Thread Sam James
> On 27 Apr 2021, at 19:22, Sergei Trofimovich wrote: > > Today gcc-11.1.0 released upstream and was added to ::gentoo as: > > https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=cc068d96fb49e308456cbe944fb29b1f78e6ad5c > And same day too! > [snip] > As usual if you can't figure out

Re: [gentoo-dev] [PATCH news v3] Add Python 3.9 news item

2021-05-03 Thread Sam James
> On 2 May 2021, at 23:04, Michał Górny wrote: > [snip] > +Upgrade commands > + > +The Python 3.8 cleanup requires that Python 3.8 is removed from complete > +dependency trees in batch. If some of the installed packages using > +an older Python version are not triaged for the

Re: [gentoo-dev] [PATCH news v3] Add Python 3.9 news item

2021-05-03 Thread Sam James
> On 3 May 2021, at 21:18, Michał Górny wrote: > > On Mon, 2021-05-03 at 19:06 +0100, Sam James wrote: >> [snip] > > I want to avoid it on the top, so people don't do it prematurely before > reading their options. > Good point - and I can’t complain, given I partl

Re: [gentoo-dev] [PATCH news v2] Add Python 3.9 news item

2021-05-03 Thread Sam James
> On 30 Apr 2021, at 08:23, Joonas Niilola wrote: > > > > On 30.4.2021 3.50, Sam James wrote: >>> On 29 Apr 2021, at 22:01, Michał Górny wrote: >>> >>> + >>> + >>> +You can also switch to Python 3.9 earlier

Re: [gentoo-dev] [PATCH news v2] Add Python 3.9 news item

2021-05-03 Thread Sam James
> On 2 May 2021, at 22:46, Michał Górny wrote: > > On Fri, 2021-04-30 at 01:50 +0100, Sam James wrote: >> >> [snip] > > I've applied most of your suggestions... and feel like this still needs > more work. I'll try to make it clearer what all options are, and

Re: [gentoo-dev] dev-python/cryptography to use rust, effectively killing alpha, hppa, ia64, m68k, s390

2021-02-08 Thread Sam James
> On 8 Feb 2021, at 11:19, Michał Górny wrote: > > Hi, > > FYI the developers of dev-python/cryptography decided that Rust is going > to be mandatory for 1.5+ versions. It's unlikely that they're going to > provide LTS support or security fixes for the old versions. > > Since cryptography is

Re: [gentoo-dev] GTK:2 EOL and incoming migration to GTK:3

2021-02-08 Thread Sam James
> On 8 Feb 2021, at 00:52, Aisha Tammy wrote: > > Hi all, > [snip] > This transition is expected to take a long time so there shouldn't be a worry > about sudden > changes in packages. We are going to keep some of the more important old > GTK:2 ebuilds, > such as the CJK ebuilds, around as

[gentoo-dev] Last-rites: oasis.eclass

2021-03-22 Thread Sam James
oasis.eclass: mark as @DEAD (last-rite eclass) Removal on 2021-04-05 when the rest of the Oasis packages, including Oasis (dev-ml/oasis) is removed. There's no point in keeping the eclass when Oasis itself is gone and nothing should be able to use this right now anyway due to the large number of

Re: [gentoo-dev] [PATCH] autotools.eclass: eclassdoc, cosmetic changes, drop old EAPIs

2021-03-28 Thread Sam James
 > On 28 Mar 2021, at 13:46, Ulrich Mueller wrote: > >  >>> On Sun, 28 Mar 2021, David Seifert wrote: >> This is just bringing it in line with the rest of the eclass. You know, >> consistency. > > If that's the goal then the patch should update all occurences, though. Well, that was

Re: [gentoo-dev] [PATCH] flag-o-matic.eclass: get rid of eutils in

2021-03-31 Thread Sam James
> On 31 Mar 2021, at 07:39, Andreas Sturmlechner wrote: > > qa-reports showing >7300 ebuilds with EAPI-7 using eutils.eclass, that can't > be right. > > - Restrict inherit eutils to - Drop bogus multilib.eclass (inherited by toolchain-funcs.eclass anyway) > - Several functions look like

Re: [gentoo-dev] [PATCH] autotools.eclass: eclassdoc, cosmetic changes, drop old EAPIs

2021-03-30 Thread Sam James
> On 27 Mar 2021, at 22:21, Sam James wrote: > Given how uncontroversial most of it is, the positive reviews, and the fact that I pushed a load of other eclassdoc changes (for other eclasses) but CI is still down, it makes sense to throw in as much as we can to not waste the big

Re: [gentoo-dev] [PATCH] flag-o-matic.eclass: get rid of eutils in

2021-04-01 Thread Sam James
> On 31 Mar 2021, at 10:09, Ulrich Mueller wrote: > >> On Wed, 31 Mar 2021, Andreas Sturmlechner wrote: > >> setup-allowed-flags() { >> +[[ ${EAPI} == [0-7] ]] || >> +die "Internal function ${FUNCNAME} is not available in >> >=EAPI-8." >> +_setup-allowed-flags >> +} >

[gentoo-dev] [PATCH v2 2/3] gnuconfig.eclass: provide basic @ECLASS block, docs

2021-04-05 Thread Sam James
Signed-off-by: Sam James --- eclass/gnuconfig.eclass | 33 +++-- 1 file changed, 23 insertions(+), 10 deletions(-) diff --git a/eclass/gnuconfig.eclass b/eclass/gnuconfig.eclass index 3433837787c..f679441445f 100644 --- a/eclass/gnuconfig.eclass +++ b/eclass

[gentoo-dev] [PATCH v2 3/3] gnuconfig.eclass: use BDEPEND, BROOT where available (drop support for EAPI <4)

2021-04-05 Thread Sam James
EPREFIX is only available in > EAPI 2 but let's take the opportuinty to clean up in general. We don't want to keep worrying about *very* old EAPI cases, especially given other eclasses either barely - or don't - support it. Signed-off-by: Sam James --- eclass/gnuconfig.eclass |

[gentoo-dev] [PATCH v2 1/3] autotools.eclass: eclassdoc, cosmetic changes, drop old EAPIs, configure.ac rename

2021-04-05 Thread Sam James
stent 'case' style * consistent variable references * consistent references to bugs in comments * consistent use of ${ECLASS}, not "autotools.eclass" * use same ${WANT_AUTOCONF} comparison test throughout Bug: https://bugs.gentoo.org/426262 Closes: https://bugs.gentoo.org/584254 Signed-of

[gentoo-dev] Packages up for grabs: app-emulation/img, app-forensics/aide, app-text/cherrytree, media-gfx/zbar, net-p2p/go-ethereum

2021-04-06 Thread Sam James
Packages up for grabs due to retirement of a proxied maintainer (and somebody giving up a package): app-emulation/img app-forensics/aide app-text/cherrytree media-gfx/zbar net-p2p/go-ethereum Most have no open bugs and are in a reasonable state. signature.asc Description: Message signed with

[gentoo-dev] s390 has been dropped to ~s390 (testing/unstable)

2021-04-06 Thread Sam James
Hi, Given I received no comments on the mailing list [0] post from 16th Feb and affirmative comments via IRC, I’ve dropped all s390 keywords to ~s390 (testing/unstable). We’ll keep the s390 arch in addition to s390x as a subprofile for now as this reduces the hassle of maintaining s390. This

[gentoo-dev] s390 has been dropped to ~s390 (testing/unstable) (resent)

2021-04-06 Thread Sam James
Hi, Given I received no comments on the mailing list [0] post from 16th Feb and affirmative comments via IRC, I’ve dropped all s390 keywords to ~s390 (testing/unstable). We’ll keep the s390 arch in addition to s390x as a subprofile for now as this reduces the hassle of maintaining s390. This

Re: [gentoo-dev] [PATCH v2 3/3] gnuconfig.eclass: use BDEPEND, BROOT where available (drop support for EAPI <4)

2021-04-06 Thread Sam James
> On 5 Apr 2021, at 17:24, Ulrich Mueller wrote: > >>>>>> On Mon, 05 Apr 2021, Sam James wrote: > >> +4|5|6) >> +DEPEND=" >> +sys-apps/grep >> +sys-devel/gnuconfig >> +

Re: [gentoo-dev] Packages up for grabs: app-emulation/img, app-forensics/aide, app-text/cherrytree, media-gfx/zbar, net-p2p/go-ethereum

2021-04-06 Thread Sam James
> On 6 Apr 2021, at 22:16, Sam James wrote: > > Packages up for grabs due to retirement of a proxied maintainer (and somebody > giving up a package): > app-emulation/img > app-forensics/aide > app-text/cherrytree > media-gfx/zbar > net-p2p/go-ethereum

Re: [gentoo-dev] [PATCH] xorg-2.eclass: Mark @DEAD for removal

2021-03-27 Thread Sam James
> On 27 Mar 2021, at 19:25, Matt Turner wrote: > > Per Sam's suggestion, I'll also add > > # @DEPRECATED: Use xorg-3.eclass > I made the same mistake with oasis, do just ‘xorg-3.class’ because the pkgcheck text says ‘replacement: ${text}’. signature.asc Description: Message signed with

[gentoo-dev] [PATCH] autotools.eclass: eclassdoc, cosmetic changes, drop old EAPIs

2021-03-27 Thread Sam James
o eqawarn * consistent 'case' style * consistent variable references * consistent references to bugs in comments * consistent use of ${ECLASS}, not "autotools.eclass" * use same ${WANT_AUTOCONF} comparison test throughout Signed-off-by: Sam James --- eclass/aut

[gentoo-dev] Last-rites: autotools-utils.eclass

2021-03-27 Thread Sam James
autotools-utils.eclass: mark as @DEAD (last-rite eclass) Removal on 2021-04-28. Please port to autotools.eclass or out-of-source.eclass. signature.asc Description: Message signed with OpenPGP

[gentoo-dev] Begging notice: please mark your packages as ALLARCHES

2021-03-11 Thread Sam James
Hi, Please mark your package as ALLARCHES if at all possible. The metadata.xml tag indicates to arch teams that the package is architecture independent and therefore testing on one architecture is sufficient. You can read more in the devmanual:

Re: [gentoo-dev] Urgent reminder to port your packages to Python 3.8 and Python 3.9

2021-03-11 Thread Sam James
> On 3 Mar 2021, at 22:55, Sam James wrote: > > Hi, > > We still have ~31 packages still not declaring support for newer Python 3 > targets than Python 3.7, > we have ~1085 packages still not declaring support for newer Python 3 targets > than Python 3.8 (i.e

[gentoo-dev] Last rites: various old dev-ml/* packages stuck on oasis.eclass

2021-03-14 Thread Sam James
# Sam James (2021-03-13) # Stuck on oasis.eclass, out of date # No reverse dependencies # bug #775785 # Removal in 14 days. Nothing should really # be able to use any of these right now anyway. dev-ml/qcheck dev-ml/macaque dev-ml/pgocaml dev-ml/csv dev-ml/gen dev-ml/tyxml dev-ml/stringext dev-ml

Re: [gentoo-dev] [PATCH] gstreamer-meson.eclass: New eclass required for gstreamer-1.18.0+

2021-03-16 Thread Sam James
> On 17 Mar 2021, at 01:49, Haelwenn (lanodan) Monnier > wrote: > > Gstreamer switched to meson in 1.16.0 and removed autotools support in 1.18.0, > this eclass is an update of gstreamer.eclass. > > [snip] Thanks for working on this! > +# > +# GStreamer consuming applications should depend

[gentoo-dev] Urgent reminder to port your packages to Python 3.8 and Python 3.9

2021-03-03 Thread Sam James
Hi, We still have ~31 packages still not declaring support for newer Python 3 targets than Python 3.7, we have ~1085 packages still not declaring support for newer Python 3 targets than Python 3.8 (i.e. Python 3.9). Please review this list to see if your packages are stuck on Python 3.7:

[gentoo-dev] Last rites: app-office/moneyguru

2021-03-03 Thread Sam James
# Sam James (2021-03-03) # Declared abandoned upstream and stuck # on Python 3.7. # Removal in 30 days. app-office/moneyguru signature.asc Description: Message signed with OpenPGP

Re: [gentoo-dev] Urgent reminder to port your packages to Python 3.8 and Python 3.9

2021-03-03 Thread Sam James
> On 3 Mar 2021, at 22:55, Sam James wrote: > > Hi, > > We still have ~31 packages still not declaring support for newer Python 3 > targets than Python 3.7, > we have ~1085 packages still not declaring support for newer Python 3 targets > than Python 3.8 (i.e.

Re: [gentoo-dev] [RFC] Dropping PyPy(3) back to ~arch

2021-03-03 Thread Sam James
> On 2 Mar 2021, at 15:05, Michał Górny wrote: > > Hi, > > I think I've made a mistake by stabilizing PyPy(3), and I would like to > drop it back to ~arch (and stable-mask the relevant flags). > > Roughly, there are 4 problems with it: > > [snip] > Honestly, I've tried to improve PyPy in

[gentoo-dev] Last rites: sci-mathematics/ggnfs

2021-02-26 Thread Sam James
# Sam James (2021-02-27) # Fails to build with GCC 10 (or otherwise!) # bug #708508, bug #728026, bug #542280 # Removal in 30 days sci-mathematics/ggnfs signature.asc Description: Message signed with OpenPGP

[gentoo-dev] Last rites: dev-scheme/greg

2021-02-26 Thread Sam James
# Sam James (2021-02-27) # Broken with newer(?) dev-scheme/guile, dead upstream # bug #642736, bug #773196 dev-scheme/greg signature.asc Description: Message signed with OpenPGP

[gentoo-dev] Last rites: dev-lang/ats

2021-02-26 Thread Sam James
# Sam James (2021-02-27) # Fails to build with GCC 10, out of date. # bug #723192, bug #737058 # Removal in 30 days dev-lang/ats signature.asc Description: Message signed with OpenPGP

[gentoo-dev] Last rites: games-strategy/0ad-data

2021-03-01 Thread Sam James
# Sam James (2021-02-28) # games-strategy/0ad-data has been merged # into games-strategy/0ad for simplicity. # Note that in most cases, the latter uses # upstream pre-built assets anyway. # Nothing should really be using this. # bug #735352, bug #768930 # Removal in 14 days. games-strategy/0ad

Re: [gentoo-dev] New tool: merge-driver-ekeyword automatically resolves git merge conflicts involving KEYWORDS=...

2021-03-01 Thread Sam James
> On 2 Mar 2021, at 05:10, Michael Orlitzky wrote: > > On Mon, 2021-03-01 at 22:54 -0500, Matt Turner wrote: >> tl;dr: In app-portage/gentoolkit-0.5.1 there's a new tool I wrote, >> called merge-driver-ekeyword that can automatically resolve git merge >> conflicts involving the KEYWORDS=...

[gentoo-dev] Re: [gentoo-dev-announce] New tool: merge-driver-ekeyword automatically resolves git merge conflicts involving KEYWORDS=...

2021-03-03 Thread Sam James
> On 2 Mar 2021, at 03:54, Matt Turner wrote: > > tl;dr: In app-portage/gentoolkit-0.5.1 there's a new tool I wrote, > called merge-driver-ekeyword that can automatically resolve git merge > conflicts involving the KEYWORDS=... line in ebuilds. > Thanks a lot for your work here, Matt! It’s

[gentoo-dev] Begging notice: please use NATTkA / CC-ARCHES for keywording/stabilisation bugs

2021-03-03 Thread Sam James
Hi, This is a begging notice to ideally use NATTkA if possible for your keywording or stabilisation bugs! [If you don’t know what to do, I hereby give you permission to nag me and ask me to check each one of your bugs to let you know if it’s working okay and if it’s all gone alright. New

[gentoo-dev] Begging notice: always CC all arches which are currently stable on your package

2021-03-03 Thread Sam James
Hi, This is a friendly reminder that you should CC arch teams *for all arches which currently have a stable keyword for your package*. NATTkA handles this for you (see my other email [0]), but if you decide to not use it, please be sure you do CC all arches for which the previous stable version

Re: [gentoo-dev] [News item review] V2 Chromium access to Google services

2021-03-08 Thread Sam James
> On 8 Mar 2021, at 19:01, Stephan Hartmann wrote: > > Hi, Hi! Review from mobile so please excuse non-ideal formatting. > > updated based on previous suggestions. > > ``` > Title: Chromium access to Google services > Author: Stephan Hartmann > Content-Type: text/plain > Posted:

[gentoo-dev] Last rites: media-gfx/openexr_viewers

2021-02-27 Thread Sam James
# Bernd Waibel (2021-02-27) # No longer actively supported upstream. # Removal needed to clean-up {ilmbase,openexr}-2.3.0 # Masked for removal in 30 days. media-gfx/openexr_viewers signature.asc Description: Message signed with OpenPGP

Re: [gentoo-dev] Non-maintainer commits and CI

2021-03-01 Thread Sam James
> On 7 Jan 2021, at 14:28, Agostino Sarubbo wrote: > > Hello, > > it happens frequently that CI discovers failure(s) in non-maintainer commits. > > The most striking examples are maintainer-needed, proxy-maint and general pull > request where who made the change has no visibility on the new

  1   2   >