Re: [gentoo-dev] [PATCH 1/2] bzr.eclass: Reinstate eclass

2021-09-27 Thread Michał Górny
On Mon, 2021-09-27 at 20:01 +0200, Ulrich Mueller wrote:
> > > > > > On Mon, 27 Sep 2021, Michał Górny wrote:
> 
> > You seem to be missing the fact that all of them hardcode "bzr".
> 
> Yes, and it is updated to "brz" in a followup commit. Would you prefer
> leaving them as "bzr"? I guess that backwards compatibility link will
> stay there for a long time.

What I'm saying is that if anyone overrides these commands, they will be
broken when the symlink disappears.

Then ofc there's the basic problem if anyone will ever actually need to
do that.  This doesn't sound likely for eclass that we expect to have
approximately one consumer.

-- 
Best regards,
Michał Górny





Re: [gentoo-dev] [PATCH 1/2] bzr.eclass: Reinstate eclass

2021-09-27 Thread Ulrich Mueller
> On Mon, 27 Sep 2021, Michał Górny wrote:

> You seem to be missing the fact that all of them hardcode "bzr".

Yes, and it is updated to "brz" in a followup commit. Would you prefer
leaving them as "bzr"? I guess that backwards compatibility link will
stay there for a long time.


signature.asc
Description: PGP signature


Re: [gentoo-dev] [PATCH 1/2] bzr.eclass: Reinstate eclass

2021-09-27 Thread Michał Górny
On Mon, 2021-09-27 at 19:25 +0200, Ulrich Mueller wrote:
> > > > > > On Sat, 25 Sep 2021, Michał Górny wrote:
> 
> > > +EBZR="bzr.eclass"
> 
> > Why do we need this?  It seems as if someone is reinventing
> > ${ECLASS}.
> 
> Replaced by ${ECLASS}.
> 
> > > +# @ECLASS-VARIABLE: EBZR_STORE_DIR
> 
> > @USER_VARIABLE?
> 
> Added.
> 
> > > +# @DESCRIPTION:
> > > +# The directory to store all fetched Bazaar live sources.
> > > +: ${EBZR_STORE_DIR:=${PORTAGE_ACTUAL_DISTDIR:-${DISTDIR}}/bzr-
> > > src}
> > > +
> > > +# @ECLASS-VARIABLE: EBZR_UNPACK_DIR
> > > +# @DESCRIPTION:
> > > +# The working directory where the sources are copied to.
> > > +: ${EBZR_UNPACK_DIR:=${WORKDIR}/${P}}
> > > +
> > > +# @ECLASS-VARIABLE: EBZR_INIT_REPO_CMD
> > > +# @DESCRIPTION:
> > > +# The Bazaar command to initialise a shared repository.
> > > +: ${EBZR_INIT_REPO_CMD:="bzr init-repository --no-trees"}
> > > +
> > > +# @ECLASS-VARIABLE: EBZR_FETCH_CMD
> > > +# @DESCRIPTION:
> > > +# The Bazaar command to fetch the sources.
> > > +: ${EBZR_FETCH_CMD:="bzr branch --no-tree"}
> > > +
> > > +# @ECLASS-VARIABLE: EBZR_UPDATE_CMD
> > > +# @DESCRIPTION:
> > > +# The Bazaar command to update the sources.
> > > +: ${EBZR_UPDATE_CMD:="bzr pull --overwrite-tags"}
> > > +
> > > +# @ECLASS-VARIABLE: EBZR_EXPORT_CMD
> > > +# @DESCRIPTION:
> > > +# The Bazaar command to export a branch.
> > > +: ${EBZR_EXPORT_CMD:="bzr export"}
> > > +
> > > +# @ECLASS-VARIABLE: EBZR_CHECKOUT_CMD
> > > +# @DESCRIPTION:
> > > +# The Bazaar command to checkout a branch.
> > > +: ${EBZR_CHECKOUT_CMD:="bzr checkout --lightweight -q"}
> > > +
> > > +# @ECLASS-VARIABLE: EBZR_REVNO_CMD
> > > +# @DESCRIPTION:
> > > +# The Bazaar command to list a revision number of the branch.
> > > +: ${EBZR_REVNO_CMD:="bzr revno"}
> 
> > Are you sure that having these overrides is a good idea?
> 
> Yes. Ebuilds had used them in the past.
> 
> > Your followup patch pretty much proves that every ebuild redefining
> > them would get broken by switch to breezy.
> 
> The only one where syntax has changed is EBZR_INIT_REPO_CMD (which has
> init-shared-repository instead of init-repository).

You seem to be missing the fact that all of them hardcode "bzr".


-- 
Best regards,
Michał Górny





Re: [gentoo-dev] [PATCH 1/2] bzr.eclass: Reinstate eclass

2021-09-27 Thread Ulrich Mueller
> On Sat, 25 Sep 2021, Michał Górny wrote:

>> +EBZR="bzr.eclass"

> Why do we need this?  It seems as if someone is reinventing ${ECLASS}.

Replaced by ${ECLASS}.

>> +# @ECLASS-VARIABLE: EBZR_STORE_DIR

> @USER_VARIABLE?

Added.

>> +# @DESCRIPTION:
>> +# The directory to store all fetched Bazaar live sources.
>> +: ${EBZR_STORE_DIR:=${PORTAGE_ACTUAL_DISTDIR:-${DISTDIR}}/bzr-src}
>> +
>> +# @ECLASS-VARIABLE: EBZR_UNPACK_DIR
>> +# @DESCRIPTION:
>> +# The working directory where the sources are copied to.
>> +: ${EBZR_UNPACK_DIR:=${WORKDIR}/${P}}
>> +
>> +# @ECLASS-VARIABLE: EBZR_INIT_REPO_CMD
>> +# @DESCRIPTION:
>> +# The Bazaar command to initialise a shared repository.
>> +: ${EBZR_INIT_REPO_CMD:="bzr init-repository --no-trees"}
>> +
>> +# @ECLASS-VARIABLE: EBZR_FETCH_CMD
>> +# @DESCRIPTION:
>> +# The Bazaar command to fetch the sources.
>> +: ${EBZR_FETCH_CMD:="bzr branch --no-tree"}
>> +
>> +# @ECLASS-VARIABLE: EBZR_UPDATE_CMD
>> +# @DESCRIPTION:
>> +# The Bazaar command to update the sources.
>> +: ${EBZR_UPDATE_CMD:="bzr pull --overwrite-tags"}
>> +
>> +# @ECLASS-VARIABLE: EBZR_EXPORT_CMD
>> +# @DESCRIPTION:
>> +# The Bazaar command to export a branch.
>> +: ${EBZR_EXPORT_CMD:="bzr export"}
>> +
>> +# @ECLASS-VARIABLE: EBZR_CHECKOUT_CMD
>> +# @DESCRIPTION:
>> +# The Bazaar command to checkout a branch.
>> +: ${EBZR_CHECKOUT_CMD:="bzr checkout --lightweight -q"}
>> +
>> +# @ECLASS-VARIABLE: EBZR_REVNO_CMD
>> +# @DESCRIPTION:
>> +# The Bazaar command to list a revision number of the branch.
>> +: ${EBZR_REVNO_CMD:="bzr revno"}

> Are you sure that having these overrides is a good idea?

Yes. Ebuilds had used them in the past.

> Your followup patch pretty much proves that every ebuild redefining
> them would get broken by switch to breezy.

The only one where syntax has changed is EBZR_INIT_REPO_CMD (which has
init-shared-repository instead of init-repository).

>> +# @ECLASS-VARIABLE: EBZR_OPTIONS
>> +# @DEFAULT_UNSET
>> +# @DESCRIPTION:
>> +# The options passed to the fetch and update commands.

> Is this intended to be set by ebuild or by user?

Ebuild.

>> +# @ECLASS-VARIABLE: EBZR_OFFLINE

> @USER_VARIABLE?

>> +# @ECLASS-VARIABLE: EVCS_UMASK

> @USER_VARIABLE?

Both added.

>> +# @FUNCTION: bzr_initial_fetch

> @INTERNAL?

Added, and renamed to _bzr_initial_fetch.

>> +if [[ -n "${EBZR_OFFLINE}" ]]; then
>> +ewarn "EBZR_OFFLINE cannot be used when there is no local 
>> branch yet."

> I dare say this is incorrect.  If user says "no online operations", then
> the eclass should just fail, not ignore the user.

Fixed.

>> +${EBZR_FETCH_CMD} ${EBZR_OPTIONS} "${repo_uri}" "${branch_dir}" \
>> +|| die "${EBZR}: can't branch from ${repo_uri}"

> You can replace the backslash with '||'.

I think that splitting the line before the operator is clearer. (It is
also what GNU coding standards recommend for C.)

>> +# @FUNCTION: bzr_update

> @INTERNAL?

Added, and renamed to _bzr_update.

>> +bzr_fetch() {
>> +local repo_dir branch_dir
>> +local save_sandbox_write=${SANDBOX_WRITE} save_umask
>> +
>> +[[ -n ${EBZR_REPO_URI} ]] || die "${EBZR}: EBZR_REPO_URI is empty"
>> +
>> +if [[ ! -d ${EBZR_STORE_DIR} ]] ; then
>> +addwrite /
>> +mkdir -p "${EBZR_STORE_DIR}" \
>> +|| die "${EBZR}: can't mkdir ${EBZR_STORE_DIR}"
>> +SANDBOX_WRITE=${save_sandbox_write}

> Looks like abusing implementation details.

Replaced by subshell.

>> +if [[ -z ${EBZR_INITIAL_URI} ]]; then
>> +bzr_initial_fetch "${EBZR_REPO_URI}" "${branch_dir}"
>> +else
>> +# Workaround for faster initial download. This clones 
>> the
>> +# branch from a fast server (which may be out of date), 
>> and
>> +# subsequently pulls from the slow original repository.
>> +bzr_initial_fetch "${EBZR_INITIAL_URI}" "${branch_dir}"
>> +if [[ ${EBZR_REPO_URI} != "${EBZR_INITIAL_URI}" ]]; then
>> +EBZR_UPDATE_CMD="${EBZR_UPDATE_CMD} --remember 
>> --overwrite" \
>> +EBZR_OFFLINE="" \

> Why do you override EBZR_OFFLINE here?

The whole else clause is dropped in a followup commit.

Ulrich


signature.asc
Description: PGP signature


Re: [gentoo-dev] [PATCH 1/2] bzr.eclass: Reinstate eclass

2021-09-25 Thread Ulrich Mueller
> On Sat, 25 Sep 2021, Arthur Zamarin wrote:

> On 25/09/2021 12:36, Ulrich Müller wrote:
>> +if [[ -z ${EBZR_INITIAL_URI} ]]; then
>> +bzr_initial_fetch "${EBZR_REPO_URI}" "${branch_dir}"
>> +else
>> +# Workaround for faster initial download. This clones 
>> the
>> +# branch from a fast server (which may be out of date), 
>> and
>> +# subsequently pulls from the slow original repository.
>> +bzr_initial_fetch "${EBZR_INITIAL_URI}" "${branch_dir}"
>> +if [[ ${EBZR_REPO_URI} != "${EBZR_INITIAL_URI}" ]]; then
>> +EBZR_UPDATE_CMD="${EBZR_UPDATE_CMD} --remember 
>> --overwrite" \
>> +EBZR_OFFLINE="" \
>> +bzr_update "${EBZR_REPO_URI}" 
>> "${branch_dir}"
>> +fi

> This logic maybe can be improved and made easier, by defaulting
> EBZR_INITIAL_URI to be by default EBZR_REPO_URI (as a result, the
> first call to bzr_initial_fetch can be done outside the if), and if
> the ebuild writer changed it (check using the if here), then do the
> next bzr_update.

> Or another option, instead of setting by default, do the first fetch as:
> bzr_initial_fetch "${EBZR_INITIAL_URI:-${EBZR_REPO_URI}}" "${branch_dir}"
> But I think this one is less readable.

>> +fi

I am going to drop support for EBZR_INITIAL_URI altogether. This was a
special case used for GNU Emacs, which historically had a slow original
repository and a fast (but possibly out of date) mirror. It is unlikely
that we will need this again.

Ulrich


signature.asc
Description: PGP signature


Re: [gentoo-dev] [PATCH 1/2] bzr.eclass: Reinstate eclass

2021-09-25 Thread Arthur Zamarin

On 25/09/2021 12:36, Ulrich Müller wrote:

Taken from commit 320fcf034f5e860454e0d2a28ed405c5b843c60c.

Signed-off-by: Ulrich Müller 
---
  eclass/bzr.eclass | 289 ++
  1 file changed, 289 insertions(+)
  create mode 100644 eclass/bzr.eclass

diff --git a/eclass/bzr.eclass b/eclass/bzr.eclass
new file mode 100644
index ..fc1de9dc9ccc
--- /dev/null
+++ b/eclass/bzr.eclass
@@ -0,0 +1,289 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# @ECLASS: bzr.eclass
+# @MAINTAINER:
+# Ulrich Müller 
+# @AUTHOR:
+# Jorge Manuel B. S. Vicetto 
+# Mark Lee 
+# Ulrich Müller 
+# Christian Faulhammer 
+# @SUPPORTED_EAPIS: 2 3 4 5 6 7
+# @BLURB: generic fetching functions for the Bazaar VCS
+# @DESCRIPTION:
+# The bzr.eclass provides functions to fetch and unpack sources from
+# repositories of the Bazaar distributed version control system.
+# The eclass was originally derived from git.eclass.
+#
+# Note: Just set EBZR_REPO_URI to the URI of the branch and src_unpack()
+# of this eclass will export the branch to ${WORKDIR}/${P}.
+
+EBZR="bzr.eclass"
+
+PROPERTIES+=" live"
+
+if [[ ${EBZR_REPO_URI%%:*} = sftp ]]; then
+   DEPEND=">=dev-vcs/bzr-2.6.0[sftp]"
+else
+   DEPEND=">=dev-vcs/bzr-2.6.0"
+fi
+
+case ${EAPI:-0} in
+   2|3|4|5|6) ;;
+   7) BDEPEND="${DEPEND}"; DEPEND="" ;;
+   *) die "${EBZR}: EAPI ${EAPI:-0} is not supported" ;;
+esac
+
+EXPORT_FUNCTIONS src_unpack
+
+# @ECLASS-VARIABLE: EBZR_STORE_DIR
+# @DESCRIPTION:
+# The directory to store all fetched Bazaar live sources.
+: ${EBZR_STORE_DIR:=${PORTAGE_ACTUAL_DISTDIR:-${DISTDIR}}/bzr-src}
+
+# @ECLASS-VARIABLE: EBZR_UNPACK_DIR
+# @DESCRIPTION:
+# The working directory where the sources are copied to.
+: ${EBZR_UNPACK_DIR:=${WORKDIR}/${P}}
+
+# @ECLASS-VARIABLE: EBZR_INIT_REPO_CMD
+# @DESCRIPTION:
+# The Bazaar command to initialise a shared repository.
+: ${EBZR_INIT_REPO_CMD:="bzr init-repository --no-trees"}
+
+# @ECLASS-VARIABLE: EBZR_FETCH_CMD
+# @DESCRIPTION:
+# The Bazaar command to fetch the sources.
+: ${EBZR_FETCH_CMD:="bzr branch --no-tree"}
+
+# @ECLASS-VARIABLE: EBZR_UPDATE_CMD
+# @DESCRIPTION:
+# The Bazaar command to update the sources.
+: ${EBZR_UPDATE_CMD:="bzr pull --overwrite-tags"}
+
+# @ECLASS-VARIABLE: EBZR_EXPORT_CMD
+# @DESCRIPTION:
+# The Bazaar command to export a branch.
+: ${EBZR_EXPORT_CMD:="bzr export"}
+
+# @ECLASS-VARIABLE: EBZR_CHECKOUT_CMD
+# @DESCRIPTION:
+# The Bazaar command to checkout a branch.
+: ${EBZR_CHECKOUT_CMD:="bzr checkout --lightweight -q"}
+
+# @ECLASS-VARIABLE: EBZR_REVNO_CMD
+# @DESCRIPTION:
+# The Bazaar command to list a revision number of the branch.
+: ${EBZR_REVNO_CMD:="bzr revno"}
+
+# @ECLASS-VARIABLE: EBZR_OPTIONS
+# @DEFAULT_UNSET
+# @DESCRIPTION:
+# The options passed to the fetch and update commands.
+
+# @ECLASS-VARIABLE: EBZR_REPO_URI
+# @DEFAULT_UNSET
+# @REQUIRED
+# @DESCRIPTION:
+# The repository URI for the source package.
+#
+# Note: If the ebuild uses an sftp:// URI, then the eclass will depend
+# on dev-vcs/bzr[sftp].
+
+# @ECLASS-VARIABLE: EBZR_INITIAL_URI
+# @DEFAULT_UNSET
+# @DESCRIPTION:
+# The URI used for initial branching of the source repository.  If this
+# variable is set, the initial branch will be cloned from the location
+# specified, followed by a pull from ${EBZR_REPO_URI}.  This is intended
+# for special cases, e.g. when download from the original repository is
+# slow, but a fast mirror exists but may be out of date.
+#
+# Normally, this variable needs not be set.
+
+# @ECLASS-VARIABLE: EBZR_PROJECT
+# @DESCRIPTION:
+# The project name of your ebuild.  Normally, the branch will be stored
+# in the ${EBZR_STORE_DIR}/${EBZR_PROJECT} directory.
+#
+# If EBZR_BRANCH is set (see below), then a shared repository will be
+# created in that directory, and the branch will be located in
+# ${EBZR_STORE_DIR}/${EBZR_PROJECT}/${EBZR_BRANCH}.
+: ${EBZR_PROJECT:=${PN}}
+
+# @ECLASS-VARIABLE: EBZR_BRANCH
+# @DEFAULT_UNSET
+# @DESCRIPTION:
+# The directory where to store the branch within a shared repository,
+# relative to ${EBZR_STORE_DIR}/${EBZR_PROJECT}.
+#
+# This variable should be set if there are several live ebuilds for
+# different branches of the same upstream project.  The branches can
+# then share the same repository in EBZR_PROJECT, which will save both
+# data traffic volume and disk space.
+#
+# If there is only a live ebuild for one single branch, EBZR_BRANCH
+# needs not be set.  In this case, the branch will be stored in a
+# stand-alone repository directly in EBZR_PROJECT.
+
+# @ECLASS-VARIABLE: EBZR_REVISION
+# @DEFAULT_UNSET
+# @DESCRIPTION:
+# Revision to fetch, defaults to the latest
+# (see http://bazaar-vcs.org/BzrRevisionSpec or bzr help revisionspec).
+
+# @ECLASS-VARIABLE: EBZR_OFFLINE
+# @DESCRIPTION:
+# Set this variable to a non-empty value to disable automatic updating
+# of a bzr source tree.  This is intended to be set 

Re: [gentoo-dev] [PATCH 1/2] bzr.eclass: Reinstate eclass

2021-09-25 Thread Michał Górny
On Sat, 2021-09-25 at 11:36 +0200, Ulrich Müller wrote:
> Taken from commit 320fcf034f5e860454e0d2a28ed405c5b843c60c.

I suppose you'll want to apply my comments as followup changes.

> 
> Signed-off-by: Ulrich Müller 
> ---
>  eclass/bzr.eclass | 289 ++
>  1 file changed, 289 insertions(+)
>  create mode 100644 eclass/bzr.eclass
> 
> diff --git a/eclass/bzr.eclass b/eclass/bzr.eclass
> new file mode 100644
> index ..fc1de9dc9ccc
> --- /dev/null
> +++ b/eclass/bzr.eclass
> @@ -0,0 +1,289 @@
> +# Copyright 1999-2019 Gentoo Authors
> +# Distributed under the terms of the GNU General Public License v2
> +
> +# @ECLASS: bzr.eclass
> +# @MAINTAINER:
> +# Ulrich Müller 
> +# @AUTHOR:
> +# Jorge Manuel B. S. Vicetto 
> +# Mark Lee 
> +# Ulrich Müller 
> +# Christian Faulhammer 
> +# @SUPPORTED_EAPIS: 2 3 4 5 6 7
> +# @BLURB: generic fetching functions for the Bazaar VCS
> +# @DESCRIPTION:
> +# The bzr.eclass provides functions to fetch and unpack sources from
> +# repositories of the Bazaar distributed version control system.
> +# The eclass was originally derived from git.eclass.
> +#
> +# Note: Just set EBZR_REPO_URI to the URI of the branch and src_unpack()
> +# of this eclass will export the branch to ${WORKDIR}/${P}.
> +
> +EBZR="bzr.eclass"

Why do we need this?  It seems as if someone is reinventing ${ECLASS}.

> +
> +PROPERTIES+=" live"
> +
> +if [[ ${EBZR_REPO_URI%%:*} = sftp ]]; then
> + DEPEND=">=dev-vcs/bzr-2.6.0[sftp]"
> +else
> + DEPEND=">=dev-vcs/bzr-2.6.0"
> +fi
> +
> +case ${EAPI:-0} in
> + 2|3|4|5|6) ;;
> + 7) BDEPEND="${DEPEND}"; DEPEND="" ;;
> + *) die "${EBZR}: EAPI ${EAPI:-0} is not supported" ;;
> +esac
> +
> +EXPORT_FUNCTIONS src_unpack
> +
> +# @ECLASS-VARIABLE: EBZR_STORE_DIR

@USER_VARIABLE?

> +# @DESCRIPTION:
> +# The directory to store all fetched Bazaar live sources.
> +: ${EBZR_STORE_DIR:=${PORTAGE_ACTUAL_DISTDIR:-${DISTDIR}}/bzr-src}
> +
> +# @ECLASS-VARIABLE: EBZR_UNPACK_DIR
> +# @DESCRIPTION:
> +# The working directory where the sources are copied to.
> +: ${EBZR_UNPACK_DIR:=${WORKDIR}/${P}}
> +
> +# @ECLASS-VARIABLE: EBZR_INIT_REPO_CMD
> +# @DESCRIPTION:
> +# The Bazaar command to initialise a shared repository.
> +: ${EBZR_INIT_REPO_CMD:="bzr init-repository --no-trees"}
> +
> +# @ECLASS-VARIABLE: EBZR_FETCH_CMD
> +# @DESCRIPTION:
> +# The Bazaar command to fetch the sources.
> +: ${EBZR_FETCH_CMD:="bzr branch --no-tree"}
> +
> +# @ECLASS-VARIABLE: EBZR_UPDATE_CMD
> +# @DESCRIPTION:
> +# The Bazaar command to update the sources.
> +: ${EBZR_UPDATE_CMD:="bzr pull --overwrite-tags"}
> +
> +# @ECLASS-VARIABLE: EBZR_EXPORT_CMD
> +# @DESCRIPTION:
> +# The Bazaar command to export a branch.
> +: ${EBZR_EXPORT_CMD:="bzr export"}
> +
> +# @ECLASS-VARIABLE: EBZR_CHECKOUT_CMD
> +# @DESCRIPTION:
> +# The Bazaar command to checkout a branch.
> +: ${EBZR_CHECKOUT_CMD:="bzr checkout --lightweight -q"}
> +
> +# @ECLASS-VARIABLE: EBZR_REVNO_CMD
> +# @DESCRIPTION:
> +# The Bazaar command to list a revision number of the branch.
> +: ${EBZR_REVNO_CMD:="bzr revno"}

Are you sure that having these overrides is a good idea?  Your followup
patch pretty much proves that every ebuild redefining them would get
broken by switch to breezy.

> +
> +# @ECLASS-VARIABLE: EBZR_OPTIONS
> +# @DEFAULT_UNSET
> +# @DESCRIPTION:
> +# The options passed to the fetch and update commands.

Is this intended to be set by ebuild or by user?

> +
> +# @ECLASS-VARIABLE: EBZR_REPO_URI
> +# @DEFAULT_UNSET
> +# @REQUIRED
> +# @DESCRIPTION:
> +# The repository URI for the source package.
> +#
> +# Note: If the ebuild uses an sftp:// URI, then the eclass will depend
> +# on dev-vcs/bzr[sftp].
> +
> +# @ECLASS-VARIABLE: EBZR_INITIAL_URI
> +# @DEFAULT_UNSET
> +# @DESCRIPTION:
> +# The URI used for initial branching of the source repository.  If this
> +# variable is set, the initial branch will be cloned from the location
> +# specified, followed by a pull from ${EBZR_REPO_URI}.  This is intended
> +# for special cases, e.g. when download from the original repository is
> +# slow, but a fast mirror exists but may be out of date.
> +#
> +# Normally, this variable needs not be set.
> +
> +# @ECLASS-VARIABLE: EBZR_PROJECT
> +# @DESCRIPTION:
> +# The project name of your ebuild.  Normally, the branch will be stored
> +# in the ${EBZR_STORE_DIR}/${EBZR_PROJECT} directory.
> +#
> +# If EBZR_BRANCH is set (see below), then a shared repository will be
> +# created in that directory, and the branch will be located in
> +# ${EBZR_STORE_DIR}/${EBZR_PROJECT}/${EBZR_BRANCH}.
> +: ${EBZR_PROJECT:=${PN}}
> +
> +# @ECLASS-VARIABLE: EBZR_BRANCH
> +# @DEFAULT_UNSET
> +# @DESCRIPTION:
> +# The directory where to store the branch within a shared repository,
> +# relative to ${EBZR_STORE_DIR}/${EBZR_PROJECT}.
> +#
> +# This variable should be set if there are several live ebuilds for
> +# different branches of the same upstream project.  The branches can
> +# then share the