Re: [gentoo-dev] Re: [PATCH 1/1] edo.eclass: add new eclass

2022-04-16 Thread Ulrich Mueller
> On Sat, 16 Apr 2022, Florian Schmaus wrote: >> edobe() { > nit: I'd personally would use 'edob', as shorter is sometimes better > plus every begin needs an end, so no need to explicitly state that > there is an end. It's even more obscure as a name however. :) >> ebegin "Running $@"

Re: [gentoo-dev] Re: [PATCH 1/1] edo.eclass: add new eclass

2022-04-16 Thread Ionen Wolkens
On Sat, Apr 16, 2022 at 06:48:56AM -0400, Ionen Wolkens wrote: > On Sat, Apr 16, 2022 at 12:23:18PM +0200, Florian Schmaus wrote: > > > ebegin "Running $@" > > > "$@" > > > eend $? || die -n "$@ failed" > return $? > > > > I think this return statement can be omitted since it

Re: [gentoo-dev] Re: [PATCH 1/1] edo.eclass: add new eclass

2022-04-16 Thread Ionen Wolkens
On Sat, Apr 16, 2022 at 12:23:18PM +0200, Florian Schmaus wrote: > > ebegin "Running $@" > > "$@" > > eend $? || die -n "$@ failed" > return $? > > I think this return statement can be omitted since it will always be > invoked with 0 as argument, and this is the default

Re: [gentoo-dev] Re: [PATCH 1/1] edo.eclass: add new eclass

2022-04-16 Thread Florian Schmaus
On 16/04/2022 10.38, Ulrich Mueller wrote: On Sat, 16 Apr 2022, Sam James wrote: +# @FUNCTION: edo Just a remark: A similar command existed a long time ago under the name "try". [1] It was executed under "env" [2], should we also do that? +# @USAGE: command [arg1 [arg2 ...]] should be