Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-emulation/xen: ChangeLog xen-3.1.1.ebuild

2007-10-30 Thread Mike Frysinger
On Monday 15 October 2007, Donnie Berkholz wrote:
 On 18:33 Mon 15 Oct , Micheal Marineau (marineam) wrote:
  1.1  app-emulation/xen/xen-3.1.1.ebuild
 
  file :
  http://sources.gentoo.org/viewcvs.py/gentoo-x86/app-emulation/xen/xen-3.1
 .1.ebuild?rev=1.1view=markup plain:
  http://sources.gentoo.org/viewcvs.py/gentoo-x86/app-emulation/xen/xen-3.1
 .1.ebuild?rev=1.1content-type=text/plain
 
  src_compile() {
  local myopt
  use debug  myopt=${myopt} debug=y
  use pae  myopt=${myopt} pae=y
 
  if use custom-cflags; then
  filter-flags -fPIE -fstack-protector
  else
  unset CFLAGS
  fi
 
  # Send raw LDFLAGS so that --as-needed works
  emake LDFLAGS=$(raw-ldflags) -C xen ${myopt} || die compile failed
  }
 
  src_install() {
  local myopt
  use debug  myopt=${myopt} debug=y
  use pae  myopt=${myopt} pae=y

 The environment should be preserved across phases, so you shouldn't have
 to repeat this stuff.

myopt is declared local
-mike


signature.asc
Description: This is a digitally signed message part.


Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-emulation/xen: ChangeLog xen-3.1.1.ebuild

2007-10-30 Thread Mike Frysinger
On Wednesday 31 October 2007, Donnie Berkholz wrote:
 On 00:31 Wed 31 Oct , Mike Frysinger wrote:
  On Monday 15 October 2007, Donnie Berkholz wrote:
   On 18:33 Mon 15 Oct , Micheal Marineau (marineam) wrote:
1.1  app-emulation/xen/xen-3.1.1.ebuild
   
file :
http://sources.gentoo.org/viewcvs.py/gentoo-x86/app-emulation/xen/xen
   -3.1 .1.ebuild?rev=1.1view=markup plain:
http://sources.gentoo.org/viewcvs.py/gentoo-x86/app-emulation/xen/xen
   -3.1 .1.ebuild?rev=1.1content-type=text/plain
   
src_compile() {
local myopt
use debug  myopt=${myopt} debug=y
use pae  myopt=${myopt} pae=y
   
if use custom-cflags; then
filter-flags -fPIE -fstack-protector
else
unset CFLAGS
fi
   
# Send raw LDFLAGS so that --as-needed works
emake LDFLAGS=$(raw-ldflags) -C xen ${myopt} || die compile
failed }
   
src_install() {
local myopt
use debug  myopt=${myopt} debug=y
use pae  myopt=${myopt} pae=y
  
   The environment should be preserved across phases, so you shouldn't
   have to repeat this stuff.
 
  myopt is declared local

 Sure, but did you notice it's set to the exact thing in both phases?
 Seems a bit pointless.

i'm not disagreeing on that point, just that myopt is not currently part of 
the environment so it wont be preserved ;)
-mike


signature.asc
Description: This is a digitally signed message part.


Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-emulation/xen: ChangeLog xen-3.1.1.ebuild

2007-10-30 Thread Donnie Berkholz
On 00:31 Wed 31 Oct , Mike Frysinger wrote:
 On Monday 15 October 2007, Donnie Berkholz wrote:
  On 18:33 Mon 15 Oct , Micheal Marineau (marineam) wrote:
   1.1  app-emulation/xen/xen-3.1.1.ebuild
  
   file :
   http://sources.gentoo.org/viewcvs.py/gentoo-x86/app-emulation/xen/xen-3.1
  .1.ebuild?rev=1.1view=markup plain:
   http://sources.gentoo.org/viewcvs.py/gentoo-x86/app-emulation/xen/xen-3.1
  .1.ebuild?rev=1.1content-type=text/plain
  
   src_compile() {
 local myopt
 use debug  myopt=${myopt} debug=y
 use pae  myopt=${myopt} pae=y
  
 if use custom-cflags; then
 filter-flags -fPIE -fstack-protector
 else
 unset CFLAGS
 fi
  
 # Send raw LDFLAGS so that --as-needed works
 emake LDFLAGS=$(raw-ldflags) -C xen ${myopt} || die compile failed
   }
  
   src_install() {
 local myopt
 use debug  myopt=${myopt} debug=y
 use pae  myopt=${myopt} pae=y
 
  The environment should be preserved across phases, so you shouldn't have
  to repeat this stuff.
 
 myopt is declared local

Sure, but did you notice it's set to the exact thing in both phases? 
Seems a bit pointless.

Thanks,
Donnie
-- 
[EMAIL PROTECTED] mailing list