Re: [gentoo-user] avahi/mdns-nss and ipv4/ipv6 while pinging

2018-06-28 Thread Jeremi Piotrowski
On Fri, Jun 29, 2018 at 12:13:39AM +0200, tu...@posteo.de wrote: > On 06/28 09:04, Mick wrote: > > On Thursday, 28 June 2018 17:55:12 BST tu...@posteo.de wrote: > > > Hi, > > > > > > I am "dicovering" (what a great word :) the IP address of my Raspberry > > > Pi now via ahavi/nss-mdns. > > > > >

Re: [gentoo-user] crossdev arm-unknown-linux-gnu failed

2018-05-27 Thread Jeremi Piotrowski
On Sun, May 27, 2018 at 05:06:43AM +0200, tu...@posteo.de wrote: > Hi, > > too feed a STM32F103C8T6 MCU (Core-M3) with some code to execute, > I want a compiler. For that I did a > > crossdev arm-unknown-linux-gnu > > . That one failed to build (gcc, binytils seem to be ok). > That

Re: [gentoo-user] error while loading shared libraries: libstdc++.so.6:

2018-01-02 Thread Jeremi Piotrowski
On Tue, Jan 02, 2018 at 11:14:24AM -0700, the...@sys-concept.com wrote: > On 01/02/2018 11:01 AM, Mick wrote: > > > > This is a coincidence. Something *else* must have happened because > > untarring > > the brother archives did not interfere in any way with your @system > > packages. > > > >

Re: [gentoo-user] is multi-core really worth it?

2017-11-21 Thread Jeremi Piotrowski
On Wed, Nov 22, 2017 at 07:52:54AM +0100, Raffaele Belardi wrote: > Hi, > > rebuilding system and world with gcc-7.2.0 on a 6-core AMD CPU I have the > impression that > most of the ebuilds limit parallel builds to 1, 2 or 3 threads. I'm aware it > is only an > impression, I did not spend the

Re: [gentoo-user] Problems copmiling firefox 57.0 (linking phase)

2017-11-15 Thread Jeremi Piotrowski
On Thu, Nov 16, 2017 at 4:05 AM, wrote: > Hi, > > building firefox 57.0 failed on my system - it looks like > the last stage (linking) fails. > It doesn't fail at the last stage - that's just when the error is repeated after other parallel tasks in the pipeline are completed.

Re: [gentoo-user] Copying USB->USB: sync after every file

2017-01-23 Thread Jeremi Piotrowski
On Mon, Jan 23, 2017 at 04:50:33PM +0100, Frank Steinmetzger wrote: > > Can you give me a nudge? My sysctl.conf has only one active line besides > some netfilter stuff: > vm.swappiness = 1 > (This is an SSD, I don’t even have swap on this machine unless I know I > definitely need it temporarily)

Re: [gentoo-user] Is there a PowerShell package?

2016-11-13 Thread Jeremi Piotrowski
On Sat, Nov 12, 2016 at 11:20:06PM +0100, Bertram Scharpf wrote: > Hi, > > for a special job I need to do a piece of work in Microsofts > PowerShell, but I have no Windows machine running. I know > that there is a PowerShell for Linux because I have one > installed on a Ubuntu. Yet, I do not want

Re: [gentoo-user] Strive for zero swap usage?

2016-10-10 Thread Jeremi Piotrowski
On Thu, Oct 06, 2016 at 03:31:59PM -0700, Grant wrote: > > Does this look OK? It looks to me like heavy swapping in and out with > plenty of free memory (minus buffers/cache). > Have you looked at the _units_ displayed by vmstat and munin? You're looking at **kilobytes** being swapped and

Re: [gentoo-user] Bash failed to compile

2016-09-23 Thread Jeremi Piotrowski
On Fri, Sep 23, 2016 at 04:14:24AM +0200, meino.cra...@gmx.de wrote: > Hi, > > may be bash is missing a lib? > > /usr/lib64/libtinfo.so.5: error adding symbols: DSO missing from command line Nope, this is a well known class of build system bugs, we have a tracker for it in our bugzilla

Re: [gentoo-user] Re: help! IP blocking not working

2016-09-06 Thread Jeremi Piotrowski
On Tue, Sep 06, 2016 at 01:57:54PM -0700, Grant wrote: > > Hi, my site is being ravaged by an IP but dropping the IP via > > shorewall is seeming to have no effect. I'm using his IP from nginx > > logs. What you really need is to set up net-anlyzer/fail2ban and not do this kind of stuff

Re: [gentoo-user] Is there a reason why LLVM/Clang ebuilds don't support "mutislot"?

2016-08-29 Thread Jeremi Piotrowski
On Sun, Aug 28, 2016 at 11:58:03PM -0400, P Levine wrote: > Other distros like Ubuntu support the installation of multiple versions of > LLVM/Clang side by side. One of the things Clang is really good at is > support for the most recently approved upcoming features of the C++17 > standard. The

Re: [gentoo-user] Re: [was cross-compile attempt] 32bit chroot

2016-08-01 Thread Jeremi Piotrowski
On Mon, Aug 01, 2016 at 10:21:20PM +0100, Mick wrote: > > I think libreoffice, chromium and firefox will be compiled in a chroot from > now > on and then emerged as binaries. This is the difference for libreoffice: > > Sat Aug 29 06:09:09 2015 >>> app-office/libreoffice-4.4.4.3 >

Re: [gentoo-user] cross-compile attempt

2016-07-31 Thread Jeremi Piotrowski
On Sun, Jul 31, 2016 at 07:40:37PM +0100, Mick wrote: > > * ARCH is not set... Are you missing the '/usr/i686-pc-linux- > * gnu/etc/portage/make.profile' symlink? Is the symlink correct? Is your > * portage tree complete? > === > > As far as I can tell the link is there: > > # ls

Re: [gentoo-user] Re: Firefox 45.2.0 segfaulting

2016-07-16 Thread Jeremi Piotrowski
On Thu, 14 Jul 2016, Grant Edwards wrote: > > Same behavior with 47.0.1. Starting 47 in "safe mode" avoids the > problem, but starting 47 in normal mode with all extensions disabled > still crashes. > > I downgraded to 38.8, and everyting works fine again. > Are you running all of these test

Re: [gentoo-user] Install dkms: which package

2016-07-16 Thread Jeremi Piotrowski
On Sat, Jul 16, 2016 at 06:37:28AM -0300, Facundo Curti wrote: > > But how can I install the module without dkms? usually I make this > automatically with dkms :S Come on - the module has an install.sh script that installs it without dkms. $ cd /usr/src $ hg clone

Re: [gentoo-user] Gitlab experiences

2016-07-13 Thread Jeremi Piotrowski
On Wed, Jul 13, 2016 at 03:19:00PM +0200, Ralf wrote: > Hi James, > > On 07/13/16 14:44, James wrote: > > > > Has anyone attempted to install a self hosted gitlab on gentoo server(s)? > > A small gentoo cluster/container setup? Using a Distributed File System, > > like cephfs, orangefs or other

Re: [gentoo-user] booting - I don't anystand how the (Linux) world works anymore

2016-06-25 Thread Jeremi Piotrowski
On Sat, Jun 25, 2016 at 08:33:31PM +0200, Helmut Jarausch wrote: > > So, I came up withroot=UUID=uuid_number of the root file system. > > But to my surprise I now got a kernel panic > syncing: VFS: unable to mount root fs on unknown block(0,0) > > So, please tell me what I'm missing?

Re: [gentoo-user] NVMe drive and grub

2016-04-07 Thread Jeremi Piotrowski
On Thu, Apr 7, 2016 at 5:24 PM, wrote: > Hello list, > > I have a new box with an NVMe SSD drive attached to the PCI bus via an M.2 > interface. The drive shows up as /dev/nvme0n1, with partitions > /dev/nvme0n1p1, /dev/nvme0n1p2, ... > > After following the instructions

Re: [gentoo-user] Can't get any boot method working

2016-03-25 Thread Jeremi Piotrowski
On Fri, Mar 25, 2016 at 04:31:11PM +, Dan Douglas wrote: > > grub2-mkconfig generates no menu entries. Do I need anything generated > by /etc/grub.d/00_header? That output looks like garbage. > You are better off not removing the header. Are you running grub2-mkconfig from the chroot? The

Re: [gentoo-user] Re: openssl upgrade may miss some needed rebuilds

2016-03-02 Thread Jeremi Piotrowski
On Wed, Mar 2, 2016 at 6:54 PM, Rich Freeman wrote: > Upstream really dropped the ball on this. When I'm updating packages > I certainly don't carefully review all their ABIs and SONAMEs. > Without some kind of automatic QA tool it would be a pretty big > undertaking. I might

Re: [gentoo-user] vdpau with intel video card

2016-03-01 Thread Jeremi Piotrowski
On Tue, Mar 01, 2016 at 09:08:45AM +0300, Ярослав wrote: > upgrading packeges all libs from /usr/lib64/vdpau got > deleted, except for libvdpau_trace.so. So I still didn't > get the libvdpau_i965.so. > There is no libvdapu_965.so. On Tue, Mar 01, 2016 at 09:52:57AM -0600, Corbin wrote: >

Re: [gentoo-user] Re: Java 8 and remote access

2016-01-31 Thread Jeremi Piotrowski
On Sun, Jan 31, 2016 at 1:02 AM, Grant wrote: >> I need to run a Java 8 app remotely. Can this be done on Gentoo? > > > Actually I could run the app locally if there is a good way to run > relatively untrusted Java apps. Otherwise I should run it remotely. > What exactly

Re: [gentoo-user] Re: Java 8 and remote access

2016-01-31 Thread Jeremi Piotrowski
On Sun, Jan 31, 2016 at 12:31:51PM +0100, Jeremi Piotrowski wrote: > On Sun, Jan 31, 2016 at 1:02 AM, Grant <emailgr...@gmail.com> wrote: > >> I need to run a Java 8 app remotely. Can this be done on Gentoo? > > > > > > Actually I could run the app l

Re: [gentoo-user] emerging with distcc: What's taking so long?

2016-01-05 Thread Jeremi Piotrowski
On Tue, Jan 5, 2016 at 12:49 PM, lee wrote: > The gui monitor doesn't seem to exist. Recompile distcc with the gtk use flag.

Re: [gentoo-user] Re: Full system encryption on Gentoo

2015-12-31 Thread Jeremi Piotrowski
On Thu, Dec 31, 2015 at 10:38:45AM +1000, Hans wrote: > I have a working VM with Gentoo on LVM on top of LUKS. Works fine in > change root, Just can't get it to boot. Probably somewhere missed > something. Will start from scratch using your 10 steps with dracut > instead of genkernel. I just

Re: [gentoo-user] Re: Full system encryption on Gentoo

2015-12-31 Thread Jeremi Piotrowski
On Thu, Dec 31, 2015 at 02:49:42PM +0100, Jeremi Piotrowski wrote: > I just tried the steps and indeed I forgot to mention a couple of things. And one more: don't format the full disk as luks, because there won't be any space for grub and grub2-install will error out. Make a single partit

[gentoo-user] Re: Full system encryption on Gentoo

2015-12-30 Thread Jeremi Piotrowski
On Thu, Dec 31, 2015 at 07:45:29AM +1000, Hans wrote: > I can't follow Sakaki's_EFI_Install_Guide. The system will run in > VirtualBox and only have BIOS. No UEFI, EFI, USB stick as boot or key disk. You should still atleast read the guide to figure out how to get the encryption part right. You

Re: [gentoo-user] dcron problem on new install

2015-11-26 Thread Jeremi Piotrowski
On Wed, Nov 25, 2015 at 10:29:52PM -0500, waltd...@waltdnes.org wrote: > I'm getting a bunch of messages like... > > > Subject: cron for user root root[ ! -x /etc/cron.hourly/0anacron ] > > && { test -x /usr/sbin/run-crons && /usr/sbin/run-crons ; } > > > > /bin/sh: root: command not

Re: [gentoo-user] PPC64 on IBM Power8

2015-11-23 Thread Jeremi Piotrowski
On Mon, Nov 23, 2015 at 03:08:26PM +0100, luciano mannucci wrote: > Now I'm wondering: should I try to build everithing from there, or is > it possible to get a more recent install version for the ppc64 > architecture? The install medium has almost zero effect on what ends up in the installed

Re: [gentoo-user] This is what I get for trying...

2015-11-19 Thread Jeremi Piotrowski
On Thu, Nov 19, 2015 at 10:17:03AM -0500, Alan Grimes wrote: > Naturally, the instructions on the gentoo wiki FAIL > > https://wiki.gentoo.org/wiki/Basic_guide_to_write_Gentoo_Ebuilds > > > atg@tortoise ~/archive $ ebuild seamonkey-2.35.ebuild clean merge >

Re: [gentoo-user] Making sense of reported ZFS disk usage

2015-10-31 Thread Jeremi Piotrowski
On Sat, Oct 31, 2015 at 10:37:55AM +0100, Remy Blank wrote: > I'm trying to make sense of the disk usage reported by "zfs list". > Here's what I get: > > $ zfs list \ > -o name,used,avail,refer,usedbydataset,usedbychildren,usedbysnapshots \ > -t all > > NAME USED AVAIL REFER

Re: [gentoo-user] kernel panick in 4.2.1 from gentoo-sources

2015-10-08 Thread Jeremi Piotrowski
On Wed, Oct 07, 2015 at 10:12:28PM -0400, cov...@ccs.covici.com wrote: > > Do you bother with the gentoo patches? Only the Kconfig patch that gives quick access to gentoo required configs is really useful, the rest I would call minor. If you copy your config from gentoo-sources to the git tree,

Re: [gentoo-user] clean-up root partition

2015-10-01 Thread Jeremi Piotrowski
On Thu, 1 Oct 2015, Philip Webb wrote: > 151001 the...@sys-concept.com wrote: > > How do you folks clean-up root partition, I have too much junk in there. > > df -h > > Filesystem Size Used Avail Use% Mounted on > > /dev/sda374G 61G 9.3G 87% / > > I've already removed all

Re: [gentoo-user] Re: new computer : any advice ?

2015-09-09 Thread Jeremi Piotrowski
On Wed, 9 Sep 2015, Stefan G. Weichinger wrote: > On 09.09.2015 20:01, Stefan G. Weichinger wrote: > > Digging up that thread now somewhere ... > > Ah, I even participated then ;-) > > AFAI understand gcc-5 should compile faster? > And generate faster code in some cases? No, and yes. Compilation

Re: [gentoo-user] Re: Portage is proposing an ncurses update and I don't understand what it means

2015-09-02 Thread Jeremi Piotrowski
On Wed, 2 Sep 2015, walt wrote: > qlop shows that both updates completed, but eix shows that I now have > only ncurses-5.9-r5 installed. (This is apparently the desired > result, but I'm only guessing what the desired result really is.) The desired output depends on what other packages you

Re: [gentoo-user] Re: a few blockers I can't figure out

2015-09-02 Thread Jeremi Piotrowski
On Wed, 2 Sep 2015, walt wrote: > Thank you. I've been running systemd for months and this is the first > time I've heard about systemd profiles. I'm not using either gnome or > kde, so should I use default/linux/amd64/13.0/systemd, which doesn't > seem to care if I'm running a desktop machine

Re: [gentoo-user] a few blockers I can't figure out

2015-08-31 Thread Jeremi Piotrowski
On Mon, 31 Aug 2015, cov...@ccs.covici.com wrote: [snip] > Just to let you know, most of the python entries were mandated by > portage, certainly the systemd one. > emerge --info > Portage 2.2.20.1 (python 2.7.10-final-0, > default/linux/amd64/13.0/desktop/gnome, gcc-4.9.3, glibc-2.21-r1, >

Re: [gentoo-user] Grub1: Cant ? Re: keeping grub 1

2015-08-28 Thread Jeremi Piotrowski
On Thursday, August 27, 2015 9:25:01 PM Michel Catudal wrote: This is nonsense. I have never had a case where it would not boot when I have grub correctly installed on the partition. This hasn't happened to you so it obviously means it isn't possible... On Fri, 28 Aug 2015, Michel

Re: [gentoo-user] Re: Grub1: Cant ? Re: keeping grub 1

2015-08-27 Thread Jeremi Piotrowski
On Thu, 27 Aug 2015, Fernando Rodriguez wrote: I use GRUB2 because my efi firmware (like most) is really buggy. Changing the boot order doesn't work at all (neither on the menu nor through efibootmgr), so I have to delete and recreate the entries in the right order. What I did is create 2 efi

Re: [gentoo-user] Re: Grub1: Cant ? Re: keeping grub 1

2015-08-27 Thread Jeremi Piotrowski
On Thu, 27 Aug 2015, Neil Bothwick wrote: On Thu, 27 Aug 2015 14:19:29 + (UTC), Grant Edwards wrote: For those of us with multiple Linux installations on a disk, that's a pretty big reason to stick with grub-legacy. Actually, that's a good scenario for GRUB2. grub2-mkconfig can

Re: [gentoo-user] Grub1: Cant ? Re: keeping grub 1

2015-08-27 Thread Jeremi Piotrowski
On Fri, 28 Aug 2015, Michel Catudal wrote: No one is asking them to do that. As mentioned before it works with some override. A solution to the problem would be to remove the arrogance toward people who want grub on a partition and remove the part in the installer that refuses to install it

Re: [gentoo-user] Re: Grub1: Cant ? Re: keeping grub 1

2015-08-26 Thread Jeremi Piotrowski
On Wed, 26 Aug 2015, Alec Ten Harmsel wrote: The main benefit is reduced compile times for some packages since I only compile the 64-bit versions, less stuff on the filesystem, etc. If you do not run any applications that use a 32-bit version of a library, that library is taking up disk space

Re: [gentoo-user] Gentoo on a Lenovo X1 Carbon (3rd gen)

2015-08-26 Thread Jeremi Piotrowski
On Wed, Aug 26, 2015 at 10:06 AM, Ralf ralf+gen...@ramses-pyramidenbau.de wrote: To answer my own question: After a lot of diffing and searching, I was able to find out, that these were the modules that I was missing: CONFIG_TCG_TPM=y CONFIG_TCG_TIS=y Are you actually using the TPM? This

Re: [gentoo-user] Re: emerge world looking grim

2015-08-25 Thread Jeremi Piotrowski
On Wed, Aug 26, 2015 at 12:10 AM, Harry Putnam rea...@newsguy.com wrote: The only thing I can say on my own behalf is that there was once a time when it wasn't so far fetched to start emerge -vC 'ing stuff. Many thing's can be removed with `emerge -C` and recovered from, but I doubt unmerging

Re: [gentoo-user] Gentoo on a Lenovo X1 Carbon (3rd gen)

2015-08-25 Thread Jeremi Piotrowski
I have a T440s and would expect the two to be quite similar from an ACPI point of view, so let's see if I can help. On Tue, 25 Aug 2015, Ralf wrote: It doesn't come back from standby. After closing the lid, the standby LED starts breathing, opening the lid doesn't change anything, even

Re: [gentoo-user] Snort compiling problems

2015-08-24 Thread Jeremi Piotrowski
On Mon, Aug 24, 2015 at 12:38 PM, Rod r...@rods.id.au wrote: USE=-* ... I have not been following this thread but why do you have this setting? # grep snort /etc/portage/package.use net-analyser/snort active-response flexresp3 gre mpls That's a typo in the category

Re: [gentoo-user] Re: emerge world looking grim

2015-08-24 Thread Jeremi Piotrowski
On Mon, 24 Aug 2015, Alan McKinnon wrote: Or you can get a binary package from anywhere else you trust. My personal favourite: chroot into a stage3 and quickpkg gcc. Then copy to your install and voila.

Re: [gentoo-user] Re: [WAS: keyboard stops working] Recent kernels block the loading of non-GPL kernel modules

2015-08-19 Thread Jeremi Piotrowski
On Wed, 19 Aug 2015, Rich Freeman wrote: It sounds like you not only expect them to comply with the license, but also with the kernel devs personal interpretation of copyright law. What is a license but a statement of the intent of the authors as to what can and can't be done with their work?

Re: [gentoo-user] how to get a couple of -9999 packages to behave

2015-08-19 Thread Jeremi Piotrowski
On Wed, 19 Aug 2015, cov...@ccs.covici.com wrote: Well, I would be willing to do that, but the only difference between the .999 ones and the regular ones is that the . ones inherit virtualx and they have the following inherit eutils gnome2 multilib-minimal virtualx if [[ ${PV} = ]];

Re: [gentoo-user] Re: !!!!

2015-08-19 Thread Jeremi Piotrowski
On Wed, 19 Aug 2015, Alan McKinnon wrote: On 19/08/2015 21:58, Alec Ten Harmsel wrote: On Wed, Aug 19, 2015 at 08:55:16PM +0100, Mick wrote: On Wednesday 19 Aug 2015 10:28:48 Jeremi Piotrowski wrote: Smart live rebuild only deals with live ebuilds. How would it help in this case

Re: [gentoo-user] how to get a couple of -9999 packages to behave

2015-08-19 Thread Jeremi Piotrowski
On Wed, 19 Aug 2015, cov...@ccs.covici.com wrote: So do I file a bug on bgo, or is there some other way I should contact the gnome overlay maintainers/? I think the easiest way would be to report throught the #gentoo-desktop IRC channel. They might tell you to go to the bugzilla.

Re: [gentoo-user] Re: [WAS: keyboard stops working] Recent kernels block the loading of non-GPL kernel modules

2015-08-19 Thread Jeremi Piotrowski
On Wed, 19 Aug 2015, Rich Freeman wrote: On Wed, Aug 19, 2015 at 8:31 AM, Jeremi Piotrowski jeremi.piotrow...@gmail.com wrote: On Wed, 19 Aug 2015, Rich Freeman wrote: It sounds like you not only expect them to comply with the license, but also with the kernel devs personal

Re: [gentoo-user] Re: !!!!

2015-08-19 Thread Jeremi Piotrowski
On Tue, 18 Aug 2015, John Campbell wrote: On 08/18/2015 06:38 PM, walt wrote: On Tue, 18 Aug 2015 18:03:31 -0700 John Campbell jdc@cox.net wrote: I haven't really been following this closely but I haven't seen any suggestion to use emerge -1 --quiet=y smart-live-rebuild to remove

Re: [gentoo-user] Re: [WAS: keyboard stops working] Recent kernels block the loading of non-GPL kernel modules

2015-08-19 Thread Jeremi Piotrowski
On Tue, 18 Aug 2015, Dale wrote: I did some searching based on the config option you gave and I'm unable to find a way to override this myself. It doesn't seem to be a setting I can put in make.conf or package.use etc either. If this is the case, I may wish Nvidia would switch to open

Re: [gentoo-user] how to get a couple of -9999 packages to behave

2015-08-18 Thread Jeremi Piotrowski
/usr/lib64/pkgconfig/atk-bridge.2.0.pc is part of at-spi2-atk which comes as a dependency of gtk+[X]. So you need at-spi2-atk[abi_x86_32] which should be pulled in by gtk+[abi_x86_32]. emerge @preserved-rebuild, make sure all flag changes are applied (emerge --changed-use --deep @world) and

Re: [gentoo-user] how to get a couple of -9999 packages to behave

2015-08-18 Thread Jeremi Piotrowski
On Tue, 18 Aug 2015, cov...@ccs.covici.com wrote: OK, I have the following in /etc/portage/package.use app-accessibility/at-spi2-atk abi_x86_32 app-accessibility/at-spi2-core abi_x86_32 Can you verify that these are being picked up properly by running emerge -av at-spi2-atk at-spi2-core

Re: [gentoo-user] Re: !!!!

2015-08-18 Thread Jeremi Piotrowski
On Tue, 18 Aug 2015, Dale wrote: Grant Edwards wrote: On 2015-08-18, Dale rdalek1...@gmail.com wrote: I don't have any libtinfo.whatever on any of my systems either. By default, I don't think a separate libtinfo is built. One suggestion I saw for this problem (on a different distro) is

Re: [gentoo-user] UEFI booting

2015-08-17 Thread Jeremi Piotrowski
On Mon, 17 Aug 2015, Rod wrote: Hi list, Hi I'm trying to figure out how to make my boot partition to boot from UEFI, I have grub2 installed, but I keep getting a error when I ask it to install the boot information. First things first, are you installing gentoo from an UEFI booted

Re: [gentoo-user] installation failure

2015-08-17 Thread Jeremi Piotrowski
On Mon, 17 Aug 2015, jfmxl wrote: but no joy. When I rebooted the machine I saw the grub and a bunch of initializations whizzed by ... but the kernel failed to mount root. Sounds pretty much like grub is passing the wrong root parameter. I opened a shell and looked at /etc/fstab, but found a

Re: [gentoo-user] Install PreQualifying Matrix

2015-08-17 Thread Jeremi Piotrowski
On Mon, 17 Aug 2015, James wrote: So another day, another borked set of installs. You are aware that for every failed install that comes to this mailing lists there are countless that go just fine, right? Planning questions are an OK-ish idea, but I surely wouldn't link to derivative

Re: [gentoo-user] Installing BTRFS on MBR with OpenRC

2015-08-14 Thread Jeremi Piotrowski
On Fri, 14 Aug 2015, Peter Humphrey wrote: I have now followed Rich's procedure to build the VM, and it does boot - once! After that, on every boot it complains failed to read the system array and Any idea what you did between the first boot and the second one? An internet search

Re: [gentoo-user] Re: Virtualbox-5.0.0 [wow!]

2015-08-12 Thread Jeremi Piotrowski
On Sat, 18 Jul 2015, Fernando Rodriguez wrote: And it works fine with 4.2.0-rc2 for me. Did you remember to re-emerge app- emulation/virtualbox-modules (after setting the /usr/src/linux symlink to the new kernel source)? So it seems I wasn't the only one with the problem on 4.2 (linux):

Re: [gentoo-user] why --noclear not set on tty1 in default /etc/inittab?

2015-08-11 Thread Jeremi Piotrowski
On Tue, 11 Aug 2015, Thanasis wrote: How do we enable logging to /var/log/rc.log ? /etc/rc.conf - rc_logger=YES and rc_log_path=/var/log/rc.log

Re: [gentoo-user] Re: Hubris?

2015-08-10 Thread Jeremi Piotrowski
Paul Tobias tobias.pal at gmail.com writes: It works, but a patched kernel is needed. Take a look at https://forums.gentoo.org/viewtopic-p-7275724.html The patch there was still working on the latest kernel a while ago. The patch from the forum thread does indeed work, and just reading it

Re: [gentoo-user] Hubris?

2015-08-09 Thread Jeremi Piotrowski
On Wed, Jul 29, 2015 at 12:53 PM, Bruce Schultz brul...@gmail.com wrote: On 29 July 2015 6:18:43 AM AEST, Neil Bothwick n...@digimed.co.uk wrote: On Wed, 29 Jul 2015 05:29:18 +1000, Bruce Schultz wrote: But I think you do if your btrfs is raid 1. The kernel can't mount multidisk btrfs until it

Re: [gentoo-user] Installing BTRFS on MBR with OpenRC

2015-08-06 Thread Jeremi Piotrowski
On Thu, 6 Aug 2015, Peter Humphrey wrote: First, btrfs balance. I had no idea that was needed, so of course I didn't include it in my attempts. Could that be why, on booting, the kernel couldn't mount the file system? I don't think that balancing an empty btrfs filesystem is necessary. It

Re: [gentoo-user] want to upgrade 50 month old installation

2015-08-04 Thread Jeremi Piotrowski
On Tue, 4 Aug 2015, Daniel Frey wrote: I found that I had to do it in little pieces at a time and portage got in my way constantly. I wish there was a setting to just forcibly compile a package and then manually deal with breakage afterward with something like revdep-rebuild, rather than

Re: [gentoo-user] New Firefox-38.1.0 headers, or is Google getting smarter?

2015-08-01 Thread Jeremi Piotrowski
On Sat, Aug 1, 2015 at 9:27 AM, Mick michaelkintz...@gmail.com wrote: I tried to connect using IMAP4 while overseas. So this tells me that Google are also logging the IP addresses I am connecting from and check my geographic location for aheam! security purposes. If you log into gmail, scroll

Re: [gentoo-user] Wifi: Hardware out of luck ?

2015-07-25 Thread Jeremi Piotrowski
On Sat, 25 Jul 2015, meino.cra...@gmx.de wrote: ...under which name/config option? If I grep through 4.1.3 sources I dont find anything, which is named 'mtu760*' or which contains that... You have the answer here: Mick michaelkintz...@gmail.com [15-07-25 15:12]: Which apparently was

Re: [gentoo-user] SOLVED xen hvm USE flag disabled (xen: How to enable a non-existant USE flag? (xen doesn't work))

2015-07-25 Thread Jeremi Piotrowski
On Wed, 15 Jul 2015, hw wrote: Hm, I'm not sure what to make of this bug. I switched profile to one that doesn't say 'no-multilib', and the flag became available. However, I could not compile xen-tools with hvm because stub-32.h was missing. FWIW, it is not enough to change the profile to

Re: [gentoo-user] Re: [~amd64] Does the EGL useflag break mesa-progs-8.2.0?

2015-07-23 Thread Jeremi Piotrowski
On Thu, 23 Jul 2015, walt wrote: Interesting. Maybe you could add some helpful ideas to this existing bug report: https://bugs.gentoo.org/show_bug.cgi?id=555186 Added what I found upstream, should be enough to get it to work. Alpine? I used Alpine a few years ago, but I thought UW had

Re: [gentoo-user] [~amd64] Does the EGL useflag break mesa-progs-8.2.0?

2015-07-23 Thread Jeremi Piotrowski
On Wed, Jul 15, 2015 at 01:53:50PM -0700, walt wrote: Just try emerging mesa-progs-8.2.0 with the EGL useflag set. Works fine here, compiles cleanly. This really requires atleast an 'emerge --info' to be able to tell more, but build logs may also be necessary. On Thu, 16 Jul 2015, wraeth

Re: [gentoo-user] gru2-mkconfig tries to read the extended partition ??

2015-07-23 Thread Jeremi Piotrowski
On Thu, 23 Jul 2015, Walter Dnes wrote: Here's my question to you... why should we junk software that works, i.e. it does what we need? I want a real reason. The fact that it's old is not a justification. Neither is teh shiney. This thread seems to prove that it doesn't just work and

Re: [gentoo-user] Re: Virtualbox-5.0.0 [wow!]

2015-07-19 Thread Jeremi Piotrowski
On Sat, 18 Jul 2015, Fernando Rodriguez wrote: Fullscreen works fine on kde and openbox. Works fine on fluxbox as will, but only with =virtualbox-4.3.30 (I'm using the binary package btw). I've had the sound problem with earlier versions and pulseaudio. IIRC I fixed it by tuning PA

Re: [gentoo-user] Re: Virtualbox-5.0.0 [wow!]

2015-07-17 Thread Jeremi Piotrowski
On Wed, 15 Jul 2015 19:43:05 -0400 Fernando Rodriguez frodriguez.develo...@outlook.com wrote: On Tuesday, July 14, 2015 6:53:43 PM walt wrote: I'd like to know if anyone else is seeing spectacular speed performance with vbox-5.0.0. No noticeable performance improvement for me using

Re: [gentoo-user] Getting rid of gcc-4.7.3...how?

2014-12-22 Thread Jeremi Piotrowski
On Sat, Dec 20, 2014 at 9:04 PM, meino.cra...@gmx.de wrote: Matti Nykyri matti.nyk...@iki.fi [14-12-20 19:48]: On Dec 20, 2014, at 17:56, meino.cra...@gmx.de wrote: Dale rdalek1...@gmail.com [14-12-20 02:47]: meino.cra...@gmx.de wrote: Dale rdalek1...@gmail.com [14-12-19 17:08]:

Re: [gentoo-user] No trace of installed simpleagenda

2013-12-23 Thread Jeremi Piotrowski
Does anybody know how one can start this extremely humble program Use equery f simpleagenda to find files installed by this package (equery is part of the gentoolkit package). Cheers