Re: [gentoo-user] Linux-4.16.* & NVidia

2018-04-18 Thread Elijah Mark Anderson
On Wednesday, April 18, 2018 7:57:20 AM CDT Mark Knecht wrote:
> On Tue, Apr 17, 2018 at 8:12 PM,   wrote:
> > On 04/17 08:19, davidroman96 wrote:
> >> Hi
> >> 
> >> 
> >> I also had problems with nvidia-drivers and linux-4.16.2, but in my case
> >> the drivers compiled well, but then Xorg was unable to load the nvidia
> >> module. With 4.15.15  it works correctly.
> >> 
> >> On 04/14/2018 08:28 PM, P Levine wrote:
> >> > On Sat, Apr 14, 2018 at 9:00 AM,  >> > 
> >> > >wrote:
> >> > Hi,
> >> > 
> >> > does anyone out there run a linux-4.16.*-kernel with
> >> > nvidia-drivers and has no problems?
> >> > 
> >> > Is so, I would be interested in the kernel configyration
> >> > and the version of the drivers used...
> >> > 
> >> > Thanks a lot for any help in advance!
> >> > Cheers!
> >> > Meino
> >> > 
> >> > Yes, gentoo-sources-4.16.0 and nvidia-drivers-390.48 with patch.from
> >> > https://bugs.gentoo.org/652476.
> > 
> > Hi,
> > 
> > same here...
> > 
> > Cheers!
> > Meino
> 
> Have any of you tried the 396 version? That's the one the web seems to
> say NVidia is targeting for this kernel.
> 
> Cheers,
> Mark

I'm running gentoo-sources-4.16.2 with nvidia-drivers-396.18-r1 on a GTX 660, 
without any patches. No issues here. 

-- 
Elijah Mark Anderson
m...@kd0bpv.name
--
「塵も積もれば山となる。」
"Even dust, when piled up, becomes a mountain" - Ancient Japanese proverb

signature.asc
Description: This is a digitally signed message part.


Re: [gentoo-user] Linux-4.16.* & NVidia

2018-04-18 Thread Mark Knecht
On Tue, Apr 17, 2018 at 8:12 PM,   wrote:
> On 04/17 08:19, davidroman96 wrote:
>> Hi
>>
>>
>> I also had problems with nvidia-drivers and linux-4.16.2, but in my case the
>> drivers compiled well, but then Xorg was unable to load the nvidia module.
>> With 4.15.15  it works correctly.
>>
>>
>>
>> On 04/14/2018 08:28 PM, P Levine wrote:
>> > On Sat, Apr 14, 2018 at 9:00 AM, > > >wrote:
>> >
>> > Hi,
>> >
>> > does anyone out there run a linux-4.16.*-kernel with
>> > nvidia-drivers and has no problems?
>> >
>> > Is so, I would be interested in the kernel configyration
>> > and the version of the drivers used...
>> >
>> > Thanks a lot for any help in advance!
>> > Cheers!
>> > Meino
>> >
>> >
>> >
>> >
>> > Yes, gentoo-sources-4.16.0 and nvidia-drivers-390.48 with patch.from
>> > https://bugs.gentoo.org/652476.
>> >
>>
>>
>
> Hi,
>
> same here...
>
> Cheers!
> Meino
>

Have any of you tried the 396 version? That's the one the web seems to
say NVidia is targeting for this kernel.

Cheers,
Mark



Re: [gentoo-user] Linux-4.16.* & NVidia

2018-04-17 Thread tuxic
On 04/17 08:19, davidroman96 wrote:
> Hi
> 
> 
> I also had problems with nvidia-drivers and linux-4.16.2, but in my case the
> drivers compiled well, but then Xorg was unable to load the nvidia module.
> With 4.15.15  it works correctly.
> 
> 
> 
> On 04/14/2018 08:28 PM, P Levine wrote:
> > On Sat, Apr 14, 2018 at 9:00 AM,  > >wrote:
> > 
> > Hi,
> > 
> > does anyone out there run a linux-4.16.*-kernel with
> > nvidia-drivers and has no problems?
> > 
> > Is so, I would be interested in the kernel configyration
> > and the version of the drivers used...
> > 
> > Thanks a lot for any help in advance!
> > Cheers!
> > Meino
> > 
> > 
> > 
> > 
> > ​Yes, gentoo-sources-4.16.0 and nvidia-drivers-390.48 with patch.​from
> > https://bugs.gentoo.org/652476.
> > 
> 
> 

Hi,

same here...

Cheers!
Meino



Re: [gentoo-user] Linux-4.16.* & NVidia

2018-04-17 Thread davidroman96

Hi


I also had problems with nvidia-drivers and linux-4.16.2, but in my case 
the drivers compiled well, but then Xorg was unable to load the nvidia 
module. With 4.15.15  it works correctly.




On 04/14/2018 08:28 PM, P Levine wrote:
On Sat, Apr 14, 2018 at 9:00 AM, >wrote:


Hi,

does anyone out there run a linux-4.16.*-kernel with
nvidia-drivers and has no problems?

Is so, I would be interested in the kernel configyration
and the version of the drivers used...

Thanks a lot for any help in advance!
Cheers!
Meino




​Yes, gentoo-sources-4.16.0 and nvidia-drivers-390.48 with patch.​from 
https://bugs.gentoo.org/652476.







Re: [gentoo-user] Linux-4.16.* & NVidia

2018-04-14 Thread tuxic
On 04/14 04:13, Elijah Mark Anderson wrote:
> On Saturday, April 14, 2018 8:00:17 AM CDT tu...@posteo.de wrote:
> > Hi,
> > 
> > does anyone out there run a linux-4.16.*-kernel with
> > nvidia-drivers and has no problems?
> > 
> > Is so, I would be interested in the kernel configyration
> > and the version of the drivers used...
> > 
> > Thanks a lot for any help in advance!
> > Cheers!
> > Meino
> 
> I'm running gentoo-sources-4.16.2 with nvidia-drivers-396.18-r1 on a GTX 660. 
> No issues here. I'll attach a copy of my kernel config for you. 
> 
> -- 
> Elijah Mark Anderson
> m...@kd0bpv.name
> --
> 「塵も積もれば山となる。」
> "Even dust, when piled up, becomes a mountain" - Ancient Japanese proverb

> #
> # Automatically generated file; DO NOT EDIT.
> # Linux/x86 4.16.2-gentoo Kernel Configuration
> #

... ... ...

> CONFIG_FONT_8x8=y
> CONFIG_FONT_8x16=y
> # CONFIG_SG_SPLIT is not set
> CONFIG_SG_POOL=y
> CONFIG_ARCH_HAS_SG_CHAIN=y
> CONFIG_ARCH_HAS_PMEM_API=y
> CONFIG_ARCH_HAS_UACCESS_FLUSHCACHE=y
> CONFIG_SBITMAP=y
> # CONFIG_STRING_SELFTEST is not set

Hi P and Elijah

Thanks a lot for your mails! This will definetly help here!
Preparing the next generation of stable versions is on its way ;) ;)
:)))

Have  a nice weekend!
Cheers!
Meino





Re: [gentoo-user] Linux-4.16.* & NVidia

2018-04-14 Thread Elijah Mark Anderson
On Saturday, April 14, 2018 8:00:17 AM CDT tu...@posteo.de wrote:
> Hi,
> 
> does anyone out there run a linux-4.16.*-kernel with
> nvidia-drivers and has no problems?
> 
> Is so, I would be interested in the kernel configyration
> and the version of the drivers used...
> 
> Thanks a lot for any help in advance!
> Cheers!
> Meino

I'm running gentoo-sources-4.16.2 with nvidia-drivers-396.18-r1 on a GTX 660. 
No issues here. I'll attach a copy of my kernel config for you. 

-- 
Elijah Mark Anderson
m...@kd0bpv.name
--
「塵も積もれば山となる。」
"Even dust, when piled up, becomes a mountain" - Ancient Japanese proverb#
# Automatically generated file; DO NOT EDIT.
# Linux/x86 4.16.2-gentoo Kernel Configuration
#

#
# Gentoo Linux
#
CONFIG_GENTOO_LINUX=y
CONFIG_GENTOO_LINUX_UDEV=y
CONFIG_GENTOO_LINUX_PORTAGE=y

#
# Support for init systems, system and service managers
#
CONFIG_GENTOO_LINUX_INIT_SCRIPT=y
# CONFIG_GENTOO_LINUX_INIT_SYSTEMD is not set
CONFIG_64BIT=y
CONFIG_X86_64=y
CONFIG_X86=y
CONFIG_INSTRUCTION_DECODER=y
CONFIG_OUTPUT_FORMAT="elf64-x86-64"
CONFIG_ARCH_DEFCONFIG="arch/x86/configs/x86_64_defconfig"
CONFIG_LOCKDEP_SUPPORT=y
CONFIG_STACKTRACE_SUPPORT=y
CONFIG_MMU=y
CONFIG_ARCH_MMAP_RND_BITS_MIN=28
CONFIG_ARCH_MMAP_RND_BITS_MAX=32
CONFIG_ARCH_MMAP_RND_COMPAT_BITS_MIN=8
CONFIG_ARCH_MMAP_RND_COMPAT_BITS_MAX=16
CONFIG_NEED_DMA_MAP_STATE=y
CONFIG_NEED_SG_DMA_LENGTH=y
CONFIG_GENERIC_ISA_DMA=y
CONFIG_GENERIC_BUG=y
CONFIG_GENERIC_BUG_RELATIVE_POINTERS=y
CONFIG_GENERIC_HWEIGHT=y
CONFIG_ARCH_MAY_HAVE_PC_FDC=y
CONFIG_RWSEM_XCHGADD_ALGORITHM=y
CONFIG_GENERIC_CALIBRATE_DELAY=y
CONFIG_ARCH_HAS_CPU_RELAX=y
CONFIG_ARCH_HAS_CACHE_LINE_SIZE=y
CONFIG_HAVE_SETUP_PER_CPU_AREA=y
CONFIG_NEED_PER_CPU_EMBED_FIRST_CHUNK=y
CONFIG_NEED_PER_CPU_PAGE_FIRST_CHUNK=y
CONFIG_ARCH_HIBERNATION_POSSIBLE=y
CONFIG_ARCH_SUSPEND_POSSIBLE=y
CONFIG_ARCH_WANT_HUGE_PMD_SHARE=y
CONFIG_ARCH_WANT_GENERAL_HUGETLB=y
CONFIG_ZONE_DMA32=y
CONFIG_AUDIT_ARCH=y
CONFIG_ARCH_SUPPORTS_OPTIMIZED_INLINING=y
CONFIG_ARCH_SUPPORTS_DEBUG_PAGEALLOC=y
CONFIG_HAVE_INTEL_TXT=y
CONFIG_X86_64_SMP=y
CONFIG_ARCH_SUPPORTS_UPROBES=y
CONFIG_FIX_EARLYCON_MEM=y
CONFIG_PGTABLE_LEVELS=4
CONFIG_IRQ_WORK=y
CONFIG_BUILDTIME_EXTABLE_SORT=y
CONFIG_THREAD_INFO_IN_TASK=y

#
# General setup
#
CONFIG_INIT_ENV_ARG_LIMIT=32
CONFIG_CROSS_COMPILE=""
# CONFIG_COMPILE_TEST is not set
CONFIG_LOCALVERSION=""
# CONFIG_LOCALVERSION_AUTO is not set
CONFIG_HAVE_KERNEL_GZIP=y
CONFIG_HAVE_KERNEL_BZIP2=y
CONFIG_HAVE_KERNEL_LZMA=y
CONFIG_HAVE_KERNEL_XZ=y
CONFIG_HAVE_KERNEL_LZO=y
CONFIG_HAVE_KERNEL_LZ4=y
CONFIG_KERNEL_GZIP=y
# CONFIG_KERNEL_BZIP2 is not set
# CONFIG_KERNEL_LZMA is not set
# CONFIG_KERNEL_XZ is not set
# CONFIG_KERNEL_LZO is not set
# CONFIG_KERNEL_LZ4 is not set
CONFIG_DEFAULT_HOSTNAME="(none)"
CONFIG_SWAP=y
CONFIG_SYSVIPC=y
CONFIG_SYSVIPC_SYSCTL=y
CONFIG_POSIX_MQUEUE=y
CONFIG_POSIX_MQUEUE_SYSCTL=y
CONFIG_CROSS_MEMORY_ATTACH=y
CONFIG_USELIB=y
CONFIG_AUDIT=y
CONFIG_HAVE_ARCH_AUDITSYSCALL=y
CONFIG_AUDITSYSCALL=y
CONFIG_AUDIT_WATCH=y
CONFIG_AUDIT_TREE=y

#
# IRQ subsystem
#
CONFIG_GENERIC_IRQ_PROBE=y
CONFIG_GENERIC_IRQ_SHOW=y
CONFIG_GENERIC_IRQ_EFFECTIVE_AFF_MASK=y
CONFIG_GENERIC_PENDING_IRQ=y
CONFIG_GENERIC_IRQ_MIGRATION=y
CONFIG_IRQ_DOMAIN=y
CONFIG_IRQ_DOMAIN_HIERARCHY=y
CONFIG_GENERIC_MSI_IRQ=y
CONFIG_GENERIC_MSI_IRQ_DOMAIN=y
CONFIG_GENERIC_IRQ_MATRIX_ALLOCATOR=y
CONFIG_GENERIC_IRQ_RESERVATION_MODE=y
CONFIG_IRQ_FORCED_THREADING=y
CONFIG_SPARSE_IRQ=y
# CONFIG_GENERIC_IRQ_DEBUGFS is not set
CONFIG_CLOCKSOURCE_WATCHDOG=y
CONFIG_ARCH_CLOCKSOURCE_DATA=y
CONFIG_CLOCKSOURCE_VALIDATE_LAST_CYCLE=y
CONFIG_GENERIC_TIME_VSYSCALL=y
CONFIG_GENERIC_CLOCKEVENTS=y
CONFIG_GENERIC_CLOCKEVENTS_BROADCAST=y
CONFIG_GENERIC_CLOCKEVENTS_MIN_ADJUST=y
CONFIG_GENERIC_CMOS_UPDATE=y

#
# Timers subsystem
#
CONFIG_TICK_ONESHOT=y
CONFIG_NO_HZ_COMMON=y
# CONFIG_HZ_PERIODIC is not set
CONFIG_NO_HZ_IDLE=y
# CONFIG_NO_HZ_FULL is not set
CONFIG_NO_HZ=y
CONFIG_HIGH_RES_TIMERS=y

#
# CPU/Task time and stats accounting
#
CONFIG_TICK_CPU_ACCOUNTING=y
# CONFIG_VIRT_CPU_ACCOUNTING_GEN is not set
# CONFIG_IRQ_TIME_ACCOUNTING is not set
CONFIG_BSD_PROCESS_ACCT=y
# CONFIG_BSD_PROCESS_ACCT_V3 is not set
CONFIG_TASKSTATS=y
CONFIG_TASK_DELAY_ACCT=y
CONFIG_TASK_XACCT=y
CONFIG_TASK_IO_ACCOUNTING=y
CONFIG_CPU_ISOLATION=y

#
# RCU Subsystem
#
CONFIG_PREEMPT_RCU=y
# CONFIG_RCU_EXPERT is not set
CONFIG_SRCU=y
CONFIG_TREE_SRCU=y
CONFIG_TASKS_RCU=y
CONFIG_RCU_STALL_COMMON=y
CONFIG_RCU_NEED_SEGCBLIST=y
# CONFIG_BUILD_BIN2C is not set
# CONFIG_IKCONFIG is not set
CONFIG_LOG_BUF_SHIFT=18
CONFIG_LOG_CPU_MAX_BUF_SHIFT=12
CONFIG_PRINTK_SAFE_LOG_BUF_SHIFT=13
CONFIG_HAVE_UNSTABLE_SCHED_CLOCK=y
CONFIG_ARCH_SUPPORTS_NUMA_BALANCING=y
CONFIG_ARCH_WANT_BATCHED_UNMAP_TLB_FLUSH=y
CONFIG_ARCH_SUPPORTS_INT128=y
# CONFIG_NUMA_BALANCING is not set
CONFIG_CGROUPS=y
# CONFIG_MEMCG is not set
# CONFIG_BLK_CGROUP is not set
CONFIG_CGROUP_SCHED=y
CONFIG_FAIR_GROUP_SCHED=y
# CONFIG_CFS_BANDWIDTH is not set
# CONFIG_RT_GROUP_SCHED is not set
# CONFIG_CGROUP_PIDS is not set
# 

Re: [gentoo-user] Linux-4.16.* & NVidia

2018-04-14 Thread P Levine
On Sat, Apr 14, 2018 at 9:00 AM,  wrote:

> Hi,
>
> does anyone out there run a linux-4.16.*-kernel with
> nvidia-drivers and has no problems?
>
> Is so, I would be interested in the kernel configyration
> and the version of the drivers used...
>
> Thanks a lot for any help in advance!
> Cheers!
> Meino
>
>
>
>
​Yes, gentoo-sources-4.16.0 and nvidia-drivers-390.48 with patch.​from
https://bugs.gentoo.org/652476.


Re: [gentoo-user] Linux-4.16.* & NVidia

2018-04-14 Thread tuxic
On 04/14 09:20, Rich Freeman wrote:
> On Sat, Apr 14, 2018 at 9:11 AM, András Csányi  wrote:
> > Stay at stable kernel version, imho. There are a few people here waiting for
> > nvidia with ~x86 flagged kernel.
> >
> 
> This is pretty much the reality of using any out-of-tree kernel
> module, and especially the case for a proprietary module like the
> nvidia drivers.  They're often not compatible across kernel 4.x
> version changes, and upstream projects often do not target mainline in
> their official releases.
> 
> IMO you're better off still sticking to longterm, such as 4.14.
> Otherwise you're still dealing with stable dropping support for your
> version but the out-of-kernel module takes a week to support the new
> version.  There isn't any overlap in linux stable support release
> across versions - they stop one and start the next.  Only the longterm
> releases get overlapping support windows.
> 
> 
> -- 
> Rich


Hi,

I jyst wanted to no, whether Yes or No.
The rest I will decide on myself,

So..."no" to summarize/ :)

Thanks for the help.
Cheers
Meino





Re: [gentoo-user] Linux-4.16.* & NVidia

2018-04-14 Thread Rich Freeman
On Sat, Apr 14, 2018 at 9:11 AM, András Csányi  wrote:
> Stay at stable kernel version, imho. There are a few people here waiting for
> nvidia with ~x86 flagged kernel.
>

This is pretty much the reality of using any out-of-tree kernel
module, and especially the case for a proprietary module like the
nvidia drivers.  They're often not compatible across kernel 4.x
version changes, and upstream projects often do not target mainline in
their official releases.

IMO you're better off still sticking to longterm, such as 4.14.
Otherwise you're still dealing with stable dropping support for your
version but the out-of-kernel module takes a week to support the new
version.  There isn't any overlap in linux stable support release
across versions - they stop one and start the next.  Only the longterm
releases get overlapping support windows.


-- 
Rich



Re: [gentoo-user] Linux-4.16.* & NVidia

2018-04-14 Thread András Csányi
Stay at stable kernel version, imho. There are a few people here waiting
for nvidia with ~x86 flagged kernel.

On 2018. Apr 14., Sat at 15:01,  wrote:

> Hi,
>
> does anyone out there run a linux-4.16.*-kernel with
> nvidia-drivers and has no problems?
>
> Is so, I would be interested in the kernel configyration
> and the version of the drivers used...
>
> Thanks a lot for any help in advance!
> Cheers!
> Meino
>
>
>
> --
- -
--  Csanyi Andras (Sayusi Ando)  -- http://sayusi.hu --
http://facebook.com/andras.csanyi
--  ""Trust in God and keep your gunpowder dry!" - Cromwell