Harald Welte has submitted this change and it was merged.

Change subject: Rename osmo_fsm to avoid illegal space in name + more 
meaningful name
......................................................................


Rename osmo_fsm to avoid illegal space in name + more meaningful name

A FSM doesn't need "FSM" in its name, as it is obvious that it is a
FSM.  Also, having two that are called RESET is confusing, so let's
try to come up with better names.

Also, after Change-Id I9ef59432f43a3cdb94e4cbb0c44ac3f9b2aac0f2 in
libosmocore, we now enforce that no FSM identifiers contain spaces
or other illegal characters.

Closes: OS#2593
Change-Id: I858a81b8a4e01b2e802e3159f2835e5ca515953d
---
M src/libcommon-cs/a_reset.c
1 file changed, 2 insertions(+), 2 deletions(-)

Approvals:
  dexter: Looks good to me, but someone else must approve
  Max: Looks good to me, but someone else must approve
  Harald Welte: Looks good to me, approved
  Jenkins Builder: Verified



diff --git a/src/libcommon-cs/a_reset.c b/src/libcommon-cs/a_reset.c
index 9a226ac..7dbd014 100644
--- a/src/libcommon-cs/a_reset.c
+++ b/src/libcommon-cs/a_reset.c
@@ -124,7 +124,7 @@
 
 /* State machine definition */
 static struct osmo_fsm fsm = {
-       .name = "FSM RESET",
+       .name = "A-RESET",
        .states = fsm_states,
        .num_states = ARRAY_SIZE(fsm_states),
        .log_subsys = DMSC,
@@ -149,7 +149,7 @@
        reset->cb = cb;
        strncpy(reset->name, name, sizeof(reset->name));
        reset->conn_loss_counter = 0;
-       reset->fsm = osmo_fsm_inst_alloc(&fsm, NULL, NULL, LOGL_DEBUG, "FSM 
RESET INST");
+       reset->fsm = osmo_fsm_inst_alloc(&fsm, NULL, NULL, LOGL_DEBUG, NULL);
        OSMO_ASSERT(reset->fsm);
        reset->fsm->priv = reset;
        LOGP(DMSC, LOGL_NOTICE, "(%s) reset handler fsm created.\n", 
reset->name);

-- 
To view, visit https://gerrit.osmocom.org/4406
To unsubscribe, visit https://gerrit.osmocom.org/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: I858a81b8a4e01b2e802e3159f2835e5ca515953d
Gerrit-PatchSet: 1
Gerrit-Project: osmo-msc
Gerrit-Branch: master
Gerrit-Owner: Harald Welte <lafo...@gnumonks.org>
Gerrit-Reviewer: Harald Welte <lafo...@gnumonks.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: Max <msur...@sysmocom.de>
Gerrit-Reviewer: dexter <pma...@sysmocom.de>

Reply via email to