[MERGED] libosmocore[master]: core/conv: do not mix up AVX and SSE code

2017-05-29 Thread Neels Hofmeyr
Neels Hofmeyr has submitted this change and it was merged. Change subject: core/conv: do not mix up AVX and SSE code .. core/conv: do not mix up AVX and SSE code According to GCC's wiki: If you specify command-line switches

libosmocore[master]: core/conv: do not mix up AVX and SSE code

2017-05-29 Thread Neels Hofmeyr
Patch Set 5: Verified+1 test run on osmo-gsm-tester was successful with this patch applied -- To view, visit https://gerrit.osmocom.org/2760 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I042cc76258df7e4c6c90a73af3d0a6e75999b2b0

libosmocore[master]: core/conv: do not mix up AVX and SSE code

2017-05-29 Thread Neels Hofmeyr
Patch Set 5: Code-Review+2 Since 34e228a9bcf3ac37287bb5e684ace46818740f3b ("core/conv: add x86 SSE support for Viterbi decoder") osmo-bts-trx threw a SIGILL on the osmo-gsm-tester main unit. With this patch applied, the problem is fixed. -- To view, visit https://gerrit.osmocom.org/2760 To

libosmocore[master]: core/conv: do not mix up AVX and SSE code

2017-05-29 Thread Max
Patch Set 5: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/2760 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I042cc76258df7e4c6c90a73af3d0a6e75999b2b0 Gerrit-PatchSet: 5 Gerrit-Project: libosmocore Gerrit-Branch: master

[PATCH] libosmocore[master]: core/conv: do not mix up AVX and SSE code

2017-05-29 Thread Vadim Yanitskiy
Hello Max, Jenkins Builder, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/2760 to look at the new patch set (#4). core/conv: do not mix up AVX and SSE code According to GCC's wiki: If you specify command-line switches such as -msse, the compiler could use

libosmocore[master]: core/conv: do not mix up AVX and SSE code

2017-05-29 Thread Max
Patch Set 3: Code-Review-1 (1 comment) In general, I'd prefer to avoid confusion with generated code which is in files ending with _gen.* as well. Calling it viterbi_generic.c would be much better. https://gerrit.osmocom.org/#/c/2760/3/src/viterbi_gen.c File src/viterbi_gen.c: Line 145: void

[PATCH] libosmocore[master]: core/conv: do not mix up AVX and SSE code

2017-05-28 Thread Vadim Yanitskiy
Hello Jenkins Builder, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/2760 to look at the new patch set (#3). core/conv: do not mix up AVX and SSE code According to GCC's wiki: If you specify command-line switches such as -msse, the compiler could use the

[PATCH] libosmocore[master]: core/conv: do not mix up AVX and SSE code

2017-05-28 Thread Vadim Yanitskiy
Hello Jenkins Builder, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/2760 to look at the new patch set (#2). core/conv: do not mix up AVX and SSE code According to GCC's wiki: If you specify command-line switches such as -msse, the compiler could use the

libosmocore[master]: core/conv: do not mix up AVX and SSE code

2017-05-28 Thread Vadim Yanitskiy
Patch Set 1: > Vadim, > > Is sse+avx code just a copy of the sse code? In this case we should > move it to an include file and then include into .c files to avoid > code duplication. Both files are almost the same, excluding the SSE_BROADCAST definition. Great idea with creating an include

libosmocore[master]: core/conv: do not mix up AVX and SSE code

2017-05-28 Thread Alexander Chemeris
Patch Set 1: Vadim, Is sse+avx code just a copy of the sse code? In this case we should move it to an include file and then include into .c files to avoid code duplication. -- To view, visit https://gerrit.osmocom.org/2760 To unsubscribe, visit https://gerrit.osmocom.org/settings

[PATCH] libosmocore[master]: core/conv: do not mix up AVX and SSE code

2017-05-28 Thread Vadim Yanitskiy
Review at https://gerrit.osmocom.org/2760 core/conv: do not mix up AVX and SSE code According to GCC's wiki: If you specify command-line switches such as -msse, the compiler could use the extended instruction sets even if the built-ins are not used explicitly in the program. For this reason,