[PATCH] osmo-trx[master]: sigProcLib: Rename demodulateBurst() to demodGmskBurst() for...

2017-03-20 Thread Alexander Chemeris
Hello Jenkins Builder, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/2137 to look at the new patch set (#2). sigProcLib: Rename demodulateBurst() to demodGmskBurst() for clarity. Change-Id: Ibcef8d7d4a2c06865bed7e4091ccc8dbbd494d77 --- M

[PATCH] osmo-trx[master]: CommonLibs: Print soft bits with less confidence to console ...

2017-03-20 Thread Alexander Chemeris
Review at https://gerrit.osmocom.org/2140 CommonLibs: Print soft bits with less confidence to console when printing a soft vector. We use other symbols to show that these bits has less confidence: o and . for 0 with less confidence | and ' for 1 with less confidence Change-Id:

[PATCH] osmo-trx[master]: BitVector: Remove convolutional codec - we don't use it in o...

2017-03-20 Thread Alexander Chemeris
Review at https://gerrit.osmocom.org/2141 BitVector: Remove convolutional codec - we don't use it in osmo-trx. Now we have more fexibility in how we represent SoftVector, since we no longer depend on the particular convolutional codec implementation. Change-Id:

[PATCH] osmo-trx[master]: BitVector: Convert SoftVector from 0..1 to -1..+1 soft bits.

2017-03-20 Thread Alexander Chemeris
Review at https://gerrit.osmocom.org/2142 BitVector: Convert SoftVector from 0..1 to -1..+1 soft bits. This makes code simpler and will allow us send -127..127 soft bits towards osmo-bts instead of 0..255 bits. Change-Id: I16ecc3d4c829dcf0f619ad995bc9d4a4ed8af0a4 --- M

[PATCH] osmo-trx[master]: sigProcLib: Rename demodulateBurst() to demodGmskBurst() for...

2017-03-20 Thread Alexander Chemeris
Review at https://gerrit.osmocom.org/2137 sigProcLib: Rename demodulateBurst() to demodGmskBurst() for clarity. Change-Id: Ibcef8d7d4a2c06865bed7e4091ccc8dbbd494d77 --- M Transceiver52M/sigProcLib.cpp M Transceiver52M/sigProcLib.h 2 files changed, 5 insertions(+), 5 deletions(-) git pull

[PATCH] osmo-trx[master]: sigProcLib: Slice SoftVector instead of signalVector for GMS...

2017-03-20 Thread Alexander Chemeris
Review at https://gerrit.osmocom.org/2138 sigProcLib: Slice SoftVector instead of signalVector for GMSK demod. This makes it similar to 8-PSK demod and also saves a bit of lines ofcode and should give us a tiny improvement in performance. Ideally we need to remove vector slicing at all,

[PATCH] osmo-trx[master]: sigProcLib: make energyDetect() simpler by returning actual ...

2017-03-20 Thread Alexander Chemeris
Review at https://gerrit.osmocom.org/2136 sigProcLib: make energyDetect() simpler by returning actual energy. Change-Id: I9bf97f2dc03fea9bebcf43198dfb05f6e4694e9c --- M Transceiver52M/Transceiver.cpp M Transceiver52M/sigProcLib.cpp M Transceiver52M/sigProcLib.h 3 files changed, 10

[PATCH] osmo-trx[master]: osmo-trx: Separate command line switch to enable EDGE filler.

2017-03-20 Thread Alexander Chemeris
Review at https://gerrit.osmocom.org/2143 osmo-trx: Separate command line switch to enable EDGE filler. Now -r comand line switch always enables GMSK filler even when EDGE mode is enabled with -e switch. If you want to enable EDGE filler, use -E switch. Change-Id:

libosmocore[master]: build: conv_gen.py: ensure parent dirs of written files exist

2017-03-20 Thread Neels Hofmeyr
Patch Set 2: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/2042 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: Ia4fba96dcf74a25cf3e515eb3e4f970e0c3cdd54 Gerrit-PatchSet: 2 Gerrit-Project: libosmocore Gerrit-Branch: master

libosmocore[master]: build: generate gsm0503.h to builddir, not srcdir

2017-03-20 Thread Neels Hofmeyr
Patch Set 7: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/1996 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: Ia773ef5893a2018feb416061aefcf51835df18d2 Gerrit-PatchSet: 7 Gerrit-Project: libosmocore Gerrit-Branch: master

[MERGED] libosmocore[master]: build: generate gsm0503.h to builddir, not srcdir

2017-03-20 Thread Neels Hofmeyr
Neels Hofmeyr has submitted this change and it was merged. Change subject: build: generate gsm0503.h to builddir, not srcdir .. build: generate gsm0503.h to builddir, not srcdir To ensure that a separate build dir keeps the

[MERGED] libosmocore[master]: build: coding/gsm0503: fix build in sep. dir: -I builddir

2017-03-20 Thread Neels Hofmeyr
Neels Hofmeyr has submitted this change and it was merged. Change subject: build: coding/gsm0503: fix build in sep. dir: -I builddir .. build: coding/gsm0503: fix build in sep. dir: -I builddir To allow building

osmo-trx[master]: buildenv: Split up SSE3 and SSE4.1 code

2017-03-20 Thread Max
Patch Set 1: Code-Review-1 AX_EXT is macro from autoconf-archive package - I think it's avery bad idea to supply our own modified copy: this means we'll have to track all upstream fixes manually. I think we should either move this code directly to configure.ac or add our own macro wrapping

openbsc[master]: twisted_ipa.py: make debug logging more robust

2017-03-20 Thread Neels Hofmeyr
Patch Set 2: Code-Review-1 it looks good at first, but what this patch does is it "degrades" all of the output to debug level. Before, some of the output could be switched off while other output remained. Would it make sense to maintain two distinct log levels? How is the __version__ change

[PATCH] openbsc[master]: twisted_ipa.py: make debug logging more robust

2017-03-20 Thread Max
Hello Neels Hofmeyr, Jenkins Builder, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/2133 to look at the new patch set (#3). twisted_ipa.py: make debug logging more robust Do not print anything to stdout directly - use proper logger object instead: either the

[PATCH] osmo-trx[master]: buildenv: Split up SSE3 and SSE4.1 code

2017-03-20 Thread dexter
Review at https://gerrit.osmocom.org/2134 buildenv: Split up SSE3 and SSE4.1 code Currently we find SSE3 and SSE4.1 code mixed togehter along with generic code in one file. This introduces the risk that the compiler exidantly mixes SSE4.1 instructions into an SSE3, or even worse into a generic

osmo-sim-auth[master]: cosmetic: add/tweak log output, add vim indenting marker

2017-03-20 Thread Max
Patch Set 1: Are we missing jenkins for this one? -- To view, visit https://gerrit.osmocom.org/2052 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: Ia2ac1215ae948558324627f76e28c72a23dc6a68 Gerrit-PatchSet: 1 Gerrit-Project:

[MERGED] openbsc[master]: bsc_/gprs_subscriber: fix: use osmo_strlcpy() to safely copy...

2017-03-20 Thread Neels Hofmeyr
Neels Hofmeyr has submitted this change and it was merged. Change subject: bsc_/gprs_subscriber: fix: use osmo_strlcpy() to safely copy IMSI .. bsc_/gprs_subscriber: fix: use osmo_strlcpy() to safely copy IMSI Fixes: coverity

openbsc[master]: python tests: allow running from separate build dir

2017-03-20 Thread Neels Hofmeyr
Patch Set 7: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/1906 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I2731f361e3b72d0980968e6cf83594ea450db7c2 Gerrit-PatchSet: 7 Gerrit-Project: openbsc Gerrit-Branch: master

[MERGED] openbsc[master]: python tests: allow running from separate build dir

2017-03-20 Thread Neels Hofmeyr
Neels Hofmeyr has submitted this change and it was merged. Change subject: python tests: allow running from separate build dir .. python tests: allow running from separate build dir The VTY tests assume that $top_builddir ==

osmo-sim-auth[master]: cosmetic: add/tweak log output, add vim indenting marker

2017-03-20 Thread Neels Hofmeyr
Patch Set 1: Verified+1 agreed :) -- To view, visit https://gerrit.osmocom.org/2052 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: Ia2ac1215ae948558324627f76e28c72a23dc6a68 Gerrit-PatchSet: 1 Gerrit-Project: osmo-sim-auth Gerrit-Branch:

osmo-trx[master]: CommonLibs: Remove unused files.

2017-03-20 Thread Tom Tsou
Patch Set 2: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/2125 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I2bfb45a1c7d01785bdb30204dba38c683a4288a9 Gerrit-PatchSet: 2 Gerrit-Project: osmo-trx Gerrit-Branch: master

[PATCH] openbsc[master]: twisted_ipa.py: bump version properly

2017-03-20 Thread Max
Review at https://gerrit.osmocom.org/2135 twisted_ipa.py: bump version properly Adjust version string to comply with PEP8 and PEP386. Change-Id: I44c8521f12e6432038998bfb1ac1bb37a1137787 Related: SYS#3028 --- M openbsc/contrib/twisted_ipa.py 1 file changed, 3 insertions(+), 1 deletion(-)

[PATCH] openbsc[master]: twisted_ipa.py: make debug logging more robust

2017-03-20 Thread Max
Hello Neels Hofmeyr, Jenkins Builder, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/2133 to look at the new patch set (#5). twisted_ipa.py: make debug logging more robust Do not print anything to stdout directly - use proper logger object instead: either the

[MERGED] libosmocore[master]: build: conv_gen.py: ensure parent dirs of written files exist

2017-03-20 Thread Neels Hofmeyr
Neels Hofmeyr has submitted this change and it was merged. Change subject: build: conv_gen.py: ensure parent dirs of written files exist .. build: conv_gen.py: ensure parent dirs of written files exist Previously, this would

osmo-hlr[master]: fix db_subscr_ps error handling

2017-03-20 Thread Neels Hofmeyr
Patch Set 2: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/2108 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I27e8b46915efd678c72138e250a9cbb4c9c8ac20 Gerrit-PatchSet: 2 Gerrit-Project: osmo-hlr Gerrit-Branch: master

[MERGED] libosmocore[master]: build: fix build dependencies for generated sources

2017-03-20 Thread Neels Hofmeyr
Neels Hofmeyr has submitted this change and it was merged. Change subject: build: fix build dependencies for generated sources .. build: fix build dependencies for generated sources Ensure that a changed conv_gen.py and/or

osmo-sim-auth[master]: cosmetic: add/tweak log output, add vim indenting marker

2017-03-20 Thread Neels Hofmeyr
Patch Set 1: yes. it's a python tool to connect to an actual sim card, so I'm not sure what a jenkins job could test here ... do a pyflakes test? so far I V+1 manually. -- To view, visit https://gerrit.osmocom.org/2052 To unsubscribe, visit https://gerrit.osmocom.org/settings

osmo-sim-auth[master]: cosmetic: add/tweak log output, add vim indenting marker

2017-03-20 Thread Max
Patch Set 1: Code-Review+1 Meh, pyflakes tends to print crapload of false-positives - manual verification is fine in this case. At least until osmo-gsm-tester got some sim cards on board ;-) -- To view, visit https://gerrit.osmocom.org/2052 To unsubscribe, visit

osmo-trx[master]: buildenv: Split up SSE3 and SSE4.1 code

2017-03-20 Thread Neels Hofmeyr
Patch Set 1: Code-Review-1 (3 comments) in OS#1869 there is mention of the 'attribute' based per-function cpu features, but I can't see them in this patch. I must apologize because I assumed you were aware of this way to solve, since Holger had already posted it a long time ago somewhere. I

[PATCH] openbsc[master]: twisted_ipa.py: make debug logging more robust

2017-03-20 Thread Max
Hello Neels Hofmeyr, Jenkins Builder, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/2133 to look at the new patch set (#4). twisted_ipa.py: make debug logging more robust Do not print anything to stdout directly - use proper logger object instead: either the

openbsc[master]: twisted_ipa.py: make debug logging more robust

2017-03-20 Thread Neels Hofmeyr
Patch Set 4: Code-Review+1 (1 comment) except... https://gerrit.osmocom.org/#/c/2133/4/openbsc/contrib/twisted_ipa.py File openbsc/contrib/twisted_ipa.py: Line 25: __version__ = "0.4" # bump this on every non-trivial change separate patch for this? -- To view, visit

[MERGED] osmo-trx[master]: sigProcLib: Typo sybols -> symbols

2017-03-20 Thread Alexander Chemeris
Alexander Chemeris has submitted this change and it was merged. Change subject: sigProcLib: Typo sybols -> symbols .. sigProcLib: Typo sybols -> symbols Change-Id: I8cbef852374d0458c4f4ad4be0df0aa998e3796a --- M

[MERGED] osmo-trx[master]: radioBuffer: Remove extra ; at the end of inline function de...

2017-03-20 Thread Alexander Chemeris
Alexander Chemeris has submitted this change and it was merged. Change subject: radioBuffer: Remove extra ; at the end of inline function definitions. .. radioBuffer: Remove extra ; at the end of inline function definitions.