Re: [Gimp-developer] GEGL errors during 'make' process

2018-02-04 Thread Elle Stone

On 02/02/2018 09:13 PM, Americo Gobbo wrote:

Hi All,
I have upgrade my system to ubuntu gnome 16.04.3 and I have tried 
again compile GEGL.


On 02/03/2018 07:37 PM, Americo Gobbo wrote:
-I/opt/gimp-default-master/include/gio-unix-2.0/ 
-I/opt/gimp-default-master/include/glib-2.0 
-I/opt/gimp-default-master/lib/glib-2.0/include 


-I/usr/include/json-glib-1.0 -I/opt/gimp-default-master/include/babl-0.1 


-I/opt/gimp-default-master/include/libpng16 
-I/opt/gimp-default-master/include 
-I/opt/gimp-default-master/include/glib-2.0 
-I/opt/gimp-default-master/lib/glib-2.0/include  -std=gnu99 -fPIC -mmmx 


-L/opt/gimp-default-master/lib -Wl,--export-dynamic -lgmodule-2.0 



-L/opt/gimp-default-master/lib -lpng16 -lspiro -lm 
-L/opt/gimp-default-master/lib -lgexiv2 -lgobject-2.0 -lglib-2.0 -o gegl 


libtool:   error: cannot find the library '/usr/local/lib/libexiv2.la' 
or unhandled argument '/usr/local/lib/libexiv2.la'



make[1]: Leaving directory '/home/jag/devel/gimp-default-master-/gegl'


Looking at the above lines, I'm confused. It looks like some stuff is 
installed in /opt/gimp-default-master, other stuff in /usr/local, and 
yet other stuff in /home/jag/devel/gimp-default-master.


Would it be easier to install *all* the requirements for installing 
babl/GEGL/GIMP (the requirements that can't be installed from the usual 
Ubuntu 16.04.3 repositories) in just one place, for example in an 
"install" folder in /home/jag/devel/gimp-default-master"? That way 
there'd be no need to tell babl or GEGL or GIMP to go "here for this 
stuff, there for some other stuff".


Anyway, something I'd wished I'd known a long time ago, all the specific 
requirements for GIMP from git are in the "configure.ac" file in the 
top-level folder for the GIMP git code, which makes it easy to see which 
Ubuntu-supplied software is current enough, and which software needs a 
more current version installed in the babl/GEGL/GIMP install prefix. 
Here's the list as of this morning:


# required versions of other packages
m4_define([babl_required_version], [0.1.42])
m4_define([gegl_required_version], [0.3.29])
m4_define([glib_required_version], [2.54.2])
m4_define([atk_required_version], [2.2.0])
m4_define([gtk_required_version], [2.24.10])
m4_define([gtk_win32_recommended_version], [2.24.32])
m4_define([gdk_pixbuf_required_version], [2.30.8])
m4_define([cairo_required_version], [1.12.2])
m4_define([cairo_pdf_required_version], [1.12.2])
m4_define([pangocairo_required_version], [1.29.4])
m4_define([fontconfig_required_version], [2.2.0])
m4_define([fontconfig_win32_recommended_version], [2.11.1])
m4_define([freetype2_required_version], [2.1.7])
m4_define([harfbuzz_required_version], [0.9.19])
m4_define([gtkdoc_required_version], [1.0])
m4_define([webkit_required_version], [1.6.1])
m4_define([alsa_required_version], [1.0.0])
m4_define([rsvg_required_version], [2.40.6])
m4_define([wmf_required_version], [0.2.8])
m4_define([pygtk_required_version], [2.10.4])
m4_define([pycairo_required_version], [1.0.2])
m4_define([poppler_required_version], [0.44.0])
m4_define([poppler_data_required_version], [0.4.7])
m4_define([libgudev_required_version], [167])
m4_define([gexiv2_required_version], [0.10.6])
m4_define([libmypaint_required_version], [1.3.0])
m4_define([lcms_required_version], [2.8])
m4_define([libpng_required_version], [1.6.25])
m4_define([liblzma_required_version], [5.0.0])
m4_define([openexr_required_version], [1.6.1])
m4_define([gtk_mac_integration_required_version], [2.0.0])
m4_define([intltool_required_version], [0.40.1])
m4_define([perl_required_version], [5.10.0])
m4_define([python2_required_version], [2.5.0])
m4_define([webp_required_version], [0.6.0])

Here's the same list for GEGL, but of course if GIMP needs a newer 
version than GEGL, use the version given in GIMP's list:


# required versions of external libraries
m4_define([babl_required_version], [0.1.42])
m4_define([cairo_required_version], [1.12.2])
m4_define([exiv2_required_version], [0.25])
m4_define([gdk_pixbuf_required_version], [2.32.0])
m4_define([introspection_required_version], [1.32.0])
m4_define([glib_required_version], [2.44.0])
m4_define([graphviz_required_version], [0.0.0])
m4_define([jasper_required_version], [1.900.1])
m4_define([lcms_required_version], [2.8])
m4_define([lensfun_required_version], [0.2.5])
m4_define([librsvg_required_version], [2.40.6])
m4_define([libv4l2_required_version], [1.0.1])
m4_define([lua_required_version], [5.1.0])
m4_define([openexr_required_version], [1.6.1])
m4_define([libraw_required_version], [0.15.4])
m4_define([pango_required_version], [1.38.0])
m4_define([png_required_version], [1.6.0])
m4_define([sdl_required_version], [1.2.0])
m4_define([libtiff_required_version], [4.0.0])
m4_define([webp_required_version], [0.5.0])
m4_define([poly2tri-c_required_version], [0.0.0])
m4_define([pygobject2_required_version], [2.26])
m4_define([pygobject3_required_version], [3.2])
m4_define([vapigen_required_version], [0.20.0])

Re: [Gimp-developer] GEGL errors during 'make' process

2018-02-04 Thread Partha Bagchi
On Sun, Feb 4, 2018 at 8:17 AM, Americo Gobbo  wrote:

> Hi Jehan,
>
> On 03/02/2018 22:47, Jehan Pagès wrote:
>
>> Well there is nothing in the command line itself which relates to
>> libexiv2. It looks like there is something wrong in the libtool script
>> wrapper generated by the build system. Delete the file "libtool" which
>> you will find in the root of the git repository. Then run the
>> configure script again (this will create again the libtool wrapper),
>> then make and let's see what happens.
>>
> Is the same behavior... very strange.
>
> libtool:   error: cannot find the library '/usr/local/lib/libexiv2.la' or
> unhandled argument '/usr/local/lib/libexiv2.la'
> Makefile:571: recipe for target 'gegl' failed
> make[2]: *** [gegl] Error 1
> make[2]: Leaving directory '/home/jag/devel/gimp-default-master-/gegl/bin'
> Makefile:634: recipe for target 'all-recursive' failed
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory '/home/jag/devel/gimp-default-master-/gegl'
> Makefile:541: recipe for target 'all' failed
> make: *** [all] Error 2
>
> ---
>
> This is my 'autogen.sh' output:
>
> config.status: creating po/Makefile
>
> Building GEGL with prefix=/opt/gimp-default-master
>
> Optional features:
>   GEGL docs:   yes
>   Build workshop:  no
>   Build website:   yes
>   SIMD:sse:yes mmx:yes
>   Vala support:yes
>
> Optional dependencies:
>   asciidoc:yes
>   enscript:no  (enscript not found)
>   mrg: no  (mrg not found)
>   Ruby:yes
>   Lua: yes
>   Cairo:   yes
>   Pango:   no  (usable pango not found)
>   pangocairo:  no  (usable pangocairo not found)
>   GDKPixbuf:   no  (gdk-pixbuf not found)
>   JPEG:yes
>   PNG: yes
>   OpenEXR: yes
>   rsvg:yes
>   SDL: yes
>   libraw:  no  (libraw library not found)
>   Jasper:  yes
>   graphviz:no  (graphviz not found)
>   avformat:no  (sufficiently new libavformat / libavcodec or
> libswcale not found)
>   V4L: no   (v4l library not found)
>   V4L2:no  (usable libv4l2 not found)
>   spiro:   yes
>   EXIV:yes
>   gexiv2:  yes
>   umfpack: yes
>   TIFF yes
>   webp:no  (webp library not found)
>   poly2tri-c:  yes (internal)
>
> We have optional dependencies not resolved... it seems that they are
> 'optional', correct!
> ciao e thanks
> americo
>
> Americo,

You're going to have serious issues since pango, gdk-pixbuf are not found
on your system. This is really strange.

Partha
___
gimp-developer-list mailing list
List address:gimp-developer-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list


Re: [Gimp-developer] GEGL errors during 'make' process

2018-02-04 Thread Americo Gobbo

Hi Jehan,

On 03/02/2018 22:47, Jehan Pagès wrote:

Well there is nothing in the command line itself which relates to
libexiv2. It looks like there is something wrong in the libtool script
wrapper generated by the build system. Delete the file "libtool" which
you will find in the root of the git repository. Then run the
configure script again (this will create again the libtool wrapper),
then make and let's see what happens.

Is the same behavior... very strange.

libtool:   error: cannot find the library '/usr/local/lib/libexiv2.la' 
or unhandled argument '/usr/local/lib/libexiv2.la'

Makefile:571: recipe for target 'gegl' failed
make[2]: *** [gegl] Error 1
make[2]: Leaving directory '/home/jag/devel/gimp-default-master-/gegl/bin'
Makefile:634: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/jag/devel/gimp-default-master-/gegl'
Makefile:541: recipe for target 'all' failed
make: *** [all] Error 2

---

This is my 'autogen.sh' output:

config.status: creating po/Makefile

Building GEGL with prefix=/opt/gimp-default-master

Optional features:
  GEGL docs:   yes
  Build workshop:  no
  Build website:   yes
  SIMD:    sse:yes mmx:yes
  Vala support:    yes

Optional dependencies:
  asciidoc:    yes
  enscript:    no  (enscript not found)
  mrg: no  (mrg not found)
  Ruby:    yes
  Lua: yes
  Cairo:   yes
  Pango:   no  (usable pango not found)
  pangocairo:  no  (usable pangocairo not found)
  GDKPixbuf:   no  (gdk-pixbuf not found)
  JPEG:    yes
  PNG: yes
  OpenEXR: yes
  rsvg:    yes
  SDL: yes
  libraw:  no  (libraw library not found)
  Jasper:  yes
  graphviz:    no  (graphviz not found)
  avformat:    no  (sufficiently new libavformat / libavcodec or 
libswcale not found)

  V4L: no   (v4l library not found)
  V4L2:    no  (usable libv4l2 not found)
  spiro:   yes
  EXIV:    yes
  gexiv2:  yes
  umfpack: yes
  TIFF yes
  webp:    no  (webp library not found)
  poly2tri-c:  yes (internal)

We have optional dependencies not resolved... it seems that they are 
'optional', correct!

ciao e thanks
americo

___
gimp-developer-list mailing list
List address:gimp-developer-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list


Re: [Gimp-developer] GEGL errors during 'make' process

2018-02-03 Thread Jehan Pagès
Hi!

On Sun, Feb 4, 2018 at 1:37 AM, Americo Gobbo  wrote:
> Hi Jehan,
>
> On 03/02/2018 22:23, Jehan Pagès wrote:
>>
>> Well I'm lost.
>
> ;-) me too!
>>
>> Are you sure you did a build from a fresh start? No
>> files at all from a previous build?
>> You can run `git clean -dfx` to erase every file from the repository
>> which are not in git (be careful not to run it carelessly and erase
>> important personal files!).
>
> So, I have the attention to apply 'git clean -xdf' first.
> I don't have personal files only the remote files of git clone updated.
>
>> Other than this, I really have no idea with only this.
>> But if you still have the error, please run `make V=1`. This will make
>> the build verbose and tell exactly which command was run. But first,
>> you should make sure you did a fresh build, really from scratch.
>
> this is the output, final parte of 'make V=1':
>
> mv -f .deps/gegl-path-spiro.Tpo .deps/gegl-path-spiro.Po
> /bin/bash ../libtool  --tag=CC   --mode=link gcc -pthread
> -I/opt/gimp-default-master/include/gio-unix-2.0/
> -I/opt/gimp-default-master/include/glib-2.0
> -I/opt/gimp-default-master/lib/glib-2.0/include -I/usr/include/json-glib-1.0
> -I/opt/gimp-default-master/include/babl-0.1
> -I/opt/gimp-default-master/include/libpng16
> -I/opt/gimp-default-master/include
> -I/opt/gimp-default-master/include/glib-2.0
> -I/opt/gimp-default-master/lib/glib-2.0/include  -std=gnu99 -fPIC -mmmx
> -msse -ftree-vectorize -ffast-math -Wall -Wdeclaration-after-statement
> -Wmissing-prototypes -Wmissing-declarations -Winit-self -Wpointer-arith
> -Wold-style-definition  ../gegl/libgegl-0.3.la
> -L/opt/gimp-default-master/lib -Wl,--export-dynamic -lgmodule-2.0 -pthread
> -ljson-glib-1.0 -lgio-2.0 -lgobject-2.0 -lgthread-2.0 -pthread -lglib-2.0
> -L/opt/gimp-default-master/lib -lbabl-0.1 -L/opt/gimp-default-master/lib
> -lpng16 -lspiro -lm -L/opt/gimp-default-master/lib -lgexiv2 -lgobject-2.0
> -lglib-2.0 -o gegl gegl.o gegl-options.o gegl-path-smooth.o
> gegl-path-spiro.o
> libtool:   error: cannot find the library '/usr/local/lib/libexiv2.la' or
> unhandled argument '/usr/local/lib/libexiv2.la'
> Makefile:571: recipe for target 'gegl' failed
> make[2]: *** [gegl] Error 1
> make[2]: Leaving directory '/home/jag/devel/gimp-default-master-/gegl/bin'
> Makefile:634: recipe for target 'all-recursive' failed
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory '/home/jag/devel/gimp-default-master-/gegl'
> Makefile:541: recipe for target 'all' failed
> make: *** [all] Error 2

Well there is nothing in the command line itself which relates to
libexiv2. It looks like there is something wrong in the libtool script
wrapper generated by the build system. Delete the file "libtool" which
you will find in the root of the git repository. Then run the
configure script again (this will create again the libtool wrapper),
then make and let's see what happens.

Jehan

> ===
> ciao
> americo
>
>

-- 
ZeMarmot open animation film
http://film.zemarmot.net
Liberapay: https://liberapay.com/ZeMarmot/
Patreon: https://patreon.com/zemarmot
Tipeee: https://www.tipeee.com/zemarmot
___
gimp-developer-list mailing list
List address:gimp-developer-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list


Re: [Gimp-developer] GEGL errors during 'make' process

2018-02-03 Thread Americo Gobbo

Hi Jehan,

On 03/02/2018 22:23, Jehan Pagès wrote:

Well I'm lost.

;-) me too!

Are you sure you did a build from a fresh start? No
files at all from a previous build?
You can run `git clean -dfx` to erase every file from the repository
which are not in git (be careful not to run it carelessly and erase
important personal files!).

So, I have the attention to apply 'git clean -xdf' first.
I don't have personal files only the remote files of git clone updated.


Other than this, I really have no idea with only this.
But if you still have the error, please run `make V=1`. This will make
the build verbose and tell exactly which command was run. But first,
you should make sure you did a fresh build, really from scratch.

this is the output, final parte of 'make V=1':

mv -f .deps/gegl-path-spiro.Tpo .deps/gegl-path-spiro.Po
/bin/bash ../libtool  --tag=CC   --mode=link gcc -pthread 
-I/opt/gimp-default-master/include/gio-unix-2.0/ 
-I/opt/gimp-default-master/include/glib-2.0 
-I/opt/gimp-default-master/lib/glib-2.0/include 
-I/usr/include/json-glib-1.0 -I/opt/gimp-default-master/include/babl-0.1 
-I/opt/gimp-default-master/include/libpng16 
-I/opt/gimp-default-master/include 
-I/opt/gimp-default-master/include/glib-2.0 
-I/opt/gimp-default-master/lib/glib-2.0/include  -std=gnu99 -fPIC -mmmx 
-msse -ftree-vectorize -ffast-math -Wall -Wdeclaration-after-statement 
-Wmissing-prototypes -Wmissing-declarations -Winit-self -Wpointer-arith 
-Wold-style-definition  ../gegl/libgegl-0.3.la 
-L/opt/gimp-default-master/lib -Wl,--export-dynamic -lgmodule-2.0 
-pthread -ljson-glib-1.0 -lgio-2.0 -lgobject-2.0 -lgthread-2.0 -pthread 
-lglib-2.0 -L/opt/gimp-default-master/lib -lbabl-0.1 
-L/opt/gimp-default-master/lib -lpng16 -lspiro -lm 
-L/opt/gimp-default-master/lib -lgexiv2 -lgobject-2.0 -lglib-2.0 -o gegl 
gegl.o gegl-options.o gegl-path-smooth.o  gegl-path-spiro.o
libtool:   error: cannot find the library '/usr/local/lib/libexiv2.la' 
or unhandled argument '/usr/local/lib/libexiv2.la'

Makefile:571: recipe for target 'gegl' failed
make[2]: *** [gegl] Error 1
make[2]: Leaving directory '/home/jag/devel/gimp-default-master-/gegl/bin'
Makefile:634: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/jag/devel/gimp-default-master-/gegl'
Makefile:541: recipe for target 'all' failed
make: *** [all] Error 2

===
ciao
americo


___
gimp-developer-list mailing list
List address:gimp-developer-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list


Re: [Gimp-developer] GEGL errors during 'make' process

2018-02-03 Thread Jehan Pagès
On Sun, Feb 4, 2018 at 1:14 AM, Americo Gobbo  wrote:
> Hi Jehan,
>
> On 03/02/2018 22:06, Jehan Pagès wrote:
>>
>> Hi!
>>
>> On Sun, Feb 4, 2018 at 12:59 AM, Americo Gobbo 
>> wrote:
>>>
>>> Hi Jehan,
>>> I have used the git repository to build.
>>> config.log is of my traditional environment to gegl
>>> config-new.log is of a ex-novo environment to gegl to test if was making
>>> something wrong in the traditional env.
>>
>> Both seem fine. pkg-config does not seem to detect any exiv2 in
>> /usr/local/.
>> Are the build still broken and outputting the same errors?
>>
>> Jehan
>
> This is final of my 'make' messages:
>
>   CCLD gegl
> libtool:   error: cannot find the library '/usr/local/lib/libexiv2.la' or
> unhandled argument '/usr/local/lib/libexiv2.la'
> Makefile:571: recipe for target 'gegl' failed
> make[2]: *** [gegl] Error 1
> make[2]: Leaving directory '/home/jag/devel/gimp-default-master-/gegl/bin'
> Makefile:634: recipe for target 'all-recursive' failed
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory '/home/jag/devel/gimp-default-master-/gegl'
> Makefile:541: recipe for target 'all' failed
> make: *** [all] Error 2
> ---
>
> In fact the archives are installed in another directory
>
> '/usr/lib/x86_64-linux-gnu/' instead that '/usr/local/lib/'

Well I'm lost. Are you sure you did a build from a fresh start? No
files at all from a previous build?
You can run `git clean -dfx` to erase every file from the repository
which are not in git (be careful not to run it carelessly and erase
important personal files!).

Other than this, I really have no idea with only this.
But if you still have the error, please run `make V=1`. This will make
the build verbose and tell exactly which command was run. But first,
you should make sure you did a fresh build, really from scratch.

Jehan

-- 
ZeMarmot open animation film
http://film.zemarmot.net
Liberapay: https://liberapay.com/ZeMarmot/
Patreon: https://patreon.com/zemarmot
Tipeee: https://www.tipeee.com/zemarmot
___
gimp-developer-list mailing list
List address:gimp-developer-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list


Re: [Gimp-developer] GEGL errors during 'make' process

2018-02-03 Thread Americo Gobbo

Hi Jehan,

On 03/02/2018 22:06, Jehan Pagès wrote:

Hi!

On Sun, Feb 4, 2018 at 12:59 AM, Americo Gobbo  wrote:

Hi Jehan,
I have used the git repository to build.
config.log is of my traditional environment to gegl
config-new.log is of a ex-novo environment to gegl to test if was making
something wrong in the traditional env.

Both seem fine. pkg-config does not seem to detect any exiv2 in /usr/local/.
Are the build still broken and outputting the same errors?

Jehan

This is final of my 'make' messages:

  CCLD gegl
libtool:   error: cannot find the library '/usr/local/lib/libexiv2.la' 
or unhandled argument '/usr/local/lib/libexiv2.la'

Makefile:571: recipe for target 'gegl' failed
make[2]: *** [gegl] Error 1
make[2]: Leaving directory '/home/jag/devel/gimp-default-master-/gegl/bin'
Makefile:634: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/jag/devel/gimp-default-master-/gegl'
Makefile:541: recipe for target 'all' failed
make: *** [all] Error 2
---

In fact the archives are installed in another directory

'/usr/lib/x86_64-linux-gnu/' instead that '/usr/local/lib/'

___
gimp-developer-list mailing list
List address:gimp-developer-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list


Re: [Gimp-developer] GEGL errors during 'make' process

2018-02-03 Thread Jehan Pagès
Hi!

On Sun, Feb 4, 2018 at 12:59 AM, Americo Gobbo  wrote:
> Hi Jehan,
> I have used the git repository to build.
> config.log is of my traditional environment to gegl
> config-new.log is of a ex-novo environment to gegl to test if was making
> something wrong in the traditional env.

Both seem fine. pkg-config does not seem to detect any exiv2 in /usr/local/.
Are the build still broken and outputting the same errors?

Jehan

> ciao
> americo
>
>
>
> On 03/02/2018 21:38, Jehan Pagès wrote:
>>
>> Were you building inside the git repository or in a separate
>> directory? In the second case, make sure the build directory is empty.
>> Could you send us the contents of "config.log"? Since gexiv2 and exiv2
>> are looked up with pkg-config, it will allow us to see what was
>> detected too.
>>
>> Since you can't attach a file, just copy-paste its contents somewhere,
>> for instance athttps://paste.gnome.org/
>> Thanks!
>
>



-- 
ZeMarmot open animation film
http://film.zemarmot.net
Liberapay: https://liberapay.com/ZeMarmot/
Patreon: https://patreon.com/zemarmot
Tipeee: https://www.tipeee.com/zemarmot
___
gimp-developer-list mailing list
List address:gimp-developer-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list


Re: [Gimp-developer] GEGL errors during 'make' process

2018-02-03 Thread Americo Gobbo

Hi Tobias,

Hi All,
I have upgrade my system to ubuntu gnome 16.04.3 and I have tried again
compile GEGL. The 'autogen.sh' is finished OK, without problems.
The 'make' process have these errors messages:

gcc: error: /usr/local/lib/libexiv2.so: No such file or directory
Makefile:571: recipe for target 'gegl' failed
make[2]: *** [gegl] Error 1
make[2]: Leaving directory 
'/home/jag/devel/gimp-default-master/gegl/bin'

Makefile:634: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/jag/devel/gimp-default-master/gegl'
Makefile:541: recipe for target 'all' failed
make: *** [all] Error 2

Someone can give some suggestion?

Is that a fresh git clone or did you compile in the directory before?
I have a made a fresh git clone of 'gegl' and it results the same 
error... is a bit odd :-)

Perhaps, the problem is on my environment setup script?

PREFIX=/opt/gimp-default-master
export PATH=$PREFIX/bin:$PATH
export LD_LIBRARY_PATH=$PREFIX/lib:$LD_LIBRARY_PATH
export XDG_DATA_DIRS=$PREFIX/share:$XDG_DATA_DIRS
export ACLOCAL_FLAGS="-I $PREFIX/share/aclocal"
export PKG_CONFIG_PATH=$PREFIX/lib/pkgconfig:$PKG_CONFIG_PATH
export GIO_EXTRA_MODULES=/usr/lib/x86_64-linux-gnu/gio/modules
export SRC_DIR=$HOME/devel/gimp-default-master/gimp-2.9/build
export CFLAGS='-std=gnu99 -fPIC'
export LESS="-F -X -R"

___
gimp-developer-list mailing list
List address:gimp-developer-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list


Re: [Gimp-developer] GEGL errors during 'make' process

2018-02-03 Thread Americo Gobbo

Hi Tobias,
thanks!

On 03/02/2018 08:40, Tobias Ellinghaus wrote:

Am Samstag, 3. Februar 2018, 03:13:18 CET schrieb Americo Gobbo:

Hi All,
I have upgrade my system to ubuntu gnome 16.04.3 and I have tried again
compile GEGL. The 'autogen.sh' is finished OK, without problems.
The 'make' process have these errors messages:

gcc: error: /usr/local/lib/libexiv2.so: No such file or directory
Makefile:571: recipe for target 'gegl' failed
make[2]: *** [gegl] Error 1
make[2]: Leaving directory '/home/jag/devel/gimp-default-master/gegl/bin'
Makefile:634: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/jag/devel/gimp-default-master/gegl'
Makefile:541: recipe for target 'all' failed
make: *** [all] Error 2

Someone can give some suggestion?

Is that a fresh git clone or did you compile in the directory before? Maybe
you used to have libexiv2 installed in/usr/local/  and that was picked up by
autofoo in the past and now it still remembers the old location.

Yes, because them are in another directory: /usr/lib/x86_64-linux-gnu
So, how is possible resolve this without 'ln -s', also because it does 
not work?


Linking libraries around (using ln -s, not ld) is not the solution and a
terrible idea.


correct.

___
gimp-developer-list mailing list
List address:gimp-developer-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list


Re: [Gimp-developer] GEGL errors during 'make' process

2018-02-03 Thread Tobias Ellinghaus
Am Samstag, 3. Februar 2018, 03:13:18 CET schrieb Americo Gobbo:
> Hi All,
> I have upgrade my system to ubuntu gnome 16.04.3 and I have tried again
> compile GEGL. The 'autogen.sh' is finished OK, without problems.
> The 'make' process have these errors messages:
> 
> gcc: error: /usr/local/lib/libexiv2.so: No such file or directory
> Makefile:571: recipe for target 'gegl' failed
> make[2]: *** [gegl] Error 1
> make[2]: Leaving directory '/home/jag/devel/gimp-default-master/gegl/bin'
> Makefile:634: recipe for target 'all-recursive' failed
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory '/home/jag/devel/gimp-default-master/gegl'
> Makefile:541: recipe for target 'all' failed
> make: *** [all] Error 2
> 
> Someone can give some suggestion?

Is that a fresh git clone or did you compile in the directory before? Maybe 
you used to have libexiv2 installed in /usr/local/ and that was picked up by 
autofoo in the past and now it still remembers the old location.

Linking libraries around (using ln -s, not ld) is not the solution and a 
terrible idea.

> Thanks
> americo

Tobias

signature.asc
Description: This is a digitally signed message part.
___
gimp-developer-list mailing list
List address:gimp-developer-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list


Re: [Gimp-developer] GEGL errors during 'make' process

2018-02-02 Thread Partha Bagchi
Americo,

Just make a symlink to get past the error. Something like:

ln -s /usr/lib/x86_64-linux-gnu/libgexiv2.so /usr/local/lib/libgexiv2.so

etc.

Though, linux systems use the silly "la" files, and so this may not work.
Better to check and see if it does work. Otherwise, yes, modify your
LDFLAGS.


On Fri, Feb 2, 2018 at 10:59 PM, Americo Gobbo 
wrote:

> Hi Partha,
> in my system these libraries are in:
>
> /usr/lib/x86_64-linux-gnu/libgexiv2.a
> /usr/lib/x86_64-linux-gnu/libgexiv2.so
>
> instead that in '/usr/local/lib/libexiv2.la'
>
> On 03/02/2018 01:46, Partha Bagchi wrote:
>
>> Hi Americo,
>>
>> What does
>> find / -name "libgexiv*.so"
>> say?
>>
>> Since I don't know how your ld.conf is setup, I am trying to guess where
>> your shared objects are. Once you find them, instead of relying on the
>> system, you can pass them directly to GIMP/GEGL while making using
>> LDFLAGS="-L/usr/lib/lib64" etc.
>>
> Perhaps I need modify my setup environment?
>
> my setup script is:
>
> less ../setup-master.sh
> PREFIX=/opt/gimp-default-master
> export PATH=$PREFIX/bin:$PATH
> export LD_LIBRARY_PATH=$PREFIX/lib:$LD_LIBRARY_PATH
> export XDG_DATA_DIRS=$PREFIX/share:$XDG_DATA_DIRS
> export ACLOCAL_FLAGS="-I $PREFIX/share/aclocal"
> export PKG_CONFIG_PATH=$PREFIX/lib/pkgconfig:$PKG_CONFIG_PATH
> export GIO_EXTRA_MODULES=/usr/lib/x86_64-linux-gnu/gio/modules
> export SRC_DIR=$HOME/devel/gimp-default-master/gimp-2.9/build
> export CFLAGS='-std=gnu99 -fPIC'
> export LESS="-F -X -R"
>
>
___
gimp-developer-list mailing list
List address:gimp-developer-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list


Re: [Gimp-developer] GEGL errors during 'make' process

2018-02-02 Thread Americo Gobbo

Hi Partha,
in my system these libraries are in:

/usr/lib/x86_64-linux-gnu/libgexiv2.a
/usr/lib/x86_64-linux-gnu/libgexiv2.so

instead that in '/usr/local/lib/libexiv2.la'

On 03/02/2018 01:46, Partha Bagchi wrote:

Hi Americo,

What does
find / -name "libgexiv*.so"
say?

Since I don't know how your ld.conf is setup, I am trying to guess where
your shared objects are. Once you find them, instead of relying on the
system, you can pass them directly to GIMP/GEGL while making using
LDFLAGS="-L/usr/lib/lib64" etc.

Perhaps I need modify my setup environment?

my setup script is:

less ../setup-master.sh
PREFIX=/opt/gimp-default-master
export PATH=$PREFIX/bin:$PATH
export LD_LIBRARY_PATH=$PREFIX/lib:$LD_LIBRARY_PATH
export XDG_DATA_DIRS=$PREFIX/share:$XDG_DATA_DIRS
export ACLOCAL_FLAGS="-I $PREFIX/share/aclocal"
export PKG_CONFIG_PATH=$PREFIX/lib/pkgconfig:$PKG_CONFIG_PATH
export GIO_EXTRA_MODULES=/usr/lib/x86_64-linux-gnu/gio/modules
export SRC_DIR=$HOME/devel/gimp-default-master/gimp-2.9/build
export CFLAGS='-std=gnu99 -fPIC'
export LESS="-F -X -R"

___
gimp-developer-list mailing list
List address:gimp-developer-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list


Re: [Gimp-developer] GEGL errors during 'make' process

2018-02-02 Thread Partha Bagchi
Hi Americo,

What does
find / -name "libgexiv*.so"
say?

Since I don't know how your ld.conf is setup, I am trying to guess where
your shared objects are. Once you find them, instead of relying on the
system, you can pass them directly to GIMP/GEGL while making using
LDFLAGS="-L/usr/lib/lib64" etc.


On Fri, Feb 2, 2018 at 10:31 PM, Americo Gobbo 
wrote:

> Hi Partha,
>
> ~$ pkg-config --libs exiv2
> -lexiv2
> ~$ pkg-config --libs gexiv2
> -lgexiv2 -lgobject-2.0 -lglib-2.0
>
>
> On 03/02/2018 01:27, Partha Bagchi wrote:
>
>> I see. So what does
>>
>> pkg-config --libs exiv2
>>
>> or
>>
>> pkg-config --libs gexiv2
>>
>>
>> say?
>>
>
>
>
___
gimp-developer-list mailing list
List address:gimp-developer-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list


Re: [Gimp-developer] GEGL errors during 'make' process

2018-02-02 Thread Americo Gobbo

Hi Partha,

~$ pkg-config --libs exiv2
-lexiv2
~$ pkg-config --libs gexiv2
-lgexiv2 -lgobject-2.0 -lglib-2.0

On 03/02/2018 01:27, Partha Bagchi wrote:

I see. So what does

pkg-config --libs exiv2

or

pkg-config --libs gexiv2


say?



___
gimp-developer-list mailing list
List address:gimp-developer-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list


Re: [Gimp-developer] GEGL errors during 'make' process

2018-02-02 Thread Partha Bagchi
I see. So what does

pkg-config --libs exiv2

or

pkg-config --libs gexiv2


say?


On Fri, Feb 2, 2018 at 10:11 PM, Americo Gobbo 
wrote:

> Hi Partha,
> thanks!
> So, in my system gexiv2 and exiv2 are installed.
>
> $ sudo apt-get install libexiv2-dev libgexiv2-dev
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> libgexiv2-dev is already the newest version (0.10.3-2).
> libexiv2-dev is already the newest version (0.25-2.1ubuntu16.04.1).
> 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
>
> It seems that doesn't find in the folder that the autogen.sh is indicating?
>
> libtool:   error: cannot find the library '/usr/local/lib/libexiv2.la' or
> unhandled argument '/usr/local/lib/libexiv2.la'
> Makefile:571: recipe for target 'gegl' failed
> make[2]: *** [gegl] Error 1
> make[2]: Leaving directory '/home/jag/devel/gimp-default-master/gegl/bin'
> Makefile:634: recipe for target 'all-recursive' failed
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory '/home/jag/devel/gimp-default-master/gegl'
> Makefile:541: recipe for target 'all' failed
> make: *** [all] Error 2
>
> On 03/02/2018 00:32, Partha Bagchi wrote:
>
>> Americo,
>>
>> I don't know about your system, but you need to make sure that you have
>> gexiv2 and exiv2 (including dev files) installed in your system.
>>
>> Partha
>>
>
>
___
gimp-developer-list mailing list
List address:gimp-developer-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list


Re: [Gimp-developer] GEGL errors during 'make' process

2018-02-02 Thread Americo Gobbo

Hi Partha,
thanks!
So, in my system gexiv2 and exiv2 are installed.

$ sudo apt-get install libexiv2-dev libgexiv2-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
libgexiv2-dev is already the newest version (0.10.3-2).
libexiv2-dev is already the newest version (0.25-2.1ubuntu16.04.1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

It seems that doesn't find in the folder that the autogen.sh is indicating?

libtool:   error: cannot find the library '/usr/local/lib/libexiv2.la' 
or unhandled argument '/usr/local/lib/libexiv2.la'

Makefile:571: recipe for target 'gegl' failed
make[2]: *** [gegl] Error 1
make[2]: Leaving directory '/home/jag/devel/gimp-default-master/gegl/bin'
Makefile:634: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/jag/devel/gimp-default-master/gegl'
Makefile:541: recipe for target 'all' failed
make: *** [all] Error 2

On 03/02/2018 00:32, Partha Bagchi wrote:

Americo,

I don't know about your system, but you need to make sure that you have
gexiv2 and exiv2 (including dev files) installed in your system.

Partha


___
gimp-developer-list mailing list
List address:gimp-developer-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list


Re: [Gimp-developer] GEGL errors during 'make' process

2018-02-02 Thread Partha Bagchi
Americo,

I don't know about your system, but you need to make sure that you have
gexiv2 and exiv2 (including dev files) installed in your system.

Partha

On Fri, Feb 2, 2018 at 9:13 PM, Americo Gobbo  wrote:

> Hi All,
> I have upgrade my system to ubuntu gnome 16.04.3 and I have tried again
> compile GEGL.
> The 'autogen.sh' is finished OK, without problems.
> The 'make' process have these errors messages:
>
> gcc: error: /usr/local/lib/libexiv2.so: No such file or directory
> Makefile:571: recipe for target 'gegl' failed
> make[2]: *** [gegl] Error 1
> make[2]: Leaving directory '/home/jag/devel/gimp-default-master/gegl/bin'
> Makefile:634: recipe for target 'all-recursive' failed
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory '/home/jag/devel/gimp-default-master/gegl'
> Makefile:541: recipe for target 'all' failed
> make: *** [all] Error 2
>
> Someone can give some suggestion?
>
>
>
> Thanks
> americo
> ___
> gimp-developer-list mailing list
> List membership:https://mail.gnome.org/mailman/listinfo/gimp-deve
> loper-list
> List archives:https://mail.gnome.org/archives/gimp-developer-list
>
> ___
> gimp-developer-list mailing list
> List address:gimp-developer-list@gnome.org
> List membership: https://mail.gnome.org/mailman
> /listinfo/gimp-developer-list
> List archives:   https://mail.gnome.org/archives/gimp-developer-list
>
___
gimp-developer-list mailing list
List address:gimp-developer-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list


[Gimp-developer] GEGL errors during 'make' process

2018-02-02 Thread Americo Gobbo

Hi All,
I have upgrade my system to ubuntu gnome 16.04.3 and I have tried again compile 
GEGL.
The 'autogen.sh' is finished OK, without problems.
The 'make' process have these errors messages:

gcc: error: /usr/local/lib/libexiv2.so: No such file or directory
Makefile:571: recipe for target 'gegl' failed
make[2]: *** [gegl] Error 1
make[2]: Leaving directory '/home/jag/devel/gimp-default-master/gegl/bin'
Makefile:634: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/jag/devel/gimp-default-master/gegl'
Makefile:541: recipe for target 'all' failed
make: *** [all] Error 2

Someone can give some suggestion?



Thanks
americo
___
gimp-developer-list mailing list
List membership:https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:https://mail.gnome.org/archives/gimp-developer-list

___
gimp-developer-list mailing list
List address:gimp-developer-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list