Re: Conditionally define vars to improve portability

2015-09-08 Thread Jeff King
On Mon, Sep 07, 2015 at 02:51:42PM -0300, Renato Botelho wrote: > Default variables used to build are set using = on Makefile, (e.g. CC, > INSTALL, CFLAGS, …). GNU make overwrite these values if it’s passed as > an argument (make CC=clang) and it works as expected. > > Default method of passing

Re: [PATCH v3 00/11] Make "local" orthogonal to date format

2015-09-08 Thread Jeff King
On Thu, Sep 03, 2015 at 10:48:50PM +0100, John Keeping wrote: > Since version 2 there are four new preparatory patches which remove > lists of date formats from documentation in favour of referring to the > detailed list in git-rev-list(1) or git-log(1) (both generated from >

Update Vietnamese translation for git-gui

2015-09-08 Thread Trần Ngọc Quân
Dear git-gui maintainers, Please pull the commit 1fa18b72184612e6615b1f119535183f40694fa4 from: https://github.com/vnwildman/git-gui.git on ``master'' branch. Thanks, -- Trần Ngọc Quân. -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to

Re: Conditionally define vars to improve portability

2015-09-08 Thread Renato Botelho
> On Sep 8, 2015, at 03:30, Jeff King wrote: > > On Mon, Sep 07, 2015 at 02:51:42PM -0300, Renato Botelho wrote: > >> Default variables used to build are set using = on Makefile, (e.g. CC, >> INSTALL, CFLAGS, …). GNU make overwrite these values if it’s passed as >> an argument

Re: [Feature request] help.autocorrect suggestion with Y/N

2015-09-08 Thread Jeff King
On Tue, Sep 08, 2015 at 10:11:20AM +0200, rubenk...@spacetrace.org wrote: > git: 'glone' is not a git command. See 'git --help'. > > Did you mean this? > clone > > It would be handsome if you could say "Yes" to this question so you > don't have to manually correct your last command

Re: [PATCH] am: match --signoff to the original scripted version

2015-09-08 Thread Jeff King
On Sat, Sep 05, 2015 at 09:56:27PM -0700, Junio C Hamano wrote: > +static void am_signoff(struct strbuf *sb) > +{ > + char *cp; > + struct strbuf mine = STRBUF_INIT; > + > + /* Does it end with our own sign-off? */ > + strbuf_addf(, "\n%s%s\n", > + sign_off_header,

Re: [PATCH] am: match --signoff to the original scripted version

2015-09-08 Thread Jeff King
On Sun, Sep 06, 2015 at 10:24:12AM -0700, Junio C Hamano wrote: > >> + /* Does it end with our own sign-off? */ > >> + strbuf_addf(, "\n%s%s\n", > >> + sign_off_header, > >> + fmt_name(getenv("GIT_COMMITTER_NAME"), > >> +

Re: Bug: git-upload-pack will return successfully even when it can't read all references

2015-09-08 Thread Jeff King
On Mon, Sep 07, 2015 at 02:11:15PM +0200, Ævar Arnfjörð Bjarmason wrote: > This turned out to be a pretty trivial filesystem error. > refs/heads/master wasn't readable by the backup process, but some > other stuff in refs/heads and objects/* was. > > [...] > > I wanted to check if this was a

Re: Improving auto conflict resolving while merge

2015-09-08 Thread Jeff King
On Mon, Sep 07, 2015 at 08:15:46PM +0300, KES wrote: > 1. git clone https://github.com/KES777/Plack > [...] > At this point I have same changes on master and branch. > master head is d095870 > branch head is a3db36a > fork point is 0a5ff84 I tried re-merging d095870 and a3db36a. I think what is

[Feature request] help.autocorrect suggestion with Y/N

2015-09-08 Thread rubenk...@spacetrace.org
When you type git clone https://repo.git now you get git: 'glone' is not a git command. See 'git --help'. Did you mean this? clone It would be handsome if you could say "Yes" to this question so you don't have to manually correct your last command like: Did you mean this?

Re: bash completion lacks options

2015-09-08 Thread Ævar Arnfjörð Bjarmason
On Mon, Sep 7, 2015 at 5:36 PM, Olaf Hering wrote: > Am 07.09.2015 um 17:34 schrieb Ævar Arnfjörð Bjarmason: >> On Mon, Sep 7, 2015 at 5:07 PM, Olaf Hering wrote: > >>> https://github.com/libguestfs/libguestfs/commit/0306c98d319d189281af3c15101c8d343e400f13 >> >>

Re: bash completion lacks options

2015-09-08 Thread Olaf Hering
Am 08.09.2015 um 13:28 schrieb Ævar Arnfjörð Bjarmason: > Yes, format-patch is written in C, but you mentioned send-email, which > is a Perl script. send-mail is handled in my copy of the bash_completion, at the end the list the format-patch options gets appended. That list could be autogenerated

Re: Bug: git-upload-pack will return successfully even when it can't read all references

2015-09-08 Thread Ævar Arnfjörð Bjarmason
On Tue, Sep 8, 2015 at 8:53 AM, Jeff King wrote: > On Mon, Sep 07, 2015 at 02:11:15PM +0200, Ævar Arnfjörð Bjarmason wrote: > >> This turned out to be a pretty trivial filesystem error. >> refs/heads/master wasn't readable by the backup process, but some >> other stuff in

[RFC/PATCH] git-multimail version 1.2 Alpha 1

2015-09-08 Thread Matthieu Moy
The changes are described in CHANGES. Contributions-by: Job Snijders Contributions-by: Richard Hansen Contributions-by: Elijah Newren Contributions-by: Michael Haggerty Contributions-by: Paul Sokolovsky

[PATCHv6 3/3] submodule: Reimplement `module_clone` shell function in C

2015-09-08 Thread Stefan Beller
This reimplements the helper function `module_clone` in shell in C as `clone`. This functionality is needed for converting `git submodule update` later on, which we want to add threading to. Signed-off-by: Stefan Beller --- builtin/submodule--helper.c | 132

Re: [PATCHv5 3/3] submodule: Reimplement `module_clone` shell function in C

2015-09-08 Thread Stefan Beller
On Thu, Sep 3, 2015 at 3:07 PM, Junio C Hamano wrote: >> + >> + cp.no_stdin = 1; >> + cp.no_stdout = 1; >> + cp.no_stderr = 1; > > Output from "git clone" is not shown, regardless of --quiet option? Removed that. >> + argc = parse_options(argc, argv, prefix,

Re: bash completion lacks options

2015-09-08 Thread Junio C Hamano
Ævar Arnfjörð Bjarmason writes: > On Mon, Sep 7, 2015 at 5:36 PM, Olaf Hering wrote: >> Am 07.09.2015 um 17:34 schrieb Ævar Arnfjörð Bjarmason: >>> On Mon, Sep 7, 2015 at 5:07 PM, Olaf Hering wrote: >>

[PATCHv6 2/3] submodule: Reimplement `module_name` shell function in C

2015-09-08 Thread Stefan Beller
This implements the helper `name` in C instead of shell, yielding a nice performance boost. Before this patch, I measured a time (best out of three): $ time ./t7400-submodule-basic.sh >/dev/null real0m11.066s user0m3.348s sys 0m8.534s With this patch applied I

Re: Conditionally define vars to improve portability

2015-09-08 Thread Junio C Hamano
Jeff King writes: > On Mon, Sep 07, 2015 at 02:51:42PM -0300, Renato Botelho wrote: > >> Default variables used to build are set using = on Makefile, (e.g. CC, >> INSTALL, CFLAGS, …). GNU make overwrite these values if it’s passed as >> an argument (make CC=clang) and it works as

[PATCHv6 1/3] submodule: Reimplement `module_list` shell function in C

2015-09-08 Thread Stefan Beller
Most of the submodule operations work on a set of submodules. Calculating and using this set is usually done via: module_list "$@" | { while read mode sha1 stage sm_path do # the actual operation done } Currently the function

[PATCHv6 0/3] submodule--helper: Have some refactoring only patches first

2015-09-08 Thread Stefan Beller
Added suggestions from Eric and Junio. Interdiff to v5 below. Stefan Beller (3): submodule: Reimplement `module_list` shell function in C submodule: Reimplement `module_name` shell function in C submodule: Reimplement `module_clone` shell function in C .gitignore | 1 +

Re: Conditionally define vars to improve portability

2015-09-08 Thread Jacob Keller
On Tue, Sep 8, 2015 at 11:57 AM, Junio C Hamano wrote: > Common things like CC are not so problematic, but more problematic > are various Git build customization in our Makefile that can be left > behind from a previous build. It is easier for users to forget, as > a

Re: Bug: git-upload-pack will return successfully even when it can't read all references

2015-09-08 Thread Jeff King
On Tue, Sep 08, 2015 at 02:16:03PM +0200, Ævar Arnfjörð Bjarmason wrote: > I wonder if --upload-pack="GIT_REF_PARANOIA=1 git-upload-pack" should > be the default when running fetch if you have --prune enabled. There's > a particularly bad edge case now where if you have permission errors > on the

Re: [PATCH] git_connect: clarify conn->use_shell flag

2015-09-08 Thread Jeff King
On Tue, Sep 08, 2015 at 10:18:41AM -0700, Junio C Hamano wrote: > > To make the flow easier to follow, let's just set > > conn->use_shell when we're setting up the "conn" struct, and > > unset it (with a comment) in the historical GIT_SSH case. > > Makes perfect sense. I think another thing

Re: [PATCH] filter-branch: add passed/remaining seconds on progress

2015-09-08 Thread Jeff King
On Tue, Sep 08, 2015 at 10:32:12AM -0700, Junio C Hamano wrote: > Also git_filter_branch__commit_count is now used only inside this > function, so it is easier to follow to increment it here. > > I suspect that the variable has this unwieldy name for historic > reasons, perhaps an attempt to

Re: Questions about git-push for huge repositories

2015-09-08 Thread Jeff King
On Tue, Sep 08, 2015 at 11:24:06AM -0700, Junio C Hamano wrote: > Jeff King writes: > > > If you turn on reachability bitmaps, git _will_ do the thorough set > > difference, because it becomes much cheaper to do so. E.g., try: > > > > git repack -adb > > > > in repo A to

Re: Improving auto conflict resolving while merge

2015-09-08 Thread Jeff King
On Tue, Sep 08, 2015 at 09:08:09PM -0300, Eugen Konkov wrote: > JK> you _could_ argue that those changes are independent But it's close > JK> enough that there's a good chance the two need to be reconciled, > JK> and a human should at least take a look. > > You are right and your words make

Re: [PATCHv5 3/3] submodule: Reimplement `module_clone` shell function in C

2015-09-08 Thread Junio C Hamano
Stefan Beller writes: > On Thu, Sep 3, 2015 at 3:07 PM, Junio C Hamano wrote: >>> + >>> + cp.no_stdin = 1; >>> + cp.no_stdout = 1; >>> + cp.no_stderr = 1; >> >> Output from "git clone" is not shown, regardless of --quiet option? > > Removed

[ANNOUNCE] Git v2.6.0-rc1

2015-09-08 Thread Junio C Hamano
A release candidate Git v2.6.0-rc1 is now available for testing at the usual places. It is comprised of 409 non-merge commits since v2.5.0, contributed by 50 people, 12 of which are new faces. The tarballs are found at: https://www.kernel.org/pub/software/scm/git/testing/ The following

Re: [PATCH] filter-branch: add passed/remaining seconds on progress

2015-09-08 Thread Junio C Hamano
Eric Sunshine writes: > On Mon, Sep 7, 2015 at 9:52 AM, Gábor Bernát wrote: >... >> # Rewrite the commits >> +report_progress () >> +{ >> +if test -n "$progress" >> +then > > Indent code within the function... Also

Re: [PATCH] git_connect: clarify conn->use_shell flag

2015-09-08 Thread Junio C Hamano
Jeff King writes: > Subject: [PATCH] git_connect: clarify conn->use_shell flag > > When executing user-specified programs, we generally always > want to use a shell, for flexibility and consistency. One > big exception is executing $GIT_SSH, which for historical > reasons must not

Re: [PATCH/RFC] Pinning of submodules

2015-09-08 Thread Junio C Hamano
Jens Lehmann writes: > Am 07.09.2015 um 01:43 schrieb Eric Sunshine: > >> My concern in asking was that some future person might come up with >> another scenario which also wants to use a "magic value" and would >> have to invent / arrive at another "illegal" representation.

Re: [PATCH] filter-branch: add passed/remaining seconds on progress

2015-09-08 Thread Eric Sunshine
On Tue, Sep 8, 2015 at 1:32 PM, Junio C Hamano wrote: > Eric Sunshine writes: >> On Mon, Sep 7, 2015 at 9:52 AM, Gábor Bernát wrote: >>... >>> # Rewrite the commits >>> +report_progress () >>> +{ >>> +if test -n "$progress" >>>

Re: Issue with Orphaned Files After Aborted Rebase

2015-09-08 Thread Johnny Sheeley
I began a rebase, and was unable to add two files that appeared as changed (1). When I aborted this rebase, these two files were left in my tree, showing as changed, and did not respond to checkout ‹(2), reset(3), or stash(4). My expectation would be that after a rebase ‹abort, the tree would be

Re: [PATCH] am: match --signoff to the original scripted version

2015-09-08 Thread Junio C Hamano
Jeff King writes: > On Sat, Sep 05, 2015 at 09:56:27PM -0700, Junio C Hamano wrote: > >> +static void am_signoff(struct strbuf *sb) >> +{ >> +char *cp; >> +struct strbuf mine = STRBUF_INIT; >> + >> +/* Does it end with our own sign-off? */ >> +strbuf_addf(,

Re: Standardization of messages - dot after the sentence

2015-09-08 Thread Junio C Hamano
Michael J Gruber writes: > sigo venit, vidit, dixit 05.09.2015 14:22: >> I've found really "little bug" with dots in the git output. >> >> $ git push >> Everything up-to-date >> >> git pull >> Already up-to-date. >> >> Could all phrases contain dots? :) >> > > In

Re[2]: Improving auto conflict resolving while merge

2015-09-08 Thread Eugen Konkov
Hi, Jeff. JK> For example, if you have the content: JK> foo(); JK> bar(); JK> baz(); JK> and one side makes it: JK> foo(); JK> x = 1; JK> bar(); JK> baz(); JK> and the other side does: JK> foo(); JK> bar(); JK> y = 2; JK> baz(); JK> you _could_ argue that those changes

Re: [PATCH v16 00/14] port tag.c to use ref-filter APIs

2015-09-08 Thread Junio C Hamano
Matthieu Moy writes: >>> This line still looks overlong. Would it help to stop spelling this >>> as a double "a = b = overlong expression" assignment? >>> >> >> I'm not sure, I get what you mean. > > I guess > > format =

Re: [PATCH v16 00/14] port tag.c to use ref-filter APIs

2015-09-08 Thread Junio C Hamano
Karthik Nayak writes: >> I am flexible with the terminology, but the point is that I think >> the quoting rules are better be specified _outside_ the description >> of a particular atom, but as a general rule. > > I definitely agree, but like Matthieu said, corrently we

Re: Questions about git-push for huge repositories

2015-09-08 Thread Junio C Hamano
Jeff King writes: > If you turn on reachability bitmaps, git _will_ do the thorough set > difference, because it becomes much cheaper to do so. E.g., try: > > git repack -adb > > in repo A to build a single pack with bitmaps enabled. Then a subsequent > push should send only a