'git stash save' is deprecated, but we still call the options for
completion 'save_opts'.  Simply renaming them to 'push_opts' is not
ideal because for example '--message foo' can't be passed directly to
'git stash', as non-option arguments are not allowed, and foo would be
treated as one.

Completing '--message' in 'git stash --<tab>' would end up being quite
confusing for the user.  Therefore name them 'default_opts', and keep
treating --message specially for 'git stash push'.

The ulterior motive for renaming 'save_opts' is that in the next
commit we're going to stop completing 'git stash save', so 'save_opts'
would be the only remaining thing referring to 'git stash save', which
would probably be confusing for future readers of this code.

Signed-off-by: Thomas Gummerer <t.gumme...@gmail.com>
---
 contrib/completion/git-completion.bash | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/contrib/completion/git-completion.bash 
b/contrib/completion/git-completion.bash
index a757073945..39c123926c 100644
--- a/contrib/completion/git-completion.bash
+++ b/contrib/completion/git-completion.bash
@@ -2773,16 +2773,16 @@ _git_show_branch ()
 
 _git_stash ()
 {
-       local save_opts='--all --keep-index --no-keep-index --quiet --patch 
--include-untracked'
+       local default_opts='--all --keep-index --no-keep-index --quiet --patch 
--include-untracked'
        local subcommands='push save list show apply clear drop pop create 
branch'
        local subcommand="$(__git_find_on_cmdline "$subcommands")"
        if [ -z "$subcommand" ]; then
                case "$cur" in
                --*)
-                       __gitcomp "$save_opts"
+                       __gitcomp "$default_opts"
                        ;;
                *)
-                       if [ -z "$(__git_find_on_cmdline "$save_opts")" ]; then
+                       if [ -z "$(__git_find_on_cmdline "$default_opts")" ]; 
then
                                __gitcomp "$subcommands"
                        fi
                        ;;
@@ -2790,10 +2790,10 @@ _git_stash ()
        else
                case "$subcommand,$cur" in
                push,--*)
-                       __gitcomp "$save_opts --message"
+                       __gitcomp "$default_opts --message"
                        ;;
                save,--*)
-                       __gitcomp "$save_opts"
+                       __gitcomp "$default_opts"
                        ;;
                apply,--*|pop,--*)
                        __gitcomp "--index --quiet"
-- 
2.17.0.252.gfe0a9eaf31

Reply via email to