Re: [PATCH 1/6] index-pack: factor out pack/idx finalization

2017-03-15 Thread Jeff King
On Wed, Mar 15, 2017 at 06:22:23PM -0400, Jeff King wrote: > Then we'd expect the newly-created .idx to have mode 0444, but it > doesn't. So yeah, I think the distinction does matter. > > I'm not sure if the best path is to include that flag in the > finalize_file() helper, or just ditch the help

Re: [PATCH 1/6] index-pack: factor out pack/idx finalization

2017-03-15 Thread Jeff King
On Wed, Mar 15, 2017 at 10:03:56PM +, Ramsay Jones wrote: > > - if (final_pack_name != curr_pack_name) { > > - if (!final_pack_name) { > > - snprintf(name, sizeof(name), "%s/pack/pack-%s.pack", > > -get_object_directory(), sha1_to_hex(s

Re: [PATCH 1/6] index-pack: factor out pack/idx finalization

2017-03-15 Thread Ramsay Jones
On 15/03/17 21:27, Jeff King wrote: > The procedure for moving the ".pack" and the ".idx" files > into place is the same. Rather than repeat the code, let's > factor it into a helper function. > > This has the added benefit of clarifying the lifetime of > "final_pack_name". In the original code

[PATCH 1/6] index-pack: factor out pack/idx finalization

2017-03-15 Thread Jeff King
The procedure for moving the ".pack" and the ".idx" files into place is the same. Rather than repeat the code, let's factor it into a helper function. This has the added benefit of clarifying the lifetime of "final_pack_name". In the original code it is sometimes redirected to our reusable "name"