Re: [PATCH v2 17/21] bisect: rename count_distance() to compute_weight()

2016-04-15 Thread Junio C Hamano
Stephan Beyer writes: > Let us use the term "weight" for the number of ancestors > of each commit, and "distance" for the number > min{weight, #commits - weight}. (Bisect finds the commit > with maximum distance.) > > In these terms, "count_distance()" is the wrong name of > the

Re: [PATCH v2 17/21] bisect: rename count_distance() to compute_weight()

2016-04-13 Thread Christian Couder
On Sun, Apr 10, 2016 at 3:19 PM, Stephan Beyer wrote: > > @@ -70,7 +70,7 @@ static inline int distance_direction(struct commit *commit) > return 0; > } > > -static int count_distance(struct commit *elem) > +static int compute_weight(struct commit *elem) > { >

[PATCH v2 17/21] bisect: rename count_distance() to compute_weight()

2016-04-10 Thread Stephan Beyer
Let us use the term "weight" for the number of ancestors of each commit, and "distance" for the number min{weight, #commits - weight}. (Bisect finds the commit with maximum distance.) In these terms, "count_distance()" is the wrong name of the function. So it is renamed to "compute_weight()", and