Re: Probable bug in file run-command.c function clear_child_for_cleanup

2012-09-11 Thread David Gould
Hi guys, Sorry for the delayed reply - what passes for my real life intruded somewhat. I'll get on to it today, but please be aware this will be my first-ever patch for ANY project, so am likely to foul up the process. I am reading the How To Submit Patches document even now Cheers,

Re: Probable bug in file run-command.c function clear_child_for_cleanup

2012-09-10 Thread Jeff King
On Sun, Sep 09, 2012 at 03:44:54PM +0100, David Gould wrote: static void clear_child_for_cleanup(pid_t pid) { struct child_to_clean **last, *p; last = children_to_clean; for (p = children_to_clean; p; p = p-next) { if (p-pid == pid) {

Re: Probable bug in file run-command.c function clear_child_for_cleanup

2012-09-10 Thread Erik Faye-Lund
On Mon, Sep 10, 2012 at 3:44 PM, Jeff King p...@peff.net wrote: On Sun, Sep 09, 2012 at 03:44:54PM +0100, David Gould wrote: You want something like: for (... { if (... { ... } last = p-next; } or (probably clearer, but I haven't read your coding style

Re: Probable bug in file run-command.c function clear_child_for_cleanup

2012-09-10 Thread Jeff King
On Mon, Sep 10, 2012 at 03:58:40PM +0200, Erik Faye-Lund wrote: for (... { if (... { ... } last = p-next; } [...] I feel like bikeshedding a bit today! I tend to either prefer either the latter or something like this: while (p) { ...

Re: Probable bug in file run-command.c function clear_child_for_cleanup

2012-09-10 Thread Junio C Hamano
Jeff King p...@peff.net writes: On Mon, Sep 10, 2012 at 03:58:40PM +0200, Erik Faye-Lund wrote: for (... { if (... { ... } last = p-next; } [...] I feel like bikeshedding a bit today! I tend to either prefer either the latter or something like

Re: Probable bug in file run-command.c function clear_child_for_cleanup

2012-09-10 Thread Jeff King
On Mon, Sep 10, 2012 at 01:00:35PM -0700, Junio C Hamano wrote: And to conclude my bikeshedding for the day: Shouldn't last ideally be called something like prev instead? It's the previously visited element, not the last element in the list. It is the last element visited (just as last

Re: Probable bug in file run-command.c function clear_child_for_cleanup

2012-09-10 Thread Junio C Hamano
Jeff King p...@peff.net writes: On Mon, Sep 10, 2012 at 01:00:35PM -0700, Junio C Hamano wrote: And to conclude my bikeshedding for the day: Shouldn't last ideally be called something like prev instead? It's the previously visited element, not the last element in the list. It is the

Probable bug in file run-command.c function clear_child_for_cleanup

2012-09-09 Thread David Gould
Hi, This is probably the wrong way to do this, and I'm sorry if I end up wasting someone's time. That said, here goes While idly browsing through the git source (as you do on a sunny Sunday afternoon), I spotted the following code (that appears to be wrong) in the file