RE: [PATCH] contrib/git-credential-gnome-keyring.c: small stylistic cleanups

2013-12-07 Thread Felipe Contreras
John Szakmeister wrote: Signed-off-by: John Szakmeister j...@szakmeister.net --- The gnome-keyring credential backend had a number of coding style violations. I believe this fixes all of them. .../gnome-keyring/git-credential-gnome-keyring.c | 55 ++ 1 file

RE: [PATCH] push: Allow @ shortcut with git-push

2013-12-07 Thread Felipe Contreras
Tomo Krajina wrote: Until now, HEAD could be used with git-push to push the current branch. Now @ is a shortcut to HEAD, but it didn't work when pushing branches. It fails with: fatal: remote part of refspec is not a valid name in @ Reinterpret all branch names from argv in order for @

Re: [PATCH v6 06/10] fast-export: add new --refspec option

2013-12-07 Thread Felipe Contreras
Junio C Hamano wrote: Junio C Hamano gits...@pobox.com writes: Felipe Contreras felipe.contre...@gmail.com writes: But it does not have to stay that way. In order to move things forward in that direction, this new configuration has to be distinguishable from the traditional refspec, as it

RE: What's cooking in git.git (Dec 2013, #02; Fri, 6)

2013-12-07 Thread Felipe Contreras
Junio C Hamano wrote: * fc/transport-helper-fixes (2013-11-13) 12 commits - remote-bzr: support the new 'force' option - transport-helper: add support to delete branches - fast-export: add support to delete refs - fast-import: add support to delete refs - transport-helper: add support

[PATCH v2] contrib/git-credential-gnome-keyring.c: small stylistic cleanups

2013-12-07 Thread John Szakmeister
Signed-off-by: John Szakmeister j...@szakmeister.net Reviewed-by: Felipe Contreras felipe.contre...@gmail.com --- v2 removes some unnecessary casting noticed by Felipe. Thanks for the feedback Felipe! .../gnome-keyring/git-credential-gnome-keyring.c | 55 ++ 1 file

Please Confirm

2013-12-07 Thread Jack Kofi (ESQ).
Greetings to you, I am Jack Kofi, esq. I want to solicit your consideration to receive some funds (US$9.5M) on my behalf. Get back to me if you are interested so that i can provide you with more details. Yours Sincerely, Jack Kofi -- To unsubscribe from this list: send the line unsubscribe

[PATCH] remote: fix status with branch...rebase=preserve

2013-12-07 Thread Felipe Contreras
Commit 66713ef (pull: allow pull to preserve merges when rebasing) didn't include an update so 'git remote status' parses branch.name.rebase=preserve correctly, let's do that. Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- builtin/remote.c | 9 +++-- 1 file changed, 7

[PATCH 0/4] remote-helpers: fixes

2013-12-07 Thread Felipe Contreras
Felipe Contreras (3): remote-helpers: add extra safety checks remote-hg: fix 'shared path' path remote-hg: add tests for special filenames jcb91 (1): remote-hg: avoid buggy strftime() contrib/remote-helpers/git-remote-bzr | 14 +--- contrib/remote-helpers/git-remote-hg | 19

[PATCH 1/4] remote-hg: avoid buggy strftime()

2013-12-07 Thread Felipe Contreras
From: jcb91 joshuacookebar...@gmail.com error on pull: fatal: Invalid raw date in ident: remote-hg Neither %s nor %z are officially supported by python, they may work on some (most?) platforms, but not all. removed strftime use of %s and %z, which are not officially supported by python,

[PATCH 3/4] remote-hg: fix 'shared path' path

2013-12-07 Thread Felipe Contreras
If the repository is moved, the absolute path of the shared repository would fail. Make sure it's always up-to-date. Reported-by: Michael Davis mjmda...@gmail.com Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- contrib/remote-helpers/git-remote-hg | 3 +++ 1 file changed, 3

[PATCH 2/4] remote-helpers: add extra safety checks

2013-12-07 Thread Felipe Contreras
Suggested-by: Roman Ovchinnikov coolthec...@gmail.com Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- contrib/remote-helpers/git-remote-bzr | 14 ++ contrib/remote-helpers/git-remote-hg | 14 ++ 2 files changed, 20 insertions(+), 8 deletions(-) diff --git

[PATCH 4/4] remote-hg: add tests for special filenames

2013-12-07 Thread Felipe Contreras
So that we check that UTF-8 and spaces work fine. Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- contrib/remote-helpers/test-hg.sh | 68 +++ 1 file changed, 68 insertions(+) diff --git a/contrib/remote-helpers/test-hg.sh

[PATCH] completion: fix completion of certain aliases

2013-12-07 Thread Felipe Contreras
Some commands need the first word to determine the actual action that is being executed, however, the command is wrong when we use an alias, for example 'alias.p=push', if we try to complete 'git p origin ', the result would be wrong because __git_complete_remote_or_refspec() doesn't know where it

Re: [PATCH v3 11/21] pack-objects: use bitmaps when packing objects

2013-12-07 Thread Thomas Rast
This week's nits... I found this harder to read than the previous patch, but I think it's mostly because the existing code is already a bit tangled. I think the second item below is worth fixing, though. Jeff King p...@peff.net writes: +static off_t write_reused_pack(struct sha1file *f) +{

Re: [PATCH v3 12/21] rev-list: add bitmap mode to speed up object lists

2013-12-07 Thread Thomas Rast
Jeff King p...@peff.net writes: Documentation/git-rev-list.txt | 1 + Documentation/rev-list-options.txt | 8 builtin/rev-list.c | 39 ++ 3 files changed, 48 insertions(+) Nice and short. Cheating though, as a lot of the

[PATCH v2 00/10] teach replace objects to sha1_object_info_extended()

2013-12-07 Thread Christian Couder
Here is version 2 of a patch series to improve the way sha1_object_info_extended() behaves when it is passed a replaced object. The idea is to add a flags argument to it in the same way as what has been done to read_sha1_file(). This patch series was inspired by a sub thread in this discussion:

[PATCH v2 10/10] Documentation/git-replace: describe --format option

2013-12-07 Thread Christian Couder
Signed-off-by: Christian Couder chrisc...@tuxfamily.org --- Documentation/git-replace.txt | 19 ++- 1 file changed, 18 insertions(+), 1 deletion(-) diff --git a/Documentation/git-replace.txt b/Documentation/git-replace.txt index f373ab4..7a07828 100644 ---

[PATCH v2 07/10] builtin/replace: teach listing using short, medium or full formats

2013-12-07 Thread Christian Couder
By default when listing replace refs, only the sha1 of the replaced objects are shown. In many cases, it is much nicer to be able to list all the sha1 of the replaced objects along with the sha1 of the replacment objects. And in other cases it might be interesting to also show the types of the

[PATCH v2 09/10] builtin/replace: unset read_replace_refs

2013-12-07 Thread Christian Couder
When checking to see if some objects are of the same type and when displaying the type of objects, git replace uses the sha1_object_info() function. Unfortunately this function by default respects replace refs, so instead of the type of a replaced object, it gives the type of the replacement

[PATCH v2 04/10] Add an unsigned flags parameter to sha1_object_info_extended()

2013-12-07 Thread Christian Couder
This parameter is not used yet, but it will be used to tell sha1_object_info_extended() if it should perform object replacement or not. Signed-off-by: Christian Couder chrisc...@tuxfamily.org --- builtin/cat-file.c | 2 +- cache.h| 2 +- sha1_file.c| 6 +++--- streaming.c

[PATCH v2 06/10] sha1_file: perform object replacement in sha1_object_info_extended()

2013-12-07 Thread Christian Couder
sha1_object_info_extended() should perform object replacement if it is needed. The simplest way to do that is to make it call lookup_replace_object_extended(). And now its unsigned flags parameter is used as it is passed to lookup_replace_object_extended(). Signed-off-by: Christian Couder

[PATCH v2 03/10] Introduce lookup_replace_object_extended() to pass flags

2013-12-07 Thread Christian Couder
Currently, there is only one caller to lookup_replace_object() that can benefit from passing it some flags, but we expect that there could be more. Signed-off-by: Christian Couder chrisc...@tuxfamily.org --- cache.h | 6 ++ sha1_file.c | 3 +-- 2 files changed, 7 insertions(+), 2

[PATCH v2 02/10] replace_object: don't check read_replace_refs twice

2013-12-07 Thread Christian Couder
Since ecef (inline lookup_replace_object() calls, May 15 2011) the read_replace_refs global variable is checked twice, once in lookup_replace_object() and once again in do_lookup_replace_object(). As do_lookup_replace_object() is called only from lookup_replace_object(), we can remove the

Re: [PATCH v3 16/21] repack: handle optional files created by pack-objects

2013-12-07 Thread Thomas Rast
Jeff King p...@peff.net writes: We ask pack-objects to pack to a set of temporary files, and then rename them into place. Some files that pack-objects creates may be optional (like a .bitmap file), in which case we would not want to call rename(). We already call stat() and make the chmod

Re: [PATCH v3 17/21] repack: consider bitmaps when performing repacks

2013-12-07 Thread Thomas Rast
Jeff King p...@peff.net writes: From: Vicent Marti tan...@gmail.com Since `pack-objects` will write a `.bitmap` file next to the `.pack` and `.idx` files, this commit teaches `git-repack` to consider the new bitmap indexes (if they exist) when performing repack operations. This implies

Re: [PATCH v3 18/21] count-objects: recognize .bitmap in garbage-checking

2013-12-07 Thread Thomas Rast
Jeff King p...@peff.net writes: From: Nguyễn Thái Ngọc Duy pclo...@gmail.com Count-objects will report any garbage files in the packs directory, including files whose extensions it does not know (case 1), and files whose matching .pack file is missing (case 2). Without having learned about

Re: [PATCH v3 19/21] t: add basic bitmap functionality tests

2013-12-07 Thread Thomas Rast
Jeff King p...@peff.net writes: Now that we can read and write bitmaps, we can exercise them with some basic functionality tests. These tests aren't particularly useful for seeing the benefit, as the test repo is too small for it to make a difference. However, we can at least check that

Re: [PATCH v3 20/21] t/perf: add tests for pack bitmaps

2013-12-07 Thread Thomas Rast
Jeff King p...@peff.net writes: +test_perf 'simulated fetch' ' + have=$(git rev-list HEAD --until=1.week.ago -1) This will give you HEAD if your GIT_PERF_LARGE_REPO hasn't seen any activity lately. I'd prefer something that always takes a fixed commit, e.g. HEAD~1000, keeping the perf

Re: [PATCH v3 21/21] pack-bitmap: implement optional name_hash cache

2013-12-07 Thread Thomas Rast
Jeff King p...@peff.net writes: Test origin/master HEAD^ HEAD - 5310.2: repack to disk36.81(37.82+1.43) 47.70(48.74+1.41) +29.6%

[PATCH 2/4] subtree: allow --squash and --message with push

2013-12-07 Thread Matthew Ogilvie
Signed-off-by: Matthew Ogilvie mmogilvi_...@miniinfo.net --- contrib/subtree/git-subtree.sh | 8 +++- contrib/subtree/git-subtree.txt | 9 - 2 files changed, 7 insertions(+), 10 deletions(-) diff --git a/contrib/subtree/git-subtree.sh b/contrib/subtree/git-subtree.sh index

[PATCH 3/4] subtree: add --edit option

2013-12-07 Thread Matthew Ogilvie
Signed-off-by: Matthew Ogilvie mmogilvi_...@miniinfo.net --- contrib/subtree/git-subtree.sh | 37 + contrib/subtree/git-subtree.txt | 4 2 files changed, 33 insertions(+), 8 deletions(-) diff --git a/contrib/subtree/git-subtree.sh

[PATCH 1/4] subtree: support split --rejoin --squash

2013-12-07 Thread Matthew Ogilvie
Allow using --squash with git subtree split --rejoin. It will still split off (and save to --branch) the complete subtree history, but the merge done for the --rejoin will be merging a squashed representation of the new subtree commits, instead of the commits themselves (similar to how git

[PATCH/BAD 4/4] subtree: poor bugfix for split new commits with parents before previous split

2013-12-07 Thread Matthew Ogilvie
Bug description: Unless you use --ignore-joins, git subtree split's optimization to avoid re-scanning all of history can trim too much. Any new merged branches that have parents before the previous split will not be re-attached properly in the split-off subtree. In the extreme case (if all the

Re: [PATCH v2 09/10] builtin/replace: unset read_replace_refs

2013-12-07 Thread Jakub Narebski
Christian Couder chriscool at tuxfamily.org writes: When checking to see if some objects are of the same type and when displaying the type of objects, git replace uses the sha1_object_info() function. Unfortunately this function by default respects replace refs, so instead of the type of

Re: [PATCH v2 09/10] builtin/replace: unset read_replace_refs

2013-12-07 Thread Christian Couder
On Sat, Dec 7, 2013 at 8:02 PM, Jakub Narebski jna...@gmail.com wrote: Wasn't replace mechanism tightened, so that replacing object must be the same type as replaced object? Yes, but if --force is used or if the replace ref is created with git update-ref, then it is not enforced. Is there a

Re: Git reports

2013-12-07 Thread Muzaffer Tolga Ozses
I looked at man git-http-backend, and I didn't understand a thing. I'll look at it tomorrow again with a clear head. On 7 December 2013 00:22, Jeff King p...@peff.net wrote: On Fri, Dec 06, 2013 at 11:26:51AM -0800, Jonathan Nieder wrote: I am cloning over http I am guessing you are using

Re: What's cooking in git.git (Dec 2013, #02; Fri, 6)

2013-12-07 Thread Karsten Blees
Am 07.12.2013 00:52, schrieb Junio C Hamano: * kb/doc-exclude-directory-semantics (2013-11-07) 1 commit - gitignore.txt: clarify recursive nature of excluded directories Originally merged to 'next' on 2013-11-13 Kicked back to 'pu' to replace with a newer reroll ($gmane/237814 looked

Re: What's cooking in git.git (Dec 2013, #02; Fri, 6)

2013-12-07 Thread Felipe Contreras
On Sat, Dec 7, 2013 at 4:03 AM, Felipe Contreras felipe.contre...@gmail.com wrote: Junio C Hamano wrote: * fc/transport-helper-fixes (2013-11-13) 12 commits - remote-bzr: support the new 'force' option - transport-helper: add support to delete branches - fast-export: add support to delete

Re: [PATCH v3 10/21] pack-bitmap: add support for bitmap indexes

2013-12-07 Thread Karsten Blees
Am 03.12.2013 19:21, schrieb Jeff King: On Tue, Dec 03, 2013 at 03:40:41PM +0100, Karsten Blees wrote: IMO, trying to improve khash isn't worth the trouble. With smaller-than-pointer types, khash _may_ actually save a few bytes compared to hash.[ch] or hashmap.[ch]. E.g. a set of 'int's

[PATCH v8 1/6] transport-helper: mismerge fix

2013-12-07 Thread Felipe Contreras
Commit 9c51558 (transport-helper: trivial code shuffle) moved these lines above, but 99d9ec0 (Merge branch 'fc/transport-helper-no-refspec') had a wrong merge conflict and readded them. Reported-by: Richard Hansen rhan...@bbn.com Signed-off-by: Felipe Contreras felipe.contre...@gmail.com

[PATCH v8 0/6] transport-helper: fixes

2013-12-07 Thread Felipe Contreras
Hi, These patches add support for remote helpers --force, --dry-run, and reporting forced update. No changes since last version. The later patches for renaming branches, deleting them, custom refspecs have beend dropped because Junio doesn't like the name --refspec, although the argument is

[PATCH v8 6/6] remote-bzr: support the new 'force' option

2013-12-07 Thread Felipe Contreras
From: Richard Hansen rhan...@bbn.com Signed-off-by: Richard Hansen rhan...@bbn.com Acked-by: Felipe Contreras felipe.contre...@gmail.com Signed-off-by: Junio C Hamano gits...@pobox.com Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- contrib/remote-helpers/git-remote-bzr | 31

[PATCH v8 5/6] test-hg.sh: tests are now expected to pass

2013-12-07 Thread Felipe Contreras
From: Richard Hansen rhan...@bbn.com Signed-off-by: Richard Hansen rhan...@bbn.com Signed-off-by: Junio C Hamano gits...@pobox.com Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- contrib/remote-helpers/test-hg.sh | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff

Re: What's cooking in git.git (Dec 2013, #02; Fri, 6)

2013-12-07 Thread Thomas Rast
Karsten Blees karsten.bl...@gmail.com writes: Extending 'struct hashmap_entry' with an int-sized member shouldn't waste memory on 64-bit systems. This is already documented in api-hashmap.txt, but needs '__attribute__((__packed__))' to work. Reduces e.g. You'd have to guard

Re: What's cooking in git.git (Dec 2013, #02; Fri, 6)

2013-12-07 Thread Karsten Blees
Am 07.12.2013 23:23, schrieb Thomas Rast: Karsten Blees karsten.bl...@gmail.com writes: Extending 'struct hashmap_entry' with an int-sized member shouldn't waste memory on 64-bit systems. This is already documented in api-hashmap.txt, but needs '__attribute__((__packed__))' to work. Reduces

[PATCH] i18n: move the trailing space out of translatable strings

2013-12-07 Thread Nguyễn Thái Ngọc Duy
I've got this with Vietnamese translation $ git status HEAD được tách rời từorigin/master One does not need to understand Vietnamese to see that a space is missing before origin/master and this is because the original string has a trailing space, but the translated one omits it. I could

Thomas Sabo Charms 2013

2013-12-07 Thread oierzn
Ich mag positiv denken, um für meine Situation Direkt Verwendung als Buch mit Tiffany Schmuck, Wann immer ich tun, die subtile Botschaft zu fahren weniger relevant. Die Schnell bläulich -Boxen sind in der Tat so schnell wie Amors Pfeil durchbohren einer Frau Mitte . Oder vielleicht das Geld

pandora charms online sale

2013-12-07 Thread oierzn
However, in all of the literature version, the mythology because all-natural theology to explain the existence of sin in pandora charms online sale http://www.designerjewelrycheapsale-usa.com the field. In a word, its one filled with possibility of beauty, and complete of strange charms.The

[PATCH 0/7] Trivial patches

2013-12-07 Thread Felipe Contreras
Felipe Contreras (7): config: avoid yoda conditions add: avoid yoda conditions abspath: trivial style fix t: trivial whitespace cleanups fetch: add missing documentation sha1_name: cleanup interpret_branch_name() sha1_name: simplify track finding Documentation/git-fetch.txt | 3

[PATCH 1/7] config: avoid yoda conditions

2013-12-07 Thread Felipe Contreras
Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- config.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/config.c b/config.c index e1d66a1..7a44414 100644 --- a/config.c +++ b/config.c @@ -610,7 +610,7 @@ static int git_config_maybe_bool_text(const char

[PATCH 3/7] abspath: trivial style fix

2013-12-07 Thread Felipe Contreras
Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- abspath.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/abspath.c b/abspath.c index e390994..8b3385a 100644 --- a/abspath.c +++ b/abspath.c @@ -143,7 +143,7 @@ static const char *real_path_internal(const char

[PATCH 5/7] fetch: add missing documentation

2013-12-07 Thread Felipe Contreras
There's no mention of the 'origin' default, or the fact that the upstream tracking branch remote is used. Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- Documentation/git-fetch.txt | 3 +++ 1 file changed, 3 insertions(+) diff --git a/Documentation/git-fetch.txt

[PATCH 4/7] t: trivial whitespace cleanups

2013-12-07 Thread Felipe Contreras
Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- t/t0002-gitfile.sh| 3 +-- t/t0003-attributes.sh | 1 - 2 files changed, 1 insertion(+), 3 deletions(-) diff --git a/t/t0002-gitfile.sh b/t/t0002-gitfile.sh index cb14425..37e9396 100755 --- a/t/t0002-gitfile.sh +++