Re: Allow git alias to override existing Git commands

2015-11-10 Thread Sitaram Chamarty
On 11/11/15 01:34, Jeremy Morton wrote: > On 10/11/2015 18:12, Stefan Beller wrote: >> On Tue, Nov 10, 2015 at 8:31 AM, Jeremy Morton wrote: >>> It's recently come to my attention that the "git alias" config functionality >>> ignores all aliases that would override existing Git commands. This see

Re: [PATCH 1/7] contrib/subtree: Clean and refactor test code

2015-11-10 Thread David A. Greene
David Greene writes: Just a ping to ask if anyone has looked at this. Apparently send-email uses the commit author as the From address. These messages are actually from me, sent on behalf of the commit authors. I've got more coming, but want to get these in first as they clean up the testsuite

[PATCH 0/5] ff-refs: builtin command to fast-forward local refs

2015-11-10 Thread Michael Rappazzo
This patch series is built on (based on) 'next' because it relies on worktree.c `ff-refs` will update local branches which can be fast-forwarded to their upstream tracking branch. Any branch which has diverged from the upstream will be left untouched by this command. Additionally, there are opti

[PATCH 4/5] ff-refs: Add documentation

2015-11-10 Thread Michael Rappazzo
Signed-off-by: Michael Rappazzo --- Documentation/git-ff-refs.txt | 55 +++ 1 file changed, 55 insertions(+) create mode 100644 Documentation/git-ff-refs.txt diff --git a/Documentation/git-ff-refs.txt b/Documentation/git-ff-refs.txt new file mode 100644 i

[PATCH 5/5] ff-refs: Add tests

2015-11-10 Thread Michael Rappazzo
Signed-off-by: Michael Rappazzo --- t/t7900-ff-refs.sh | 164 + 1 file changed, 164 insertions(+) create mode 100755 t/t7900-ff-refs.sh diff --git a/t/t7900-ff-refs.sh b/t/t7900-ff-refs.sh new file mode 100755 index 000..3cfbcb8 --- /dev/n

[PATCH 3/5] ff-refs: add --dry-run and --skip-worktree options

2015-11-10 Thread Michael Rappazzo
'--dry-run' reports the updatable state of each ref without acutally updating any refs. Refs which are fast-forwardable are reported as 'WOULD-UPDATE'. '--skip-worktrees' does not update refs which are checked out in any worktree. Branches which are fast-forwardable but checked out in a worktree

[PATCH 1/5] ff-refs: builtin cmd to check and fast forward local refs to their upstream

2015-11-10 Thread Michael Rappazzo
Each local branch with an upstream remote is checked to see if it can be fast-forwarded to its upstream. If fast-forward applies to the branch, then this is reported to the user. The statuses are UP-TO-DATE - The local branch is the same or equal to the upstream WOULD-UPDATE - The

[PATCH 2/5] ff-refs: update each updatable ref

2015-11-10 Thread Michael Rappazzo
If an updatable ref is checked out in any worktree, emulate merge --ff-only to also update the local work tree (including executing the post-merge hook). If an updatable ref is not checked out in any worktree, the ref is simply updated. If a ref update is successful, that ref is reported as 'UPDA

Re: [PATCH] http: fix some printf format warnings on 32-bit builds

2015-11-10 Thread Stefan Beller
On Tue, Nov 10, 2015 at 5:22 PM, Eric Sunshine wrote: > On Tue, Nov 10, 2015 at 7:23 PM, Ramsay Jones > wrote: >> Commit f8117f55 ("http: use off_t to store partial file size", >> 02-11-2015) changed the type of some variables from long to off_t. >> The 32-bit build, which enables the large files

Re: [PATCH] http: fix some printf format warnings on 32-bit builds

2015-11-10 Thread Eric Sunshine
On Tue, Nov 10, 2015 at 7:23 PM, Ramsay Jones wrote: > Commit f8117f55 ("http: use off_t to store partial file size", > 02-11-2015) changed the type of some variables from long to off_t. > The 32-bit build, which enables the large filesystem interface > (_FILE_OFFSET_BITS == 64), defines the off_t

[PATCH] http: fix some printf format warnings on 32-bit builds

2015-11-10 Thread Ramsay Jones
Commit f8117f55 ("http: use off_t to store partial file size", 02-11-2015) changed the type of some variables from long to off_t. The 32-bit build, which enables the large filesystem interface (_FILE_OFFSET_BITS == 64), defines the off_t type as a 64-bit integer, whereas long is a 32-bit integer.

Re: git-credential-cache--daemon quits on SIGHUP, can we change it to ignore instead?

2015-11-10 Thread Noam Postavsky
I think you're right about the automated test not being worth the trouble. On Tue, Nov 10, 2015 at 7:26 AM, Jeff King wrote: > To clarify: just telling me it's OK to add your sign-off is fine here. I > can add it (and fix up the style thing) as I apply. Ok, please do that then, thanks. -- To uns

Re: Allow git alias to override existing Git commands

2015-11-10 Thread Stefan Beller
On Tue, Nov 10, 2015 at 1:57 PM, Jens Lehmann wrote: > Am 10.11.2015 um 19:12 schrieb Stefan Beller: >> >> On Tue, Nov 10, 2015 at 8:31 AM, Jeremy Morton >> wrote: >>> >>> It's recently come to my attention that the "git alias" config >>> functionality >>> ignores all aliases that would override

Re: [PATCHv3 08/11] fetching submodules: respect `submodule.jobs` config option

2015-11-10 Thread Stefan Beller
On Tue, Nov 10, 2015 at 2:21 PM, Jens Lehmann wrote: >> +submodule.jobs:: >> + This is used to determine how many submodules can be operated on in >> + parallel. Specifying a positive integer allows up to that number >> + of submodules being fetched in parallel. This is used in f

Re: [PATCHv3 08/11] fetching submodules: respect `submodule.jobs` config option

2015-11-10 Thread Jens Lehmann
Am 04.11.2015 um 01:37 schrieb Stefan Beller: This allows to configure fetching and updating in parallel without having the command line option. This moved the responsibility to determine how many parallel processes to start from builtin/fetch to submodule.c as we need a way to communicate "The

Re: Allow git alias to override existing Git commands

2015-11-10 Thread Jens Lehmann
Am 10.11.2015 um 19:12 schrieb Stefan Beller: On Tue, Nov 10, 2015 at 8:31 AM, Jeremy Morton wrote: It's recently come to my attention that the "git alias" config functionality ignores all aliases that would override existing Git commands. This seems like a bad idea to me. This ensures that

Re: [PATCH 0/5] Use watchman to reduce index refresh time

2015-11-10 Thread David Turner
On Mon, 2015-11-09 at 21:06 +0100, Christian Couder wrote: > Using David's series I get worse results than all of the above but I > guess it's because his series is based on an ancient git version > (v2.0.0-rc0). My more-recent series is on top of 2.4, but (for webkit): mine: 0m0.206s duy's: 0m0.

Re: [PATCH v5] Add git-grep threads param

2015-11-10 Thread Eric Sunshine
On Tue, Nov 10, 2015 at 8:28 AM, Victor Leschuk wrote: > "git grep" can now be configured (or told from the command line) > how many threads to use when searching in the working tree files. > > Signed-off-by: Victor Leschuk > --- As an aid for reviewers, please use this space (below the "---" l

Re: Allow git alias to override existing Git commands

2015-11-10 Thread Stefan Beller
On Tue, Nov 10, 2015 at 12:04 PM, Jeremy Morton wrote: > On 10/11/2015 18:12, Stefan Beller wrote: >> >> On Tue, Nov 10, 2015 at 8:31 AM, Jeremy Morton >> wrote: >>> >>> It's recently come to my attention that the "git alias" config >>> functionality >>> ignores all aliases that would override exi

Re: [PATCH 2/2] contrib/git-candidate: Add README

2015-11-10 Thread David Turner
I didn't actually read the code. Instead, I started with the README and decided to provide both text and UX comments all mixed up. These are mostly my personal preferences; take them or leave them as you choose. I'm really excited about this tool and I think it's got great potential! On Tue, 2

Announcing Git for Windows 2.6.3

2015-11-10 Thread Johannes Schindelin
Dear Git users, it is my pleasure to announce that Git for Windows 2.6.3 is available from https://git-for-windows.github.io/ Changes since Git for Windows v2.6.2 (October 19th 2015) New Features • Comes with Git v2.6.3. • Enables the stack smasher to protect against buffer overflows. Bug

Re: Allow git alias to override existing Git commands

2015-11-10 Thread Jeremy Morton
On 10/11/2015 18:12, Stefan Beller wrote: On Tue, Nov 10, 2015 at 8:31 AM, Jeremy Morton wrote: It's recently come to my attention that the "git alias" config functionality ignores all aliases that would override existing Git commands. This seems like a bad idea to me. This ensures that the

Re: gitk fails to start after upgrading to 2.6.3 (cannot load translation)

2015-11-10 Thread Beat Bolli
On 10.11.15 10:48, Peter Krefting wrote: > Hi! > > After upgrading Git to 2.6.3 (from 2.5.0), gitk refuses to start when > trying to load the Swedish translation if I pass it a commit range: The patch can be found here: http://article.gmane.org/gmane.comp.version-control.git/278863 Cheers, Beat

Re: Allow git alias to override existing Git commands

2015-11-10 Thread Stefan Beller
On Tue, Nov 10, 2015 at 8:31 AM, Jeremy Morton wrote: > It's recently come to my attention that the "git alias" config functionality > ignores all aliases that would override existing Git commands. This seems > like a bad idea to me. This ensures that the plumbing commands always work as expecte

[PATCH v2] contrib/subtree: remove "push" command from the "todo" file

2015-11-10 Thread Fabio Porcedda
Because the "push" command is already available, remove it from the "todo" file. Signed-off-by: Fabio Porcedda --- contrib/subtree/todo | 2 -- 1 file changed, 2 deletions(-) diff --git a/contrib/subtree/todo b/contrib/subtree/todo index 7e44b00..0d0e777 100644 --- a/contrib/subtree/todo +++ b/

Re: [PATCH] contrib/subtree: remove "push" command from the "todo" file

2015-11-10 Thread Eric Sunshine
On Tue, Nov 10, 2015 at 12:58 PM, Fabio Porcedda wrote: > On Thu, Nov 5, 2015 at 11:57 PM, Eric Sunshine > wrote: >> On Thu, Nov 5, 2015 at 10:26 AM, Fabio Porcedda >> wrote: >> > Because the "push" command is already avaiable, remove it from the >> >> s/avaiable/available/ > > Thanks, i will se

Allow git alias to override existing Git commands

2015-11-10 Thread Jeremy Morton
It's recently come to my attention that the "git alias" config functionality ignores all aliases that would override existing Git commands. This seems like a bad idea to me. For example, I wanted to setup "git clone" to automatically act as "git clone --recursive". Sure I could do it in the

[bug] git 2.6.2 (64-bit) blocks keyboard input (running in RDP, Win7 x64)

2015-11-10 Thread Ryabov, Vasily V
Hi, I'm trying to run something like this (on the remote machine (Win7 x64 with git 2.6.2 64-bit) through RDP): ``` git pull --tags --progress ssh://@:/ +refs/heads/*:refs/remotes/origin/* ``` It worked on local machine with git 1.9.5. Git asks to confirm an action: ``` The server's host k

[PATCH v5] Add git-grep threads param

2015-11-10 Thread Victor Leschuk
"git grep" can now be configured (or told from the command line) how many threads to use when searching in the working tree files. Signed-off-by: Victor Leschuk --- Documentation/config.txt | 7 + Documentation/git-grep.txt | 15 ++ builtin/grep.c

[PATCH 1/2] contrib: Add git-candidate subcommand

2015-11-10 Thread Richard Ipsum
git-candidate provides candidate review and patch tracking, allowing distributed comment and review facilities with all content stored in git. Signed-off-by: Richard Ipsum --- contrib/git-candidate/GitUtils.pm| 207 +++ contrib/git-candidate/git-candidate.perl | 2541 +++

[PATCH 0/2] git-candidate: git based patch tracking and review

2015-11-10 Thread Richard Ipsum
Hi, I've continued my work[1] to add patch tracking and candidate review capability to git. git-candidate now has a more git-like user interface, so remote candidates can now be specified in a similar way to remote refs (e.g. origin/candidate) as well as various other improvements, such as versio

[PATCH 2/2] contrib/git-candidate: Add README

2015-11-10 Thread Richard Ipsum
Describes motivation for git-candidate and shows an example workflow. Signed-off-by: Richard Ipsum --- contrib/git-candidate/README.md | 154 1 file changed, 154 insertions(+) create mode 100644 contrib/git-candidate/README.md diff --git a/contrib/git-c

Re: git-credential-cache--daemon quits on SIGHUP, can we change it to ignore instead?

2015-11-10 Thread Jeff King
On Tue, Nov 10, 2015 at 07:25:02AM -0500, Jeff King wrote: > > Introduce new option "credentialCache.ignoreSIGHUP" which stops > > git-credential-cache--daemon from quitting on SIGHUP. This is useful > > when "git push" is started from Emacs, because all child > > processes (including the daemon)

Re: git-credential-cache--daemon quits on SIGHUP, can we change it to ignore instead?

2015-11-10 Thread Jeff King
On Mon, Nov 09, 2015 at 08:05:25PM -0500, Noam Postavsky wrote: > > Automated tests would be nice, but I suspect it may be too complicated > > to be worth it. > > I attempted > > test_ignore_sighup () > { > mkdir "$HOME/.git-credential-cache" && > chmod 0700 "$HOME/.git-credential-cache"

[PATCH v8 03/10] copy_msg(): rename to copy_reflog_msg()

2015-11-10 Thread Michael Haggerty
From: David Turner We will soon increase the visibility of this function, so make its name more distinctive. Signed-off-by: David Turner Signed-off-by: Junio C Hamano Signed-off-by: Michael Haggerty --- refs.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/refs.c b/r

[PATCH v8 02/10] verify_refname_available(): new function

2015-11-10 Thread Michael Haggerty
From: Ronnie Sahlberg Add a new verify_refname_available() function, which checks whether the refname is available for use, taking all references (both packed and loose) into account. This function, unlike the old verify_refname_available(), has semantics independent of the choice of reference st

[PATCH v8 04/10] pack_if_possible_fn(): use ref_type() instead of is_per_worktree_ref()

2015-11-10 Thread Michael Haggerty
is_per_worktree_ref() will soon be made private, so use the public interface, ref_type(), in its place. And now that we're using ref_type(), we can make it clear that we won't pack pseudorefs. This was the case before, but due to the not-so-obvious reason that this function is applied to references

[PATCH v8 05/10] refname_is_safe(): improve docstring

2015-11-10 Thread Michael Haggerty
Signed-off-by: Michael Haggerty --- refs.c | 16 ++-- 1 file changed, 10 insertions(+), 6 deletions(-) diff --git a/refs.c b/refs.c index 82129f0..f48c58a 100644 --- a/refs.c +++ b/refs.c @@ -341,13 +341,17 @@ static struct ref_dir *get_ref_dir(struct ref_entry *entry) } /* - *

[PATCH v8 09/10] files_log_ref_write: new function

2015-11-10 Thread Michael Haggerty
From: David Turner Because HEAD and stash are per-worktree, every refs backend needs to go through the files backend to write these refs. So create a new function, files_log_ref_write, and add it to refs/refs-internal.h. Later, we will use this to handle reflog updates for per-worktree symbolic

[PATCH v8 06/10] refs/refs-internal.h: new header file

2015-11-10 Thread Michael Haggerty
There are a number of constants, structs, and static functions defined in refs.c and treated as private to the references module. But we want to support multiple reference backends within the reference module, and those backends will need access to some heretofore private declarations. We don't wa

[PATCH v8 01/10] verify_refname_available(): rename function

2015-11-10 Thread Michael Haggerty
From: Ronnie Sahlberg Rename verify_refname_available() to verify_refname_available_dir() to make the old name available for a more general purpose. Signed-off-by: Ronnie Sahlberg Signed-off-by: David Turner Signed-off-by: Junio C Hamano Signed-off-by: Michael Haggerty --- refs.c | 44 +

[PATCH v8 08/10] initdb: make safe_create_dir public

2015-11-10 Thread Michael Haggerty
From: David Turner Soon we will want to create initdb functions for ref backends, and code from initdb that calls this function needs to move into the files backend. So this function needs to be public. Signed-off-by: David Turner Signed-off-by: Junio C Hamano Signed-off-by: Michael Haggerty

[PATCH v8 10/10] refs: break out ref conflict checks

2015-11-10 Thread Michael Haggerty
From: David Turner Create new function find_descendant_ref, to hold one of the ref conflict checks used in verify_refname_available. Multiple backends will need this function, so move it to the common code. Also move rename_ref_available to the common code, because alternate backends might need

[PATCH v8 00/10] refs backend pre-vtable

2015-11-10 Thread Michael Haggerty
Another re-roll of this patch series, to address the comments of Ramsay Jones (thanks!) about v7 [1]. This version has the following changes compared to v7: * Drop "refs: make is_branch public" patch. This was already done quite a while ago: e7e0f26 refs.c: add a public is_branch functio

Re: gitk fails to start after upgrading to 2.6.3 (cannot load translation)

2015-11-10 Thread Dennis Kaarsemaker
On di, 2015-11-10 at 10:48 +0100, Peter Krefting wrote: > Hi! > > After upgrading Git to 2.6.3 (from 2.5.0), gitk refuses to start when > trying to load the Swedish translation if I pass it a commit range: Hi Peter, This bug has been reported a few times already and a fix will be in git 2.7. --

gitk fails to start after upgrading to 2.6.3 (cannot load translation)

2015-11-10 Thread Peter Krefting
Hi! After upgrading Git to 2.6.3 (from 2.5.0), gitk refuses to start when trying to load the Swedish translation if I pass it a commit range: $ gitk v2.5.0..v2.6.3 Error in startup script: bad menu entry index "Ändra vy..." while executing ".bar.view entryconf [mca "Edit view..."]