[PATCH] git-p4: parse marshal output "p4 -G" in p4 changes

2017-07-03 Thread Miguel Torroja
The option -G of p4 (python marshal output) gives more context about the data being output. That's useful when using the command "change -o" as we can distinguish between warning/error line and real change description. Some p4 triggers in the server side generate some warnings when executed.

Re: [PATCH] git-p4: parse marshal output "p4 -G" in p4 changes

2017-07-03 Thread Miguel Torroja
I changed the patch a little bit, first change is to ignore by default any {'code':'info'} in p4CmdList (they are not exposed to the caller) as those are the verbose messages from triggers (p4 Debug does show them). the second change is to check the p4 trigger is really set in the test (Lars

Cash Benefit

2017-07-03 Thread Julie Leach
You are a recipient to Mrs Julie Leach Donation of $3 million USD. Contact ( julieleac...@gmail.com ) for claims.

Re: [PATCH] push: add config option to --force-with-lease by default.

2017-07-03 Thread Ævar Arnfjörð Bjarmason
On Mon, Jul 03 2017, Ævar Arnfjörð Bjarmason jotted: > On Mon, Jul 03 2017, Francesco Mazzoli jotted: > > A couple of things I didn't notice at first: Oh and also, makes sense to add tests for this, see t/t5533-push-cas.sh. I.e. just make sure the cases where the option works work with the

Re: [PATCH] push: add config option to --force-with-lease by default.

2017-07-03 Thread Ævar Arnfjörð Bjarmason
On Mon, Jul 03 2017, Francesco Mazzoli jotted: A couple of things I didn't notice at first: > git_config(git_push_config, ); > + if (push_always_force_with_lease) { > + cas.use_tracking_for_rest = 1; > + } This should go in git_push_config. > + if (!strcmp(var,

[PATCH] push: add config option to --force-with-lease by default.

2017-07-03 Thread Francesco Mazzoli
The flag can be overridden with `--no-force-with-lease`, or by passing the config via the command line. Signed-off-by: Francesco Mazzoli --- Documentation/config.txt | 5 + Documentation/git-push.txt | 4 +++- builtin/push.c | 3 +++ cache.h|

Should "head" also work for "HEAD" on case-insensitive FS?

2017-07-03 Thread Ævar Arnfjörð Bjarmason
I don't have a OSX box, but was helping a co-worker over Jabber the other day, and he pasted something like: $ git merge-base github/master head Which didn't work for me, and I thought he had a local "head" branch until realizing that of course we were just resolving HEAD on the FS. Has

Re: [PATCH] push: add config option to --force-with-lease by default.

2017-07-03 Thread Francesco Mazzoli
On 3 July 2017 at 23:47, Ævar Arnfjörð Bjarmason wrote: > > On Mon, Jul 03 2017, Francesco Mazzoli jotted: > > > The flag can be overridden with `--no-force-with-lease`, or by > > passing the config via the command line. > > Thanks for hacking on this. A couple of things: > > *

Re: [PATCH] push: add config option to --force-with-lease by default.

2017-07-03 Thread Ævar Arnfjörð Bjarmason
On Mon, Jul 03 2017, Francesco Mazzoli jotted: > The flag can be overridden with `--no-force-with-lease`, or by > passing the config via the command line. Thanks for hacking on this. A couple of things: * Most things (but not all) that configure `git whatevs --some-option` are configurable

Re: [PATCH v5 3/7] fsmonitor: teach git to optionally utilize a file system monitor to speed up detecting new or changed files.

2017-07-03 Thread Ben Peart
On 6/27/2017 11:43 AM, Christian Couder wrote: On Sat, Jun 10, 2017 at 3:40 PM, Ben Peart wrote: +int read_fsmonitor_extension(struct index_state *istate, const void *data, + unsigned long sz) +{ + const char *index = data; + uint32_t hdr_version; +

[PATCH] push: add config option to --force-with-lease by default.

2017-07-03 Thread Francesco Mazzoli
The flag can be overridden with `--no-force-with-lease`, or by passing the config via the command line. Signed-off-by: Francesco Mazzoli --- Documentation/config.txt | 5 + builtin/push.c | 3 +++ cache.h | 1 + config.c | 4

Re: [PATCH 06/12] builtin/update_ref: convert to struct object_id

2017-07-03 Thread Ævar Arnfjörð Bjarmason
On Mon, Jul 03 2017, brian m. carlson jotted: > Convert the uses of unsigned char * to struct object_id. I read all of this over (but didn't apply/test it) and it looks good to me, Just a small nit: > [...] > 1 file changed, 34 insertions(+), 35 deletions(-) > [...] > struct strbuf err

[GSoC][PATCH 4/5 v4] submodule: port submodule subcommand 'status' from shell to C

2017-07-03 Thread Prathamesh Chavan
This aims to make git-submodule 'status' a built-in. Hence, the function cmd_status() is ported from shell to C. This is done by introducing three functions: module_status(), submodule_status() and print_status(). The function module_status() acts as the front-end of the subcommand. It parses

[GSoC][PATCH 1/5 v4] submodule--helper: introduce get_submodule_displaypath()

2017-07-03 Thread Prathamesh Chavan
Introduce function get_submodule_displaypath() to replace the code occurring in submodule_init() for generating displaypath of the submodule with a call to it. This new function will also be used in other parts of the system in later patches. Mentored-by: Christian Couder

[GSoC][PATCH 3/5 v4] submodule: port set_name_rev() from shell to C

2017-07-03 Thread Prathamesh Chavan
Function set_name_rev() is ported from git-submodule to the submodule--helper builtin. The function get_name_rev() generates the value of the revision name as required, and the function print_name_rev() handles the formating and printing of the obtained revision name. Mentored-by: Christian

[GSoC][PATCH 5/5 v4] submodule: port submodule subcommand 'sync' from shell to C

2017-07-03 Thread Prathamesh Chavan
Port the submodule subcommand 'sync' from shell to C using the same mechanism as that used for porting submodule subcommand 'status'. Hence, here the function cmd_sync() is ported from shell to C. This is done by introducing three functions: module_sync(), sync_submodule() and

[GSoC][PATCH 2/5 v4] submodule--helper: introduce for_each_submodule_list()

2017-07-03 Thread Prathamesh Chavan
Introduce function for_each_submodule_list() and replace a loop in module_init() with a call to it. The new function will also be used in other parts of the system in later patches. Mentored-by: Christian Couder Mentored-by: Stefan Beller

Re: [PATCH v3 2/3] sha1dc: optionally use sha1collisiondetection as a submodule

2017-07-03 Thread Ævar Arnfjörð Bjarmason
On Mon, Jul 03 2017, Junio C. Hamano jotted: > Ævar Arnfjörð Bjarmason writes: > >> Add an option to use the sha1collisiondetection library from the >> submodule in sha1collisiondetection/ instead of in the copy in the >> sha1dc/ directory. >> >> This allows us to try out the

[GSoC] Update: Week 7

2017-07-03 Thread Prathamesh Chavan
SUMMARY OF MY PROJECT: Git submodule subcommands are currently implemented by using shell script 'git-submodule.sh'. There are several reasons why we'll prefer not to use the shell script. My project intends to convert the subcommands into C code, thus making them builtins. This will increase

Re: What's cooking in git.git (Jun 2017, #09; Fri, 30)

2017-07-03 Thread Junio C Hamano
"Philip Oakley" writes: > Am I right that the What's cooking is prepared by a script? Because I have to keep track of so many topics, its maintenance is heavily helped by a script. I do not think it is sensible to expect me to (or it would be good use of my time)

Re: Help needed for solving a few issues with building git

2017-07-03 Thread Junio C Hamano
Junio C Hamano writes: >> While trying to build (without the 'gettext' library that's required >> for localization) I get the following error, >> >> Manifying 8 pod documents >> SUBDIR templates >> MSGFMT po/build/locale/pt_PT/LC_MESSAGES/git.mo >>

Re: What's cooking in git.git (Jun 2017, #09; Fri, 30)

2017-07-03 Thread Philip Oakley
From: "Junio C Hamano" "Philip Oakley" writes: Junio, Is it possible to include a table of contents that lists the integration branches, split by your categories, to help find areas of interest? [Graduated to "master"] * topic list [New Topics]

[PATCH 10/12] Convert remaining callers of get_sha1 to get_oid.

2017-07-03 Thread brian m. carlson
Signed-off-by: brian m. carlson --- builtin/receive-pack.c | 4 ++-- mailmap.c | 6 +++--- 2 files changed, 5 insertions(+), 5 deletions(-) diff --git a/builtin/receive-pack.c b/builtin/receive-pack.c index 71c0c768d..1efa48fec 100644 ---

[PATCH 08/12] builtin/unpack-file: convert to struct object_id

2017-07-03 Thread brian m. carlson
Signed-off-by: brian m. carlson --- builtin/unpack-file.c | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a/builtin/unpack-file.c b/builtin/unpack-file.c index 73f133419..281ca1db6 100644 --- a/builtin/unpack-file.c +++

[PATCH 11/12] sha1_name: convert get_sha1* to get_oid*

2017-07-03 Thread brian m. carlson
Now that all the callers of get_sha1 directly or indirectly use struct object_id, rename the functions starting with get_sha1 to start with get_oid. Convert the internals in sha1_name.c to use struct object_id as well, and eliminate explicit length checks where possible. Outside of sha1_name.c

[PATCH 12/12] sha1_name: convert GET_SHA1* flags to GET_OID*

2017-07-03 Thread brian m. carlson
Convert the flags for get_oid_with_context and friends to use "OID" instead of "SHA1" in their names. This transform was made by running the following one-liner on the affected files: perl -pi -e 's/GET_SHA1/GET_OID/g' Signed-off-by: brian m. carlson ---

[PATCH 09/12] builtin/verify-tag: convert to struct object_id

2017-07-03 Thread brian m. carlson
Signed-off-by: brian m. carlson --- builtin/verify-tag.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/builtin/verify-tag.c b/builtin/verify-tag.c index f9a5f7535..30e4c826e 100644 --- a/builtin/verify-tag.c +++ b/builtin/verify-tag.c

[PATCH 03/12] submodule: convert submodule config lookup to use object_id

2017-07-03 Thread brian m. carlson
Signed-off-by: brian m. carlson --- builtin/grep.c | 4 ++-- builtin/submodule--helper.c | 8 config.c | 12 ++-- config.h | 4 ++-- submodule-config.c | 36

[PATCH 06/12] builtin/update_ref: convert to struct object_id

2017-07-03 Thread brian m. carlson
Convert the uses of unsigned char * to struct object_id. Signed-off-by: brian m. carlson --- builtin/update-ref.c | 69 ++-- 1 file changed, 34 insertions(+), 35 deletions(-) diff --git a/builtin/update-ref.c

[PATCH 04/12] remote: convert struct push_cas to struct object_id

2017-07-03 Thread brian m. carlson
This gets rid of one use of get_sha1. Signed-off-by: brian m. carlson --- remote.c | 6 +++--- remote.h | 2 +- 2 files changed, 4 insertions(+), 4 deletions(-) diff --git a/remote.c b/remote.c index d87482573..9da9040bf 100644 --- a/remote.c +++ b/remote.c @@

[PATCH 00/12] object_id part 9

2017-07-03 Thread brian m. carlson
This is the ninth in a series of series to convert Git to use struct object_id. This series converts the remaining callers of get_sha1 and friends to take and use struct object_id, and in doing so, renames them to get_oid and friends. It is possible there will be some other conflicts with in

[PATCH 02/12] builtin/merge-tree: convert remaining caller of get_sha1 to object_id

2017-07-03 Thread brian m. carlson
Signed-off-by: brian m. carlson --- builtin/merge-tree.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/builtin/merge-tree.c b/builtin/merge-tree.c index bad6735c7..f12da292c 100644 --- a/builtin/merge-tree.c +++ b/builtin/merge-tree.c @@

[PATCH 05/12] sequencer: convert to struct object_id

2017-07-03 Thread brian m. carlson
Convert the remaining instances of unsigned char * to struct object_id. This removes several calls to get_sha1. Signed-off-by: brian m. carlson --- sequencer.c | 59 ++- 1 file changed, 30 insertions(+), 29

[PATCH 01/12] builtin/fsck: convert remaining caller of get_sha1 to object_id

2017-07-03 Thread brian m. carlson
Signed-off-by: brian m. carlson --- builtin/fsck.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/builtin/fsck.c b/builtin/fsck.c index 87c675689..d601d07fd 100644 --- a/builtin/fsck.c +++ b/builtin/fsck.c @@ -738,12 +738,12 @@ int

[PATCH 07/12] bisect: convert bisect_checkout to struct object_id

2017-07-03 Thread brian m. carlson
Signed-off-by: brian m. carlson --- bisect.c | 18 +- 1 file changed, 9 insertions(+), 9 deletions(-) diff --git a/bisect.c b/bisect.c index a9fd9fbc6..2549eaf7b 100644 --- a/bisect.c +++ b/bisect.c @@ -680,16 +680,16 @@ static int

Re: What's cooking in git.git (Jun 2017, #09; Fri, 30)

2017-07-03 Thread Junio C Hamano
"Philip Oakley" writes: > Junio, > Is it possible to include a table of contents that lists the > integration branches, split by your categories, to help find areas of > interest? > > [Graduated to "master"] > * topic list > [New Topics] > [Stalled] > [Cooking] >

Re: Help needed for solving a few issues with building git

2017-07-03 Thread Junio C Hamano
Kaartic Sivaraam writes: > Hello all, > > Building without localization support > > I tried to build git from source without localization support by adding > the following line to the Makefile, > > NO_GETTEXT=1 > > It

Re: [PATCH] area: git-merge: add --signoff flag to git-merge

2017-07-03 Thread Junio C Hamano
Łukasz Gryglicki writes: > Subject: Re: [PATCH] area: git-merge: add --signoff flag to git-merge s/area: //; > Added --signoff flag to `git-merge` command, added test coverage, > updated documentation. That can be seen from the title and the patch text. While it is

Re: Why doesn't merge fail if message has only sign-off?

2017-07-03 Thread Junio C Hamano
Kaartic Sivaraam writes: > While trying to merge a branch using "git merge" if a merge > message consists only of a "Sign-off" line it doesn't fail. > To be consistent with the behaviour of "git commit" shouldn't the merge > fail? I think that it is not by design

Re: [PATCH v3 2/3] sha1dc: optionally use sha1collisiondetection as a submodule

2017-07-03 Thread Junio C Hamano
Ævar Arnfjörð Bjarmason writes: > Add an option to use the sha1collisiondetection library from the > submodule in sha1collisiondetection/ instead of in the copy in the > sha1dc/ directory. > > This allows us to try out the submodule in sha1collisiondetection > without breaking

Re: "git intepret-trailers" vs. "sed script" to add the signature

2017-07-03 Thread Junio C Hamano
Kaartic Sivaraam writes: > So, it seems that excepting for 'commit' it has quite a nice spacing. I > guess we could add something like the following to fix that, > > # Add new line after SOB in case of "git commit" > NEW_LINE='\ > ' > if [ -z "$2"

Re: [RFC/PATCH v4 00/49] Add initial experimental external ODB support

2017-07-03 Thread Junio C Hamano
Christian Couder writes: > On Sat, Jul 1, 2017 at 10:33 PM, Junio C Hamano wrote: >> Christian Couder writes: >> I think it would be good to ensure the interface is robust and performant enough to actually

Greetings!!!.

2017-07-03 Thread Paul Benk
Greetings! I have a proposal for you, this however is not mandatory nor will I in any manner compel you to honor against your will. I am Dr.Paul Benk a former executive director with Arab Tunisian Bank here in Tunis; I retired 1 year 7 months ago after putting in 28 years of meticulous service.

[PATCH v3 1/1] cygwin: Allow pushing to UNC paths

2017-07-03 Thread tboegi
From: Torsten Bögershausen cygwin can use an UNC path like //server/share/repo $ cd //server/share/dir $ mkdir test $ cd test $ git init --bare However, when we try to push from a local Git repository to this repo, there is a problem: Git converts the leading "//" into a

Re: Help needed for solving a few issues with building git

2017-07-03 Thread Torsten Bögershausen
On 2017-07-03 15:18, Kaartic Sivaraam wrote: > Hello all, > > Building without localization support > > I tried to build git from source without localization support by adding > the following line to the Makefile, > > NO_GETTEXT=1 > May be make

Help needed for solving a few issues with building git

2017-07-03 Thread Kaartic Sivaraam
Hello all, Building without localization support I tried to build git from source without localization support by adding the following line to the Makefile, NO_GETTEXT=1 It doesn't seem to be working for reasons I'm unable to find. I used the following

Re: Continous Integration (was: RE: Git v2.13.1 SHA1 very broken)

2017-07-03 Thread Johannes Schindelin
Hi Adam, On Sun, 2 Jul 2017, Adam Dinwoodie wrote: > I do the builds for the Cygwin distribution on my normal PC (so > reasonably powerful but definitely not devoted to the purpose), and > doing the build and running the default tests takes in the region of 8 > hours for the 64-bit build and 12

[PATCH] area: git-merge: add --signoff flag to git-merge

2017-07-03 Thread Łukasz Gryglicki
Added --signoff flag to `git-merge` command, added test coverage, updated documentation. Signed-off-by: lukaszgryglicki --- Documentation/git-merge.txt | 8 ++ builtin/merge.c | 4 +++ t/t9904-git-merge-signoff.sh | 60

Re: speeding up git pull from a busy gerrit instance over a slow link?

2017-07-03 Thread Noel Grandin
On 2017/06/30 11:59 PM, Jonathan Tan wrote: Out of curiosity, what is the timestamp difference between the first and last GIT_TRACE_PACKET log message containing "refs/changes"? Cut down log looks like: 08:37:17.734527 pkt-line.c:80 packet:fetch<