[PATCH v3 2/2] send-email: Support separate Reply-To address

2018-03-03 Thread Christian Ludwig
re-uses the $reply_to variable. This could break out-of-tree patches! Signed-off-by: Christian Ludwig <chrissic...@gmail.com> --- Documentation/git-send-email.txt | 5 + contrib/completion/git-completion.bash | 2 +- git-send-email.perl| 18 +++

git-send-email: Support for Reply-To

2018-03-03 Thread Christian Ludwig
Hi, this is the third iteration of this series. There was a request to rebase the changes on the refactoring patch b6049542 ("send-email: extract email-parsing code into a subroutine", 2017-12-15). This is the result. The diffstat is the same compared to the last revision. It could be made

[PATCH v3 1/2] send-email: Rename variable for clarity

2018-03-03 Thread Christian Ludwig
The SMTP protocol has both, the 'Reply-To' and the 'In-Reply-To' header fields. We only use the latter. To avoid confusion, rename the variable for it. Signed-off-by: Christian Ludwig <chrissic...@gmail.com> --- git-send-email.perl | 38 +++--- 1 file chang

[PATCH v2 2/2] send-email: Support separate Reply-To address

2018-01-17 Thread Christian Ludwig
the $reply_to variable name was already taken for the 'In-Reply-To' header field. To reduce code churn, use $reply_address as variable name instead. Signed-off-by: Christian Ludwig <chrissic...@gmail.com> --- Documentation/git-send-email.txt | 5 + contrib/completion/git-completio

[PATCH v2 1/2] send-email: Rename variable for clarity

2018-01-17 Thread Christian Ludwig
The SMTP protocol has both, the 'Reply-To' and the 'In-Reply-To' header fields. We only use the latter. To avoid confusion, rename the variable for it. Signed-off-by: Christian Ludwig <chrissic...@gmail.com> --- git-send-email.perl | 38 +++--- 1 file chang

[PATCH] send-email: Support separate Reply-To address

2018-01-12 Thread Christian Ludwig
the $reply_to variable name was already taken for the 'In-Reply-To' header field. To reduce code churn, use $reply_address as variable name instead. Signed-off-by: Christian Ludwig <chrissic...@gmail.com> --- Documentation/git-send-email.txt | 5 + git-send-email.perl

[PATCH] tests: Deduplicate code in send-email test

2018-01-12 Thread Christian Ludwig
Use the wrapper function around the sed statement like everywhere else in the test. Unfortunately the wrapper function is defined pretty late. Move the wrapper to the top of the test file, so future users have it available right away. Signed-off-by: Christian Ludwig <chrissic...@gmail.