[PATCH] send-email: extract email-parsing code into a subroutine

2017-12-15 Thread Nathan Payre
quot;filter_body()" could be used for refactoring the part of code which parses the header to prepare the email and send it. In contrast to the previous version it doesn't keep the header order and strip duplicate headers. Signed-off-by: Nathan Payre <nathan.pa...@etu.univ-lyon1.fr> S

[PATCH] send-email: extract email-parsing code into a subroutine

2017-12-14 Thread Nathan Payre
quot;filter_body()" could be used for refactoring the part of code which parses the header to prepare the email and send it. Signed-off-by: Nathan Payre <nathan.pa...@etu.univ-lyon1.fr> Signed-off-by: Matthieu Moy <matthieu@univ-lyon1.fr> Signed-off-by: Timothee Albertin <ti

Re: [PATCH] send-email: extract email-parsing code into a subroutine

2017-12-14 Thread Nathan PAYRE
2017-12-11 22:12 GMT+01:00 Matthieu Moy : > "PAYRE NATHAN p1508475" wrote: >> + my %parsed_email; >> + $parsed_email{'body'} = ''; >> + while (my $line = <$c>) { >> + next if $line =~ m/^GIT:/; >> +

[PATCH] send-email: extract email-parsing code into a subroutine

2017-12-09 Thread Nathan Payre
quot;filter_body()" could be used for refactoring the part of code which parses the header to prepare the email and send it. Signed-off-by: Nathan Payre <nathan.pa...@etu.univ-lyon1.fr> Signed-off-by: Matthieu Moy <matthieu@univ-lyon1.fr> Signed-off-by: Timothee Albertin <ti

[PATCH v4] send-email: extract email-parsing code into a subroutine

2017-12-07 Thread Nathan Payre
quot;filter_body()" could be used for refactoring the part of code which parses the header a last time to prepare the email and send it. Signed-off-by: Nathan Payre <nathan.pa...@etu.univ-lyon1.fr> Signed-off-by: Matthieu Moy <matthieu@univ-lyon1.fr> Signed-off-by: Timothee Alb

[PATCH v3] send-email: extract email-parsing code into a subroutine

2017-12-06 Thread Nathan Payre
The existing code mixes parsing of email header with regular expression and actual code. Extract the parsing code into a new subroutine 'parse_header_line()'. This improves the code readability and make parse_header_line reusable in other place. Signed-off-by: Nathan Payre <nathan.pa...@etu.u

Re: [PATCH v2] send-email: extract email-parsing code into a subroutine

2017-12-06 Thread Nathan PAYRE
Junio C Hamano : writes: > ... throughout this patch, not limited to this section, indentation > is strange and there seem to be many "print" that show messages that > do not seem to be meant for end-user consumption. I can see that > this aspires to improve the readability,

[PATCH v2] send-email: extract email-parsing code into a subroutine

2017-12-06 Thread Nathan Payre
The existing code mixes parsing of email header with regular expression and actual code. Extract the parsing code into a new subroutine 'parse_header_line()'. This improves the code readability and make parse_header_line reusable in other place. Signed-off-by: Nathan Payre <nathan.pa...@etu.u

[PATCH v2] send-email: extract email-parsing code into a subroutine

2017-12-06 Thread Nathan Payre
The existing code mixes parsing of email header with regular expression and actual code. Extract the parsing code into a new subroutine 'parse_header_line()'. This improves the code readability and make parse_header_line reusable in other place. Signed-off-by: Nathan Payre <nathan.pa...@etu.u

Re: [PATCH] send-email: extract email-parsing code into a subroutine

2017-12-03 Thread Nathan PAYRE
I've tested your code, and after few changes it's works perfectly! The code looks better now. Thanks a lot for your review. 2017-12-03 23:00 GMT+01:00 Ævar Arnfjörð Bjarmason <ava...@gmail.com>: > > On Sat, Dec 02 2017, Payre Nathan jotted: > >> From: Nathan Payre &l

Re: [PATCH] send-email: extract email-parsing code into a subroutine

2017-12-02 Thread Nathan PAYRE
I found a mistake in my signed-off-by, please replace <nathan.pa...@etu.univ-lyon1.fr.> by <second.pa...@gmail.com> Excuse me. 2017-12-02 18:02 GMT+01:00 Payre Nathan <second.pa...@gmail.com>: > From: Nathan Payre <second.pa...@gmail.com> > > The existing c

Re: [PATCH 1/2] quote-email populates the fields

2017-11-09 Thread Nathan PAYRE
I Will send the modification in the next patch, I prefer to refractor a part of the code before. >> diff --git a/git-send-email.perl b/git-send-email.perl >> index 2208dcc21..665c47d15 100755 >> --- a/git-send-email.perl >> +++ b/git-send-email.perl >> @@ -57,6 +57,7 @@ git send-email

Re: [PATCH] Documentation/git-config.txt: reword missleading sentence

2017-10-10 Thread Nathan PAYRE
Hi, Thanks you for the this complete answer, we take note of your comments. We would like to reword something else in the same line and we don't know what is the best way to do that properly. Should we do a [PATCH v2] or revert the last commit and commit a new one? 2017-10-05 12:13 GMT+02:00

Re: new contributors presentation

2017-10-10 Thread Nathan PAYRE
, ...) will be automatically filled. For now the code contains a syntax error then our obvious first goal is to fix it. Discussion of the previous team with more information: https://public-inbox.org/git/1464031829-6107-1-git-send-email-tom.russe...@grenoble-inp.org/ 2017-10-04 6:05 GMT+02

new contributors presentation

2017-10-02 Thread Nathan PAYRE
Hi all, me and my two other partner (Daniel and Timothee) have make the choice to contribute to gitHub for a university project supervised by Mattieu Moy. The principal project is to improve the git-send-email function, for example we will try to implement the possibility to answer to a email by