Re: [PATCH] Documentation/git-add.txt: add `add.ginore-errors` configuration variable

2015-01-27 Thread Junio C Hamano
Eric Sunshine sunsh...@sunshineco.com writes:

 On Mon, Jan 26, 2015 at 11:55 AM, Alexander Kuleshov
 kuleshovm...@gmail.com wrote:
 'git add' supports not only `add.ignoreErrors`, but also `add.ignore-errors`
 configuration variable.

 See 6b3020a2 (add: introduce add.ignoreerrors synonym for
 add.ignore-errors,  2010-12-01) for why this patch is undesirable.

We might want to do this instead, as the correction to the
misspelled configuration variable name was from the 1.7.0-era that
is sufficiently old (v1.7.0.8 was done in December 2010).

-- 8 --
Subject: doc: clarify naming rules for configuration variables

Also mark deprecated variables in the documentation more clearly.

The text for the rules are partly taken from the log message of
Jonathan's 6b3020a2 (add: introduce add.ignoreerrors synonym for
add.ignore-errors, 2010-12-01).

Signed-off-by: Junio C Hamano gits...@pobox.com
---
 Documentation/CodingGuidelines | 25 +
 Documentation/config.txt   | 15 +++
 2 files changed, 32 insertions(+), 8 deletions(-)

diff --git a/Documentation/CodingGuidelines b/Documentation/CodingGuidelines
index 894546d..8fbac15 100644
--- a/Documentation/CodingGuidelines
+++ b/Documentation/CodingGuidelines
@@ -413,6 +413,31 @@ Error Messages
  - Say what the error is first (cannot open %s, not %s: cannot open)
 
 
+Externally Visible Names
+
+ - For configuration variable names, follow the existing convention:
+
+   . The section name indicates the affected subsystem.
+
+   . The subsection name, if any, indicates which of an unbounded set
+ of things to set the value for.
+
+   . The variable name describes the effect of tweaking this knob.
+
+   The section and variable names that consist of multiple words are
+   formed by concatenating the words without punctuations (e.g. `-`),
+   and are broken using bumpyCaps in documentation as a hint to the
+   reader.
+
+   When choosing the variable namespace, do not use variable name for
+   specifying possibly unbounded set of things, most notably anything
+   an end user can freely come up with (e.g. branch names), but also
+   large fixed set defined by the system that can grow over time
+   (e.g. what kind of common whitespace problems to notice).  Use
+   subsection names or variable values, like existing variables
+   branch.name.description and core.whitespace do, instead.
+
+
 Writing Documentation:
 
  Most (if not all) of the documentation pages are written in the
diff --git a/Documentation/config.txt b/Documentation/config.txt
index 0a4d22a..8a76d1d 100644
--- a/Documentation/config.txt
+++ b/Documentation/config.txt
@@ -664,14 +664,13 @@ core.abbrev::
for abbreviated object names to stay unique for sufficiently long
time.
 
-add.ignore-errors::
 add.ignoreErrors::
+add.ignore-errors (deprecated)::
Tells 'git add' to continue adding files when some files cannot be
added due to indexing errors. Equivalent to the '--ignore-errors'
-   option of linkgit:git-add[1].  Older versions of Git accept only
-   `add.ignore-errors`, which does not follow the usual naming
-   convention for configuration variables.  Newer versions of Git
-   honor `add.ignoreErrors` as well.
+   option of linkgit:git-add[1].  `add.ignore-errors` is deprecated,
+   as it does not follow the usual naming convention for configuration
+   variables.
 
 alias.*::
Command aliases for the linkgit:git[1] command wrapper - e.g.
@@ -1924,7 +1923,7 @@ pack.useBitmaps::
true. You should not generally need to turn this off unless
you are debugging pack bitmaps.
 
-pack.writebitmaps::
+pack.writebitmaps (deprecated)::
This is a deprecated synonym for `repack.writeBitmaps`.
 
 pack.writeBitmapHashCache::
@@ -2235,7 +2234,7 @@ sendemail.smtpencryption::
See linkgit:git-send-email[1] for description.  Note that this
setting is not subject to the 'identity' mechanism.
 
-sendemail.smtpssl::
+sendemail.smtpssl (deprecated)::
Deprecated alias for 'sendemail.smtpencryption = ssl'.
 
 sendemail.smtpsslcertpath::
@@ -2273,7 +2272,7 @@ sendemail.thread::
 sendemail.validate::
See linkgit:git-send-email[1] for description.
 
-sendemail.signedoffcc::
+sendemail.signedoffcc (deprecated)::
Deprecated alias for 'sendemail.signedoffbycc'.
 
 showbranch.default::

--
To unsubscribe from this list: send the line unsubscribe git in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[PATCH] Documentation/git-add.txt: add `add.ginore-errors` configuration variable

2015-01-26 Thread Alexander Kuleshov
'git add' supports not only `add.ignoreErrors`, but also `add.ignore-errors`
configuration variable.

Signed-off-by: Alexander Kuleshov kuleshovm...@gmail.com
---
 Documentation/git-add.txt | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/Documentation/git-add.txt b/Documentation/git-add.txt
index 1c74907..f68c2a2 100644
--- a/Documentation/git-add.txt
+++ b/Documentation/git-add.txt
@@ -155,8 +155,8 @@ for git add --no-all pathspec..., i.e. ignored removed 
files.
If some files could not be added because of errors indexing
them, do not abort the operation, but continue adding the
others. The command shall still exit with non-zero status.
-   The configuration variable `add.ignoreErrors` can be set to
-   true to make this the default behaviour.
+   The configuration variable `add.ignoreErrors` or `add.ignore-errors`
+   can be set to true to make this the default behaviour.
 
 --ignore-missing::
This option can only be used together with --dry-run. By using
-- 
2.3.0.rc1.275.g028c360

--
To unsubscribe from this list: send the line unsubscribe git in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH] Documentation/git-add.txt: add `add.ginore-errors` configuration variable

2015-01-26 Thread Eric Sunshine
On Mon, Jan 26, 2015 at 11:55 AM, Alexander Kuleshov
kuleshovm...@gmail.com wrote:
 'git add' supports not only `add.ignoreErrors`, but also `add.ignore-errors`
 configuration variable.

See 6b3020a2 (add: introduce add.ignoreerrors synonym for
add.ignore-errors,  2010-12-01) for why this patch is undesirable.

 Signed-off-by: Alexander Kuleshov kuleshovm...@gmail.com
 ---
  Documentation/git-add.txt | 4 ++--
  1 file changed, 2 insertions(+), 2 deletions(-)

 diff --git a/Documentation/git-add.txt b/Documentation/git-add.txt
 index 1c74907..f68c2a2 100644
 --- a/Documentation/git-add.txt
 +++ b/Documentation/git-add.txt
 @@ -155,8 +155,8 @@ for git add --no-all pathspec..., i.e. ignored 
 removed files.
 If some files could not be added because of errors indexing
 them, do not abort the operation, but continue adding the
 others. The command shall still exit with non-zero status.
 -   The configuration variable `add.ignoreErrors` can be set to
 -   true to make this the default behaviour.
 +   The configuration variable `add.ignoreErrors` or `add.ignore-errors`
 +   can be set to true to make this the default behaviour.

  --ignore-missing::
 This option can only be used together with --dry-run. By using
 --
 2.3.0.rc1.275.g028c360
--
To unsubscribe from this list: send the line unsubscribe git in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html