Re: [PATCH v2 01/11] builtin/pack-objects.c: change check_pbase_path() to use ALLOC_GROW()

2014-03-03 Thread Junio C Hamano
Jeff King writes: > I realize that I just bikeshedded on subject lines for half a page, and > part of me wants to go kill myself in shame. But I feel like I see the > technique misapplied often enough that maybe some guidance is merited. Thanks. What I queued read like these: $ git shortlog ..

Re: [PATCH v2 01/11] builtin/pack-objects.c: change check_pbase_path() to use ALLOC_GROW()

2014-02-28 Thread Jeff King
On Fri, Feb 28, 2014 at 11:03:19AM -0800, Junio C Hamano wrote: > Michael Haggerty writes: > > > So my vote is that the patches are OK the way Dmitry wrote them (mind, I > > have only read through 05/11 so far). > > Seconded ;-) > > By the way, I do not like these long subjects. "change" is a

Re: [PATCH v2 01/11] builtin/pack-objects.c: change check_pbase_path() to use ALLOC_GROW()

2014-02-28 Thread Junio C Hamano
Michael Haggerty writes: > So my vote is that the patches are OK the way Dmitry wrote them (mind, I > have only read through 05/11 so far). Seconded ;-) By the way, I do not like these long subjects. "change" is a redundant word when one sends a patch---as all patches are about changing someth

Re: [PATCH v2 01/11] builtin/pack-objects.c: change check_pbase_path() to use ALLOC_GROW()

2014-02-28 Thread Duy Nguyen
On Fri, Feb 28, 2014 at 9:20 PM, Michael Haggerty wrote: > Duy, > > The example in Documentation/technical/api-allocation-growing.txt does > it the same way as Dmitry: > > ALLOC_GROW(item, nr + 1, alloc); > item[nr++] = value you like; > > The alternative, > > nr++; > ALLOC_GROW(it

Re: [PATCH v2 01/11] builtin/pack-objects.c: change check_pbase_path() to use ALLOC_GROW()

2014-02-28 Thread Michael Haggerty
On 02/28/2014 01:40 PM, Duy Nguyen wrote: > On Fri, Feb 28, 2014 at 7:32 PM, Duy Nguyen wrote: >>> done_pbase_paths_num++; >> >> If you move this up one line, then you don't have to "+ 1" in ALLOC_GROW >> > > same comment to a few other patches. The rest of your series looks good. Duy,

Re: [PATCH v2 01/11] builtin/pack-objects.c: change check_pbase_path() to use ALLOC_GROW()

2014-02-28 Thread Duy Nguyen
On Fri, Feb 28, 2014 at 7:32 PM, Duy Nguyen wrote: >> done_pbase_paths_num++; > > If you move this up one line, then you don't have to "+ 1" in ALLOC_GROW > same comment to a few other patches. The rest of your series looks good. -- Duy -- To unsubscribe from this list: send the line "un

Re: [PATCH v2 01/11] builtin/pack-objects.c: change check_pbase_path() to use ALLOC_GROW()

2014-02-28 Thread Duy Nguyen
On Fri, Feb 28, 2014 at 4:40 PM, Dmitry S. Dolzhenko wrote: > Signed-off-by: Dmitry S. Dolzhenko > --- > builtin/pack-objects.c | 7 +-- > 1 file changed, 1 insertion(+), 6 deletions(-) > > diff --git a/builtin/pack-objects.c b/builtin/pack-objects.c > index c733379..56a6fc8 100644 > --- a/b

[PATCH v2 01/11] builtin/pack-objects.c: change check_pbase_path() to use ALLOC_GROW()

2014-02-28 Thread Dmitry S. Dolzhenko
Signed-off-by: Dmitry S. Dolzhenko --- builtin/pack-objects.c | 7 +-- 1 file changed, 1 insertion(+), 6 deletions(-) diff --git a/builtin/pack-objects.c b/builtin/pack-objects.c index c733379..56a6fc8 100644 --- a/builtin/pack-objects.c +++ b/builtin/pack-objects.c @@ -1213,12 +1213,7 @@ st