Gitweb:     
http://git.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=f4beee9420773faefd3eac23bb5ba65b0395c1a1
Commit:     f4beee9420773faefd3eac23bb5ba65b0395c1a1
Parent:     5218c892652c1e8f89964a7fd4cf8b71cc863094
Author:     Jiang zhe <[EMAIL PROTECTED]>
AuthorDate: Thu Jan 17 11:19:26 2008 +0100
Committer:  Jaroslav Kysela <[EMAIL PROTECTED]>
CommitDate: Thu Jan 31 17:30:04 2008 +0100

    [ALSA] hda-codec - Fix capture source for Cx5045 codec
    
    For codec conexant 5045, I found that the name of 'Capture Source Items'
    is different from the name of mixer.
    The mixer is:
    HDA_CODEC_VOLUME('Ext Mic Playback Volume', 0x17, 0x2, HDA_INPUT),
    HDA_CODEC_MUTE('Ext Mic Playback Switch', 0x17, 0x2, HDA_INPUT),
    But the capture source item is :
    static struct hda_input_mux cxt5045_capture_source = {
        .num_items = 2,
        .items = {
                { 'IntMic', 0x1 },
                { 'LineIn', 0x2 },
        }
    };
    I think that it's better to change the name of capture_source to avoid
    misunderstanding.
    
    Signed-off-by: Jiang zhe <[EMAIL PROTECTED]>
    Signed-off-by: Takashi Iwai <[EMAIL PROTECTED]>
    Signed-off-by: Jaroslav Kysela <[EMAIL PROTECTED]>
---
 sound/pci/hda/patch_conexant.c |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/sound/pci/hda/patch_conexant.c b/sound/pci/hda/patch_conexant.c
index 23a3be5..dab2ce1 100644
--- a/sound/pci/hda/patch_conexant.c
+++ b/sound/pci/hda/patch_conexant.c
@@ -453,7 +453,7 @@ static struct hda_input_mux cxt5045_capture_source = {
        .num_items = 2,
        .items = {
                { "IntMic", 0x1 },
-               { "LineIn", 0x2 },
+               { "ExtMic", 0x2 },
        }
 };
 
-
To unsubscribe from this list: send the line "unsubscribe git-commits-head" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to