Gitweb:     
http://git.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=f5a421a4509a7e2dff11da0f01b0548f4f84d503
Commit:     f5a421a4509a7e2dff11da0f01b0548f4f84d503
Parent:     422b14c2e2f816f58ce8ce0ab0beeae02dfb7a75
Author:     Oleg Nesterov <[EMAIL PROTECTED]>
AuthorDate: Sun Jul 15 23:41:44 2007 -0700
Committer:  Linus Torvalds <[EMAIL PROTECTED]>
CommitDate: Mon Jul 16 09:05:51 2007 -0700

    rename cancel_rearming_delayed_work() to cancel_delayed_work_sync()
    
    Imho, the current naming of cancel_xxx workqueue functions is very 
confusing.
    
        cancel_delayed_work()
        cancel_rearming_delayed_work()
        cancel_rearming_delayed_workqueue()     // obsolete
    
        cancel_work_sync()
    
    This looks as if the first 2 functions differ in "type" of their argument
    which is not true any longer, nowadays the difference is the behaviour.
    
    The semantics of cancel_rearming_delayed_work(dwork) was changed
    significantly, it doesn't require that dwork rearms itself, and cancels 
dwork
    synchronously.
    
    Rename it to cancel_delayed_work_sync().  This matches cancel_delayed_work()
    and cancel_work_sync().  Re-create cancel_rearming_delayed_work() as a 
simple
    inline obsolete wrapper, like cancel_rearming_delayed_workqueue().
    
    Signed-off-by: Oleg Nesterov <[EMAIL PROTECTED]>
    Acked-by: Jarek Poplawski <[EMAIL PROTECTED]>
    Signed-off-by: Andrew Morton <[EMAIL PROTECTED]>
    Signed-off-by: Linus Torvalds <[EMAIL PROTECTED]>
---
 include/linux/workqueue.h |   13 ++++++++++---
 kernel/workqueue.c        |    6 +++---
 2 files changed, 13 insertions(+), 6 deletions(-)

diff --git a/include/linux/workqueue.h b/include/linux/workqueue.h
index ce0719a..5c89ac6 100644
--- a/include/linux/workqueue.h
+++ b/include/linux/workqueue.h
@@ -166,14 +166,21 @@ static inline int cancel_delayed_work(struct delayed_work 
*work)
        return ret;
 }
 
-extern void cancel_rearming_delayed_work(struct delayed_work *work);
+extern void cancel_delayed_work_sync(struct delayed_work *work);
 
-/* Obsolete. use cancel_rearming_delayed_work() */
+/* Obsolete. use cancel_delayed_work_sync() */
 static inline
 void cancel_rearming_delayed_workqueue(struct workqueue_struct *wq,
                                        struct delayed_work *work)
 {
-       cancel_rearming_delayed_work(work);
+       cancel_delayed_work_sync(work);
+}
+
+/* Obsolete. use cancel_delayed_work_sync() */
+static inline
+void cancel_rearming_delayed_work(struct delayed_work *work)
+{
+       cancel_delayed_work_sync(work);
 }
 
 #endif
diff --git a/kernel/workqueue.c b/kernel/workqueue.c
index 3bebf73..ad96568 100644
--- a/kernel/workqueue.c
+++ b/kernel/workqueue.c
@@ -486,13 +486,13 @@ void cancel_work_sync(struct work_struct *work)
 EXPORT_SYMBOL_GPL(cancel_work_sync);
 
 /**
- * cancel_rearming_delayed_work - reliably kill off a delayed work.
+ * cancel_delayed_work_sync - reliably kill off a delayed work.
  * @dwork: the delayed work struct
  *
  * It is possible to use this function if @dwork rearms itself via queue_work()
  * or queue_delayed_work(). See also the comment for cancel_work_sync().
  */
-void cancel_rearming_delayed_work(struct delayed_work *dwork)
+void cancel_delayed_work_sync(struct delayed_work *dwork)
 {
        while (!del_timer(&dwork->timer) &&
               !try_to_grab_pending(&dwork->work))
@@ -500,7 +500,7 @@ void cancel_rearming_delayed_work(struct delayed_work 
*dwork)
        wait_on_work(&dwork->work);
        work_clear_pending(&dwork->work);
 }
-EXPORT_SYMBOL(cancel_rearming_delayed_work);
+EXPORT_SYMBOL(cancel_delayed_work_sync);
 
 static struct workqueue_struct *keventd_wq __read_mostly;
 
-
To unsubscribe from this list: send the line "unsubscribe git-commits-head" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to