Gitweb:     
http://git.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=8f286c33f1e838d631f4a3260b33efce4bc5973c
Commit:     8f286c33f1e838d631f4a3260b33efce4bc5973c
Parent:     34c6538413e5648b63cb785add509f500b3a7b11
Author:     Andrew Morton <[EMAIL PROTECTED]>
AuthorDate: Thu Oct 18 03:05:07 2007 -0700
Committer:  Linus Torvalds <[EMAIL PROTECTED]>
CommitDate: Thu Oct 18 14:37:21 2007 -0700

    stop using DMA_xxBIT_MASK
    
    Now that we have DMA_BIT_MASK(), these macros are pointless.
    
    Cc: Jeremy Fitzhardinge <[EMAIL PROTECTED]>
    Signed-off-by: Andrew Morton <[EMAIL PROTECTED]>
    Signed-off-by: Linus Torvalds <[EMAIL PROTECTED]>
---
 include/linux/dma-mapping.h |   10 ++++++++--
 1 files changed, 8 insertions(+), 2 deletions(-)

diff --git a/include/linux/dma-mapping.h b/include/linux/dma-mapping.h
index 29b0285..101a2d4 100644
--- a/include/linux/dma-mapping.h
+++ b/include/linux/dma-mapping.h
@@ -13,9 +13,15 @@ enum dma_data_direction {
        DMA_NONE = 3,
 };
 
-#define DMA_BIT_MASK(n)        ((1ULL<<(n))-1)
+#define DMA_BIT_MASK(n)        (((n) == 64) ? ~0ULL : ((1ULL<<(n))-1))
 
-#define DMA_64BIT_MASK (~0ULL)
+/*
+ * NOTE: do not use the below macros in new code and do not add new definitions
+ * here.
+ *
+ * Instead, just open-code DMA_BIT_MASK(n) within your driver
+ */
+#define DMA_64BIT_MASK DMA_BIT_MASK(64)
 #define DMA_48BIT_MASK DMA_BIT_MASK(48)
 #define DMA_47BIT_MASK DMA_BIT_MASK(47)
 #define DMA_40BIT_MASK DMA_BIT_MASK(40)
-
To unsubscribe from this list: send the line "unsubscribe git-commits-head" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to