This is an automated email from the git hooks/post-receive script.

stefan pushed a change to annotated tag v1.17.0-alpha1
in repository core/elementary.

        at  b6b0850   (tag)
   tagging  f761a440adc9d9a83f2fc59a73f376cc9732fe20 (commit)
  replaces  v1.16.0
 tagged by  Stefan Schmidt
        on  Tue Jan 5 15:52:28 2016 +0100

- Log -----------------------------------------------------------------
v1.17.0-alpha1

Aditya Raj (1):
      Popup Example: Fix size calculation issue in popup

Amitesh Singh (3):
      notify: fix broken timeout feature in elm_notify
      notify: fix hide animation
      notify: remove duplicate call of _sizing_eval.

Carsten Haitzler (7):
      elm - cursor - fix job handling to not leave rogue jobs
      elm config - allow the ability to save out to another hidden profile
      elm config tool - dont need to call save if flush is saving anyway
      elm config - add function to check if profile exists
      elm config - add the ability to have derived configurations from others
      elm wl cnp - fix paste to not crash anymore
      elm config - monitor JUST the correct files for profile and cfg change

Chidambar Zinnoury (1):
      elementary spinner: Disable dragging over the decrease and increase 
buttons in the default theme.

Chris Michael (4):
      elementary: Don't call ecore_wl2_shutdown unless we have a display
      elementary: Comment out unused functions
      elementary: Fix formatting
      elementary: Fix elementary not compiling

Christopher Michael (10):
      elementary: Fix test_colorclass function
      elementary: Use ecore_wl2 library for elementary
      elementary: Include header for Ecore_Wl2 and add external display
      elementary: Port elementary cursor code to use ecore_wl2 library
      elementary: Port elementary window code to use Ecore_Wl2
      elementary: Port elementary copy/paste code to use Ecore_Wl2 library
      elementary: Port elementary config code to use Ecore_Wl2 library
      elementary: Remove misuse of EINA_UNUSED
      elementary: Port elementary to use Ecore_Wl2 library
      elementary: Update ecore wayland window geometry

Daniel Hirt (3):
      Entry: add markup cnp handlers
      Entry: add "selection,reset" state
      Elm entry: fix null item in item provider.

Daniel Juyung Seo (2):
      genlist: Make more realistic scenario.
      genlist: Remove genlist clear scenario from the basic genlist test.

Daniel Kolesa (1):
      build: don't provide --eo to eolian_gen

Daniel Zaoui (1):
      Clouseau: handle case when the library is not installed

Felipe Magno de Almeida (1):
      efl-js: JavaScript Eolian binding

Hermet Park (2):
      rename an author
      tooltip : prevent blowing memory up in the middle of function.

Hosang Kim (2):
      slider: fix slider focus bug
      scroller: add color classes

Jaehyun Cho (1):
      elm_win: Remove unnecessary layer set for elm_win.

Jean Guyomarc'h (9):
      segment_control: fix variable affectation
      config: add error messages when profile or config could not be saved.
      cursor: add support for Cocoa system cursors.
      cnp: cocoa support for copy and paste (text only).
      win: use EINA_UNUSED instead of void casting.
      win: add Cocoa support for elm_win_window_id_get() API
      priv: centralized and safe inclusion of Ecore_Cocoa.h
      elementary_test: fix memory leak
      sys_notify: support several notification servers

Jean-Philippe ANDRÉ (1):
      image: Lock access to thread variables

Jee-Yong Um (5):
      hover/hoversel: clean up code for getting edje_object_data
      theme: add DBG() message when style is set to default (fallback)
      elm: fix the default value for size_hint_min
      inwin: remove a meaningless line in sizing_eval
      hoversel: auto update hoversel after dismiss animation finished.

Lukasz Stanislawski (24):
      atspi: unprotect subset of methods
      atspi: move root object creation to atspi class.
      atspi: support key modifers in bridge.
      atspi: typo fix
      atspi: fix default text attribute signature
      atspi: remove useless "GetDefaultAttributeSet" method
      atspi: add type of accessibility object
      bg: do not make background accessibility object.
      atspi: always use widget's subobj as accessible children
      box: skip box in accessibility tree by default
      menu: enhance accessibility support
      slider: minor accessibility events fix
      hoversel: change accessibility role to popup
      hoversel: accessibility enhancements
      multibutton_entry: improve atspi support
      naviframe: set better accessibility role and name
      widget: limit emission of state-changed:showing
      atspi: return previous name in overloaded getters
      tests: adjust atspi roles.
      popup: enable to dismiss popup with accessibility API
      widget: remove redundat resize_object_set call
      index: accessibilitize index items
      genlist: new SCROLLTO_BOTTOM alignment
      gengrid: add scrollto BOTTOM alignment type.

Marcel Hollerbach (1):
      Elm config: use a name instead of elm_widget_type_get

Mike Blumenkrantz (12):
      win: only perform maximize frame state updating during ecore-evas callback
      ibar: stop mouse-in animation after current animation completes
      table: implement Evas.Object_Smart.calculate
      comp base: allow mouse events to propagate through comp base -> wallpaper
      elm border: change shadow toggle program signal source e -> elm
      elm border: also change shadow program signal name...
      win: run wayland region updating during RENDER_FLUSH_PRE
      win: redo resize deferral to trigger during pre render
      image: do not block null image loading in the elm layer
      box: implement Evas.Object_Smart.calculate
      box: implement aspected item layout
      box: re-set max extents sizes to -1 during recalc

Nicolas Aguirre (1):
      cocoa: call ecore_cocoa_init as part of the init process.

Prince Kumar Dubey (1):
      conform: if window is in background, indicator must not update the plug 
information.

SangHyeon Lee (5):
      genlist: supporting homogeneous mode about each item class.
      genlist : fix size hash issue when genlist layout sizing evaluated
      genlist: remove unnecessary data creation
      genlist : fix genlist build errors
      genlist : add size_calc forcely about content when elm_layout.

Shilpa Singh (6):
      calendar: weekdays do not get translated when language is dynamically 
changed issue fix
      colorselector: read color names instead of RGBA when accessibility is set
      toolbar: add item_signal_emit.
      naviframe: subtitle,show signal not sent
      elm: set language to edje when elm_language_set is called.
      spinner: add possibility to enter negative value.

Shinwoo Kim (2):
      conform: retry connect to indicator when confrom fails connect.
      [config] fix static analysis issue

Stefan Schmidt (15):
      configure: Switch to dev mode again. Merge window for 1.17 is open now
      elm_main: mark some local symbols static
      elm_map: mark some local symbols static
      elm_transit: mark some local symbols static
      elm_prefs: remove some unused functions
      elm_prefs: mark some local symbols static and align thus with their 
declaration
      elm_prefcs_cc: correct declaration of  function with no parameters
      test: correct declaration of  function with no parameters
      elm_widget: correct declaration of  function with no parameters
      test_access: correct argument order for calloc()
      atspi: correct argument order for calloc()
      test_gesture_layer: correct argument order for calloc()
      test: correct argument order for calloc()
      elm_font: correct argument order for calloc()
      release: Update NEWS and bump version for 1.17.0-alpha1 release

Subodh Kumar (5):
      hoversel: refactor a bit to avoid code duplication.
      Elm entry: Keep cursor at inserted position after dnd.
      Elm entry: Fix a typo
      Entry: Add newline filter for single line entry
      Elm entry: Fix to hide magnifier when menu is disabled.

Sung-Taek Hong (3):
      elm_layout: fix typo in error message
      elm_photocam: add NULL check
      button: add color classes

Thiep Ha (1):
      wayland cnp: check selection owner before calling losscb

Tom Hacohen (10):
      Elm spinner: Fix potential null deref in decimal get function.
      Genlist: Put null check before the deref.
      Genlist: Add NULL item check to *_item_next_get().
      Colorselector: Fix out of bound read.
      Colorselector: Fix some coding style issues.
      Examples performance: Fix resource leak + potential null deref.
      Examples performance: Fix wrong always true condition.
      Examples genlist 5: Fix children aspect of the test not working.
      Elm win: Fix potential NULL deref.
      Entry: clean up single line init function.

Umesh Tanwar (1):
      gengrid: fix Logic in _item_single_select_left and 
_item_single_select_right.

Vaibhav Gupta (1):
      Entry: Context Menu is now configurable

Vincent Torri (5):
      cnp: add Copy & Paste support for Windows
      win32: call ecore_win32 shutdown as part of the shutdown subsystem.
      cursor: add cursor support on Windows.
      Fix compilation on Windows (and propably also on Mac)
      Fix compilation after dlfcn integration into Evil

Yakov Goldberg (1):
      Fileselector entry: fix a case when file was not selected

Yeshwanth Reddivari (1):
      Theme: label - Add fixed to silent warnings.

Youngbok Shin (7):
      toolbar: remove a legacy code.
      toolbar: reduce changing widget parent-child relationship when an item is 
added.
      gengrid: Prevent duplicated selected function calls when item is 
unselected in the function.
      calendar: Apply elm_button widgets instead of manually implemented 
spinner buttons.
      toolbar: Send a signal when shrink mode is changed.
      calendar: add color classes and text classes.
      entry: add new text classes and color classes for Entry widget

divyesh purohit (3):
      hoversel: fix hover position in hoversel, when it goes out of the viewport
      hover: fix segfault when smart direction is used in content_set in hover
      combobox: add new widget.

godly.talias (2):
      hoversel: do item view creation at the time of item addition.
      hoversel: add item disabling support.

indefini (1):
      Entry focus region : if single line, show the whole object.

shashank.p (2):
      genlist: modified first/last/prev/next get API for filtered list.
      Genlist: Fixed a possible crash in filter iterator and a typo.

taehyub (4):
      popup: add popup default align config for other profiles.
      popup: add popup dismiss function for hide effect
      popup: apply popup color class
      ctxpopup: add color class

woochan lee (12):
      index: internal item's edje object handling logic changed to improve 
performance.
      spinner: add entry filter for accepted only digits and "."
      spinner: code clean up for readability.
      multibuttonentry: change default format count.
      multibuttonentry: internal entry cnp mode set as "ELM_CNP_MODE_PLAINTEXT".
      datetime: fix field arrange code for dynamically field sequence change 
case.
      spinner: prevent scrolling when longpress timer enabled.
      spinner: Internal code refactoring.
      datetime: add color classes and text classes.
      index: add color classes and text classes.
      spinner: add color classes and text classes.
      multibuttonentry: add color classes and text classes.

-----------------------------------------------------------------------

No new revisions were added by this update.

-- 


Reply via email to