Re: [PATCH] git-gui: Prevent double UTF-8 conversion

2017-12-02 Thread Łukasz Stelmach
On Tue, 28 Nov 2017 15:35:21 +0100, Johannes Schindelin wrote: > On Tue, 28 Nov 2017, Łukasz Stelmach wrote: > > With encoding on the file descriptor set to "binary" Tcl (8.6 in my > > case) does double conversion which breaks e.g. author name in amended > > commits. > > Is the problem in

Re: git checkout's stderr v stdout usage

2017-12-02 Thread nemo54
I found this an useful post. Thanks for sharing such a valuable details. I appreciates you very much. Now, you can check your Karnataka SSLC PUC Results 2018 at anywhere. Check for more information www.karresults.nic.in . -- Sent from:

[PATCH] Add a sample hook which saves push certs as notes

2017-12-02 Thread Shikher Verma
hooks--post-receive.sample: If push cert is present, add it as a git note to the top most commit of the updated ref. Signed-off-by: Shikher Verma --- templates/hooks--post-receive.sample | 38 1 file changed, 38 insertions(+) create

Re: [PATCH] send-email: extract email-parsing code into a subroutine

2017-12-02 Thread Nathan PAYRE
I found a mistake in my signed-off-by, please replace by Excuse me. 2017-12-02 18:02 GMT+01:00 Payre Nathan : > From: Nathan Payre > > The existing code mixes parsing of email header with

[PATCH v2] git-gui: Prevent double UTF-8 conversion

2017-12-02 Thread Łukasz Stelmach
Convert author's name from the UTF-8 (or any other) encoding in load_last_commit function the same way commit message is converted. Amending commits in git-gui without such conversion breaks UTF-8 strings. For example, "\305\201ukasz" (as written by git cat-file) becomes "\303\205\302\201ukasz"

Re: [PATCH v4 3/4] RUNTIME_PREFIX relocatable Git

2017-12-02 Thread Dan Jacques
My initial set of replies are inline here: https://public-inbox.org/git/20171129223807.91343-1-...@google.com/T/#m1ff5cda787eaea4a4015a8f00a8be5966122c73a I put together this solution for the I18N module. It exports "localedir" to the Perl header and injects the correct value into Git::I18N. It

Re: How hard would it be to implement sparse fetching/pulling?

2017-12-02 Thread Philip Oakley
Hi Jonathan, Thanks for the outline. It has help clarify some points and see the very similar alignments. The one thing I wasn't clear about is the "promised" objects/remote. Is that "promisor" remote a fixed entity, or could it be one of many remotes that could be a "provider"? (sort of

Re: How hard would it be to implement sparse fetching/pulling?

2017-12-02 Thread Philip Oakley
From: "Jeff Hostetler" Sent: Friday, December 01, 2017 2:30 PM On 11/30/2017 8:51 PM, Vitaly Arbuzov wrote: I think it would be great if we high level agree on desired user experience, so let me put a few possible use cases here. 1. Init and fetch into a new repo with

Re: [PATCH v5 08/10] sha1_file: support lazily fetching missing objects

2017-12-02 Thread Christian Couder
On Tue, Nov 21, 2017 at 10:07 PM, Jeff Hostetler wrote: > From: Jonathan Tan > diff --git a/sha1_file.c b/sha1_file.c > index 10c3a00..fc7718a 100644 > --- a/sha1_file.c > +++ b/sha1_file.c > @@ -29,6 +29,7 @@ > #include "mergesort.h" >

Re: How hard would it be to implement sparse fetching/pulling?

2017-12-02 Thread Philip Oakley
From: "Vitaly Arbuzov" Sent: Friday, December 01, 2017 1:27 AM Jonathan, thanks for references, that is super helpful, I will follow your suggestions. Philip, I agree that keeping original DVCS off-line capability is an important point. Ideally this feature should work even

Re: [PATCH v5 10/10] gc: do not repack promisor packfiles

2017-12-02 Thread Christian Couder
On Tue, Nov 21, 2017 at 10:07 PM, Jeff Hostetler wrote: > From: Jonathan Tan > pack_as_from_promisor () { > HASH=$(git -C repo pack-objects .git/objects/pack/pack) && > >repo/.git/objects/pack/pack-$HASH.promisor > + echo

Re: How hard would it be to implement sparse fetching/pulling?

2017-12-02 Thread Philip Oakley
From: "Jeff Hostetler" Sent: Friday, December 01, 2017 5:23 PM On 11/30/2017 6:43 PM, Philip Oakley wrote: From: "Vitaly Arbuzov" [...] comments below.. On Thu, Nov 30, 2017 at 9:01 AM, Vitaly Arbuzov wrote: Hey Jeff, It's great, I

Re: git-p4: cloning with a change number does not import all files

2017-12-02 Thread Patrick Rouleau
On Fri, Dec 1, 2017 at 7:45 AM, Lars Schneider wrote: > Oh, I am with you. However, I only used git-p4 for a very short time in the > way you want to use it. Therefore, I don't have much experience in that kind > of usage pattern. I was able to convice my management to

Re: git-p4: cloning with a change number does not import all files

2017-12-02 Thread Luke Diamand
On 2 December 2017 at 15:35, Patrick Rouleau wrote: > On Fri, Dec 1, 2017 at 7:45 AM, Lars Schneider > wrote: >> Oh, I am with you. However, I only used git-p4 for a very short time in the >> way you want to use it. Therefore, I don't have much

Re: [PATCH] Add a sample hook which saves push certs as notes

2017-12-02 Thread Todd Zullinger
Hi Shikher, I'm not familiar with push certs, but I did notice some general issues in the sample hook. I hope they're helpful. Shikher Verma wrote: index 0..b4366e43f --- /dev/null +++ b/templates/hooks--post-receive.sample +#!/bin/sh ... +if test -z GIT_PUSH_CERT ; then +exit 0

Re: [PATCH v6 2/2] t5560-http-backend-noserver.sh: add CONTENT_LENGTH cases

2017-12-02 Thread Junio C Hamano
Max Kirillov writes: > If nobody objects changing the user-visible behavior, I'll > consider using this. What user-visible behaviour? A user tries to use a new test helper introduced by the previous round and does not find it? That's OK. > PS: I'll respond to your other

Re: [PATCH v6 1/2] http-backend: respect CONTENT_LENGTH as specified by rfc3875

2017-12-02 Thread Junio C Hamano
Jeff King writes: > 3. For large inputs (like incoming packfiles), we connect the > descriptor directly to index-pack or unpack-objects, and they try > to read to EOF. > > For a well-formed pack, I _think_ this would work OK. We'd see the > end of the pack

Re: git status always modifies index?

2017-12-02 Thread Junio C Hamano
Jonathan Nieder writes: > I am worried that the project is not learning from what happened here. > ... > Fair enough, though that feels like overengineering. But I *still* > don't see what that has to do with the name "no-optional-locks". When > is a lock *optional*? And

Re: git-p4: cloning with a change number does not import all files

2017-12-02 Thread Patrick Rouleau
On Sat, Dec 2, 2017 at 12:55 PM, Luke Diamand wrote: > I think I've sort of stumbled across something like the problem you've > described in the past. Perhaps the files you need have been deleted > and then re-integrated or some such. > > Would you be able to take a look at some

Re: [PATCH v6 0/2] http-backend: respect CONTENT_LENGTH as specified by rfc3875

2017-12-02 Thread Junio C Hamano
Max Kirillov writes: > On Mon, Nov 27, 2017 at 01:02:10PM +0900, Junio C Hamano wrote: >> To recap (other than the typofix in the proposed log message), here >> is what I would have as SQUASH??? on top of (or interspersed with) >> v6. > > Thank you. I'll update it a bit later.

Re: [PATCH 4/5] rebase -i: learn to abbreviate command names

2017-12-02 Thread Junio C Hamano
Johannes Schindelin writes: > I am a fan of not relying too heavily on compiler optimization and e.g. > extract code from loops when it does not need to be evaluated every single > iteration. In this case: > > const char *pick = abbreviate_commands ? "p" :

Re: Antw: Re: bug deleting "unmerged" branch (2.12.3)

2017-12-02 Thread Philip Oakley
Hi Ulrich From: "Johannes Schindelin" To: "Ulrich Windl" Cc: Sent: Wednesday, November 29, 2017 12:27 PM Subject: Re: Antw: Re: bug deleting "unmerged" branch (2.12.3) Hi Ulrich, On Wed, 29 Nov 2017,

Re: Re: Unify annotated and non-annotated tags

2017-12-02 Thread anatoly techtonik
On Fri, Nov 24, 2017 at 1:24 PM, Ævar Arnfjörð Bjarmason wrote: > On Fri, Nov 24, 2017 at 10:52 AM, anatoly techtonik > wrote: >> On Thu, Nov 23, 2017 at 6:08 PM, Randall S. Becker >> wrote: >>> On 2017-11-23 02:31 (GMT-05:00)

Re: What's cooking in git.git (Nov 2017, #08; Tue, 28)

2017-12-02 Thread Junio C Hamano
Jeff Hostetler writes: > On 11/28/2017 8:17 PM, Junio C Hamano wrote: >> [Cooking] >> >> >> * jh/object-filtering (2017-11-22) 6 commits >>(merged to 'next' on 2017-11-27 at e5008c3b28) >> + pack-objects: add list-objects filtering >> + rev-list: add list-objects

GREETINGS BELOVED

2017-12-02 Thread MISS BORTE OGOTAI
-- GREETINGS BELOVED I AM BORTE ,I WAS DIAGNOSE WITH OVARIAN CANCER,WHICH DOCTORS HAVE CONFIRMED THAT I HAVE ONLY FEW WEEKS TO LIVE, SO I HAVE DECIDED TO DONATE EVERYTHING I HAVE TO THE ORPHANAGE AND THE POOR WIDOWS THROUGH YOU AND YOUR HELP .PLEASE KINDLY REPLY ME ONLY ON MY EMAIL ADDRES

Hello

2017-12-02 Thread MISS BORTE OGORTAI
-- GREETINGS, I AM BORTE ,I WAS DIAGNOSE OF OVARIAN CANCER,WHICH DOCTORS HAVE CONFIRMED THAT I HAVE ONLY FEW WEEKS TO LIVE, SO I HAVE DECIDED TO DONATE EVERYTHING I HAVE TO THE ORPHANAGE AND THE POOR WIDOWS THROUGH YOU .PLEASE KINDLY REPLY ME(missbortiogo...@gmail.com) AS SOON AS POSIBLE

[PATCH] send-email: extract email-parsing code into a subroutine

2017-12-02 Thread Payre Nathan
From: Nathan Payre The existing code mixes parsing of email header with regular expression and actual code. Extract the parsing code into a new subroutine 'parse_header_line()'. This improves the code readability and make parse_header_line reusable in other place.

Re: [PATCH v3 2/2] Doc/check-ref-format: clarify information about @{-N} syntax

2017-12-02 Thread Junio C Hamano
Kaartic Sivaraam writes: > When the N-th previous thing checked out syntax (@{-N}) is used > with '--branch' option of check-ref-format the result might not > always be a valid branch name (see NOTE below). This is because > @{-N} is used to refer to the N-th last

Re: [PATCH] hashmap: adjust documentation to reflect reality

2017-12-02 Thread Junio C Hamano
Jeff King writes: > My second suggestion (which I'm on the fence about) is: would it better > to just say "see t/helper/test-hashmap.c for a representative example?" I also had the same thought. It is rather unwieldy to ask people to lift code from comment text, and it is also

Re: Unify annotated and non-annotated tags

2017-12-02 Thread Junio C Hamano
anatoly techtonik writes: >> Git is not doomed to preserve anything forever. We've gradually broken >> backwards compatibility for a few core things like these. >> >> However, just as a bystander reading this thread I haven't seen any >> compelling reason for why these

Re: [PATCH v6 1/2] http-backend: respect CONTENT_LENGTH as specified by rfc3875

2017-12-02 Thread Junio C Hamano
Jeff King writes: > ... Eventually our fill() will block trying to get data that is > not there. On an Apache server, the webserver would know there is > nothing left to send us and close() the pipe, and we'd get EOF. > But on IIS, I think the pipe remains open and we'd just block

Re: [PATCH] Add a sample hook which saves push certs as notes

2017-12-02 Thread Junio C Hamano
Todd Zullinger writes: > (I also noticed the tests which use $GIT_PUSH_CERT, like t5534, use > 'cat-file blob ...' rather than 'cat-file -p ...'. I don't know if > that's much safer/better than letting cat-file guess the object type > in the hook. The '-p' option is meant for

Re: bug deleting "unmerged" branch (2.12.3)

2017-12-02 Thread Junio C Hamano
"Philip Oakley" writes: > I think it was that currently you are on M, and neither A nor B are > ancestors (i.e. merged) of M. > > As Junio said:- "branch -d" protects branches that are yet to be > merged to the **current branch**. Actually, I think people loosened this

Re: "git describe" documentation and behavior mismatch

2017-12-02 Thread Junio C Hamano
Daniel Knittl-Frank writes: > An interesting fact (and intentional behavior?) is that describing a > commit with only a lightweight tag will properly display the tags/ > prefix. I assume this is because the annotated tags only store the > tagname without any ref

Re: [PATCH] doc: clarify triangular workflow

2017-12-02 Thread Junio C Hamano
Timothee Albertin writes: > diff --git a/Documentation/gitworkflows.txt b/Documentation/gitworkflows.txt > index 02569d0..21f6dc8 100644 > --- a/Documentation/gitworkflows.txt > +++ b/Documentation/gitworkflows.txt > @@ -407,8 +407,8 @@ follows. > `git pull ` >

Re: [PATCH v6 1/2] http-backend: respect CONTENT_LENGTH as specified by rfc3875

2017-12-02 Thread Jeff King
On Sat, Dec 02, 2017 at 05:02:37PM -0800, Junio C Hamano wrote: > Jeff King writes: > > > 3. For large inputs (like incoming packfiles), we connect the > > descriptor directly to index-pack or unpack-objects, and they try > > to read to EOF. > > > > For a

Re: [PATCH v4 2/2] launch_editor(): indicate that Git waits for user input

2017-12-02 Thread Junio C Hamano
Jeff King writes: > I tried to think of ways this "show a message and then delete it" could > go wrong. It should work OK with editors that just do curses-like > things, taking over the terminal and then restoring it at the end. > ... I think that it is not worth to special-case

Re: [PATCH v4 1/4] Makefile: generate Perl header from template file

2017-12-02 Thread Junio C Hamano
Johannes Sixt writes: >> +sed -e 's=@@PATHSEP@@=$(pathsep)=g' \ > > This doesn't work, unfortunately. When $(pathsep) is ';', we get an > incomplete sed expression because ';' is also a command separator in > the sed language. It is correct that ';' can be and does get used

Re: [PATCH] l10n: update de_DE translation

2017-12-02 Thread Ralf Thielow
Robert Abel wrote: > Der-, die- and dasselbe and their declensions are spelt as one word in German. > Thanks! > Signed-off-by: Robert Abel > --- > po/de.po | 6 +++--- > 1 file changed, 3 insertions(+), 3 deletions(-) > > diff --git a/po/de.po

Re: [add-default-config] add --default option to git config.

2017-12-02 Thread Philip Oakley
From: "Soukaina NAIT HMID" From: Soukaina NAIT HMID From a coursory read, there does need a bit more explanation. I see you also add a --color description and code, and don't say what the problem being solved is. If it is trickty to

Re: [PATCH v5 07/10] introduce fetch-object: fetch one promisor object

2017-12-02 Thread Christian Couder
On Tue, Nov 21, 2017 at 10:07 PM, Jeff Hostetler wrote: > From: Jonathan Tan > +void fetch_object(const char *remote_name, const unsigned char *sha1) > +{ > + struct remote *remote; > + struct transport *transport; > + struct

Re: Re: bug deleting "unmerged" branch (2.12.3)

2017-12-02 Thread Philip Oakley
From: "Ulrich Windl" To: Cc: Sent: Wednesday, November 29, 2017 8:32 AM Subject: Antw: Re: bug deleting "unmerged" branch (2.12.3) "Ulrich Windl" writes: I think if more than

Re: Re: Unify annotated and non-annotated tags

2017-12-02 Thread Philip Oakley
From: "anatoly techtonik" comment at end - Philip On Fri, Nov 24, 2017 at 1:24 PM, Ævar Arnfjörð Bjarmason wrote: On Fri, Nov 24, 2017 at 10:52 AM, anatoly techtonik wrote: On Thu, Nov 23, 2017 at 6:08 PM, Randall S. Becker

Re: [PATCH v2 2/2] Doc/check-ref-format: clarify information about @{-N} syntax

2017-12-02 Thread Junio C Hamano
Kaartic Sivaraam writes: >> I have a mild suspicion that "git checkout -B @{-1}" would want to >> error out instead of creating a valid new branch whose name is >> 40-hex that happen to be the name of the commit object you were >> detached at previously. > > I thought