Re: RFC: Native clean/smudge filter for UTF-16 files

2017-12-03 Thread Lars Schneider
> On 24 Nov 2017, at 19:04, Jeff King wrote: > > On Thu, Nov 23, 2017 at 04:18:59PM +0100, Lars Schneider wrote: > >> Alternatively, I could add a native attribute to Git that translates UTF-16 >> to UTF-8 and back. A conversion function is already available in "mingw.h" >>

Re: [PATCH 1/3] git-compat-util: introduce skip_to_opt_val()

2017-12-03 Thread Christian Couder
On Sun, Dec 3, 2017 at 7:45 PM, Junio C Hamano wrote: > Christian Couder writes: > >> From: Christian Couder >> >> We often accept both a "--key" option and a "--key=" option. >> >> These options currently are parsed

Re: [SCRIPT/RFC 0/3] git-commit --onto-parent (three-way merge, no working tree file changes)

2017-12-03 Thread Igor Djordjevic
Hi Chris, On 30/11/2017 23:40, Chris Nerwert wrote: > > I'm actually doing the described workflow quite often with git rebase > when working on a topic. Given the following structure: > > ---o (master) > \ >o---A---B---C (topic) > > When I want to make changes to

Re: bug deleting "unmerged" branch (2.12.3)

2017-12-03 Thread Philip Oakley
From: "Junio C Hamano" "Philip Oakley" writes: I think it was that currently you are on M, and neither A nor B are ancestors (i.e. merged) of M. As Junio said:- "branch -d" protects branches that are yet to be merged to the **current branch**.

[PATCH v2 3/9] rebase -i: set commit to null in exec commands

2017-12-03 Thread Liam Beguin
Make sure commit is set to NULL when parsing exec instructions from the todo list. If not, we may try to access an uninitialized address later while updating the todo list. Signed-off-by: Liam Beguin --- sequencer.c | 1 + 1 file changed, 1 insertion(+) diff --git

[PATCH v2 8/9] rebase -i: learn to abbreviate command names

2017-12-03 Thread Liam Beguin
`git rebase -i` already know how to interpret single-letter command names. Teach it to generate the todo list with these same abbreviated names. Based-on-patch-by: Johannes Schindelin Signed-off-by: Liam Beguin ---

[PATCH v2 0/9] rebase -i: add config to abbreviate command names

2017-12-03 Thread Liam Beguin
Hi everyone, This series will add the 'rebase.abbreviateCommands' configuration option to allow `git rebase -i` to default to the single-letter command names when generating the todo list. Using single-letter command names can present two benefits. First, it makes it easier to change the action

[PATCH v2 4/9] rebase -i: refactor transform_todo_ids

2017-12-03 Thread Liam Beguin
The transform_todo_ids function is a little hard to read. Lets try to make it easier by using more of the strbuf API. Also, since we'll soon be adding command abbreviations, let's rename the function so it's name reflects that change. Signed-off-by: Liam Beguin ---

[PATCH v2 7/9] rebase -i -x: add exec commands via the rebase--helper

2017-12-03 Thread Liam Beguin
Recent work on `git-rebase--interactive` aims to convert shell code to C. Even if this is most likely not a big performance enhancement, let's convert it too since a coming change to abbreviate command names requires it to be updated. Signed-off-by: Liam Beguin ---

[PATCH v2 9/9] t3404: add test case for abbreviated commands

2017-12-03 Thread Liam Beguin
Make sure the todo list ends up using single-letter command abbreviations when the rebase.abbreviateCommands is enabled. This configuration option should not change anything else. Signed-off-by: Liam Beguin --- t/t3404-rebase-interactive.sh | 22 ++ 1

[PATCH v2 6/9] rebase -i: update functions to use a flags parameter

2017-12-03 Thread Liam Beguin
Update functions used in the rebase--helper so that they take a generic 'flags' parameter instead of a growing list of options. Signed-off-by: Liam Beguin --- builtin/rebase--helper.c | 13 +++-- sequencer.c | 9 + sequencer.h |

[PATCH v2 1/9] Documentation: move rebase.* configs to new file

2017-12-03 Thread Liam Beguin
Move all rebase.* configuration variables to a separate file in order to remove duplicates, and include it in config.txt and git-rebase.txt. The new descriptions are mostly taken from config.txt as they are more verbose. Signed-off-by: Liam Beguin ---

[PATCH v2 2/9] Documentation: use preferred name for the 'todo list' script

2017-12-03 Thread Liam Beguin
Use "todo list" instead of "instruction list" or "todo-list" to reduce further confusion regarding the name of this script. Signed-off-by: Liam Beguin --- Documentation/rebase-config.txt | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git

[PATCH v2 5/9] rebase -i: replace reference to sha1 with oid

2017-12-03 Thread Liam Beguin
Since we are trying to abstract the hash function name elsewhere in the code base, lets use OID instead of SHA-1 in the rebase--helper too. Signed-off-by: Liam Beguin --- builtin/rebase--helper.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git

Re: [PATCH 1/3] git-compat-util: introduce skip_to_opt_val()

2017-12-03 Thread Junio C Hamano
Christian Couder writes: > From: Christian Couder > > We often accept both a "--key" option and a "--key=" option. > > These options currently are parsed using something like: > > if (!strcmp(arg, "--key")) { > /* do something */ > }

Re: [PATCH] send-email: extract email-parsing code into a subroutine

2017-12-03 Thread Matthieu Moy
Nathan PAYRE writes: > I found a mistake in my signed-off-by, please replace > by I think you want exactly the opposite of this. You're contributing as a Lyon 1 student, hence your identity is @etu.univ-lyon1.fr.

Re: [PATCH] send-email: extract email-parsing code into a subroutine

2017-12-03 Thread Ævar Arnfjörð Bjarmason
On Sat, Dec 02 2017, Payre Nathan jotted: > From: Nathan Payre > > The existing code mixes parsing of email header with regular > expression and actual code. Extract the parsing code into a new > subroutine 'parse_header_line()'. This improves the code readability > and

Re: [RFE] Inverted sparseness

2017-12-03 Thread Philip Oakley
From: "Randall S. Becker" Sent: Friday, December 01, 2017 6:31 PM On December 1, 2017 1:19 PM, Jeff Hostetler wrote: On 12/1/2017 12:21 PM, Randall S. Becker wrote: I recently encountered a really strange use-case relating to sparse clone/fetch that is really backwards

Re: [PATCH] send-email: extract email-parsing code into a subroutine

2017-12-03 Thread Nathan PAYRE
I've tested your code, and after few changes it's works perfectly! The code looks better now. Thanks a lot for your review. 2017-12-03 23:00 GMT+01:00 Ævar Arnfjörð Bjarmason : > > On Sat, Dec 02 2017, Payre Nathan jotted: > >> From: Nathan Payre >> >>

RE: [RFE] Inverted sparseness

2017-12-03 Thread Randall S. Becker
On December 3, 2017 6:14 PM, Philip Oakley wrote a nugget of wisdom: >From: "Randall S. Becker" >Sent: Friday, December 01, 2017 6:31 PM >> On December 1, 2017 1:19 PM, Jeff Hostetler wrote: >>>On 12/1/2017 12:21 PM, Randall S. Becker wrote: I recently encountered a

Re: [PATCH 1/3] git-compat-util: introduce skip_to_opt_val()

2017-12-03 Thread Junio C Hamano
Christian Couder writes: > Anyway there is a design choice to be made. Adding a "const char > *default" argument makes the function more generic,... I didn't suggest anything of that sort, and I do not understand why you are repeatedly talking about "default" that

Re: [PATCH v5 4/4] builtin/branch: strip refs/heads/ using skip_prefix

2017-12-03 Thread SZEDER Gábor
On Fri, Dec 1, 2017 at 6:59 AM, Kaartic Sivaraam wrote: > Sorry, missed a ';' in v4. > > The surprising thing I discovered in the TravisCI build for v4 > was that apart from the 'Documentation' build the 'Static Analysis' > build passed, with the following output, > >

Re: [PATCH 1/3] git-compat-util: introduce skip_to_opt_val()

2017-12-03 Thread Christian Couder
On Sun, Dec 3, 2017 at 11:48 PM, Junio C Hamano wrote: > Christian Couder writes: > >> Anyway there is a design choice to be made. Adding a "const char >> *default" argument makes the function more generic,... > > I didn't suggest anything of that

AW: [PATCH v6 1/2] http-backend: respect CONTENT_LENGTH as specified by rfc3875

2017-12-03 Thread Florian Manschwetus
Hi All, I could provide a bash script I used in between to make this working with IIS, without fixing http-backend binary, maybe this helps to understand how this cases might be handled. Mit freundlichen Grüßen / With kind regards Florian Manschwetus > -Ursprüngliche Nachricht- >

Re: [SCRIPT/RFC 0/3] git-commit --onto-parent (three-way merge, no working tree file changes)

2017-12-03 Thread Igor Djordjevic
Hi Hannes, On 01/12/2017 18:23, Johannes Sixt wrote: > > > To work with `--onto-parent` and be able to commit on top of any of > > the topic branches, you would need a situation like this instead: > > > > (1) ...C <- topic C > > | > > ...A | <- topic A > > \|

Re: [PATCH v4 1/4] Makefile: generate Perl header from template file

2017-12-03 Thread Ævar Arnfjörð Bjarmason
On Sun, Dec 03 2017, Junio C. Hamano jotted: > Johannes Sixt writes: > >>> + sed -e 's=@@PATHSEP@@=$(pathsep)=g' \ >> >> This doesn't work, unfortunately. When $(pathsep) is ';', we get an >> incomplete sed expression because ';' is also a command separator in >> the sed

Re: [PATCH v4 2/2] launch_editor(): indicate that Git waits for user input

2017-12-03 Thread Lars Schneider
> On 02 Dec 2017, at 04:45, Kaartic Sivaraam wrote: > > On Friday 01 December 2017 11:59 PM, Jeff King wrote: >> On Fri, Dec 01, 2017 at 01:52:14PM +0100, Lars Schneider wrote: >>> >>> Thanks for the review :-) >> Actually, I meant to bikeshed one part but forgot.

[PATCH v2] Makefile: replace perl/Makefile.PL with simple make rules

2017-12-03 Thread Ævar Arnfjörð Bjarmason
Replace the perl/Makefile.PL and the fallback perl/Makefile used under NO_PERL_MAKEMAKER=NoThanks with a much simpler implementation heavily inspired by how the i18n infrastructure's build process works[1]. The reason for having the Makefile.PL in the first place is that it was initially[2]

Re: [PATCH v4 2/2] launch_editor(): indicate that Git waits for user input

2017-12-03 Thread Lars Schneider
> On 03 Dec 2017, at 06:15, Junio C Hamano wrote: > > Jeff King writes: > >> I tried to think of ways this "show a message and then delete it" could >> go wrong. It should work OK with editors that just do curses-like >> things, taking over the terminal and

[PATCH] list-objects-filter-options: fix 'keword' typo in comment

2017-12-03 Thread Christian Couder
From: Christian Couder Signed-off-by: Christian Couder --- list-objects-filter-options.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/list-objects-filter-options.c b/list-objects-filter-options.c index

DARPA icon test

2017-12-03 Thread Jacob Chassereau
https://www.w3.org/Icons/DARPA/inline.html Sent from my iPhone

Re: [PATCH] git-gui: allow Ctrl+T to toggle multiple paths (Re: [BUG] git gui can't commit multiple files)

2017-12-03 Thread Timon
On 12/2/17, Jonathan Nieder wrote: > Jonathan Nieder wrote: > >> From: Johannes Schindelin >> Subject: git-gui: allow Ctrl+T to toggle multiple paths >> >> In the Unstaged Changes panel, selecting multiple lines (using >> shift+click) and pressing

[PATCH 1/3] git-compat-util: introduce skip_to_opt_val()

2017-12-03 Thread Christian Couder
From: Christian Couder We often accept both a "--key" option and a "--key=" option. These options currently are parsed using something like: if (!strcmp(arg, "--key")) { /* do something */ } else if (skip_prefix(arg, "--key=", )) { /* do something

[PATCH 3/3] diff: use skip_to_opt_val()

2017-12-03 Thread Christian Couder
From: Christian Couder Let's simplify diff option parsing using skip_to_opt_val(). Signed-off-by: Christian Couder --- diff.c | 22 -- 1 file changed, 8 insertions(+), 14 deletions(-) diff --git a/diff.c b/diff.c index

[PATCH 2/3] index-pack: use skip_to_opt_val()

2017-12-03 Thread Christian Couder
From: Christian Couder Let's simplify index-pack option parsing using skip_to_opt_val(). Signed-off-by: Christian Couder --- builtin/index-pack.c | 11 +++ 1 file changed, 3 insertions(+), 8 deletions(-) diff --git